Subject: [Rfced-future] Another possible issue to consider

From: Jay Daley <[email-masked]>
Date: Wed, 6 May 2020 11:35:56 +1200

I’ve seen some people suggest that the RFC Series could be open to other standards development organisations (SDO) to use as their primary publication stream and therefore that the RFC Series needs to maintain a degree of independence that allows that.

My issue then is how that fits with the use of the RFC Series for publishing administrative RFCs about the IETF - Does this practice intertwine the RFC Series with the IETF too much?  Would any other SDO also be able to publish administrative RFCs?  Is there any point at which the ratio of administrative to technical RFCs becomes an issue for the RFC Series?   Are any changes needed to mitigate against that becoming a problem?

To be clear I do not include RFCs about the RFC Series itself in my definition of administrative RFCs.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 5 May 2020 20:30:53 -0400

I think slowing other SDOs to publish RFCs will make end runs a lot easier. I do not think making it possible for the RFC editor to do this is a good goal. 

> On May 5, 2020, at 19:36, Jay Daley <[email-masked]> wrote:
> 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 6 May 2020 13:12:19 +1200

> I think slowing other SDOs to publish RFCs will make end runs a lot easier. I do not think making it possible for the RFC editor to do this is a good goal. 

I tend to agree. While I think that having diverse streams is a real asset, allowing N streams that all assert that they are standards is asking for confusion.

However, having this issue on the list of issues seems reasonable. We may end up with a category of Bad Ideas.

    Brian

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 May 2020 06:19:29 +0200

On 2020-05-06, at 02:30, Ted Lemon <[email-masked]> wrote:
> 
> slowing other SDOs to publish RFCs

Nice Freudian slip your autocorrector created for you.  SCNR.

Apart from sorting this under Bad Idea, one other question is how much control we (IETF/IRTF/IAB) have to prevent this from happening if we think that is a Bad Idea
(a.k.a. hostile takeover protection).

Grüße, Carsten

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 6 May 2020 07:08:30 -0400

As a hypothetical, what if an SDO or industry forum were to come to the RFC
Editor and say that they would like their output documents to be published
in the RFC series, and they would be willing to do so using the existing
RFC publishing procedures and provide the necessary funding to cover the
expenses for additional personnel and overhead? This wouldn't be a hostile
takeover, it would just be a new source stream.

Would there be different opinions if this SDO were somewhat IETF-adjacent
(like the W3C) vs. something less so (the Society of Automotive Engineers)?

Cheers,
Andy

On Wed, May 6, 2020 at 12:19 AM Carsten Bormann <[email-masked]> wrote:

> Apart from sorting this under Bad Idea, one other question is how much
> control we (IETF/IRTF/IAB) have to prevent this from happening if we think
> that is a Bad Idea

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 6 May 2020 09:12:09 -0400

The cases in the past where this (other SDOs publishing RFCs) has been 
allowed it was for a group with very low publication rate.  And their 
documents were published through the Independent Stream, and marked as 
Informational.  The particular group was happy with that.

There was discussion of creating additional streams for such use, and 
there was sufficient concern that it was not done.

Yours,
Joel

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 May 2020 15:23:17 +0200

On 2020-05-06, at 15:12, Joel M. Halpern <[email-masked]> wrote:
> 
> The cases in the past where this (other SDOs publishing RFCs) has been allowed it was for a group with very low publication rate.  And their documents were published through the Independent Stream,

Right, and we have the IESG process review to make sure this does not create confusion.

> and marked as Informational.  The particular group was happy with that.
> 
> There was discussion of creating additional streams for such use, and there was sufficient concern that it was not done.

Which does not surprise me, as it would remove the IESG as a final gate.

Grüße, Carsten

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 6 May 2020 15:00:40 +0100

Just chiming in here with my ISE hat on...

This ISE is not inclined to use the Independent Stream as a mechanism for other SDOs to publish their material. If they are real SDOs they will have their own publication venues. However, their may be occasions where it is deemed beneficial to the Internet Community to reproduce material from other SDOs in RFC format thus making that material more accessible. A recent example is the translation (from Russian) of certain security specifications first published in Russia.

Now, without any hats on...

This thread cuts to the very core of one of the issues that is least clear in my mind: who owns the RFC series, and what is it for?

To take a very concrete example which has echoes in what IANA does, suppose that the W3C [1] decided it would like to publish its output as RFCs. Suppose that the RSE thought this was a good idea, suppose that the output was "related to the Internet" (which it probably is), and suppose that the W3C had money to fund the RPC and RFC Editor system/tools proportional to the number of pages of RFC it wanted to publish.
- Who would make the decision?
- Who would have input to the decision?
- Who would arrange any contracts?
- Who would be responsible for ensuring that the W3C RFCs were easily 
  distinguishable from the other RFCs, and who would agree that was the
  right thing to do?

Best,
Adrian

[1] Note, I am not suggesting that the W3C wants to do any of this. Nor am I suggesting it is a good idea. I am simply using this as an example that may make the hypothetical more tangible.

-----Original Message-----
From: Rfced-future <[email-masked]> On Behalf Of Joel M. Halpern
Sent: 06 May 2020 14:12
Cc: [email-masked]
Subject: Re: [Rfced-future] Another possible issue to consider

Yours,
Joel

---

From: "John Levine" <[email-masked]>
Date: 6 May 2020 10:06:05 -0400

>there was sufficient concern that it was not done.

This sounds sufficiently hypothetical that I wouldn't want to spend a
lot of time planning for it.

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 06 May 2020 09:00:49 -0700

> Informational.  The particular group was happy with that.

And this makes sense right?  The IETF is an open organization without
true membership.  Anyone can publish documents within IETF streams by
getting it through that stream's approval process, regardless of whether
it came from another SDO or not.  Some see the WG formation as
burdensome, many others don't know about the independent stream (or more
importantly: understand when it's acceptable to use it), etc.

The question is: are we happy with the current balance, or in the
process of re-thinking things do we want to shift that balance slightly
to make it easier or harder for publication of specifications that may
have originated in other SDOs.  We could make it easier by having a
new, separate stream as some have mentioned.  We could make it harder by
requiring copyright transfer or refusing anything that isn't original
publication (like many academic journals do).  And, is this even the
right thing to be thinking about now or is it a distraction from the
primary purpose of this group?

[note: intentionally not supplying my own answers]

-- 
Wes Hardaker
USC/ISI

---

From: Michael StJohns <[email-masked]>
Date: Wed, 6 May 2020 12:00:54 -0400

> However, having this issue on the list of issues seems reasonable. We may end up with a category of Bad Ideas.

Given that we already have a stream that's published at least a few 
standards in all but name (e.g. IRTF), I'm afraid that horse has left 
the barn.   The question is more do we either a) ban it going forward, 
b) grandfather it for the IRTF only, or c) normalize it as a possible 
model for the community going forward?

I agree with Adrian's plaintive cry that this shouldn't end up in the 
ISE's stream in any case.

There are a few ways of doing this - the obvious one is just keep doing 
what we're already doing and allow re-publications of other SDO 
standards as appropriate and useful.  Other possibilities include 
distinct streams for non-I* productions but still published as RFCs and 
a complete new series (think "imprint" in publisher terms) that - while 
published by the RFC Editor using the services of the RPC is labeled 
distinctly and disjointly from the RFC series.   The latter could 
provide an independent revenue stream for the RFC process and help 
defray some of the IETFs sunk costs for getting RFCs out.

Later, Mike

---

From: Ted Lemon <[email-masked]>
Date: Wed, 6 May 2020 12:50:41 -0400

On May 6, 2020, at 12:00 PM, Michael StJohns <[email-masked]> wrote:
> Given that we already have a stream that's published at least a few standards in all but name (e.g. IRTF), I'm afraid that horse has left the barn.   The question is more do we either a) ban it going forward, b) grandfather it for the IRTF only, or c) normalize it as a possible model for the community going forward?

Brian's point that we should list all the ideas so that we can discuss them is probably right.

I think the IRTF publishing RFCs is a bit problematic, but Mostly Harmless because there is a close tie between the IETF and the IRTF. Imagine ETSI publishing RFCs, though.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 7 May 2020 09:31:44 +1200

> This ISE is not inclined to use the Independent Stream as a mechanism for other SDOs to publish their material. If they are real SDOs they will have their own publication venues. However, their may…

Yes (half wearing my hat as an ISEB member).

For those who don't know, ISEB = Independent Submissions Editorial Board 
 
> Now, without any hats on...

Ditto
 
> This thread cuts to the very core of one of the issues that is least clear in my mind: who owns the RFC series, and what is it for?

Indeed. See my earlier note about Principles/Charter/Strategy.

To respond to one of Andy's points:

>> Would there be different opinions if this SDO were somewhat IETF-adjacent (like the W3C) vs. something less so (the Society of Automotive Engineers)?

Yes. To the extent that the RFC Editor operates under ISOC auspices, the Society of Automotive Engineers would be out of scope, according to ISOC's Articles of Incorporation. If the RFC Editor had Principles/Charter/Strategy, we would have a clearer statement of scope, of course.

    Brian

---

From: Jay Daley <[email-masked]>
Date: Thu, 7 May 2020 09:35:31 +1200

> On 7/05/2020, at 9:31 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Yes. To the extent that the RFC Editor operates under ISOC auspices, the Society of Automotive Engineers would be out of scope, according to ISOC's Articles of Incorporation.

Can you explain what you mean by the RFC Editor operating under ISOC auspices?

Jay

> If the RFC Editor had Principles/Charter/Strategy, we would have a clearer statement of scope, of course.
> 
>    Brian
> 
>> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 6 May 2020 18:07:47 -0400

In article <[email-masked]>,
Brian E Carpenter  <[email-masked]> wrote:
>Yes. To the extent that the RFC Editor operates under ISOC auspices, the Society of Automotive Engineers would be out of scope,
>according to ISOC's Articles of Incorporation. If the RFC Editor had Principles/Charter/Strategy, we would have a clearer
>statement of scope, of course.

I dunno, what if SAE were publishing documents about network protocols
on a vehicle's internal bus, or between vehicles?

This still seems awfully hypothetical.  If it were up to me, I would
say that adding any new stream needs the agreement of all of the
existing streams and burn that bridge when we get to it.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 May 2020 23:40:16 +0100

Hiya,

On 06/05/2020 23:07, John Levine wrote:
> If it were up to me, I would

I'd maybe consider "agreement of the RSE and all the
stream managers" or somesuch but yeah, that kind of
decision-process seems rightish.

S.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 7 May 2020 10:59:59 +1200

> decision-process seems rightish.

I agree. 

Incidentally, CANbus (now Controller Area Network, originally Car Area Network) is ISO 11898. "The protocol was officially released in 1986 at the Society of Automotive Engineers (SAE) conference in Detroit, Michigan" [Wikipedia]. I don't think they'll be asking for an RFC number. But the IETF is doing vehicle-related work in IPWAVE.

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 7 May 2020 11:03:47 +1200

On 07-May-20 09:35, Jay Daley wrote:
> 
> 
>> On 7/05/2020, at 9:31 AM, Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
>>

Sure. Until the LLC came along, ISOC was the direct funding agency. Now, it's an ISOC disregarded entity that's the funding agency. Until the IETF Trust came along, ISOC copyright was asserted for RFCs. I think if anything ever came to court, that would all count as much as the IAB's charter claim to oversight.

Another reason why I believe the RFC Series needs a well defined charter of its own.

Regards
   Brian

>>> From: Rfced-future <[email-masked] <mailto:[email-masked]>> On Behalf Of Joel M. Halpern
>>> Sent: 06 May 2020 14:12
>>> Cc: [email-masked] <mailto:[email-masked]>
>>>> On 2020-05-06, at 02:30, Ted Lemon <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
>