Subject: [Rfced-future] Fwd: I-D Action: draft-carpenter-rfc-principles-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Mon, 18 May 2020 15:13:49 +1200

Updated according to my interpretation of the long, complicated thread.
More comments welcome, of course.

Prettiest version:
https://www.ietf.org/id/draft-carpenter-rfc-principles-01.html

    Brian

-------- Forwarded Message --------
Subject: I-D Action: draft-carpenter-rfc-principles-01.txt
Date: Sun, 17 May 2020 20:05:41 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Principles of the Request for Comments Series
        Author          : Brian Carpenter
	Filename        : draft-carpenter-rfc-principles-01.txt
	Pages           : 10
	Date            : 2020-05-17

Abstract:
   This document discusses the underlying principles of the Internet
   technical community's Request for Comments document Series.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-carpenter-rfc-principles/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-carpenter-rfc-principles-01
https://datatracker.ietf.org/doc/html/draft-carpenter-rfc-principles-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-carpenter-rfc-principles-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 18 May 2020 14:16:02 +1000

Hi Brian,

A good document improved.

A few notes from a quick read:

* S 3.2 says the RSE '[l]eads the community in the design of improvements to the RFC Series.' It seems a bit odd to say that this position leads the community when we don't yet have a definition of the community or any idea how it makes decisions. Perhaps we should figure out the leadership afterwards?

* Ibid, the RSE '[i]s responsible for planning and overseeing the execution of improvements in the RFC Editor production and access processes, in collaboration with IETF LLC as appropriate.' The mention of the LLC makes the absence of the community seem deliberate here -- is that the case?

* S 5 states: `An assumption in our community is that all actors act in good faith, subject of course to normal human failures.  As far as possible, the RFC Editor regime needs to be immune to malicious acts of any kind. For that reason, it is important that appropriate organisational checks and balances are in place.'  This seems odd to me; AFAICT we don't stress such immunity in the definition of any other leadership positions, and no mention is made of the other reason for 'appropriate ... checks and balances' -- to assure that the RSE's powers are appropriate used.

Cheers,

> On 18 May 2020, at 1:13 pm, Brian E Carpenter <[email-masked]> wrote:
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

--
Mark Nottingham   https://www.mnot.net/

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 18 May 2020 16:48:31 +1200

> * S 3.2 says the RSE '[l]eads the community in the design of improvements to the RFC Series.' It seems a bit odd to say that this position leads the community when we don't yet have a definition of…

Well, yes, this is a bit of a chicken-and-egg situation. As you may realise, I lifted this text from the existing model. But somebody has to be the proxy for the community consensus.
 
> * Ibid, the RSE '[i]s responsible for planning and overseeing the execution of improvements in the RFC Editor production and access processes, in collaboration with IETF LLC as appropriate.' The me…

Not really. But since it's the LLC that holds the budget and the contracts, they can't be out of the loop. We will have a slightly double-headed monster as a result.
 
> * S 5 states: `An assumption in our community is that all actors act in good faith, subject of course to normal human failures.  As far as possible, the RFC Editor regime needs to be immune to mali…

I'll leave that to Carsten who suggested this point. Maybe s/immune to/protected against/ ?

Regards
    Brian