Subject: Re: [Rfced-future] Questions and closed groups

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 6 Oct 2020 14:54:40 +0200

Hi Mike, hi all,

Sorry for top-posting but I would quickly like to comment on two point you've made (and all catching up after holidays…).

First, just because we have some closed groups in the IETF, I don’t think that is necessarily an argument that this is the right approach for the RFC series. However, I also really don’t like the term “closed” here because the purpose of those groups is not to decide things in secret but rather to have a dedicated group of people that have made a commitment to do work and spend time on certain topics. In both, the IESG and IAB, we have been and are implementing new measures to increase transparency and also make sure we have good ways to collect feedback from the community where needed. (The ISE is different but very much on purpose in order to actually be independent). There might be a need for a person or group that dictates work and time for the RFC series as well, however, I’m still trying to understand how much work force is needed if we separate out the daily business (which I think is the most important step we should take here). Such a person or group might be a leadership position, however, if that is the case I would feel more comfortable if that would be run on a voluntarily based instead by a paid contractor as we also do for other leadership positions.

Second, the streams we have are all very different and as such have very different procedures. That’s exactly the reason that we have different streams. The most noticeable different between the IETF streams and others is that only the IETF can publish PSs and BCPs. The other streams can only only publish INF or EXP and explicitly as such are not required to establish any kind of consensus. For the IAB particularly, we now announce adoption of drafts and have a request for community feedback before publication, however, when an IAB document (I'm talking about recommendation or guidance documents, not process related docs) is published all IAB members who where on the IAB at that time are listed and it’s clearly indicated that it is the opinion of that group. For IETF stream document, a single AD can block a document (at least temporally), however, there is no way to unilaterally decide for publication, not even by the IESG, as an IETF last call is always required. In case of the RFC series, I think we really want community based decisions as well where those people, who write and read RFC as their daily business, have a say or at least some kind of veto like the IETF last call.

Mirja

> On 28. Sep 2020, at 18:25, Michael StJohns <[email-masked]> wrote:
> 
> Hi Brian - 
> 
> Inline.
> 
> On 9/27/2020 3:47 PM, Brian E Carpenter wrote:
>> On 27-Sep-20 20:40, Martin J. Dürst wrote:
>> 
>>> Hello everybody,
>>> 
>>> On 27/09/2020 06:16, Michael StJohns wrote:
>>> 
>>> 
>>>> The IETF community has a lot of closed groups - IESG, IRSG, IAB, IETF 
>>>> Trust, LLC Board, and for that matter the model for research groups is 
>>>> that they MAY be closed. Oh yes, most of the IAB programs appear to be 
>>>> mostly closed. Decisions for publication in 3 of the 4 streams are made 
>>>> by closed groups.    For the IAB as much as 1/2 (guessing here - didn't 
>>>> count) of the IAB stream documents originate within the IAB itself and 
>>>> are not subject to mandatory external review prior to publication. 
>>>> Irrespective of where the documents originate, a closed group makes the 
>>>> final decisions on publication for all but the documents in the 
>>>> independent stream.
>>>> 
>>> The ISE in general has a lower bar, but isn't s/he essentially a closed 
>>> group of one?
>>> 
>> No. You are overlooking the ISEB (Independent Series Editorial Board).
>> True, the ISE's decision is final, but I've been an ISEB member for
>> quite a few years, and the Editor has always consulted the Board
>> whenever there was a tricky issue, and used it as a (non exclusive)
>> source of reviewers.
>> 
> From RFC6548
> 
>>  The ISE is supported by an Editorial Board for the review of
>>    Independent Submission stream documents.  This board is known as the
>>    Independent Submission Editorial Board.  This volunteer Editorial
>>    Board exists at the pleasure of the ISE, and its members serve at the
>>    pleasure of the ISE.  The existence of this board is simply noted
>>    within this model, and additional discussion of such is considered
>>    out of scope of this document.
>> 
> So this is a choice of the ISE to seek commentary, not a requirement of the process.  Which in the end reduces to the ISE making the decision, regardless of how he seeks to make that decision.  The fact that Adrian is smart enough to pay attention to his board, does not actually change the documented process.
> 
> 
> 
>> 
>> A difference compared to the IETF review process is that it more
>> closely resembles an academic peer review process. The reviews
>> aren't published, for example. But they usually aren't blinded, either
>> (i.e. the authors usually know who the reviewers are).
>> 
>> Getting back to Mike's message:
>> 
>> 
>>>> Brian - Authored by anyone with perhaps some RSA input and guidance, consensus of the WG, consensus determined by the WG chairs, approved for publication by the ISE, published in the Independent stream.
>>>> 
>> My draft doesn't say that ("ISE"), but leaves it rather open. In fact I think this stream should be owned by what I called the RSAWG, so the RSAWG chairs would declare consensus to publish. I don't think that this would be a busy stream, except for an initial bunch of documents.
>> 
>>     Brian
>> 
>> 
> Hi Brian - your draft didn't say that, but your email did responding to my question about an editorial stream:  (if not the Editorial stream, then where?):
> 
> 
>> Again, it's model-dependent. In draft-thomson, it's clearly the IAB stream as
>> today. In the other two models, we are presumably left with the Independent
>> stream
>> 
> 
> Apologies if I mis-represented anything.  
> 
> WRT to each of the current streams, there's either a body determines by vote that a document is ready for publication in the stream, or the ISE does (with whatever consultation he in his judgement determines is necessary).   
> 
> 
> 
> So digging down a bit on your last comment and assuming an Editorial Stream (whatever its called) - you think that the WG (or the loud voices therein) would direct for publication any document they felt was ready for publication, and that decision  (of agreement to publish) would be made by the WG chairs.   There       would be no further decision points?
> 
> Logically it looks like you've got a Editorial stream document production group of N people and a voting (sort of) RSEB consisting of the WG chairs actually deciding whether the documents get published.   And from your previous comments do I understand that the 4 other stream editors would be treated the same as any other participant except that their comments may be given heavier weight (or ignored for that matter) during the discussion period even if one of their stream might be more affected than another?
> 
> We've noted before that its relatively common to get WGs into forms of consensus paralysis on trying to get out documents, and that the IAB and IESG have at various times completely avoided the WG model, either self-editing/self-publishing or creating relatively closed design teams to make progress.   They've invoked that model also on the "boring" where the documents needed to get done, but there was no one all that interested in doing them as part of their day job.    If we choose an open group model, I believe that a few nuclear options for such groups need to be incorporated to ensure progress when necessary.   That seems anathema to the IETF model, but we've done similar things to complete the meta tasks of legally organizing ourselves.  Alternately, a closed body vote to publish like we have for all the other streams is a worked example.
> 
> 
> 
> Thanks for the comments - Mike
> 
> 
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Michael StJohns <[email-masked]>
Date: Tue, 6 Oct 2020 13:25:16 -0400

> Hi Mike, hi all,

Hi Mirja -

> First, just because we have some closed groups in the IETF, I don’t think that is necessarily an argument that this is the right approach for the RFC series. However, I also really don’t like the term “closed” here because the purpose of those groups is not to decide things in secret but rather to have a dedicated group of people that have made a commitment to do work and spend time on certain topics.

I used "closed group" in the way that means "this fixed membership group 
of people gather to make a set of decisions, and while they may take 
input from the outside, the sole right to make a decision within a 
particular domain rests with them". "Closed" is not about how the 
decisions are made, but rather about who gets to make the decisions.

>   In both, the IESG and IAB, we have been and are implementing new measures to increase transparency and also make sure we have good ways to collect feedback from the community where needed.

I appreciate that, but that doesn't change either of the IAB or IESG 
from being closed.   Nor from operating in a totally closed mode for 
some of their responsibilities (e.g. selection of the ISE and RSE for 
example by calling them personnel actions).

>   (The ISE is different but very much on purpose in order to actually be independent). There might be a need for a person or group that dictates work and time for the RFC series as well, however, I’m still trying to understand how much work force is needed if we separate out the daily business (which I think is the most important step we should take here).

I think you're asking two questions:  "what is the daily load for the 
RSE vice the long-term strategic load? " as well as "can these two 
actually be separated and what are the pro's and con's for doing so?"  
Speaking as someone who has occasionally had a job with both tactical 
and strategic responsibilities in the same limited domain - it's rare 
that you can slice off the day to day stuff and have the coherency you 
need for the long term.

> Such a person or group might be a leadership position, however, if that is the case I would feel more comfortable if that would be run on a voluntarily based instead by a paid contractor as we also do for other leadership positions.

Voluntarily based is a red-herring.  Almost all of the folk who do work 
for the IETF get compensated for it some how.  Your "volunteer" in this 
case is going to end up finding someone to pay for the work (unless the 
work becomes so trivial and intermittent that it's rounding error work).

> Second, the streams we have are all very different and as such have very different procedures. That’s exactly the reason that we have different streams. The most noticeable different between the IE…

Except that these are all RFC's.  And in the final analysis, they all 
have to follow the general guidelines for publication as an RFC.  The 
fact that the input models are different, and that some RFCs have 
additional tags added to them (BCP, Standard) doesn't change the fact 
that the similarities far outweigh the differences.

And while we have rules related to the IESG publication of standards, 
it's unclear there is anything preventing the IESG from publishing an 
IESG originated document even in the face of negative last calls.  There 
definitely isn't anything preventing either the IRSG or the IAB from 
self-publication without additional approvals.

The last call is not a veto in any sense of the word, and characterizing 
it as such is misleading.  The IESG may publish any document simply by 
declaring its understanding of consensus.  It may get in trouble the 
next time the Nomcom meets, but that won't keep the document from being 
published.

Later, Mike