Subject: [Rfced-future] Fwd: I-D Action: draft-nottingham-where-does-that-come-from-00.txt

From: Martin J. Dürst <[email-masked]>
Date: Mon, 15 Mar 2021 10:11:54 +0900

I think this draft is a simple example of work that might in some way or 
another in the future be done by the roles and in the structures that we 
are currently working on.

Regards,   Martin.

-------- Forwarded Message --------
Subject: I-D Action: draft-nottingham-where-does-that-come-from-00.txt
Date: Thu, 11 Mar 2021 17:44:33 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

         Title           : Clarifying IETF Document Status
         Author          : Mark Nottingham
	Filename        : draft-nottingham-where-does-that-come-from-00.txt
	Pages           : 7
	Date            : 2021-03-11

Abstract:
    There is widespread confusion about the status of Internet-Drafts and
    RFCs, especially regarding their association with the IETF and other
    streams.  This document recommends several interventions to more
    closely align reader perceptions with actual document status.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-nottingham-where-does-that-come-from/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-nottingham-where-does-that-come-from-00.html

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
.

---

From: Russ Housley <[email-masked]>
Date: Mon, 15 Mar 2021 10:05:11 -0400

I think the logo in RFCs is a good idea.  However, in I-Ds, we often put forward an idea thinking that we know which stream it will land, but due to comments or other events the document lands in a different stream.  

Russ

-------- Forwarded Message --------
Subject: I-D Action: draft-nottingham-where-does-that-come-from-00.txt
Date: Thu, 11 Mar 2021 17:44:33 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Abstract:

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 15 Mar 2021 11:47:05 -0600

I’m think have the logo in the RFC, and a authoritative location to get them from is a good idea. 

> On Mar 14, 2021, at 7:11 PM, Martin J. Dürst <[email-masked]> wrote:
> 
> I think this draft is a simple example of work that might in some way or another in the future be done by the roles and in the structures that we are currently working on.
> 
> Regards,   Martin.
> 
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 15 Mar 2021 15:44:59 -0400

If one wants an authoritative location for RFCs, then one gets them from 
rfc-editor.org.

The logos may be a good idea.  (We have an unfortunate problem that 
there is no decision process for resolving that part.  It isn't the 
IETF's call by itself.)

Yours,
Joel

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Mar 2021 09:15:34 +1300

I'm not completely convinced that a logo is a good idea. But something, certainly, in every PDF, HTML or HTMLized rendering: for example a simple status line in big bold letters:

Informational (IETF)
Informational (IAB)
Informational (IRTF)
Informational (Independent)

Experimental (IETF)
Experimental (IRTF)
Experimental (Independent)

Best Current Practice (IETF)
Proposed Standard (IETF)
Standard (IETF)

and retrofit:

Obsolete
Historic
Status Unknown

Regards
   Brian Carpenter

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 15 Mar 2021 20:37:35 +0000

It is up to the IETF Trust, as the logo is part of the intellectual property they manage.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 15 Mar 2021 16:50:58 -0400

I may have phrased my point badly.  My concern is not whether we can get 
permission to use the logos.  The Trust will do what it is told in terms 
of making such available to the IETF.  The problem is that this 
"program" has a very narrow remit, and until it finishes and determines 
what the structure should be, there is no program authorized to make the 
level of decision to decide to modify the format by including different 
logos (or bold header lines, or...).  (John Levine's remit is carefully 
narrow.  And the RSOC is not decisional.  Assuming it still exists, it 
is oversight.)

Yours,
Joel

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 15 Mar 2021 17:40:40 -0400

Joel,

Since there's no one entity that currently has remit to make a decision of
this sort, perhaps it's up to each stream manager to decide whether to have
a logo or not for their stream, although it would be nice if they all
agreed. :-)

Actually, I think Brian's suggestion and a logo are both good ideas. These
days, branding is everything.

Cheers,
Andy

---

From: Jay Daley <[email-masked]>
Date: Tue, 16 Mar 2021 10:55:21 +1300

You may all be interested in the following note I’ve just sent to the tools-discuss list:

> As we all know, RFCs are published on three sites: RFC Editor site, Datatracker and tools.ietf.org; and I-Ds on a different three: www.ietf.org, Datatracker and tools.ietf.org. These documents are published in TXT, HTMLised TXT, native HTML, PDF and XML, with different sites publishing different combinations, different metadata, different features, different URL structures and different combinations of links to each other.
> 
> To understand this and to help the various groups/people think about what changes are needed to declutter this, I’ve been through each of the three site and drawn up a comprehensive feature matrix:
> 
> 	https://docs.google.com/spreadsheets/d/1Ljj4QV6YmvQo4F8MtydZH9owvwH-dMOJcwSaz5CW4E0/edit?usp=sharing
> 
> I so far have not looked at this through the lens of sub-series (e.g BCP)
> 
> Please let me know if you see any errors or omissions.
> 
> Jay
> 
> PS the switch between RFC 8179 and RFC 8719 for examples is deliberate not a typo.

The matrix currently does not include logos or stream names as the former are not used and the latter are ubiquitous.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Mar 2021 15:35:56 +1300

On 16-Mar-21 10:40, Andrew G. Malis wrote:
> Joel,
> 
> Since there's no one entity that currently has remit to make a decision of this sort, perhaps it's up to each stream manager to decide whether to have a logo or not for their stream, although it would be nice if they all agreed. :-)
> 
> Actually, I think Brian's suggestion and a logo are both good ideas. These days, branding is everything.

Here's how my suggestion might look:
https://www.cs.auckland.ac.nz/~brian/rfc1X.html
https://www.cs.auckland.ac.nz/~brian/rfc8989X.html

    Brian

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 19 Mar 2021 00:21:00 +1100

> If one wants an authoritative location for RFCs, then one gets them from 

I am new enough to the IETF that I can tell you for sure that before I joined the IETF there's no way that I would have known that "rfc-editor.org" was the authoritative location for the IETF's RFCs.  Lots of other organisations and open source projects also call their specs "RFC" - it's the IETF brand that I would have recognised.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 18 Mar 2021 15:17:01 +0000

*   I am new enough to the IETF that I can tell you for sure that before I joined the IETF there's no way that I would have known that "rfc-editor.org" was the authoritative location for the IETF's RFCs.  Lots of other organisations and open source projects also call their specs "RFC" - it's the IETF brand that I would have recognised.

So maybe we make rfc.ietf.org be a CNAME to point to rfc-editor.org ?

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 19 Mar 2021 07:59:25 +1100

On Fri, Mar 19, 2021, at 02:17, Salz, Rich wrote:

> So maybe we make rfc.ietf.org be a CNAME to point to rfc-editor.org ? 

I'm not sure I understand how that would help - maybe my understanding of CNAMEs is totally off - most of my knowledge is how they interact (badly) with email routing - but my impression is that users wouldn't be more likely to see "ietf" in either search results or the URL bar after following a link to rfc.ietf.org if it was CNAME.

Bron.