Subject: [Rfced-future] #120 Clarification on performance targets text

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Nov 2021 16:23:32 +0100

Hi all,

I don’t have strong opinion here but given #120 doesn’t provided any context, I would like to provide this context here before we close the issue.

The only text we currently have in the draft about performance targets it this:

"Therefore, the IETF LLC has authority over negotiating performance targets for the RPC and also has responsibility for ensuring that those targets are adhered to.”

We don’t say anything about where this performance targets come from and what they should be about. I believe we had a lengthy discussion that we don’t want to micro-manage here and I even made a strong point about this, but I think we could at the end just say a tiny little more. So I proposed to add this sentence:

"Performance targets are set based on the current publication load as well as additional efforts as requested in policies by the RSWG and may be consulted with the community.”

Other proposals are of course welcome. Not adding anything is also okay for me.

Mirja

---

From: Jay Daley <[email-masked]>
Date: Thu, 11 Nov 2021 04:31:07 +1300

> On 11/11/2021, at 4:23 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi all,
> 

I would prefer not to try and scope the nature of RPC performance targets here and now as this is already a complex area that is going to change in ways we don’t yet properly understand in the new model.  For example, "performance" is likely to mean more than "speed of processing", including:

- correctness
- cost per page
- author satisfaction

and so on.

Jay

> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 11 Nov 2021 02:34:46 +1100

On Thu, Nov 11, 2021, at 02:31, Jay Daley wrote:
> I would prefer not to try and scope the nature of RPC performance 
> targets here and now as this is already a complex area that is going to 
> change in ways we don’t yet properly understand in the new model.  

This seems sensible to me.  One of the many issues with the RSOC model was their involvement in this part of the process.  We should - to the extent possible - not add those to the set of things this group needs to concern itself with.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Nov 2021 16:36:41 +0100

Okay, thanks for confirming.

> On 10. Nov 2021, at 16:34, Martin Thomson <[email-masked]> wrote:
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Nov 2021 16:39:02 +0100

Actually, just to warp this up entirely then. So we maybe then even need to say less and strike the existing sentence about performance targets as well?

The full paragraph is:

"The IETF LLC is responsible for the method of and management of the engagement of the RPC. Therefore, the IETF LLC has authority over negotiating performance targets for the RPC and also has responsibility for ensuring that those targets are adhered to. The IETF LLC is empowered to appoint a manager or to convene a committee to complete these activities.”

> On 10. Nov 2021, at 16:36, Mirja Kuehlewind <[email-masked]> wrote:
>

---

From: Jay Daley <[email-masked]>
Date: Thu, 11 Nov 2021 04:39:42 +1300

> On 11/11/2021, at 4:34 AM, Martin Thomson <[email-masked]> wrote:
> 

I’m happy for the draft to include a requirement for the LLC to consult on the performance targets or otherwise ensure community engagement in their development, though as Brian has pointed out before, that is the expected standard operating procedure for the LLC.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 11 Nov 2021 12:02:54 -0700

Jay, what say you?

---

From: Jay Daley <[email-masked]>
Date: Fri, 12 Nov 2021 11:11:19 +1300

> On 12/11/2021, at 8:02 AM, Peter Saint-Andre <[email-masked]> wrote:
> 
> Jay, what say you?

Fine by me.  I should note that we appear to be rather casually removing text that a number of people previously asked for and went through a few iterations to get right, but if nobody objects then I certainly don’t.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Fri, 12 Nov 2021 07:19:18 +0100

Indeed.  There needs to be a lot more support for change.