Subject: [Rfced-future] pricniples and review

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 17 Nov 2021 22:27:29 -0500

EKR correctly pointed out in a response to me that we already have text 
that says that the RSAB members are expected to watch out for harm to 
the long term health of the series.
This caused me to try to think through what I am trying to get out of 
having these principles in the document, and what mechanisms we might 
use to achieve it.  So I am now wondering if a slightly different 
approach to the sensitivity of the principles might help; instead of 
pointing to the IAB and IESG.
(Side note: I have not talked to any of the other proponents of having 
principles, and I have not tried to wordsmith the below.):

     The following principles are understood to be important to
     the RFC series.  When reviewing documents from the RSWG that
     either change these principles, or significantly change the
     way they are realized, the RSAB members are expected to pay
     particular attention to
     a) whether the changes adversely affect the long term health
         of the RFC series; and
     b) whether the changes have received sufficient review and
         comment in the larger community affected by the RFC Series

?

Yours,
Joel

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 18 Nov 2021 14:37:27 +1100

Just for clarity - is that proposal a complete replacement, or to be prepended to Mike's proposed list?

> On 18 Nov 2021, at 2:27 pm, Joel M. Halpern <[email-masked]> wrote:
> 
> EKR correctly pointed out in a response to me that we already have text that says that the RSAB members are expected to watch out for harm to the long term health of the series.
> This caused me to try to think through what I am trying to get out of having these principles in the document, and what mechanisms we might use to achieve it.  So I am now wondering if a slightly different approach to the sensitivity of the principles might help; instead of pointing to the IAB and IESG.
> (Side note: I have not talked to any of the other proponents of having principles, and I have not tried to wordsmith the below.):
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

--
Mark Nottingham   https://www.mnot.net/

---

From: John C Klensin <[email-masked]>
Date: Wed, 17 Nov 2021 23:23:02 -0500

--On Wednesday, November 17, 2021 22:27 -0500 "Joel M. Halpern"
<[email-masked]> wrote:

> EKR correctly pointed out in a response to me that we already
> have text that says that the RSAB members are expected to
> watch out for harm to the long term health of the series.
> This caused me to try to think through what I am trying to get
> out of having these principles in the document, and what
> mechanisms we might use to achieve it.  So I am now wondering
> if a slightly different approach to the sensitivity of the
> principles might help; instead of pointing to the IAB and IESG.
> (Side note: I have not talked to any of the other proponents
> of having principles, and I have not tried to wordsmith the
> below.):
> 

Joel,

I think this may be on the right track.  However, with the way
we have composed the RSAB, there is really no reason to believe
that its members will have the expertise to reliably answer
either of those questions without introducing additional
process.  That leads back to either my interpretation of that
part of Mike's proposal, i.e., 

	* force review and approval by additional bodies who
	have perspective and general responsibility beyond the
	series, specifically the IAB, IESG, and LLC Board (if it
	is working correctly, I consider the IAB the most
	important of these, but that is a detail)
	
or some variation on mine,

	* think through in advance how to be sure a much broader
	community can be made aware of the potential changes and
	given an opportunity rather that relying on either
	contacts made in the middle of the review process or on
	the "feelings" of RSAG members as to what the effects
	might be. 

best,
   john

---

From: Eliot Lear <[email-masked]>
Date: Thu, 18 Nov 2021 09:51:17 +0100

Thank you Joel.

You have placed a concrete proposal on the table.

>         comment in the larger community affected by the RFC Series 

Is this text a reasonable basis for discussion?   It provides what could 
be described as extraordinary review, but perhaps not TOO 
extraordinary.  It requires a starter list of principles. Some of those 
principles are already stated in the document.  I suspect we could 
incorporate one or two more from Mike's list (I doubt that anyone would 
object, for instance, to accessibility showing up).  I recognize that 
there is some concern abut having ANY principle in the draft, but this 
would be a compromise.

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 18 Nov 2021 08:44:40 -0500

My suggestion is that the text I provided, or text along those lines, 
become the opening of the section on principles.  That the principles 
themselves not refer to the approach to modification.
As for what the content of the principles would be, I would start with 
Mike's list.  We can add or subtract from there.

The primary objection I was seeing was to the proposed modification 
process.  So I am trying to see if there is something in between that we 
can live with.

Yours,
Joel

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 18 Nov 2021 06:27:20 -0800

> process.  So I am trying to see if there is something in between that we

Just to clarify, my objection is *both* to the proposed modification process
*and* to much of the text in Mike's proposal, so this would not address
my concern.

-Ekr

Yours,
> that says that the RSAB members are expected to watch out for harm to the
> long term health of the series.
> having these principles in the document, and what mechanisms we might use
> to achieve it.  So I am now wondering if a slightly different approach to
> the sensitivity of the principles might help; instead of pointing to the
> IAB and IESG.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 19 Nov 2021 10:03:09 +1300

On 19-Nov-21 03:27, Eric Rescorla wrote:
> 
> 
> On Thu, Nov 18, 2021 at 5:44 AM Joel M. Halpern <[email-masked] <mailto:[email-masked]>> wrote:
> 
To be clear: do you object to:

>  the RSAB members are expected to pay
>     particular attention to

and if so, why?

> *and* to much of the text in Mike's proposal

Please be specific, line by line. You can't just hand wave.

Regards
     Brian

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 18 Nov 2021 13:23:23 -0800

> >         comment in the larger community affected by the RFC Series

This text on its own doesn't seem particularly problematic. The question is
what its
referents are.

> Please be specific, line by line. You can't just hand wave.

I'm not just handwaving. I've provided several examples of pieces I object
to. However,
given that I don't think this text should exist at all, I also do not
propose to go through
the entire thing in an attempt to find some unobjectionable parts. Once the
RSWG is
properly formed, if people want to try to form a principles doc, then that
process
will be appropriate, but at the moment it's a distraction.

-Ekr

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 19 Nov 2021 11:09:36 +1100

FWIW -

> On 18 Nov 2021, at 7:51 pm, Eliot Lear <[email-masked]> wrote:
> 
> Thank you Joel.
> 
> Is this text a reasonable basis for discussion?   It provides what could be described as extraordinary review, but perhaps not TOO extraordinary.  

As far as the change process issue goes, I have no issue with this text. However...

> It requires a starter list of principles. Some of those principles are already stated in the document.  I suspect we could incorporate one or two more from Mike's list (I doubt that anyone would object, for instance, to accessibility showing up).  I recognize that there is some concern abut having ANY principle in the draft, but this would be a compromise.

I (and I suspect others) haven't thought deeply about either Mike's list or what principles I'd propose because we haven't yet gained consensus to include principles in the draft. That is a conscious decision that we should make before talking about their content. 

As I argued earlier,[1] defining principles for the series aren't a good fit for this body. We're supposed to be coming up with a process to create policy, not guidance for that policy itself. The RSWG has better oversight than this body, in that it has multiple layers and doesn't depend on a frankly fragile agreement in the community to function. I also would like to get this work done and move on, and I suspect establishing principles worthy of the series is going to take at least several months.

If -- despite all of that -- we gain consensus to establish principles, we need to do so properly.

To me, that means that the Chairs should make a call for proposed principles -- not privileging Mike's list as a de facto starting point. We need to create an issue per principle and discuss them separately, not as a job lot, and only those that gain consensus should be included. If folks want to withhold consensus on the entire document because their favoured principle didn't make it in, we'll have to cross that bridge when we get to it.

Underlying all of this -- I think we can all agree that principles should be robust over time, and reflect the experience and wisdom we've managed to gather. They cannot be tacked on at the last minute. 

Cheers,

1. https://mailarchive.ietf.org/arch/msg/rfced-future/7YIKkSFWgo8eSWraf3LCmNhcFzY

---

From: Eliot Lear <[email-masked]>
Date: Fri, 19 Nov 2021 07:10:29 +0100

Mark,

> As far as the change process issue goes, I have no issue with this text. However...

Good to know.

> I (and I suspect others) haven't thought deeply about either Mike's list or what principles I'd propose because we haven't yet gained consensus to include principles in the draft. That is a conscio…

Enough people have expressed just such a desire that in order for the 
document to go forward, we must take the view that we are past that point.

>
> As I argued earlier,[1] defining principles for the series aren't a good fit for this body. We're supposed to be coming up with a process to create policy, not guidance for that policy itself.

While I am not taking a position about the wisdom of going through this 
exercise, the IAB placed no constraint on us doing so.  If you think I 
am misreading this group's charter, please explain which part.

There are, I think, principles that we may already already decided NOT 
to debate, and as and when those arise, the chairs can rule on those points.

>   The RSWG has better oversight than this body, in that it has multiple layers and doesn't depend on a frankly fragile agreement in the community to function. I also would like to get this work done and move on, and I suspect establishing principles worthy of the series is going to take at least several months.
>
> To me, that means that the Chairs should make a call for proposed principles -- not privileging Mike's list as a de facto starting point.

I agree that Mike's list cannot not be privileged.  For one thing, it 
lacks rough consensus.  For another, you and others might wish to add a 
few principles of your own for consideration, and you would certainly be 
entitled to do so.  However, see below.

> We need to create an issue per principle and discuss them separately, not as a job lot, and only those that gain consensus should be included.

The chairs will discuss the mechanism today, but I think the group has a 
choice.  We can be conservative in this list and include those 
principles where it is clear that we ALREADY have consensus – and I 
think there several we can find where this is the case; or we can go on 
what is likely to be a lengthy exercise to try to further develop 
consensus on additional points.  We can also document in this draft 
principles we discussed that didn't find consensus but may be worth 
considering in the context of the RSWG.  I think the key point to make 
relating to the above text you have no problem with is that the process 
is designed to allow the community to evolve its views and policies over 
time.

> If folks want to withhold consensus on the entire document because their favoured principle didn't make it in, we'll have to cross that bridge when we get to it.
>
> Underlying all of this -- I think we can all agree that principles should be robust over time, and reflect the experience and wisdom we've managed to gather. They cannot be tacked on at the last minute. '

Gosh I hope so.

Eliot

---

From: Eliot Lear <[email-masked]>
Date: Fri, 19 Nov 2021 07:12:28 +0100

Sorry... one edit:

On 19.11.21 07:10, Eliot Lear wrote:
>
> I agree that Mike's list cannot not be privileged.

s/cannot not/cannot/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 19 Nov 2021 17:54:05 +1100

Eliot,

> On 19 Nov 2021, at 5:10 pm, Eliot Lear <[email-masked]> wrote:
> Enough people have expressed just such a desire that in order for the document to go forward, we must take the view that we are past that point.

That's unpleasantly surprising to hear from a chair. In my mind the entire discussion to date has been of the character -- 'should we do this'. Doubtless a few people want to hurry that along and get to what they perceive as the 'meat' of the discussion, but that doesn't mean that we should (or can) make such a weighty decision so quietly and arbitrarily.

If I'm the only person that feels that way, I'll (unhappily) demure. I suspect I'm not -- I.e., I do *not* believe that we already have consensus to include principles in the draft. If you want to try to declare a consensus there, do it properly, not as an aside.

> While I am not taking a position about the wisdom of going through this exercise, the IAB placed no constraint on us doing so.  If you think I am misreading this group's charter, please explain which part.

It says:

"This program is intended to foster discussion and consensus on potential changes to the RFC Editor model.  Discussion of changes to how the RFC Editor function is managed, staffed, and overseen are all within scope."

It also says:

"This program has no predetermined constraints on the decisions of the group.  Updates to or retention of the oversight model, management, and the roles involved in the RFC Editor function are all within scope."

"no predetermined constraints" is clearly *not* a get-out clause to cover anything we wish. Everything in this charter is about _process_, not the actual outcomes (policies).

As I recall there was earlier strong pushback on actually establishing policy in this group, and consensus to avoid doing so. Establishing principles -- many of which have a strong character of policy (e.g., English as the official language) -- violates that.

Again, if I'm in the rough, so be it, but please do it properly.

> There are, I think, principles that we may already already decided NOT to debate, and as and when those arise, the chairs can rule on those points.

I wish you'd say 'attempt to find consensus' instead of 'rule'...

> I agree that Mike's list cannot not be privileged.  For one thing, it lacks rough consensus.  For another, you and others might wish to add a few principles of your own for consideration, and you would certainly be entitled to do so.  However, see below.
> 
> The chairs will discuss the mechanism today, but I think the group has a choice.  We can be conservative in this list and include those principles where it is clear that we ALREADY have consensus – and I think there several we can find where this is the case; or we can go on what is likely to be a lengthy exercise to try to further develop consensus on additional points.  We can also document in this draft principles we discussed that didn't find consensus but may be worth considering in the context of the RSWG.  I think the key point to make relating to the above text you have no problem with is that the process is designed to allow the community to evolve its views and policies over time.

You're again assuming consensus that hasn't yet been established. Please stop, and please do this correctly -- we've all invested a lot of time in this so far.

---

From: Eliot Lear <[email-masked]>
Date: Fri, 19 Nov 2021 08:53:25 +0100

Mark,

> That's unpleasantly surprising to hear from a chair. In my mind the entire discussion to date has been of the character -- 'should we do this'.

Based on who has commented on list, a somewhat larger number of people 
want some discussion of principles in the document than those who do 
not.  I am acknowledging that as should you.  I see no point in 
repeating the exercise of counting hands. Furthermore, it's clear to the 
chairs that we cannot close the document without accommodating that view 
in some way.  We may not be able to close the document in any case.  
That is something we will determine later, as you previously noted.

> [The Charter] says:
> "no predetermined constraints" is clearly *not* a get-out clause to cover anything we wish.

I take the text to mean is that we can cover ground relating to "**the 
management, the oversight model, management, and roles involved..." 
without predetermined constraints.  You can appeal to the IAB on this 
point if you wish- these are their words, and they can clarify them or 
change the charter, but to me, the plain reading does not constrain us.  
What's more, it's clear from the majority of views expressed that people 
want  some statement about principles, and we won't close the document 
without them. Conveniently there are already some stated in the draft.

> You're again assuming consensus that hasn't yet been established.

To be clear, if we as a group can establish crisply on that which we 
already agree, that is at least one list we can include in the 
document.  As I wrote earlier, we can poll to determine this.  I am 
making no assumptions.

Eliot

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 19 Nov 2021 20:42:26 +1100

On Fri, Nov 19, 2021, at 18:53, Eliot Lear wrote:
> Furthermore, it's clear to 
> the chairs that we cannot close the document without accommodating that 
> view in some way.  

Addressing. Not accommodating.

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 19 Nov 2021 06:17:13 -0800

On Thu, Nov 18, 2021 at 10:54 PM Mark Nottingham <[email-masked]> wrote:

> >> I (and I suspect others) haven't thought deeply about either Mike's
> list or what principles I'd propose because we haven't yet gained consensus
> to include principles in the draft. That is a conscious decision that we
> should make before talking about their content.
> >
> That's unpleasantly surprising to hear from a chair. In my mind the entire
> discussion to date has been of the character -- 'should we do this'.
> Doubtless a few people want to hurry that along and get to what they
> perceive as the 'meat' of the discussion, but that doesn't mean that we
> should (or can) make such a weighty decision so quietly and arbitrarily.
>

> If I'm the only person that feels that way, I'll (unhappily) demure. I
> suspect I'm not -- I.e., I do *not* believe that we already have consensus
> to include principles in the draft. If you want to try to declare a
> consensus there, do it properly, not as an aside.
>

Unsurprisingly, I concur with Mark. If you think that there is rough
consensus to include principles in the draft, then declare it.

However, what you say above is entirely different, which is that you
believe that there are enough people who want them that we cannot proceed
without it. However, it is possible that the opposite is *also* true. The
way that this situation is handled is to continue the WG process until we
*do* reach some rough consensus, not for the chairs to just arbitrarily
decide

-Ekr

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Nov 2021 17:17:42 -0700

> As I argued earlier,[1] defining principles for the series aren't a good fit for this body. We're supposed to be coming up with a process to create policy, not guidance for that policy itself. The…

This strongly matches my understanding of our remit and that's one 
reason I signed on to editing our document. Personally as editor I am 
comfortable defining a process to create policy, but I am not 
comfortable defining policy itself (or active guidance for policy - the 
line between them is quite fuzzy, in my mind at least).

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 23 Nov 2021 10:23:39 -0700

On 11/22/21 5:17 PM, Peter Saint-Andre wrote:
>> As I argued earlier,[1] defining principles for the series aren't a 
>> good fit for this body. We're supposed to be coming up with a process 
>> to create policy, not guidance for that policy itself. The RSWG has 
>> better oversight than this body, in that it has multiple layers and 
>> doesn't depend on a frankly fragile agreement in the community to 
>> function. I also would like to get this work done and move on, and I 
>> suspect establishing principles worthy of the series is going to take 
>> at least several months.
> 

Someone contacted me offlist about this topic, and I wanted to add one 
more amplification. The Program definition [1] states:

   This program is intended to foster discussion and consensus on
   potential changes to the RFC Editor model.

That is, our job is to develop the next version of the RFC Editor 
*model*, not to define principles or policies for the RFC *series*.

Although opinions may differ and some folks think we can do whatever we 
want, I'd prefer to be "conservative in what we send" here.

Peter

[1] 
https://www.iab.org/activities/programs/rfc-editor-future-development-program/