Subject: [Rfced-future] How can this process be changed?

From: Eliot Lear <[email-masked]>
Date: Wed, 10 Nov 2021 17:38:54 +0100

There seems to be some confusion – and justifiably so – as to how the 
RSWG/RSAB process can change.  We don't say so in the document, and we 
need to do so.  What we say is that the scope of the editorial stream 
can't change.

My proposal is that we be explicit, that the RSWG may propose changes to 
THIS process.  The reason I think that's safe is that the streams are 
well represented in the RSAB and will pay particular attention to such 
changes.

If others want to offer alternatives, please do so quickly.

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 10 Nov 2021 12:01:34 -0500

The RSAB does not have the level of oversight and review of the RSWG 
that the IESG has relative to IETF working groups.

Technically, the IESG defines working group charters.  Working groups 
can't change their own charters.

changing the scope (charter) of the RSWG is something that should be 
visibly a big deal.  Not something that can be part of the normal 
process.   We can not constrain how the IESG and IAB want to manage 
this.  But the process has to be up to them, not up to the RSWG.

I can live with leaving this unspecified as that leaves it to the IESG / 
IAB implicitly to handle.  I can live with adding text that says that 
amendments to this RFC are to be handled by a process defined by 
agreement between the IESG and IAB.  At least there is a decent chance 
that their announcement of how they want to work on such a change will 
go to enough places early enough, and attract enough attention, to get 
folks involved before the RSWG forms a consensus, and then drives it.

Yours,
Joel

---

From: Eliot Lear <[email-masked]>
Date: Wed, 10 Nov 2021 20:42:14 +0100

> this.  But the process has to be up to them, not up to the RSWG.

Let's agree that it can't be done by the RSWG alone.  We can even say 
that we would like the same approvals that change the scope of the 
editorial stream, which reads:

> This policy may be changed only by agreement of the IAB, IESG, and 
> IETF LLC.

We can say something else.  But we have to say something, because the 
IETF are about to remove authority from the IAB, and we haven't 
specified additional authority for anyone else.

Eliot

---

From: "jmh.direct" <[email-masked]>
Date: Wed, 10 Nov 2021 14:50:54 -0500

I can live with proposed text below.Yours,JoelSent via the Samsung Galaxy S20 FE 5G, an AT&T 5G smartphone
-------- Original message --------From: Eliot Lear <[email-masked]> Date: 11/10/21  2:42 PM  (GMT-05:00) To: "Joel M. Halpern" <[email-masked]>, [email-masked] Subject: Re: How can this process be changed? On 10.11.21 18:01, Joel M. Halpern wrote:> The RSAB does not have the level of oversight and review of the RSWG > that the IESG has relative to IETF working groups.>> Technically, the IESG defines working group charters.  Working groups > can't change their own charters.>> changing the scope (charter) of the RSWG is something that should be > visibly a big deal.  Not something that can be part of the normal > process.   We can not constrain how the IESG and IAB want to manage > this.  But the process has to be up to them, not up to the RSWG.Let's agree that it can't be done by the RSWG alone.  We can even say that we would like the same approvals that change the scope of the editorial stream, which reads:> This policy may be changed only by agreement of the IAB, IESG, and > IETF LLC.We can say something else.  But we have to say something, because the IETF are about to remove authority from the IAB, and we haven't specified additional authority for anyone else.Eliot

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 11 Nov 2021 15:26:34 +1100

How about:

Updates, amendments and refinements of this document can be produced using the process documented here, but are only operative upon agreement of the IAB, the IESG, and the IETF LLC. Note that this does not preclude such changes from being defined outside this process, so long as the same agreement is found.

> On 11 Nov 2021, at 6:42 am, Eliot Lear <[email-masked]> wrote:
> 
> 
>> The RSAB does not have the level of oversight and review of the RSWG that the IESG has relative to IETF working groups.
>> 
>> Technically, the IESG defines working group charters.  Working groups can't change their own charters.
>> 
>> changing the scope (charter) of the RSWG is something that should be visibly a big deal.  Not something that can be part of the normal process.   We can not constrain how the IESG and IAB want to manage this.  But the process has to be up to them, not up to the RSWG.
> 
> Let's agree that it can't be done by the RSWG alone.  We can even say that we would like the same approvals that change the scope of the editorial stream, which reads:
> 
>> This policy may be changed only by agreement of the IAB, IESG, and IETF LLC.
> 
> We can say something else.  But we have to say something, because the IETF are about to remove authority from the IAB, and we haven't specified additional authority for anyone else.
> 
> Eliot
> 
> <OpenPGP_0x87B66B46D9D27A33.asc>-- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 11 Nov 2021 15:52:44 +0900

Hello Mark, others,

> Updates, amendments and refinements of this document can be produced using the process documented here, but are only operative upon agreement of the IAB, the IESG, and the IETF LLC. Note that this…

I really like this, because it gives the RSWG/RSAB the chance to fix 
obvious issues in the process (e.g. after a review of the current 
process a few years in), while also allowing changes from the outside if 
needed.

Regards,    Martin.

---

From: Eliot Lear <[email-masked]>
Date: Thu, 11 Nov 2021 08:44:09 +0100

Hi Martin,

On 11.11.21 07:52, Martin J. Dürst wrote:
>> Updates, amendments and refinements of this document can be produced 
>> using the process documented here, but are only operative upon 
>> agreement of the IAB, the IESG, and the IETF LLC. Note that this does 
>> not preclude such changes from being defined outside this process, so 
>> long as the same agreement is found.
>
> process a few years in), while also allowing changes from the outside 
> if needed.
>
Ok.  Are there any objections to this approach?  This will be tied with 
one other proposed resolution.  See a separate note soon.

Eliot

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 11 Nov 2021 19:06:17 +1100

WFM

---

From: Jay Daley <[email-masked]>
Date: Thu, 11 Nov 2021 21:42:38 +1300

> On 11/11/2021, at 9:06 PM, Martin Thomson <[email-masked]> wrote:
> 
> WFM

+1

-- 
Jay Daley
IETF Executive Director 
[email-masked]

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Nov 2021 10:20:00 +0100

I'm okay with the text below, however, I think most of word are just unnecessary. The requirement below is simply:

"Updates, amendments and refinements of this document require agreement of the IAB, the IESG, and the IETF LLC."

The text below basically says then further than any process can be used to produce these changes. But that doesn’t really say anything. So I would prefer a wording like the above to make the requirement crystal clear. If we want to be explicit I guess we can add another sentence:

“Such changes can be produced in the RSWG or any other process that is accepted by the community.”

Mirja

> On 11. Nov 2021, at 09:42, Jay Daley <[email-masked]> wrote:
> 
> 
>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 11 Nov 2021 10:29:14 +0100

Fewer words are better.  More comments?

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 11 Nov 2021 06:41:57 -0500

I prefer these words to the proposal from Mark.
They put the responsibility in the right place. (While I find myself 
wanting stronger words, I think that is probably over-specifying.)

Yours,
Joel

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 12 Nov 2021 13:39:05 +1100

I think explicitly saying that such changes are in scope for discussion in the RSWG is worthwhile, given the uncertainty that we've seen so far. 

I'm very economical with words when I know lots of people are going to be reading a document and extra words will get in their way. However, when a point is potentially contentious in the future, spending some words now is a very good investment.

Cheers,

> On 11 Nov 2021, at 8:29 pm, Eliot Lear <[email-masked]> wrote:
>