Subject: [Rfced-future] Appeals issues

From: "Martin Thomson" <[email-masked]>
Date: Wed, 03 Nov 2021 14:23:53 +1100

Eliot prompted me to suggest resolutions to the issues I raised about appeals.

For #93, I suggest:

OLD:
    However, in the interest of time the disagreement may be resolved as the parties best see fit while the RSWG formulates a more general policy.
NEW:
    However, in the interest of time the RSAB may propose resolutions for disagreements after referring the matter to the RSWG to formulate a more general policy.

For #94, I suggest:

ADD:
    Decisions of the RSAB can be appealed on grounds of failure to follow the correct process. Where the RSAB makes a decision in order to resolve a dispute (or for other reasons??), appeals can be filed on the basis that the RSAB misinterpreted an approved policy that was established by the RSWG. In other cases, disagreements about the conduct of the RSAB are not subject to appeal.

That is, we allow people to appeal if the RSAB is *wrong*, but we have to allow the RSAB to resolve disputes.  The policies will sometimes not cover things and decisions need to be made.  People can take their dispute to the bodies that have delegates on the RSAB as a last resort.  Also, people can attempt to convince the RSWG to set a policy that is different than what the RSAB might have decided in the heat of the moment.

---

From: Eliot Lear <[email-masked]>
Date: Wed, 3 Nov 2021 08:02:19 +0100

Thanks, Martin.  At this stage, there should be support for changes.  
Please discuss, agree or disagree.

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 4 Nov 2021 10:48:13 +1300

I'm a definite NO OBJECTION on these changes (i.e. I see no harm in them, 
but I'm not sure of the necessity).

Regards
    Brian Carpenter

On 03-Nov-21 20:02, Eliot Lear wrote:
>> That is, we allow people to appeal if the RSAB is *wrong*, but we have 
to allow the RSAB to resolve disputes.  The policies will sometimes not cover things and decisions need to be made.  People can take their dispute 
to the bodies that have delegates on the RSAB as a last resort.  Also, people can attempt to convince the RSWG to set a policy that is different than what the RSAB might have decided in the heat of the moment.

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 9 Nov 2021 16:15:59 -0700

>      However, in the interest of time the RSAB may propose resolutions for disagreements after referring the matter to the RSWG to formulate a more general policy.

I'm not sure the first part is an improvement, since presumably people 
or entities other than the RSAB can propose resolutions (RPC folks, 
document authors, WG chairs, stream managers, document shepherds, etc.).

The bit about referring the matter to the RSWG seems mostly fine, 
although I'm not 100% sure about the order of events (let's say the 
parties to the discussion realize only after the fact that perhaps 
there's a more general policy issue involved - is it an appealable 
offense that the RSAB didn't refer the matter to the RSWG first?), nor 
about the wisdom of always involving the RSWG in issues that could be 
quite picayune (we haven't always done a good job of steering clear of 
micromanagement - e.g., I recall very long discussions not long ago 
about whether there should be one space or two spaces after a period!).

> That is, we allow people to appeal if the RSAB is *wrong*, but we have to allow the RSAB to resolve disputes.  The policies will sometimes not cover things and decisions need to be made.  People ca…

It seems to me that (1) appeals aren't usually successful so why 
encourage them (2) sometimes a decision needs to be made with relative 
alacrity (3) it's more important to figure out whether we need a general 
policy and to get that policy right than it is to second-guess or appeal 
a decision covered under (2).

Peter

---

From: Michael StJohns <[email-masked]>
Date: Tue, 9 Nov 2021 18:54:14 -0500

On 11/9/2021 6:15 PM, Peter Saint-Andre wrote:
> that the RSAB misinterpreted an approved policy that was established 
> by the RSWG.

For about the 50th time - the RSWG does not establish policy, it 
proposes it.     Someone might argue that the RSAB misinterpreted an 
Editorial RFC, but who determines what the proper interpretations of 
such documents are if it isn't the RSAB?

So a big NO on your proposed language.

Mike

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 9 Nov 2021 17:16:44 -0700

> So a big NO on your proposed language.

I was quoting a previous email from Martin Thomson. That was not my text.

Peter

---

From: Michael StJohns <[email-masked]>
Date: Tue, 9 Nov 2021 19:21:23 -0500

> I was quoting a previous email from Martin Thomson. That was not my text.

My apologies to mis-attributing this to you.  My objection stands to the 
language.

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 9 Nov 2021 17:25:14 -0700

On 11/9/21 5:21 PM, Michael StJohns wrote:
> My apologies to mis-attributing this to you. 

No worries!

> My objection stands to the 
> language.
> 

Yes, agreed. For clarity, a policy is established through the process 
described in our document: an RSWG proposal, approved by the RSAB, 
published as an RFC. I suspect Martin's phrasing was merely shorthand.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Nov 2021 14:21:15 +1300

> My apologies to mis-attributing this to you.  My objection stands to the

That being duly noted, it seems to me that the sentence would work, and
be useful, if it ended thus:
"...that the RSAB misinterpreted an approved policy."
It's all a bit of a corner case, though, and I'm not sure that death by
a thousand corner cases is helping us. Whatever we do will have corner cases,
so we cannot win by more and more analysis.

    Brian

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 10 Nov 2021 14:58:35 +1100

> document authors, WG chairs, stream managers, document shepherds, etc.).

The problem I'm trying to address here is that there is no responsibility in the original text.  Who owns the decision?

Sure, in most cases, things will just be resolved to mutual satisfaction.  But someone has to be responsible if the decision is wrong.

> although I'm not 100% sure about the order of events 

I don't care about order of events.  

Maybe instead:

> However, in the interest of time the RSAB may propose resolutions for disagreements. Disagreements about the interpretation of policies shall be referred to the RSWG so they might consider proposals for policies that address shortcomings.

> encourage them 

I don't see how the text I proposed did that.  I'm just trying to say what can be appealed and what cannot.

> (2) sometimes a decision needs to be made with relative alacrity 

Not sure how that is relevant to that text either.  If relative alacrity is necessary, that doesn't absolve those responsible from their responsibility to conform with established policies.

> (3) it's more important to figure out whether we need a general 

Yes, I agree, but I would prefer that the appeal be answered that way than there be no recourse when there is a direct and deliberate violation of policy.

As the remediation for appeals of this nature is probably just better clarification of policies (and not any form of censure on RSAB members or anything like that), I fail to see why this proposal is objectionable.

As for MSJ's response:

> established by the RSWG.

replace with

> established by the process described in this document.

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 10 Nov 2021 08:18:03 -0700

> The problem I'm trying to address here is that there is no responsibility in the original text.  Who owns the decision?

Ah, I see.

We could say (tweaking some text in the rest of the paragraph):

    *  If the disagreement raises a new issue that is not covered by an
       existing policy or that cannot be resolved through consultation
       between the RPC and other relevant individuals and bodies (as
       described above), the RSAB should bring to the RSWG in order
       to formulate a new policy.  However, if needed, in the interest of
       time the RSAB is responsible for resolving the disagreement before
       a new policy is defined.

>> However, in the interest of time the RSAB may propose resolutions for disagreements. Disagreements about the interpretation of policies shall be referred to the RSWG so they might consider proposa…

I think the foregoing text says that, although perhaps in a roundabout way?

Peter

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Nov 2021 16:57:13 +0100

See below.

> On 10. Nov 2021, at 16:18, Peter Saint-Andre <[email-masked]> wrote:
> 

Actually I also think that someone needs to be clearly responsible to make decisions. This sentence only takes about the case where there is an issue that should be brought to the RSWG. However even if an issue is resolved without the need for a new policy, I think it should be clear who is making the final decision, how that is document, and who is respectively responsible if the decision is wrong/gets applied. I don’t think this is fully covered in this section yet, but maybe it actually goes beyond Resolution of Disagreements between the Authors and the RPC which this section talks about…?

Mirja

> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 10 Nov 2021 12:20:02 -0700

On 11/10/21 8:57 AM, Mirja Kuehlewind wrote:
> Actually I also think that someone needs to be clearly responsible to make decisions. This sentence only takes about the case where there is an issue that should be brought to the RSWG. 

That wasn't the intent of the text, so I need to make it clearer.

> However even if an issue is resolved without the need for a new policy, I think it should be clear who is making the final decision, how that is document, and who is respectively responsible if the decision is wrong/gets applied. I don’t think this is fully covered in this section yet, but maybe it actually goes beyond Resolution of Disagreements between the Authors and the RPC which this section talks about…?

Hmm, perhaps. The interface between authors and RPC might be the main 
place where we uncover an ambiguity or gap in existing policies, but not 
the only place. I'll have a think about this and report back.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Nov 2021 09:17:45 +1300

On 11-Nov-21 08:20, Peter Saint-Andre wrote:
>> Actually I also think that someone needs to be clearly responsible to make decisions. This sentence only takes about the case where there is an 
issue that should be brought to the RSWG.
>> However even if an issue is resolved without the need for a new policy, I think it should be clear who is making the final decision, how that is document, and who is respectively responsible if the decision is wrong/gets applied. I don’t think this is fully covered in this section 
yet, but maybe it actually goes beyond Resolution of Disagreements between the Authors and the RPC which this section talks about…?
> the only place. I'll have a think about this and report back.

Like it or not, this is what you get by not having an RFC Series Editor.

It seems to me that operational issues are decided by the RPC and that
policy issues are decided by the RSWG/RSAB, so disputes can really only be
about (a) failure to correctly implement policy or (b) incomplete or
incorrect policy. That leads to two completely different appeal paths.
(a) -> RPC -> LLC and (b) ->  RSWG -> RSAB -> IAB. What we are dealing
with here is how to jump from path (a) to path (b), i.e. jump from
section 4.4 of the draft to section 3.2. We can't expect most authors
to realise this; they just want to use a non-Latin character where
policy doesn't allow it, etc.

I have no text to propose, but I hope this frames the issue.

    Brian

---

From: John C Klensin <[email-masked]>
Date: Thu, 11 Nov 2021 00:03:42 -0500

--On Thursday, November 11, 2021 09:17 +1300 Brian E Carpenter
<[email-masked]> wrote:

>> Hmm, perhaps. The interface between authors and RPC might be
>> the main place where we uncover an ambiguity or gap in
>> existing policies, but not the only place. I'll have a think
>> about this and report back.
> 

Exactly.

> It seems to me that operational issues are decided by the RPC
> and that policy issues are decided by the RSWG/RSAB, so
> disputes can really only be about (a) failure to correctly
> implement policy or (b) incomplete or incorrect policy. That
> leads to two completely different appeal paths.

No, there can also be a (c) which is a disagreement about
whether something is a policy issue, an implementation one, or
both.   We've actually seen that happen many times over the
years when an issue pops up for which the fix seems like a small
operational or implementation decision but is one that turns out
to have longer term or broader implications.  As you suggest
above, the traditional solution has rested in an RSE (or
predecessor title) who has expertise (including sufficient
expertise to know when to seek additional help and where to find
it), responsibility, and authority for publications expertise,
policy, and operations and whom the community is willing to
trust to identify issues that require or would benefit from
community input and to decide on others without wasting the
community's time.

Both the behavior of the IAB and RSOC that led us into this
process and this effort are trying to replace that model with
authority distributed into the community and a great deal of
process and complicated relationships.  That may have
significant appeal (and I think it does) but it also leads
inevitably to this kind of tangled situation.

> (a) -> RPC -> LLC and (b) ->  RSWG -> RSAB -> IAB. What we are
> dealing with here is how to jump from path (a) to path (b),
> i.e. jump from section 4.4 of the draft to section 3.2. We
> can't expect most authors to realise this; they just want to
> use a non-Latin character where policy doesn't allow it, etc.

Since you have chosen that particular example, I note that "can
I put this character there, where the policy permits it" is an
operational question but might turn into a policy one if the
character is a compatibility one or has unfortunate
composition/decomposition properties.  Or, if the issue is
really a string that poses special rendering challenges, that
could be either a policy problem or several different
operational or tooling ones.
 
> I have no text to propose, but I hope this frames the issue.

Right.  I'm in the same position.

   john

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 11 Nov 2021 15:50:09 +0900

John K. says it very well below. The issue with policy and 
implementation is that they may overlap, leading to duplicate work and 
conflicts, or that things may fall between the cracks (the policy side 
thinks it's operational, and the operations side thinks its policy).

Except for "everybody is nice with each other and does the right 
thing™", I don't yet see how our document deals with that issue.

Regards,   Martin.

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan