Subject: [Rfced-future] Issue 126: who issues the community last call

From: Eliot Lear <[email-masked]>
Date: Wed, 10 Nov 2021 17:23:22 +0100

We didn't get to cover this issue today.  The proposal in this issue is 
to change responsibility from the RSWG chairs to the RSAB chairs.  I 
pointed out that it is a matter of who evaluates community consensus.

Because I didn't get to ask in the meeting, I would like to ask this 
question:

  * Is there support for the RSWG chairs issuing this call?

By support, is this something that should hold up this document? If you 
support moving this responsibility to the RSWG chairs, could you crisply 
say what benefit you perceive in making the change?

Eliot

---

From: Eliot Lear <[email-masked]>
Date: Wed, 10 Nov 2021 17:24:08 +0100

And of course, that's issue 129, not 126.  Sorry.

On 10.11.21 17:23, Eliot Lear wrote:
>
> We didn't get to cover this issue today.  The proposal in this issue 
> is to change responsibility from the RSWG chairs to the RSAB chairs.  
> I pointed out that it is a matter of who evaluates community consensus.
>
> By support, is this something that should hold up this document?  If 
> you support moving this responsibility to the RSWG chairs, could you 
> crisply say what benefit you perceive in making the change?
>
> Eliot
>
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 10 Nov 2021 17:54:16 +0100

And that should read (I reversed things):

On 10.11.21 17:24, Eliot Lear wrote:
> is to change responsibility from the RSAB chairs RSWG chairs.  I

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Nov 2021 02:21:58 +0100

I think the RSAB should issue community calls because a) it’s the stream representatives that are best suited to decide and sent any calls to the community they represent and b) from a practical point of view I would expect the RSAB chair to have posting right e.g. on ietf-announce or other lists but not the RSSWG chair. I not proposing to necessarily send all community calls to ietf-announce@ but there might be things where it could make sense.

For feedback resolution I would like to see the following way in order to always have a clear view who is responsible for the document in which step: The RSWG chair request publication approval and document handling goes over to the RSAB (chair). If there are any comments in the community last call(s) there are three options:

1) comments are signification and need more RSSWG work, so the RSAB hands the document back to the RSWG chairs. 
2) comments are straight-forward to address. The RSAB confirms with the document authors/shepherd that they work on a document update and waits for the document update before an RSAB approval request is issued.
3) there are only minor comments (like nits or editorial). The RSAB approval request is issued and comments can be addressed with the next update after approvals or even during RFC editor state.

Mirja

> On 10. Nov 2021, at 17:54, Eliot Lear <[email-masked]> wrote:
> 
>> We didn't get to cover this issue today.  The proposal in this issue is to change responsibility from the RSAB chairs RSWG chairs.  I pointed out that it is a matter of who evaluates community consensus.
>>> Because I didn't get to ask in the meeting, I would like to ask this question:
>>> 
>>> 	• Is there support for the RSWG chairs issuing this call?
>>> By support, is this something that should hold up this document?  If you support moving this responsibility to the RSWG chairs, could you crisply say what benefit you perceive in making the change?
>>> 
>>> Eliot
>>> 
>>> 
>> 
>> 
> 
> <OpenPGP_0x87B66B46D9D27A33.asc>-- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Jay Daley <[email-masked]>
Date: Thu, 11 Nov 2021 15:59:36 +1300

Hi Mirja

A few questions:

- How is the non-IETF community included in this last call?  In the new model they primarily interact with the RSWG, RSCE and RPC. 

- We spent a long time agreeing that the streams could appoint anyone they wanted to the RSAB so what if a stream appoints someone who doesn’t have posting rights to ietf-announce and is not someone who can speak more widely for the stream, how do they issue the last call to their stream?

- Do we need to have three separate last call messages going to ietf-announce for the same thing? (IESG stream last call, IAB stream last call, ISE stream last call)

- If a stream representative issues a last call then they could be saying one of three things to their community 
1. Please tell the RSWG your issues with the doc
2. Please tell the RSAB any reasons why they shouldn’t approve this doc
3. Please tell your stream representative any reasons why they shouldn’t vote to approve this doc
I can see value in all three so how are these disambiguated if it is the stream representatives that issue the last call?

While it’s not for me to give a view on who issues the last call, I will note that if the last call is handled by the RSWG then all of these questions are moot. (the RPC could send the ietf-announce message on behalf of the RSWG if we are worried about posting rights for RSWG chairs).

Jay
-- 
Jay Daley
IETF Executive Director 
[email-masked]

> On 11/11/2021, at 2:22 PM, Mirja Kuehlewind <[email-masked]> wrote:
> 
> --

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Nov 2021 16:29:41 +1300

I wonder whether we should even cover these details. As long as the document says that the LC must be sent widely, and that the RSWG must review any non-editorial changes, experience will show the best way to do it.

Regards
    Brian

On 11-Nov-21 15:59, Jay Daley wrote:
> Hi Mirja
> 
> A few questions:
> 
> - How is the non-IETF community included in this last call?  In the new 
model they primarily interact with the RSWG, RSCE and RPC.
> While it’s not for me to give a view on who issues the last call, I will note that if the last call is handled by the RSWG then all of these questions are moot. (the RPC could send the ietf-announce message on 
behalf of the RSWG if we are worried about posting rights for RSWG chairs).

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 11 Nov 2021 13:15:36 +0900

I prefer the last call to be issued by the RSWG chairs. The reasons are 
best expressed by Mike StJohns in
https://mailarchive.ietf.org/arch/msg/rfced-future/IjhCkjCEwxaT51As_ibbA9Ul9SU,
and in 
https://mailarchive.ietf.org/arch/msg/rfced-future/t1ZHIlgzdQBY5mADDy6ZvdPpClc/

While I clearly prefer this solution, I can live with the last call 
being issued by the RSAB chair, too.

Regards,   Martin.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Nov 2021 10:33:47 +0100

See below.

> On 11. Nov 2021, at 03:59, Jay Daley <[email-masked]> wrote:
> 
> Hi Mirja
> 
> A few questions:
> 

Non-IETF community might already be part of the RSWG last call. However, there is still the requirement in the text to send the community last call to ref-interest@@. That won’t change.

> - We spent a long time agreeing that the streams could appoint anyone they wanted to the RSAB so what if a stream appoints someone who doesn’t have posting rights to ietf-announce and is not someon…

I was assuming that we actually give the RSAB chair posting right to ietf@announce@. Given we use this list for multiple communities, there should only be one call send by the RSAB chair. The other stream representative might decide send to e.g. last-call@, iab@, architecture-discuss@, or irsg@. I guess over time we might add a function to the Datatracker to send these things more or less automatically to the right list(s) (or those lists could be selected in the Datatracker when the call is issued). Point is that I would prefer the calls to come from a group of stream representations that have some knowledge of their stream needs.

I assume that the role of the stream representative means that that person can speak more widely for the stream, or maybe I don’t understand what you mean with that?

> - Do we need to have three separate last call messages going to ietf-announce for the same thing? (IESG stream last call, IAB stream last call, ISE stream last call)

See above; no, only one call send from the RSAB.

> I can see value in all three so how are these disambiguated if it is the stream representatives that issue the last call?

We don’t distinguish this kind of feedback in the IETF last call. People send feedback and the AD or in this case the RSAB needs to decide in which category the feedback falls and how to handle it. Note that the RSAB has to do that for your point 2 and 3 not mater who sends the call.

> While it’s not for me to give a view on who issues the last call, I will note that if the last call is handled by the RSWG then all of these questions are moot. (the RPC could send the ietf-announc…

I don’t think the RPC should send out last calls in the name of anybody. We might ask secretariat support for the RSAB in the future and the secretariat to send it out in the name the RSAB (or as I said above the datatracker might have a function to do that automatically).

Also the question of where exactly the community last calls need to be send for a given document is not moot and needs to be addressed by the RSAB and thereby the stream representatives and not the RSWG.

Mirja

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Nov 2021 10:48:31 +0100

I wasn’t proposing to specify this in this detail. As you say one sentence and/or maybe some word tweaks fo the existing text might be enough.

Note that the currently procedure as specified is already mostly aligned with what I propose:

6) Once consensus is established in the RSWG, the RSAB shall issue a community call for comments as further described in {{cfc}}. If substantial comments have been received, the RSWG will again consider those comments and make revisions as they see fit. At this same time, the RSAB will also consider the proposal.

7) If substantial changes have been made, additional community calls for comment should be issued by the RSAB, and again comments considered by the RSWG.

8) Once all comments have been addressed, the RSWG chairs will submit the proposal to the RSAB for its consideration.

I think what I have in mind (and is probably slightly closer to the IESG process with the respective states in the datatracker) would be this:

6) Once consensus is established in the RSWG, the RSWG will request approval for publication and hand the document to the RSSAB.

7) The RSAB shall issue a community call for comments as further described in {{cfc}}. 

8) If substantial comments have been received, the RSAB will hand the document back to the RSWG. If substantial changes have been made, an additional RSWG call last should be consider by the RSWG chairs. When all comments have been addressed to the satisfaction of the RSWG, the chairs will re-request approval by the RSAB which may decide to issue additional community calls respectively.

8) Once all substantial comments have been addressed or if no/only non-substantial comments have been received, the RSAB will consider the proposal for approval.

I think this text would make it more clear who is responsible for processing of a document in each step.

Mirja

> On 11. Nov 2021, at 04:29, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 11 Nov 2021 11:00:23 +0100

This group discussed and agreed that the RSAB does NOT measure 
consensus, precisely because it allows for a pocket veto.  I propose not 
to revisit that aspect.

Eliot

---

From: Michael StJohns <[email-masked]>
Date: Thu, 11 Nov 2021 08:40:50 -0500

On 11/11/2021 5:00 AM, Eliot Lear wrote:
> consensus, precisely because it allows for a pocket veto.  I propose 
> not to revisit that aspect.

I'm pretty sure that the group did not give the RSWG carte blanche to 
ignore community input, but if they are the only ones measuring 
consensus, it sounds like that's exactly what can happen.

I don't recall interpreting the RSAB role as you do.  The RSAB gets to 
decide if process isn't followed, and that AFAICT includes deciding that 
community input was ignored or community consensus was not achieved.

You've got the archives - could you point to where you're interpretation 
overrides mine?

Mirja's process makes sense given that the RSAB is making the community 
call.

Later, Mike

>> 8) If substantial comments have been received, the RSAB will hand the 
>> document back to the RSWG. If substantial changes have been made, an 
>> additional RSWG call last should be consider by the RSWG chairs. When 
>> all comments have been addressed to the satisfaction of the RSWG, the 
>> chairs will re-request approval by the RSAB which may decide to issue 
>> additional community calls respectively.
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 11 Nov 2021 08:48:26 -0500

The wording here is a bit strange.  One of the appeals grounds we 
already discussed is that the RSAB can be asked to rule that the RSWG 
chairs misjudged the RSWG rough consensus.  So, to some degree, the RSAB 
clearly does end up judging rough consensus.

Which suggests the same balance here.  Let the RSWG do the job, and 
allow the RSAB to say "you got it wrong". (whether only in response to 
an appeal or as part of the RSAB review seems to be a minor fillip.)

Yours,
Joel

---

From: Eliot Lear <[email-masked]>
Date: Thu, 11 Nov 2021 14:58:10 +0100

On 11.11.21 14:48, Joel M. Halpern wrote:
> chairs misjudged the RSWG rough consensus.  So, to some degree, the 
> RSAB clearly does end up judging rough consensus.
>

This is how I interpret the text today, and it was not an accident, but 
it was rather a negotiation.  You may recall the detail we went through 
to get to what the authority of the RSAB is, and on what the RSAB can 
decide, and on the role of the RSWG chairs, which oughtn't be 
forgotten.  They are selected from the IAB and IESG to see that process 
is followed.

Eliot

>> I don't recall interpreting the RSAB role as you do.  The RSAB gets 
>> to decide if process isn't followed, and that AFAICT includes 
>> deciding that community input was ignored or community consensus was 
>> not achieved.
>>
>> You've got the archives - could you point to where you're 
>> interpretation overrides mine?
>>
>> Mirja's process makes sense given that the RSAB is making the 
>> community call.
>>
>> Later, Mike
>>
>>
>>>
>>> Eliot
>>>
>>>> 8) If substantial comments have been received, the RSAB will hand 
>>>> the document back to the RSWG. If substantial changes have been 
>>>> made, an additional RSWG call last should be consider by the RSWG 
>>>> chairs. When all comments have been addressed to the satisfaction 
>>>> of the RSWG, the chairs will re-request approval by the RSAB which 
>>>> may decide to issue additional community calls respectively.
>>>
>>
>>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 12 Nov 2021 08:43:19 +1300

On 12-Nov-21 02:58, Eliot Lear wrote:
> it was rather a negotiation.

True. However, if the text still needs interpretation, that suggests that
it isn't quite clear enough. Or that we should revisit it a couple of years
from now, and make any adjustments then. Trying to make it perfect now is
unrealistic.

    Brian

> You may recall the detail we went through