Subject: [Rfcplusplus] A note on tonight's plenary

From: Ted Hardie <[email-masked]>
Date: Wed, 18 Jul 2018 13:31:22 -0400

Greetings,

The IESG and IAB understand that there are significant questions about the
RFC++ BoF likely to come up during the plenary.  Given the IAB's role as a
shepherd of the RFC series, we anticipate questions during the IAB portion
of the open mic.

As context, below are some thoughts on the BoF from the IAB.

First, some of this is the result of tired people working to a deadline.
That rushed effort tried to capture a set of discussions, some of which go
back before the current IAB (RFC 1796
<http://tools.ietf.org/html/rfc1796>, potential
adoption of BCOPs
<https://www.nanog.org/sites/default/files/monday_general_publicoptions_aronson_63.3.pdf>,
possible new IRTF publication stream), and some of which started at this
year’s IESG and IAB retreats.   Second, while the experiment in the BoF
proposal did not have IAB consensus, the IAB strongly believed that we
needed to hold the related discussions in a public forum.  Holding that
discussion only within the IAB or even with the RSOC and RSE did not seem
to us to match the need for transparency for a set of issues of this
importance to the community.

The proponents brought the discussion to the IAB and IESG in the context of
a BoF because the basic function of a "birds of a feather" session is to
hold a public meeting for folks interested in a common topic or issue.
While our usual BoFs are about working group formation, that core meaning
is why the proponents took that route to reach the community.

We made some mistakes in that:

   -

   The context built up by the IESG and IAB at their retreat and in other
   discussions did not translate into the BoF description, even for those who
   read all the listed background material.
   -

   Some of the folks already involved in the RFC processes were not part of
   early coordination.
   -

   The problem statement was not sufficiently articulated, and the
   discussion on the list did not start early enough to help.
   -

   The use of the BoF term and the location of the meeting at an IETF
   caused some concern that other parts of the Internet technical community
   were being deliberately ignored.
   -

   Engaging folks who were not deeply familiar with the IETF process did
   not work, despite some folks putting in significant effort to do so.
   -

   The proposed experiment also did not resonate at all well with the
   community, and the IAB has heard that feedback loud and clear.
   -

   The early discussion on the list also caused the chairs to reshape the
   agenda; while that had some positive effects in moving the discussion up a
   level, some folks found removing all mention of the experiment confusing.

On the positive side, the BoF did give folks a forum to share both their
concerns about the issue of confusion and for members of the community to
give clear feedback on their perception of the risks inherent in making
changes to address the issue.  It also gave clear feedback that Heather, as
RFC Series Editor, sees gathering data about market perception of the RFC
Series as in her bailiwick under the terms of RFC 6635. She noted at the
BoF that she will bump it up her priority stack. We'll take that into
account in understanding where she's spending her time, and we'll make sure
the RSOC will do so too.

The IAB confirms that any data she brings to us on that topic will be made
public and that any discussion of next steps will similarly be public.
That won’t use a BoF format, given the feedback, but it will be as open as
we can manage.

We also heard questions about how the IAB spends its time.  You can see the
IAB report to the community, sent earlier, on the IAB website
<https://www.iab.org/2018/07/12/report-to-the-community-from-the-iab-for-ietf-102/>.
Further input on what our priorities should be is always welcome at
[email-masked] or [email-masked].

See you at the plenary,

Ted Hardie

For the IAB

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 18 Jul 2018 13:59:05 -0400

Ted,

Thank you for your clear summarization of the IAB’s thoughts.

To make the next step clear, would that be for the RSE to analyze the
issues discussed during the BOF and to gather data on market perception,
and then report the results to the community?

Thanks,
Andy

On Wed, Jul 18, 2018 at 1:31 PM, Ted Hardie <[email-masked]> wrote:

> back before the current IAB (RFC 1796 <http://tools.ietf.org/html/rfc1796>,
> potential adoption of BCOPs
> The proponents brought the discussion to the IAB and IESG in the context
> of a BoF because the basic function of a "birds of a feather" session is to
>    Some of the folks already involved in the RFC processes were not part
>    of early coordination.
>    -
>
> We also heard questions about how the IAB spends its time.  You can see
> the IAB report to the community, sent earlier, on the IAB website
> _______________________________________________
> Rfcplusplus mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rfcplusplus
>
>

---

From: Ted Hardie <[email-masked]>
Date: Wed, 18 Jul 2018 14:16:51 -0400

> and then report the results to the community?
I've copied Heather explicitly here, in case she has not yet seen your
question.

I think there is likely to be more than one next step, but I believe among
them will be Heather gathering data on market perception of the RFC series.
Note, however, that she only committed at the BoF to moving it up the
priority stack; she and the RSOC are very busy with the final stretch on
the format work at the moment.

She may be able to comment further,

regards,

Ted

>> The IESG and IAB understand that there are significant questions about
>> the RFC++ BoF likely to come up during the plenary.  Given the IAB's role
>> as a shepherd of the RFC series, we anticipate questions during the IAB
>> portion of the open mic.
>>
>> <http://tools.ietf.org/html/rfc1796>, potential adoption of BCOPs
>>    The context built up by the IESG and IAB at their retreat and in
>>    other discussions did not translate into the BoF description, even for
>>    those who read all the listed background material.
>>    -
>>
>>    The early discussion on the list also caused the chairs to reshape
>>    the agenda; while that had some positive effects in moving the discussion
>>    up a level, some folks found removing all mention of the experiment
>>    confusing.
>>
>>
>> The IAB confirms that any data she brings to us on that topic will be
>> made public and that any discussion of next steps will similarly be
>> public.  That won’t use a BoF format, given the feedback, but it will be as
>> open as we can manage.
>>

---

From: Randy Bush <[email-masked]>
Date: Wed, 18 Jul 2018 14:22:58 -0400

does the iab micro-manage everything it touches?  if so, perhaps there
is some adjustment needed.  i was there for kobe-1.

rsndy

---

From: Heather Flanagan <[email-masked]>
Date: Wed, 18 Jul 2018 15:34:39 -0400

> On Jul 18, 2018, at 14:16, Ted Hardie <[email-masked]> wrote:
> 
>> To make the next step clear, would that be for the RSE to analyze the issues discussed during the BOF and to gather data on market perception, and then report the results to the community?
>> 
> 
> I've copied Heather explicitly here, in case she has not yet seen your question.
> 
> I think there is likely to be more than one next step, but I believe among them will be Heather gathering data on market perception of the RFC series. Note, however, that she only committed at the BoF to moving it up the priority stack; she and the RSOC are very busy with the final stretch on the format work at the moment.  
> 

Indeed she can! I’m not quite sure how much detail you all are looking for, but I’ll give you a quick outline. I’ll also note that I’m always open to feedback if people think I might be missing an area to explore. 

My most immediate next steps involve talking to a wide variety of people, both within the SDO universe and some a bit farther afield. For example, I have set up time to talk to a few people at the Internet Society about how they generally go about doing market research; I’d like to know what resources within this area of expertise are immediately available.  From there, I will be reaching out to several of my contacts within the scholarly and technical publishing community to get some ideas of what they do when they encounter a journal that might need to be broken out into separate entities. (Note: I don’t know that we’re ever going to want to do that, but the information on the process from folks who do this kind of thing relatively frequently will be useful.) I also plan on collecting (perhaps commiserating) with contacts at the W3C, IEEE, NISO, and possibly ISO to get a better understanding of what they do, what they wish they had done, and what (if any) changes we make would do to their workflow and reference material. 

The IETF community can also expect me to be reaching out to see if I can find contacts within some of the big companies that reference our documents to see what they know (or think they know) about RFCs and how they would expect to find out about changes to the series. But honestly, I don’t expect to get to this step for a while. I need to have clearly formed questions first.

What happens after all that information gathering largely depends on what I find out. As always, I’ll try to keep people updated via my RSE reports, discussions on rfc-interest, hallway conversations, bar conversations, RFC Editor desk conversations, airplane boarding queue conversations, and any other ways I can think of that might be useful. 

I hope that helps clarify what I’m going to do next in with this topic. As Ted pointed out, my priority is to get the format project in production. I’d also like to spend some quality time determining how to improve the quality of metadata for RFCs, explore the possibility of a sandbox space to experiment with things like web annotations, work with the RPC to see how their tools and workflow can be improved, and several other things. 

Thanks for all the feedback this week! As always, contact me if you have any questions, ideas, concerns, or other feedback you’d like to offer.

-Heather Flanagan, RSE

---

From: Adam Roach <[email-masked]>
Date: Wed, 18 Jul 2018 16:06:11 -0400

Thanks for the detailed outline, Heather! I have one bit of feedback.

On 7/18/18 15:34, Heather Flanagan wrote:
> The IETF community can also expect me to be reaching out to see if I 
> can find contacts within some of the big companies that reference our 
> documents to see what they know (or think they know) about RFCs and 
> how they would expect to find out about changes to the series.

In the interest of completeness, I would suggest that such an effort 
needs to include reaching out to the communities associated with 
open-source projects as well.

/a

---

From: heather flanagan <[email-masked]>
Date: Wed, 18 Jul 2018 16:13:18 -0400

> On Jul 18, 2018, at 16:06, Adam Roach <[email-masked]> wrote:
> 
>> The IETF community can also expect me to be reaching out to see if I can find contacts within some of the big companies that reference our documents to see what they know (or think they know) about RFCs and how they would expect to find out about changes to the series.
> 
> In the interest of completeness, I would suggest that such an effort needs to include reaching out to the communities associated with open-source projects as well.
> 

ooooh, excellent idea! Thanks! If you have any particular communities and/or contacts in mind, please drop me a note off list.

It occurs to me, as I continue to think about this, that groups like the NOGs, the RIRs, and other operator groups should be on the list, too.

-Heather