From mailnull@www1.ietf.org  Thu Apr 10 06:21:13 2003
Received: from www1.ietf.org (ietf.org [132.151.1.19] (may be forged))
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id GAA14221
	for <rmt-archive@odin.ietf.org>; Thu, 10 Apr 2003 06:21:13 -0400 (EDT)
Received: (from mailnull@localhost)
	by www1.ietf.org (8.11.6/8.11.6) id h3AAQp329599
	for rmt-archive@odin.ietf.org; Thu, 10 Apr 2003 06:26:51 -0400
Received: from ietf.org (odin.ietf.org [132.151.1.176])
	by www1.ietf.org (8.11.6/8.11.6) with ESMTP id h3AAQp829596
	for <rmt-web-archive@optimus.ietf.org>; Thu, 10 Apr 2003 06:26:51 -0400
Received: from www1.ietf.org (ietf-mx.ietf.org [132.151.6.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id GAA14197
	for <rmt-web-archive@ietf.org>; Thu, 10 Apr 2003 06:20:42 -0400 (EDT)
Received: from www1.ietf.org (localhost.localdomain [127.0.0.1])
	by www1.ietf.org (8.11.6/8.11.6) with ESMTP id h3AAH3829054;
	Thu, 10 Apr 2003 06:17:03 -0400
Received: from ietf.org (odin.ietf.org [132.151.1.176])
	by www1.ietf.org (8.11.6/8.11.6) with ESMTP id h3AAB4828856
	for <rmt@optimus.ietf.org>; Thu, 10 Apr 2003 06:11:04 -0400
Received: from cbibipnt02.HC.BT.COM (ietf-mx.ietf.org [132.151.6.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id GAA13800
	for <rmt@ietf.org>; Thu, 10 Apr 2003 06:04:55 -0400 (EDT)
From: maziar.nekovee@bt.com
Received: by cbibipnt02.hc.bt.com with Internet Mail Service (5.5.2654.89)
	id <2JF0C364>; Thu, 10 Apr 2003 11:07:24 +0100
Message-ID: <282B85C8BBEF47499A3069ECBCB2E028E8F6CE@i2km11-ukbr.domain1.systemhost.net>
To: rmt@ietf.org
Cc: maziar.nekovee@bt.com
Date: Thu, 10 Apr 2003 11:07:01 +0100
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2654.89)
content-class: urn:content-classes:message
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 8bit
X-MIME-Autoconverted: from quoted-printable to 8bit by www1.ietf.org id h3AAB4828857
Subject: [Rmt] Postdoc position on   multicast applications to GRID computing
Sender: rmt-admin@ietf.org
Errors-To: rmt-admin@ietf.org
X-BeenThere: rmt@ietf.org
X-Mailman-Version: 2.0.12
Precedence: bulk
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/rmt>,
	<mailto:rmt-request@ietf.org?subject=unsubscribe>
List-Id: Reliable Multicast Transport <rmt.ietf.org>
List-Post: <mailto:rmt@ietf.org>
List-Help: <mailto:rmt-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/rmt>,
	<mailto:rmt-request@ietf.org?subject=subscribe>
Content-Transfer-Encoding: 8bit
Content-Transfer-Encoding: 8bit

Dear Colleagues 

We will have an opening for a 2 year postdoc at BTexcat (BT Labs)-University
of Manchester on application of  IP multicast to grid computing, starting
early this summer. I would be  grateful if  you could forward the attached
ad to any interested candidate  (preferably with a solid background in
multicast).
Informal enquiries could be emailed to me.  The deadline  for applications
is April 28. 

mailto:maziar.nekovee@bt.com  

Many thanks 
Maziar Nekovee

----------------------------------------------------------------------------
----------------------------------------------------------------------------
----------------------------------------------------------------------------
---
University of Manchester - BT Labs Martlesham
Research Associate

Manchester Computing, Europe's premier university computing facility,
together with BTexact, BT's 
advanced communication technologies business, are about to undertake an
exciting new project applying IP 
multicast to Grid computing.

We require a Research Associate to implement multicast communication
protocols for rapid, efficient and 
reliable data transmission for very high data rate transfer scenarios, and
to investigate their performance 
through network traffic measurements. 

The ideal candidate will be able to demonstrate applied knowledge of sound
programming practice in C, 
C++ or Java in a Unix environment, good technical writing abilities and
excellent communication skills. 
Knowledge of multicast and network traffic measurements will be an
advantage. 

The appointee will spend some time both at BTexact in Martlesham and at the
University of Manchester, 
the exact proportions at each to be agreed with the successful candidate.

This post will be on RA scale in the range £20,311 to £26,270 for two years
in the first instance. Informal 
enquiries for the above post should be made to Dr  Maziar  Nekovee
(maziar.nekovee@bt.com, +44-1473 
645 470).
Further details and application forms can be found  from the 
Office of the Director of Personnel, University of Manchester, Manchester
M13 9PL. Telephone: +44 
(0)161 275 2028; fax +44(0)161 275 2471; Minicom: +44(0)161 275 7889; email:
personnel@man.ac.uk. 
Please quote the relevant reference number. 


----------------------------
Dr Maziar Nekovee
Complexity Research Group
Polaris 134
BTexact Technologies
Martlesham
Suffolk IP5 3RE, UK
tel:  +44-1473 645470
fax: +44-1473-642161
web: http://more.btexact.com/projects/complexity/nekovee/

_______________________________________________
Rmt mailing list
Rmt@ietf.org
https://www1.ietf.org/mailman/listinfo/rmt



From mailnull@www1.ietf.org  Fri Apr 11 02:59:48 2003
Received: from www1.ietf.org (ietf.org [132.151.1.19] (may be forged))
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA01562
	for <rmt-archive@odin.ietf.org>; Fri, 11 Apr 2003 02:59:48 -0400 (EDT)
Received: (from mailnull@localhost)
	by www1.ietf.org (8.11.6/8.11.6) id h3B75q432099
	for rmt-archive@odin.ietf.org; Fri, 11 Apr 2003 03:05:52 -0400
Received: from ietf.org (odin.ietf.org [132.151.1.176])
	by www1.ietf.org (8.11.6/8.11.6) with ESMTP id h3B75o832096
	for <rmt-web-archive@optimus.ietf.org>; Fri, 11 Apr 2003 03:05:50 -0400
Received: from ietf-mx (ietf-mx.ietf.org [132.151.6.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA01555
	for <rmt-web-archive@ietf.org>; Fri, 11 Apr 2003 02:59:16 -0400 (EDT)
Received: from localhost ([127.0.0.1] helo=ietf-mx)
	by ietf-mx with esmtp (Exim 4.12)
	id 193sFC-0007NC-00
	for rmt-web-archive@ietf.org; Fri, 11 Apr 2003 02:42:38 -0400
Received: from ietf.org ([132.151.1.19] helo=www1.ietf.org)
	by ietf-mx with esmtp (Exim 4.12)
	id 193sFC-0007N8-00
	for rmt-web-archive@ietf.org; Fri, 11 Apr 2003 02:42:38 -0400
Received: from www1.ietf.org (localhost.localdomain [127.0.0.1])
	by www1.ietf.org (8.11.6/8.11.6) with ESMTP id h3B6x7831716;
	Fri, 11 Apr 2003 02:59:07 -0400
Received: from ietf.org (odin.ietf.org [132.151.1.176])
	by www1.ietf.org (8.11.6/8.11.6) with ESMTP id h3B6la831345
	for <rmt@optimus.ietf.org>; Fri, 11 Apr 2003 02:47:36 -0400
Received: from ietf-mx (ietf-mx.ietf.org [132.151.6.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA01354
	for <rmt@ietf.org>; Fri, 11 Apr 2003 02:41:03 -0400 (EDT)
Received: from localhost ([127.0.0.1] helo=ietf-mx)
	by ietf-mx with esmtp (Exim 4.12)
	id 193rxY-00072f-00
	for rmt@ietf.org; Fri, 11 Apr 2003 02:24:24 -0400
Received: from sj-core-2.cisco.com ([171.71.177.254])
	by ietf-mx with esmtp (Exim 4.12)
	id 193rxY-00072c-00
	for rmt@ietf.org; Fri, 11 Apr 2003 02:24:24 -0400
Received: from cisco.com (cypher.cisco.com [171.69.11.143])
	by sj-core-2.cisco.com (8.12.6/8.12.6) with ESMTP id h3B6h6gE027553;
	Thu, 10 Apr 2003 23:43:06 -0700 (PDT)
Received: (from lorenzo@localhost)
	by cisco.com (8.8.8/2.6/Cisco List Logging/8.8.8) id XAA25086;
	Thu, 10 Apr 2003 23:43:05 -0700 (PDT)
Date: Thu, 10 Apr 2003 23:43:05 -0700
From: Lorenzo Vicisano <lorenzo@cisco.com>
To: rmt@ietf.org
Cc: Allison Mankin <mankin@psg.com>,
        Roger Kermode <Roger.Kermode@motorola.com>, jon.peterson@neustar.biz,
        Lorenzo Vicisano <lorenzo@cisco.com>
Message-ID: <20030410234305.B22809@cisco.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.3.23i
Subject: [Rmt] new-new Charter/Milestones
Sender: rmt-admin@ietf.org
Errors-To: rmt-admin@ietf.org
X-BeenThere: rmt@ietf.org
X-Mailman-Version: 2.0.12
Precedence: bulk
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/rmt>,
	<mailto:rmt-request@ietf.org?subject=unsubscribe>
List-Id: Reliable Multicast Transport <rmt.ietf.org>
List-Post: <mailto:rmt@ietf.org>
List-Help: <mailto:rmt-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/rmt>,
	<mailto:rmt-request@ietf.org?subject=subscribe>

Dear RMTers,

Following the discussion that we had in the last WG meeting,
please find attached a revised version of the *proposed*
new Charter. This is the one the ADs plan to discuss with the
IESG soon.

These are the changes for the one discussed at the meeting:

   - removed "small-group replication service"
   - added some text on GRA
   - added a milestone for GRA
   - canged the timelines for CC BBs in the milestones

	thank you,
	the chairs.


Reliable Multicast Transport (rmt) Working Group

Chairs:
Roger Kermode <roger.kermode@motorola.com>
Lorenzo Vicisano <lorenzo@cisco.com>

Area Director:  Allison Mankin <mankin@psg.com>



The purpose of this WG is to standardize reliable multicast transport.

Initial efforts have focused solely on the standardization of the
one-to-many transport of large amounts of data. Due to the large
number of applications that fall into this category, and the sometimes
orthogonal requirements these applications exhibit, it is believed
that a "one size fits all" protocol will be unable to meet the
requirements of all applications. In recognition of this observation,
this working group will standardize two protocol instantiations,
initially as Experimental protocols, and then as warranted, in the
standards track, from the following families:

1) A NACK-based protocol.
2) An "Asynchronous Layered Coding protocol that uses Forward Error
   Correction.

The WG will carry out protocol standardization in general by composing a
a set of RFCs that specify
       
- building blocks: A set of easily-separable coarse-grained modular
components that are common to multiple protocols along with abstract
APIs that define a building block's access methods and their
arguments.

- protocol instantiations: Specifications that define the necessary
gluing logic and minimal additional functionality required to realize
a working protocol from one or more building blocks. These
specifications will also include an abstract API that defines the
interface between the protocol implementation and an application.

The WG has previously completed work on three documents to assist in
the standardization process. RFC2887 describes the design-space in  
which the one-to-many transport protocols will be developed. RFC3048
explains the concepts of building-blocks and protocol
instantiations. RFC3269 provides guidelines to authors of drafts that
specify building-blocks and protocol instantiations.

The WG will generate and submit for standardization drafts of the
following building-blocks for use in the construction of the two
protocols: congestion control, negative acknowledgments, forward error
correction, and to address the  RFC 2357 security requirements.

Generic mechanisms for router assist are also considered for an
additional building block. Initial work on the framework for
router-assist has already been performed, the WG will evaluate whether
to complete this task basing on available resource and interest.

The WG will also standardize and generate RFCs for the following two
protocol instantiations: A NACK-based protocol, and an Asynchronous 
Layered Coding (ALC) protocol that uses Forward Error Correction.   
RFC 3450 is the Experimental RFC of the ALC protocol instantiation. 

If new requirements are identified that cannot be satisfied with the
building-blocks and protocol instantiations described above, the Area
Directors in consultation with the IESG may add additional
building-blocks and protocol instantiations to the working group
deliverables.

This working group will work closely with the Internet Research Task
Force (IRTF) groups on Reliable Multicast (RMRG) and
Secure Multicast (SMUG), especially for meeting the congestion control
and security requirements mandated by RFC 2357. This working group may
work with the Area Directors to recharter to standardize reliable
multicast for additional scenarios beyond the one-to-many transport of
bulk data once they are sufficiently well understood.

Done MILESTONES:

 Done Submit design-space, building-blocks, and guidelines drafts for
      publication as Informational RFCs

 Done Initial Drafts for the following building blocks: negative
      acknowledgments, forward error correction, a generic signaling
      mechanism for router assist, and transport protection

 Done Submit Initial Drafts for the two protocol instantiations.

 Done Submit Initial Drafts for Congestion Control

 Done Complete most building-block drafts WG Last-Call and submit for
      publication as Experimental RFC

 Done Complete building blocks and protocol instantiations for
      ALC and submit for publication as Experimental RFC

New MILESTONES:

 MAY 03 Submit WEBRC (congestion control building block) for
        publication as Experimental

 MAY 03 WG Decision on whether to pursue the router-assist building
        block work. These milestones may have to be modified
        accordingly.

 AUG 03 Submit remaining congestion control building blocks (TFMCC, PGMCC) for
        publication as Experimental

 AUG 03 Submit NACK building block and protocol instantiation for publication
        as Experimental

 DEC 03 Evaluate when and how the RMT Experimental specifications
        will be submitted for publication as Proposed Standard, and
        update this charter accordingly.
_______________________________________________
Rmt mailing list
Rmt@ietf.org
https://www1.ietf.org/mailman/listinfo/rmt



