
From rstangarone-ietf@whataboutbob.org  Tue Feb  1 21:13:13 2011
Return-Path: <rstangarone-ietf@whataboutbob.org>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id A7FF93A6CF1 for <rohc@core3.amsl.com>; Tue,  1 Feb 2011 21:13:13 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.812
X-Spam-Level: 
X-Spam-Status: No, score=-0.812 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, FH_HOST_EQ_D_D_D_D=0.765, HELO_MISMATCH_ORG=0.611, HOST_MISMATCH_COM=0.311, RDNS_DYNAMIC=0.1]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 2fbf7U+hc+zQ for <rohc@core3.amsl.com>; Tue,  1 Feb 2011 21:13:12 -0800 (PST)
Received: from whataboutbob.org (netblock-72-25-108-170.dslextreme.com [72.25.108.170]) by core3.amsl.com (Postfix) with ESMTP id C99583A67D3 for <rohc@ietf.org>; Tue,  1 Feb 2011 21:13:12 -0800 (PST)
Received: from localhost (localhost.localdomain [127.0.0.1]) by whataboutbob.org (Postfix) with ESMTP id 17BD38732167 for <rohc@ietf.org>; Tue,  1 Feb 2011 21:16:29 -0800 (PST)
Received: from [192.168.2.75] (unknown [192.168.3.24]) by whataboutbob.org (Postfix) with ESMTPSA id BBE3B87320CB for <rohc@ietf.org>; Tue,  1 Feb 2011 21:16:28 -0800 (PST)
Message-ID: <4D48E8AD.3000100@whataboutbob.org>
Date: Tue, 01 Feb 2011 21:16:29 -0800
From: rstangarone-ietf <rstangarone-ietf@whataboutbob.org>
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101208 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
To: rohc@ietf.org
References: <8BFE2075-5B98-4B58-B66D-0A8F3B9C70DA@nokia.com>	<3FE00204-1925-45D7-B04A-BCAAFB9CF8F3@tzi.org> <95BB5766-B716-48E3-9D52-70E9B3C9DDCB@nokia.com>
In-Reply-To: <95BB5766-B716-48E3-9D52-70E9B3C9DDCB@nokia.com>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Subject: Re: [rohc] Errata against ROHC RFCs
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
Reply-To: rstangarone-ietf@whataboutbob.org
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 02 Feb 2011 05:13:13 -0000

I agree with Carsten's assessment.

Bob

On 02/01/2011 12:02 AM, Lars Eggert wrote:
> Thanks, Carsten. I'll wait a few days to give others a chance to chime in, but your suggestions seem reasonable to me.
> 
> On 2011-1-31, at 21:02, Carsten Bormann wrote:
> 
>> On Jan 31, 2011, at 13:21, Lars Eggert wrote:
>>
>>> Please discuss these errata on this list.
>>
>> Here is my assessment.
>> Thanks for bringing these up!
>>
>> Gruesse, Carsten
>>
>>
>> * RFC 3816:
>>
>> http://www.rfc-editor.org/errata_search.php?eid=737
>> -- many typos, some opportunity for editorial improvement
>> -- very little risk for misinterpretation, except maybe for 2f
>> -> Hold for Update
>> (The large number of errata leaves the document in a somwhat sorry
>> state.  It might be worthwhile to look at the implementation status of
>> RFC 3816 to assess the need for a re-spin.)
>>
>> * RFC 5795:
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2107
>> -- opportunity for minor editorial improvement
>> -- no risk
>> -> Hold for Update
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2108
>> -- errata submission simply misreads text (reads verb as noun)
>> -- could be improved editorially anyway (but not in the way proposed)
>> -- no risk
>> -> Reject, but make note to improve this text in next update
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2109
>> -- proposed change is somewhat pedantic;
>> -- it actually might reduce readability for some readers
>> -- no risk
>> -> Reject
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2110
>> "RFC Errata Report"
>> -- punctuation fix (typo)
>> -- no risk
>> -> Hold for Update
>>
>> * RFC 5857
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2274
>> -- editorial fix required: the wording on top of page 4 can be misread
>>   (the section reference parenthesis is about the new Notify Message
>>   Type value, not about the channel parameters carried by this
>>   message type).
>> -- also: this (and another) reference that should point to section 5
>>   (IANA considerations) incorrectly say "Section 4" (they should not
>>   say 3.1.2 as the errata states either).
>> -- annoying, but very little risk of misunderstanding
>> -> Hold for Update
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2275
>> -- typo
>> -- no risk
>> -> Hold for Update
>>
>> * RFC 5858
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2276
>> -- typos
>> -- no risk
>> -> Hold for Update
>>
>> http://www.rfc-editor.org/errata_search.php?eid=2277
>> -- idea for a very desirable editorial improvement
>> -- can probably be improved on further
>> -- even without that improvement, minimal risk of misinterpretation
>> -> Hold for Update
>>
> 
> 
> 
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc

From carl.knutsson@effnet.com  Wed Feb  2 01:30:32 2011
Return-Path: <carl.knutsson@effnet.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 38A3D3A713F for <rohc@core3.amsl.com>; Wed,  2 Feb 2011 01:30:32 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.599
X-Spam-Level: 
X-Spam-Status: No, score=-2.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id tnbk6XNPG0Lg for <rohc@core3.amsl.com>; Wed,  2 Feb 2011 01:30:31 -0800 (PST)
Received: from lists.levonline.com (lists.levonline.com [217.70.33.37]) by core3.amsl.com (Postfix) with ESMTP id 9BC6A3A7138 for <rohc@ietf.org>; Wed,  2 Feb 2011 01:30:29 -0800 (PST)
Received: from localhost (localhost.localdomain [127.0.0.1]) by lists.levonline.com (Postfix) with ESMTP id C801A26814F for <rohc@ietf.org>; Wed,  2 Feb 2011 10:33:47 +0100 (CET)
Received: from lists.levonline.com ([127.0.0.1]) by localhost (lists.levonline.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id nNqVivemYSdY for <rohc@ietf.org>; Wed,  2 Feb 2011 10:33:46 +0100 (CET)
Received: from traktor2.skognet.levonline.com (webhotel.fordon.levonline.com [217.70.32.2]) by lists.levonline.com (Postfix) with ESMTP id 3471B2681F0 for <rohc@ietf.org>; Wed,  2 Feb 2011 10:33:46 +0100 (CET)
Received: from [192.168.101.21] (c-b10171d5.04-205-6c756c1.cust.bredbandsbolaget.se [213.113.1.177]) (authenticated bits=0) by traktor2.skognet.levonline.com (8.13.8/8.13.8) with ESMTP id p129Xjdc004214 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO) for <rohc@ietf.org>; Wed, 2 Feb 2011 10:33:45 +0100
Message-ID: <4D4924F4.2000402@effnet.com>
Date: Wed, 02 Feb 2011 10:33:40 +0100
From: Carl Knutsson <carl.knutsson@effnet.com>
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101208 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
To: rohc@ietf.org
References: <8BFE2075-5B98-4B58-B66D-0A8F3B9C70DA@nokia.com>	<3FE00204-1925-45D7-B04A-BCAAFB9CF8F3@tzi.org>	<95BB5766-B716-48E3-9D52-70E9B3C9DDCB@nokia.com> <4D48E8AD.3000100@whataboutbob.org>
In-Reply-To: <4D48E8AD.3000100@whataboutbob.org>
X-Enigmail-Version: 1.1.2
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Subject: Re: [rohc] Errata against ROHC RFCs
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 02 Feb 2011 09:30:32 -0000

+1 for Carsten's assessment.

Cheers,

/Calle

On 02/02/2011 06:16 AM, rstangarone-ietf wrote:
> I agree with Carsten's assessment.
> 
> Bob
> 
> On 02/01/2011 12:02 AM, Lars Eggert wrote:
>> Thanks, Carsten. I'll wait a few days to give others a chance to chime in, but your suggestions seem reasonable to me.
>>
>> On 2011-1-31, at 21:02, Carsten Bormann wrote:
>>
>>> On Jan 31, 2011, at 13:21, Lars Eggert wrote:
>>>
>>>> Please discuss these errata on this list.
>>>
>>> Here is my assessment.
>>> Thanks for bringing these up!
>>>
>>> Gruesse, Carsten
>>>
>>>
>>> * RFC 3816:
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=737
>>> -- many typos, some opportunity for editorial improvement
>>> -- very little risk for misinterpretation, except maybe for 2f
>>> -> Hold for Update
>>> (The large number of errata leaves the document in a somwhat sorry
>>> state.  It might be worthwhile to look at the implementation status of
>>> RFC 3816 to assess the need for a re-spin.)
>>>
>>> * RFC 5795:
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2107
>>> -- opportunity for minor editorial improvement
>>> -- no risk
>>> -> Hold for Update
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2108
>>> -- errata submission simply misreads text (reads verb as noun)
>>> -- could be improved editorially anyway (but not in the way proposed)
>>> -- no risk
>>> -> Reject, but make note to improve this text in next update
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2109
>>> -- proposed change is somewhat pedantic;
>>> -- it actually might reduce readability for some readers
>>> -- no risk
>>> -> Reject
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2110
>>> "RFC Errata Report"
>>> -- punctuation fix (typo)
>>> -- no risk
>>> -> Hold for Update
>>>
>>> * RFC 5857
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2274
>>> -- editorial fix required: the wording on top of page 4 can be misread
>>>   (the section reference parenthesis is about the new Notify Message
>>>   Type value, not about the channel parameters carried by this
>>>   message type).
>>> -- also: this (and another) reference that should point to section 5
>>>   (IANA considerations) incorrectly say "Section 4" (they should not
>>>   say 3.1.2 as the errata states either).
>>> -- annoying, but very little risk of misunderstanding
>>> -> Hold for Update
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2275
>>> -- typo
>>> -- no risk
>>> -> Hold for Update
>>>
>>> * RFC 5858
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2276
>>> -- typos
>>> -- no risk
>>> -> Hold for Update
>>>
>>> http://www.rfc-editor.org/errata_search.php?eid=2277
>>> -- idea for a very desirable editorial improvement
>>> -- can probably be improved on further
>>> -- even without that improvement, minimal risk of misinterpretation
>>> -> Hold for Update
>>>
>>
>>
>>
>> _______________________________________________
>> Rohc mailing list
>> Rohc@ietf.org
>> https://www.ietf.org/mailman/listinfo/rohc
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc


From sasha.koruga.ctr@navy.mil  Wed Feb  2 08:40:56 2011
Return-Path: <sasha.koruga.ctr@navy.mil>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 4B4813A6C3D for <rohc@core3.amsl.com>; Wed,  2 Feb 2011 08:40:56 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.599
X-Spam-Level: 
X-Spam-Status: No, score=-6.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id wnOkC+OuXc5v for <rohc@core3.amsl.com>; Wed,  2 Feb 2011 08:40:55 -0800 (PST)
Received: from gate1-sandiego.nmci.navy.mil (gate1-sandiego.nmci.navy.mil [138.163.0.41]) by core3.amsl.com (Postfix) with ESMTP id 20ADD3A6D7B for <rohc@ietf.org>; Wed,  2 Feb 2011 08:40:50 -0800 (PST)
Received: from nawesdnieg06v.nadsuswe.nads.navy.mil ([10.0.0.163]) by gate1-sandiego.nmci.navy.mil with Microsoft SMTPSVC(5.0.2195.6872);  Wed, 2 Feb 2011 08:31:28 -0800
Received: from nawesdnieb13v.nadsuswe.nads.navy.mil ([10.0.10.79]) by nawesdnieg06v.nadsuswe.nads.navy.mil with Microsoft SMTPSVC(6.0.3790.4675); Wed, 2 Feb 2011 08:44:11 -0800
Received: from nawespsceb01v.nadsuswe.nads.navy.mil ([10.1.120.15]) by nawesdnieb13v.nadsuswe.nads.navy.mil with Microsoft SMTPSVC(6.0.3790.4675); Wed, 2 Feb 2011 08:44:10 -0800
Received: from nawespscez02v.nadsuswe.nads.navy.mil ([10.1.120.21]) by nawespsceb01v.nadsuswe.nads.navy.mil with Microsoft SMTPSVC(6.0.3790.4675); Wed, 2 Feb 2011 09:44:10 -0700
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Date: Wed, 2 Feb 2011 09:44:10 -0700
Message-ID: <2FFB75E6EB5AD746A81F398DDF04D7F18C3576@nawespscez02v.nadsuswe.nads.navy.mil>
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
Thread-Topic: [rohc] Errata against ROHC RFCs
Thread-Index: AcvC+GpF0Jf5RI9GTqmF9cFFygAynw==
From: "Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110" <sasha.koruga.ctr@navy.mil>
To: <rohc@ietf.org>
X-OriginalArrivalTime: 02 Feb 2011 16:44:10.0233 (UTC) FILETIME=[6A5CB690:01CBC2F8]
Subject: Re: [rohc] Errata against ROHC RFCs
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 02 Feb 2011 16:46:32 -0000

Hi Lars,

Is it possible to include an errata as Calle proposed here: =
http://www.ietf.org/mail-archive/web/rohc/current/msg05960.html
Specifically, "I would like to change the text in 6.6.11 to say 'for =
each IPv4 header' instead of 'for each IP header'."
That issue has been a great source of confusion for my team, and the =
suggested change would quell our concerns.
Thank you.

Regards,
Sasha


On Mon, Jan 31, 2011 at 4:21 AM, Lars Eggert <lars.eggert@nokia.com> =
wrote:
> Hi,
>
> several errata have been submitted against ROHC RFCs: =
http://www.rfc-editor.org/errata_search.php?rec_status=3D2&area_acronym=3D=
tsv&wg_acronym=3Drohc&presentation=3Dtable
>
> The TSV ADs would like to enlist the help of the RFC authors and the =
broader ROHC community in order to determine how to process these, i.e., =
which should be "verified", "held" or "rejected".
>
> Please discuss these errata on this list.
>
> Lars
>
> PS: IESG guidelines on errata handling:
>
>   In order to help you determine the correct handling for the errata
>   in step (4), the IESG has come up with a few guidelines:
>
>  1. Only errors that could cause implementation or deployment
>    problems or significant confusion should be Approved.
>
>  2. Things that are clearly wrong but could not cause an
>    implementation or deployment problem should be Hold for Document
>    Update.
>
>  3. Errata on obsolete RFCs should be treated the same as errata on
>    RFCs that are not obsolete where there is strong evidence that
>    some people are still making use of the related technology.
>
>  4. Trivial grammar corrections should be Hold for Document Update.
>
>  5. Typographical errors which would not cause any confusions to
>    implementation or deployments should be Hold for Document Update.
>
>  6. Changes which are simply stylistic issues or simply make things
>    read better should be Hold for Document Update.
>
>  7. Changes that modify the working of a protocol to something that
>    might be different from the intended consensus when the document
>    was approved should be either Hold for Document Update or
>    Rejected. Deciding between these two depends on judgment.
>    Changes that are clearly modifications to the intended consensus,
>    or involve large textual changes, should be Rejected. In unclear
>    situations, small changes can be Hold for Document Update.
>
>  8. Changes that modify the working of a process, such as changing an
>    IANA registration procedure, to something that might be different
>    from the intended consensus when the document was approved should
>    be Rejected.
>
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc
>
>


From lars.eggert@nokia.com  Wed Feb  2 18:16:52 2011
Return-Path: <lars.eggert@nokia.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 0461A3A67A5 for <rohc@core3.amsl.com>; Wed,  2 Feb 2011 18:16:52 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -102.674
X-Spam-Level: 
X-Spam-Status: No, score=-102.674 tagged_above=-999 required=5 tests=[AWL=-1.144, BAYES_00=-2.599, DATE_IN_PAST_06_12=1.069, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id SI4dq+wjd-rz for <rohc@core3.amsl.com>; Wed,  2 Feb 2011 18:16:50 -0800 (PST)
Received: from mgw-da02.nokia.com (smtp.nokia.com [147.243.128.26]) by core3.amsl.com (Postfix) with ESMTP id B14103A659A for <rohc@ietf.org>; Wed,  2 Feb 2011 18:16:49 -0800 (PST)
Received: from mail.fit.nokia.com (esdhcp030222.research.nokia.com [172.21.30.222]) by mgw-da02.nokia.com (Switch-3.4.3/Switch-3.4.3) with ESMTP id p132K7rq027541 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Thu, 3 Feb 2011 04:20:09 +0200
X-Virus-Status: Clean
X-Virus-Scanned: clamav-milter 0.96.5 at fit.nokia.com
Mime-Version: 1.0 (Apple Message framework v1082)
Content-Type: multipart/signed; boundary=Apple-Mail-31-535536765; protocol="application/pkcs7-signature"; micalg=sha1
From: Lars Eggert <lars.eggert@nokia.com>
In-Reply-To: <2FFB75E6EB5AD746A81F398DDF04D7F18C3576@nawespscez02v.nadsuswe.nads.navy.mil>
Date: Wed, 2 Feb 2011 20:11:56 +0200
Message-Id: <1FA12F82-DF37-4ED7-8202-5118309610E5@nokia.com>
References: <2FFB75E6EB5AD746A81F398DDF04D7F18C3576@nawespscez02v.nadsuswe.nads.navy.mil>
To: sasha.koruga.ctr@navy.mil
X-Mailer: Apple Mail (2.1082)
X-Greylist: Sender succeeded SMTP AUTH, not delayed by milter-greylist-4.2.6 (mail.fit.nokia.com); Wed, 02 Feb 2011 20:11:56 +0200 (EET)
X-Nokia-AV: Clean
Cc: rohc@ietf.org
Subject: Re: [rohc] Errata against ROHC RFCs
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 02:16:52 -0000

--Apple-Mail-31-535536765
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=us-ascii

Hi,

On 2011-2-2, at 18:44, sasha.koruga.ctr@navy.mil wrote:
> Is it possible to include an errata as Calle proposed here: =
http://www.ietf.org/mail-archive/web/rohc/current/msg05960.html

yes, but not by email. See http://www.rfc-editor.org/errata.php and =
report it using the web form. It'll then undergo the review process.

Lars

> Specifically, "I would like to change the text in 6.6.11 to say 'for =
each IPv4 header' instead of 'for each IP header'."
> That issue has been a great source of confusion for my team, and the =
suggested change would quell our concerns.
> Thank you.
>=20
> Regards,
> Sasha
>=20
>=20
> On Mon, Jan 31, 2011 at 4:21 AM, Lars Eggert <lars.eggert@nokia.com> =
wrote:
>> Hi,
>>=20
>> several errata have been submitted against ROHC RFCs: =
http://www.rfc-editor.org/errata_search.php?rec_status=3D2&area_acronym=3D=
tsv&wg_acronym=3Drohc&presentation=3Dtable
>>=20
>> The TSV ADs would like to enlist the help of the RFC authors and the =
broader ROHC community in order to determine how to process these, i.e., =
which should be "verified", "held" or "rejected".
>>=20
>> Please discuss these errata on this list.
>>=20
>> Lars
>>=20
>> PS: IESG guidelines on errata handling:
>>=20
>>  In order to help you determine the correct handling for the errata
>>  in step (4), the IESG has come up with a few guidelines:
>>=20
>> 1. Only errors that could cause implementation or deployment
>>   problems or significant confusion should be Approved.
>>=20
>> 2. Things that are clearly wrong but could not cause an
>>   implementation or deployment problem should be Hold for Document
>>   Update.
>>=20
>> 3. Errata on obsolete RFCs should be treated the same as errata on
>>   RFCs that are not obsolete where there is strong evidence that
>>   some people are still making use of the related technology.
>>=20
>> 4. Trivial grammar corrections should be Hold for Document Update.
>>=20
>> 5. Typographical errors which would not cause any confusions to
>>   implementation or deployments should be Hold for Document Update.
>>=20
>> 6. Changes which are simply stylistic issues or simply make things
>>   read better should be Hold for Document Update.
>>=20
>> 7. Changes that modify the working of a protocol to something that
>>   might be different from the intended consensus when the document
>>   was approved should be either Hold for Document Update or
>>   Rejected. Deciding between these two depends on judgment.
>>   Changes that are clearly modifications to the intended consensus,
>>   or involve large textual changes, should be Rejected. In unclear
>>   situations, small changes can be Hold for Document Update.
>>=20
>> 8. Changes that modify the working of a process, such as changing an
>>   IANA registration procedure, to something that might be different
>>   from the intended consensus when the document was approved should
>>   be Rejected.
>>=20
>> _______________________________________________
>> Rohc mailing list
>> Rohc@ietf.org
>> https://www.ietf.org/mailman/listinfo/rohc
>>=20
>>=20
>=20
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc


--Apple-Mail-31-535536765
Content-Disposition: attachment;
	filename=smime.p7s
Content-Type: application/pkcs7-signature;
	name=smime.p7s
Content-Transfer-Encoding: base64
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--Apple-Mail-31-535536765--

From cabo@tzi.org  Thu Feb  3 00:41:01 2011
Return-Path: <cabo@tzi.org>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 50AF83A689C for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 00:41:01 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -106.367
X-Spam-Level: 
X-Spam-Status: No, score=-106.367 tagged_above=-999 required=5 tests=[AWL=-0.118, BAYES_00=-2.599, HELO_EQ_DE=0.35, RCVD_IN_DNSWL_MED=-4, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id jdQ55N5eDctl for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 00:40:57 -0800 (PST)
Received: from informatik.uni-bremen.de (mailhost.informatik.uni-bremen.de [IPv6:2001:638:708:30c9::12]) by core3.amsl.com (Postfix) with ESMTP id 92BE53A6897 for <rohc@ietf.org>; Thu,  3 Feb 2011 00:40:54 -0800 (PST)
X-Virus-Scanned: amavisd-new at informatik.uni-bremen.de
Received: from smtp-fb3.informatik.uni-bremen.de (smtp-fb3.informatik.uni-bremen.de [134.102.224.120]) by informatik.uni-bremen.de (8.14.3/8.14.3) with ESMTP id p138i5kU001618; Thu, 3 Feb 2011 09:44:06 +0100 (CET)
Received: from [192.168.217.101] (p5489FC97.dip.t-dialin.net [84.137.252.151]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by smtp-fb3.informatik.uni-bremen.de (Postfix) with ESMTPSA id BCD0B2A0; Thu,  3 Feb 2011 09:44:05 +0100 (CET)
Mime-Version: 1.0 (Apple Message framework v1082)
Content-Type: text/plain; charset=us-ascii
From: Carsten Bormann <cabo@tzi.org>
In-Reply-To: <1FA12F82-DF37-4ED7-8202-5118309610E5@nokia.com>
Date: Thu, 3 Feb 2011 09:44:04 +0100
Content-Transfer-Encoding: quoted-printable
Message-Id: <CE52A0DF-48E5-4DAD-A3A0-F186C904E6B2@tzi.org>
References: <2FFB75E6EB5AD746A81F398DDF04D7F18C3576@nawespscez02v.nadsuswe.nads.navy.mil> <1FA12F82-DF37-4ED7-8202-5118309610E5@nokia.com>
To: Lars Eggert <lars.eggert@nokia.com>
X-Mailer: Apple Mail (2.1082)
Cc: rohc@ietf.org, sasha.koruga.ctr@navy.mil
Subject: Re: [rohc] Errata against ROHC RFCs
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 08:41:01 -0000

On Feb 2, 2011, at 19:11, Lars Eggert wrote:

> yes, but not by email. See http://www.rfc-editor.org/errata.php and =
report it using the web form. It'll then undergo the review process.

Yeah, in the referenced mail from September 2010, Carl Knutsson said he =
was going to do that based on Sasha's input -- nudge, nudge.

Gruesse, Carsten


From carl.knutsson@effnet.com  Thu Feb  3 03:16:14 2011
Return-Path: <carl.knutsson@effnet.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 4D87A3A68E7 for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 03:16:14 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.599
X-Spam-Level: 
X-Spam-Status: No, score=-2.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id iQUJFVN7MVqC for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 03:16:13 -0800 (PST)
Received: from lists.levonline.com (lists.levonline.com [217.70.33.37]) by core3.amsl.com (Postfix) with ESMTP id 6FACF3A6885 for <rohc@ietf.org>; Thu,  3 Feb 2011 03:16:10 -0800 (PST)
Received: from localhost (localhost.localdomain [127.0.0.1]) by lists.levonline.com (Postfix) with ESMTP id A7305268393 for <rohc@ietf.org>; Thu,  3 Feb 2011 12:19:31 +0100 (CET)
Received: from lists.levonline.com ([127.0.0.1]) by localhost (lists.levonline.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 75Hg3aYQGEVD for <rohc@ietf.org>; Thu,  3 Feb 2011 12:19:30 +0100 (CET)
Received: from traktor2.skognet.levonline.com (webhotel.fordon.levonline.com [217.70.32.2]) by lists.levonline.com (Postfix) with ESMTP id CD92C2681C2 for <rohc@ietf.org>; Thu,  3 Feb 2011 12:19:30 +0100 (CET)
Received: from [192.168.101.21] (c-b10171d5.04-205-6c756c1.cust.bredbandsbolaget.se [213.113.1.177]) (authenticated bits=0) by traktor2.skognet.levonline.com (8.13.8/8.13.8) with ESMTP id p13BJUTh014056 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO) for <rohc@ietf.org>; Thu, 3 Feb 2011 12:19:30 +0100
Message-ID: <4D4A8F3D.6040509@effnet.com>
Date: Thu, 03 Feb 2011 12:19:25 +0100
From: Carl Knutsson <carl.knutsson@effnet.com>
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101208 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
To: rohc@ietf.org
References: <2FFB75E6EB5AD746A81F398DDF04D7F18C3576@nawespscez02v.nadsuswe.nads.navy.mil>	<1FA12F82-DF37-4ED7-8202-5118309610E5@nokia.com> <CE52A0DF-48E5-4DAD-A3A0-F186C904E6B2@tzi.org>
In-Reply-To: <CE52A0DF-48E5-4DAD-A3A0-F186C904E6B2@tzi.org>
X-Enigmail-Version: 1.1.2
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Subject: Re: [rohc] Errata against ROHC RFCs
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 11:16:14 -0000

Sorry about the delay Sasha. I should have done this months ago. I will
do as soon as I pressed the send button.

cheers,

/Calle


On 02/03/2011 09:44 AM, Carsten Bormann wrote:
> On Feb 2, 2011, at 19:11, Lars Eggert wrote:
> 
>> yes, but not by email. See http://www.rfc-editor.org/errata.php and report it using the web form. It'll then undergo the review process.
> 
> Yeah, in the referenced mail from September 2010, Carl Knutsson said he was going to do that based on Sasha's input -- nudge, nudge.
> 
> Gruesse, Carsten
> 
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc


From wwwrun@rfc-editor.org  Thu Feb  3 04:18:39 2011
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 39AF53A6947 for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 04:18:39 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -102.31
X-Spam-Level: 
X-Spam-Status: No, score=-102.31 tagged_above=-999 required=5 tests=[AWL=0.290, BAYES_00=-2.599, NO_RELAYS=-0.001, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ZCCUo0VIGJoc for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 04:18:38 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [IPv6:2001:1890:1112:1::2f]) by core3.amsl.com (Postfix) with ESMTP id 352A43A6946 for <rohc@ietf.org>; Thu,  3 Feb 2011 04:18:38 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id A4749E06B4; Thu,  3 Feb 2011 04:22:00 -0800 (PST)
To: ghyslain.pelletier@ericsson.com, kristofer.sandlund@ericsson.com, ietfdbh@comcast.net, lars.eggert@nokia.com, carl.knutsson@effnet.com
From: RFC Errata System <rfc-editor@rfc-editor.org>
Message-Id: <20110203122200.A4749E06B4@rfc-editor.org>
Date: Thu,  3 Feb 2011 04:22:00 -0800 (PST)
Cc: rohc@ietf.org, rfc-editor@rfc-editor.org
Subject: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 12:18:39 -0000

The following errata report has been submitted for RFC5225,
"RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=2703

--------------------------------------
Type: Technical
Reported by: Carl Knutsson <carl.knutsson@effnet.com>

Section: 6.6.11

Original Text
-------------
o  ip_id_behavior, one octet for each IP header in the compressible
   header chain starting from the outermost header.  Each octet
   consists of 2 bits padded with 6 MSBs of zeroes.

Corrected Text
--------------
o  ip_id_behavior_outer, one octet for each IPv4 header except the
   innermost in the compressible header chain starting from the outermost 
   header. Each octet consists of 2 bits padded with 6 MSBs of zeroes.

o  ip_id_behavior_innermost, one octet if the innermost header is an 
   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of zeroes.

Notes
-----
There is no control field called ip_ip_behavior in the document. There are two control fields related to IP-ID behavior, ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the ip_id_behavior_innermost field exists and its value is always IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to include ip_id_behavior_outer when calculating the crc for IPv6 headers. Furthermore, since the ip_id_behavior_innermost is constant it makes no sense to include it in the crc calculation.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
--------------------------------------
Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
Publication Date    : April 2008
Author(s)           : G. Pelletier, K. Sandlund
Category            : PROPOSED STANDARD
Source              : Robust Header Compression
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

From lars.eggert@nokia.com  Thu Feb  3 05:07:30 2011
Return-Path: <lars.eggert@nokia.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 81F443A68FD for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:07:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -103.196
X-Spam-Level: 
X-Spam-Status: No, score=-103.196 tagged_above=-999 required=5 tests=[AWL=-0.597, BAYES_00=-2.599, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8zAZKQzZ8tS5 for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:07:29 -0800 (PST)
Received: from mgw-da02.nokia.com (smtp.nokia.com [147.243.128.26]) by core3.amsl.com (Postfix) with ESMTP id 53CA43A68F8 for <rohc@ietf.org>; Thu,  3 Feb 2011 05:07:29 -0800 (PST)
Received: from mail.fit.nokia.com (esdhcp030222.research.nokia.com [172.21.30.222]) by mgw-da02.nokia.com (Switch-3.4.3/Switch-3.4.3) with ESMTP id p13DA8fT013220 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Thu, 3 Feb 2011 15:10:09 +0200
X-Virus-Status: Clean
X-Virus-Scanned: clamav-milter 0.96.5 at fit.nokia.com
Mime-Version: 1.0 (Apple Message framework v1082)
Content-Type: multipart/signed; boundary=Apple-Mail-47-602751659; protocol="application/pkcs7-signature"; micalg=sha1
From: Lars Eggert <lars.eggert@nokia.com>
In-Reply-To: <20110203122200.A4749E06B4@rfc-editor.org>
Date: Thu, 3 Feb 2011 14:52:11 +0200
Message-Id: <DF9B84C1-2794-49B6-BF7E-9C871E5673F2@nokia.com>
References: <20110203122200.A4749E06B4@rfc-editor.org>
To: rohc@ietf.org
X-Mailer: Apple Mail (2.1082)
X-Greylist: Sender succeeded SMTP AUTH, not delayed by milter-greylist-4.2.6 (mail.fit.nokia.com); Thu, 03 Feb 2011 14:52:16 +0200 (EET)
X-Nokia-AV: Clean
Cc: kristofer.sandlund@ericsson.com, David Harrington <ietfdbh@comcast.net>, ghyslain.pelletier@ericsson.com
Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 13:07:30 -0000

--Apple-Mail-47-602751659
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=us-ascii

Based on the ongoing discussion, I assume the community consensus is to =
approve this?

On 2011-2-3, at 14:22, RFC Errata System wrote:

>=20
> The following errata report has been submitted for RFC5225,
> "RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, =
IP, ESP and UDP-Lite".
>=20
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=3D5225&eid=3D2703
>=20
> --------------------------------------
> Type: Technical
> Reported by: Carl Knutsson <carl.knutsson@effnet.com>
>=20
> Section: 6.6.11
>=20
> Original Text
> -------------
> o  ip_id_behavior, one octet for each IP header in the compressible
>=20
>   header chain starting from the outermost header.  Each octet
>=20
>   consists of 2 bits padded with 6 MSBs of zeroes.
>=20
> Corrected Text
> --------------
> o  ip_id_behavior_outer, one octet for each IPv4 header except the
>=20
>   innermost in the compressible header chain starting from the =
outermost=20
>=20
>   header. Each octet consists of 2 bits padded with 6 MSBs of zeroes.
>=20
>=20
>=20
> o  ip_id_behavior_innermost, one octet if the innermost header is an=20=

>=20
>   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of =
zeroes.
>=20
> Notes
> -----
> There is no control field called ip_ip_behavior in the document. There =
are two control fields related to IP-ID behavior, =
ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the =
ip_id_behavior_innermost field exists and its value is always =
IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to =
include ip_id_behavior_outer when calculating the crc for IPv6 headers. =
Furthermore, since the ip_id_behavior_innermost is constant it makes no =
sense to include it in the crc calculation.
>=20
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.=20
>=20
> --------------------------------------
> RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
> --------------------------------------
> Title               : RObust Header Compression Version 2 (ROHCv2): =
Profiles for RTP, UDP, IP, ESP and UDP-Lite
> Publication Date    : April 2008
> Author(s)           : G. Pelletier, K. Sandlund
> Category            : PROPOSED STANDARD
> Source              : Robust Header Compression
> Area                : Transport
> Stream              : IETF
> Verifying Party     : IESG


--Apple-Mail-47-602751659
Content-Disposition: attachment;
	filename=smime.p7s
Content-Type: application/pkcs7-signature;
	name=smime.p7s
Content-Transfer-Encoding: base64
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--Apple-Mail-47-602751659--

From carl.knutsson@effnet.com  Thu Feb  3 05:32:42 2011
Return-Path: <carl.knutsson@effnet.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id B33773A694C for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:32:42 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.599
X-Spam-Level: 
X-Spam-Status: No, score=-2.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id zFYzMTioc04K for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:32:41 -0800 (PST)
Received: from lists.levonline.com (lists.levonline.com [217.70.33.37]) by core3.amsl.com (Postfix) with ESMTP id 15A973A6919 for <rohc@ietf.org>; Thu,  3 Feb 2011 05:32:41 -0800 (PST)
Received: from localhost (localhost.localdomain [127.0.0.1]) by lists.levonline.com (Postfix) with ESMTP id A1EF5268566 for <rohc@ietf.org>; Thu,  3 Feb 2011 14:36:02 +0100 (CET)
Received: from lists.levonline.com ([127.0.0.1]) by localhost (lists.levonline.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id mXDWTpUdmzcW for <rohc@ietf.org>; Thu,  3 Feb 2011 14:36:00 +0100 (CET)
Received: from traktor1.fordonnet.levonline.com (webhotel.fordon.levonline.com [217.70.32.2]) by lists.levonline.com (Postfix) with ESMTP id E796626810E; Thu,  3 Feb 2011 14:35:59 +0100 (CET)
Received: from [192.168.101.21] (c-b10171d5.04-205-6c756c1.cust.bredbandsbolaget.se [213.113.1.177]) (authenticated bits=0) by traktor1.fordonnet.levonline.com (8.13.8/8.13.8) with ESMTP id p13DZxcj003052 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Thu, 3 Feb 2011 14:35:59 +0100
Message-ID: <4D4AAF39.5050405@effnet.com>
Date: Thu, 03 Feb 2011 14:35:53 +0100
From: Carl Knutsson <carl.knutsson@effnet.com>
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101208 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
To: Lars Eggert <lars.eggert@nokia.com>
References: <20110203122200.A4749E06B4@rfc-editor.org> <DF9B84C1-2794-49B6-BF7E-9C871E5673F2@nokia.com>
In-Reply-To: <DF9B84C1-2794-49B6-BF7E-9C871E5673F2@nokia.com>
X-Enigmail-Version: 1.1.2
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Cc: kristofer.sandlund@ericsson.com, rohc@ietf.org, David Harrington <ietfdbh@comcast.net>, ghyslain.pelletier@ericsson.com
Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 13:32:42 -0000

Lars, others,

I have had an on-list discussion with Sasha and an off-list with
Kristofer and I have come up with the suggested correction. The actual
details of the suggestion in the errata haven't been discussed. So I
would like people to review the errata. Comments from the authors would
also be appreciated.

There are three things that I'd like to point out here:

1) There is no ip_id_behavior control field in the FN of RFC 5225. Only
ip_id_behavior_innermost and ip_id_behavior_outer.

2) Not to include the control field for outer IPv6 headers is the actual
bug fix. There does not exist any ip_id_behavior_outer control field in
the FN for ipv6 (it does for ipv4).

3) Excluding the control field for the innermost IPv6 header may be
considered a change and not a correction, but since the whole business
with the ip_id_behavior is not crystal clear...

So especially number 3) is up for discussion and also my suggestion for
the Corrected Text.

cheers,

/Calle

On 02/03/2011 01:52 PM, Lars Eggert wrote:
> Based on the ongoing discussion, I assume the community consensus is to approve this?
> 
> On 2011-2-3, at 14:22, RFC Errata System wrote:
> 
>>
>> The following errata report has been submitted for RFC5225,
>> "RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".
>>
>> --------------------------------------
>> You may review the report below and at:
>> http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=2703
>>
>> --------------------------------------
>> Type: Technical
>> Reported by: Carl Knutsson <carl.knutsson@effnet.com>
>>
>> Section: 6.6.11
>>
>> Original Text
>> -------------
>> o  ip_id_behavior, one octet for each IP header in the compressible
>>
>>   header chain starting from the outermost header.  Each octet
>>
>>   consists of 2 bits padded with 6 MSBs of zeroes.
>>
>> Corrected Text
>> --------------
>> o  ip_id_behavior_outer, one octet for each IPv4 header except the
>>
>>   innermost in the compressible header chain starting from the outermost 
>>
>>   header. Each octet consists of 2 bits padded with 6 MSBs of zeroes.
>>
>>
>>
>> o  ip_id_behavior_innermost, one octet if the innermost header is an 
>>
>>   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of zeroes.
>>
>> Notes
>> -----
>> There is no control field called ip_ip_behavior in the document. There are two control fields related to IP-ID behavior, ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the ip_id_behavior_innermost field exists and its value is always IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to include ip_id_behavior_outer when calculating the crc for IPv6 headers. Furthermore, since the ip_id_behavior_innermost is constant it makes no sense to include it in the crc calculation.
>>
>> Instructions:
>> -------------
>> This errata is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party (IESG)
>> can log in to change the status and edit the report, if necessary. 
>>
>> --------------------------------------
>> RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
>> --------------------------------------
>> Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
>> Publication Date    : April 2008
>> Author(s)           : G. Pelletier, K. Sandlund
>> Category            : PROPOSED STANDARD
>> Source              : Robust Header Compression
>> Area                : Transport
>> Stream              : IETF
>> Verifying Party     : IESG
> 


From kristofer.sandlund@ericsson.com  Thu Feb  3 05:23:20 2011
Return-Path: <kristofer.sandlund@ericsson.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 5B45C3A693B for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:23:20 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.599
X-Spam-Level: 
X-Spam-Status: No, score=-6.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id gMuKELawRWMW for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:23:19 -0800 (PST)
Received: from mailgw9.se.ericsson.net (mailgw9.se.ericsson.net [193.180.251.57]) by core3.amsl.com (Postfix) with ESMTP id 06F573A6942 for <rohc@ietf.org>; Thu,  3 Feb 2011 05:23:18 -0800 (PST)
X-AuditID: c1b4fb39-b7cfbae000005c8e-e7-4d4aad1051fb
Received: from esessmw0237.eemea.ericsson.se (Unknown_Domain [153.88.253.125]) by mailgw9.se.ericsson.net (Symantec Mail Security) with SMTP id 80.C4.23694.01DAA4D4; Thu,  3 Feb 2011 14:26:40 +0100 (CET)
Received: from ESESSCMS0361.eemea.ericsson.se ([169.254.1.239]) by esessmw0237.eemea.ericsson.se ([153.88.115.90]) with mapi; Thu, 3 Feb 2011 14:26:40 +0100
From: Kristofer Sandlund <kristofer.sandlund@ericsson.com>
To: Lars Eggert <lars.eggert@nokia.com>, "rohc@ietf.org" <rohc@ietf.org>
Date: Thu, 3 Feb 2011 14:26:39 +0100
Thread-Topic: [Technical Errata Reported] RFC5225 (2703)
Thread-Index: AcvDo8hN/Wkrs96eSgClxicXPgqmHgAAYbaQ
Message-ID: <61D017C9E2225D4A974A141907F3CD1013E9FCFE83@ESESSCMS0361.eemea.ericsson.se>
References: <20110203122200.A4749E06B4@rfc-editor.org> <DF9B84C1-2794-49B6-BF7E-9C871E5673F2@nokia.com>
In-Reply-To: <DF9B84C1-2794-49B6-BF7E-9C871E5673F2@nokia.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: en-US
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
X-Brightmail-Tracker: AAAAAA==
X-Mailman-Approved-At: Thu, 03 Feb 2011 05:33:45 -0800
Cc: David Harrington <ietfdbh@comcast.net>
Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 13:25:34 -0000

Ongoing discussion? I'm no longer subscribed to the rohc list (and I'm quit=
e sure my co-author doesn't read it either), so I don't know of anything th=
at has been discussed there.

But I have previously discussed the below issue with Calle and I agree with=
 his suggested update.

/Kristofer

at den 3 februari 2011 13:52, Lars Eggert wrote :
> Based on the ongoing discussion, I assume the community
> consensus is to approve this?
>=20
> On 2011-2-3, at 14:22, RFC Errata System wrote:
>=20
> >=20
> > The following errata report has been submitted for
> > RFC5225, "RObust Header Compression Version 2 (ROHCv2):
> > Profiles for=20
> RTP, UDP, IP, ESP and UDP-Lite".
> >=20
> > --------------------------------------
> > You may review the report below and at:
> > http://www.rfc-editor.org/errata_search.php?rfc=3D5225&eid=3D2703
> >=20
> > --------------------------------------
> > Type: Technical
> > Reported by: Carl Knutsson <carl.knutsson@effnet.com>
> >=20
> > Section: 6.6.11
> >=20
> > Original Text
> > -------------
> > o  ip_id_behavior, one octet for each IP header in the
> > compressible=20
> >=20
> >   header chain starting from the outermost header.=20
> > Each octet=20
> >=20
> >   consists of 2 bits padded with 6 MSBs of zeroes.
> >=20
> > Corrected Text
> > --------------
> > o  ip_id_behavior_outer, one octet for each IPv4 header
> > except the=20
> >=20
> >   innermost in the compressible header chain starting
> > from=20
> the outermost
> >=20
> >   header. Each octet consists of 2 bits padded with 6
> > MSBs=20
> of zeroes.
> >=20
> >=20
> >=20
> > o  ip_id_behavior_innermost, one octet if the innermost
> header is an
> >=20
> >   IPv4 header. The octet consists of 2 bits padded with
> > 6=20
> MSBs of zeroes.
> >=20
> > Notes
> > -----
> > There is no control field called ip_ip_behavior in the
> document. There are two control fields related to IP-ID
> behavior, ip_id_behavior_innermost and
> ip_id_behavior_outer. For IPv6, only the
> ip_id_behavior_innermost field exists and its value is
> always IP_ID_BEHAVIOR_RANDOM according to the FN. This
> makes it impossible to include ip_id_behavior_outer when
> calculating the crc for IPv6 headers. Furthermore, since
> the ip_id_behavior_innermost is constant it makes no
> sense to include it in the crc calculation.=20
> >=20
> > Instructions:
> > -------------
> > This errata is currently posted as "Reported". If
> > necessary, please use "Reply All" to discuss whether it
> > should be verified or rejected. When a decision is
> > reached, the verifying party (IESG) can log in to
> > change the status and edit the report, if necessary.=20
> >=20
> > --------------------------------------
> > RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
> > --------------------------------------
> > Title               : RObust Header Compression Version
> > 2=20
> (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
> > Publication Date    : April 2008
> > Author(s)           : G. Pelletier, K. Sandlund
> > Category            : PROPOSED STANDARD
> > Source              : Robust Header Compression
> > Area                : Transport
> > Stream              : IETF
> > Verifying Party     : IESG=

From sasha.koruga.ctr@navy.mil  Thu Feb  3 08:15:25 2011
Return-Path: <sasha.koruga.ctr@navy.mil>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 2DD363A6A14 for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 08:15:25 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.542
X-Spam-Level: 
X-Spam-Status: No, score=-6.542 tagged_above=-999 required=5 tests=[AWL=0.057,  BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id fcPdlUnlgbum for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 08:15:24 -0800 (PST)
Received: from gate1-sandiego.nmci.navy.mil (gate1-sandiego.nmci.navy.mil [138.163.0.41]) by core3.amsl.com (Postfix) with ESMTP id 171793A6A13 for <rohc@ietf.org>; Thu,  3 Feb 2011 08:15:23 -0800 (PST)
Received: from nawesdnieg05v.nadsuswe.nads.navy.mil ([10.0.0.161]) by gate1-sandiego.nmci.navy.mil with Microsoft SMTPSVC(5.0.2195.6872);  Thu, 3 Feb 2011 08:06:03 -0800
Received: from nawesdnieb10v.nadsuswe.nads.navy.mil ([10.0.10.27]) by nawesdnieg05v.nadsuswe.nads.navy.mil with Microsoft SMTPSVC(6.0.3790.4675); Thu, 3 Feb 2011 08:18:46 -0800
Received: from nawespsceb02v.nadsuswe.nads.navy.mil ([10.1.120.16]) by nawesdnieb10v.nadsuswe.nads.navy.mil with Microsoft SMTPSVC(6.0.3790.4675); Thu, 3 Feb 2011 08:18:46 -0800
Received: from nawespscez02v.nadsuswe.nads.navy.mil ([10.1.120.21]) by nawespsceb02v.nadsuswe.nads.navy.mil with Microsoft SMTPSVC(6.0.3790.4675); Thu, 3 Feb 2011 09:18:46 -0700
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Date: Thu, 3 Feb 2011 09:18:46 -0700
Message-ID: <2FFB75E6EB5AD746A81F398DDF04D7F18C3579@nawespscez02v.nadsuswe.nads.navy.mil>
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
Thread-Topic: [rohc] [Technical Errata Reported] RFC5225 (2703)
Thread-Index: AcvDvghACN5KS7jWTzWZs/EKa4nCEw==
From: "Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110" <sasha.koruga.ctr@navy.mil>
To: <rohc@ietf.org>
X-OriginalArrivalTime: 03 Feb 2011 16:18:46.0049 (UTC) FILETIME=[084A7110:01CBC3BE]
Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 16:15:25 -0000

Calle's correction looks good to me. Thank you, Calle.

-Sasha

On Thu, Feb 3, 2011 at 5:35 AM, Carl Knutsson <carl.knutsson@effnet.com> =
wrote:
> Lars, others,
>
> I have had an on-list discussion with Sasha and an off-list with
> Kristofer and I have come up with the suggested correction. The actual
> details of the suggestion in the errata haven't been discussed. So I
> would like people to review the errata. Comments from the authors =
would
> also be appreciated.
>
> There are three things that I'd like to point out here:
>
> 1) There is no ip_id_behavior control field in the FN of RFC 5225. =
Only
> ip_id_behavior_innermost and ip_id_behavior_outer.
>
> 2) Not to include the control field for outer IPv6 headers is the =
actual
> bug fix. There does not exist any ip_id_behavior_outer control field =
in
> the FN for ipv6 (it does for ipv4).
>
> 3) Excluding the control field for the innermost IPv6 header may be
> considered a change and not a correction, but since the whole business
> with the ip_id_behavior is not crystal clear...
>
> So especially number 3) is up for discussion and also my suggestion =
for
> the Corrected Text.
>
> cheers,
>
> /Calle
>
> On 02/03/2011 01:52 PM, Lars Eggert wrote:
>> Based on the ongoing discussion, I assume the community consensus is =
to approve this?
>>
>> On 2011-2-3, at 14:22, RFC Errata System wrote:
>>
>>>
>>> The following errata report has been submitted for RFC5225,
>>> "RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, =
UDP, IP, ESP and UDP-Lite".
>>>
>>> --------------------------------------
>>> You may review the report below and at:
>>> http://www.rfc-editor.org/errata_search.php?rfc=3D5225&eid=3D2703
>>>
>>> --------------------------------------
>>> Type: Technical
>>> Reported by: Carl Knutsson <carl.knutsson@effnet.com>
>>>
>>> Section: 6.6.11
>>>
>>> Original Text
>>> -------------
>>> o  ip_id_behavior, one octet for each IP header in the compressible
>>>
>>>   header chain starting from the outermost header.  Each octet
>>>
>>>   consists of 2 bits padded with 6 MSBs of zeroes.
>>>
>>> Corrected Text
>>> --------------
>>> o  ip_id_behavior_outer, one octet for each IPv4 header except the
>>>
>>>   innermost in the compressible header chain starting from the =
outermost
>>>
>>>   header. Each octet consists of 2 bits padded with 6 MSBs of =
zeroes.
>>>
>>>
>>>
>>> o  ip_id_behavior_innermost, one octet if the innermost header is an
>>>
>>>   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of =
zeroes.
>>>
>>> Notes
>>> -----
>>> There is no control field called ip_ip_behavior in the document. =
There are two control fields related to IP-ID behavior, =
ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the =
ip_id_behavior_innermost field exists and its value is always =
IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to =
include ip_id_behavior_outer when calculating the crc for IPv6 headers. =
Furthermore, since the ip_id_behavior_innermost is constant it makes no =
sense to include it in the crc calculation.
>>>
>>> Instructions:
>>> -------------
>>> This errata is currently posted as "Reported". If necessary, please
>>> use "Reply All" to discuss whether it should be verified or
>>> rejected. When a decision is reached, the verifying party (IESG)
>>> can log in to change the status and edit the report, if necessary.
>>>
>>> --------------------------------------
>>> RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
>>> --------------------------------------
>>> Title               : RObust Header Compression Version 2 (ROHCv2): =
Profiles for RTP, UDP, IP, ESP and UDP-Lite
>>> Publication Date    : April 2008
>>> Author(s)           : G. Pelletier, K. Sandlund
>>> Category            : PROPOSED STANDARD
>>> Source              : Robust Header Compression
>>> Area                : Transport
>>> Stream              : IETF
>>> Verifying Party     : IESG
>>
>
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc
>


From rstangarone-ietf@whataboutbob.org  Thu Feb  3 20:55:48 2011
Return-Path: <rstangarone-ietf@whataboutbob.org>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 9B4D43A6AFF for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 20:55:48 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.812
X-Spam-Level: 
X-Spam-Status: No, score=-0.812 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, FH_HOST_EQ_D_D_D_D=0.765, HELO_MISMATCH_ORG=0.611, HOST_MISMATCH_COM=0.311, RDNS_DYNAMIC=0.1]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 9vo4jE8Bd6wt for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 20:55:46 -0800 (PST)
Received: from whataboutbob.org (netblock-72-25-108-170.dslextreme.com [72.25.108.170]) by core3.amsl.com (Postfix) with ESMTP id 2A70A3A6AF8 for <rohc@ietf.org>; Thu,  3 Feb 2011 20:55:46 -0800 (PST)
Received: from localhost (localhost.localdomain [127.0.0.1]) by whataboutbob.org (Postfix) with ESMTP id 8A4CC8732169; Thu,  3 Feb 2011 20:59:08 -0800 (PST)
Received: from [192.168.2.75] (unknown [192.168.3.24]) by whataboutbob.org (Postfix) with ESMTPSA id D6DE987315C9; Thu,  3 Feb 2011 20:59:07 -0800 (PST)
Message-ID: <4D4B879C.90402@whataboutbob.org>
Date: Thu, 03 Feb 2011 20:59:08 -0800
From: rstangarone-ietf <rstangarone-ietf@whataboutbob.org>
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101208 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
To: "Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110" <sasha.koruga.ctr@navy.mil>
References: <2FFB75E6EB5AD746A81F398DDF04D7F18C3579@nawespscez02v.nadsuswe.nads.navy.mil>
In-Reply-To: <2FFB75E6EB5AD746A81F398DDF04D7F18C3579@nawespscez02v.nadsuswe.nads.navy.mil>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Cc: rohc@ietf.org
Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
Reply-To: rstangarone-ietf@whataboutbob.org
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 04 Feb 2011 04:55:48 -0000

I've also discussed this with Sasha offline, I'll take a look at the
errata again and give you some input shortly.

Bob

On 02/03/2011 08:18 AM, Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110
wrote:
> Calle's correction looks good to me. Thank you, Calle.
> 
> -Sasha
> 
> On Thu, Feb 3, 2011 at 5:35 AM, Carl Knutsson <carl.knutsson@effnet.com> wrote:
>> Lars, others,
>>
>> I have had an on-list discussion with Sasha and an off-list with
>> Kristofer and I have come up with the suggested correction. The actual
>> details of the suggestion in the errata haven't been discussed. So I
>> would like people to review the errata. Comments from the authors would
>> also be appreciated.
>>
>> There are three things that I'd like to point out here:
>>
>> 1) There is no ip_id_behavior control field in the FN of RFC 5225. Only
>> ip_id_behavior_innermost and ip_id_behavior_outer.
>>
>> 2) Not to include the control field for outer IPv6 headers is the actual
>> bug fix. There does not exist any ip_id_behavior_outer control field in
>> the FN for ipv6 (it does for ipv4).
>>
>> 3) Excluding the control field for the innermost IPv6 header may be
>> considered a change and not a correction, but since the whole business
>> with the ip_id_behavior is not crystal clear...
>>
>> So especially number 3) is up for discussion and also my suggestion for
>> the Corrected Text.
>>
>> cheers,
>>
>> /Calle
>>
>> On 02/03/2011 01:52 PM, Lars Eggert wrote:
>>> Based on the ongoing discussion, I assume the community consensus is to approve this?
>>>
>>> On 2011-2-3, at 14:22, RFC Errata System wrote:
>>>
>>>>
>>>> The following errata report has been submitted for RFC5225,
>>>> "RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".
>>>>
>>>> --------------------------------------
>>>> You may review the report below and at:
>>>> http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=2703
>>>>
>>>> --------------------------------------
>>>> Type: Technical
>>>> Reported by: Carl Knutsson <carl.knutsson@effnet.com>
>>>>
>>>> Section: 6.6.11
>>>>
>>>> Original Text
>>>> -------------
>>>> o  ip_id_behavior, one octet for each IP header in the compressible
>>>>
>>>>   header chain starting from the outermost header.  Each octet
>>>>
>>>>   consists of 2 bits padded with 6 MSBs of zeroes.
>>>>
>>>> Corrected Text
>>>> --------------
>>>> o  ip_id_behavior_outer, one octet for each IPv4 header except the
>>>>
>>>>   innermost in the compressible header chain starting from the outermost
>>>>
>>>>   header. Each octet consists of 2 bits padded with 6 MSBs of zeroes.
>>>>
>>>>
>>>>
>>>> o  ip_id_behavior_innermost, one octet if the innermost header is an
>>>>
>>>>   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of zeroes.
>>>>
>>>> Notes
>>>> -----
>>>> There is no control field called ip_ip_behavior in the document. There are two control fields related to IP-ID behavior, ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the ip_id_behavior_innermost field exists and its value is always IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to include ip_id_behavior_outer when calculating the crc for IPv6 headers. Furthermore, since the ip_id_behavior_innermost is constant it makes no sense to include it in the crc calculation.
>>>>
>>>> Instructions:
>>>> -------------
>>>> This errata is currently posted as "Reported". If necessary, please
>>>> use "Reply All" to discuss whether it should be verified or
>>>> rejected. When a decision is reached, the verifying party (IESG)
>>>> can log in to change the status and edit the report, if necessary.
>>>>
>>>> --------------------------------------
>>>> RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
>>>> --------------------------------------
>>>> Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
>>>> Publication Date    : April 2008
>>>> Author(s)           : G. Pelletier, K. Sandlund
>>>> Category            : PROPOSED STANDARD
>>>> Source              : Robust Header Compression
>>>> Area                : Transport
>>>> Stream              : IETF
>>>> Verifying Party     : IESG
>>>
>>
>> _______________________________________________
>> Rohc mailing list
>> Rohc@ietf.org
>> https://www.ietf.org/mailman/listinfo/rohc
>>
> 
> _______________________________________________
> Rohc mailing list
> Rohc@ietf.org
> https://www.ietf.org/mailman/listinfo/rohc

From ghyslain@live.se  Thu Feb  3 05:55:12 2011
Return-Path: <ghyslain@live.se>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id F32613A6970 for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:55:11 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.598
X-Spam-Level: 
X-Spam-Status: No, score=-2.598 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, STOX_REPLY_TYPE=0.001]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 5jaN4vZXVkxI for <rohc@core3.amsl.com>; Thu,  3 Feb 2011 05:55:10 -0800 (PST)
Received: from bay0-omc3-s18.bay0.hotmail.com (bay0-omc3-s18.bay0.hotmail.com [65.54.190.156]) by core3.amsl.com (Postfix) with ESMTP id EAA303A696F for <rohc@ietf.org>; Thu,  3 Feb 2011 05:55:09 -0800 (PST)
Received: from BAY146-DS2 ([65.54.190.189]) by bay0-omc3-s18.bay0.hotmail.com with Microsoft SMTPSVC(6.0.3790.4675);  Thu, 3 Feb 2011 05:58:32 -0800
X-Originating-IP: [64.194.250.99]
X-Originating-Email: [ghyslain@live.se]
Message-ID: <BAY146-ds293E84115FA0D199F1AFBDBE70@phx.gbl>
From: "Ghyslain Pelletier" <ghyslain@live.se>
To: "Kristofer Sandlund" <kristofer.sandlund@ericsson.com>, "Lars Eggert" <lars.eggert@nokia.com>, <rohc@ietf.org>
References: <20110203122200.A4749E06B4@rfc-editor.org> <DF9B84C1-2794-49B6-BF7E-9C871E5673F2@nokia.com> <61D017C9E2225D4A974A141907F3CD1013E9FCFE83@ESESSCMS0361.eemea.ericsson.se>
In-Reply-To: <61D017C9E2225D4A974A141907F3CD1013E9FCFE83@ESESSCMS0361.eemea.ericsson.se>
Date: Thu, 3 Feb 2011 08:58:32 -0500
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Mailer: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
X-OriginalArrivalTime: 03 Feb 2011 13:58:32.0489 (UTC) FILETIME=[716B1190:01CBC3AA]
X-Mailman-Approved-At: Thu, 03 Feb 2011 23:49:41 -0800
Cc: David Harrington <ietfdbh@comcast.net>
Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 03 Feb 2011 14:19:01 -0000

Similar to Kristofer, I am also no longer subscribed to the ROHC list and no 
longer follow discussions in that forum. I also agree with the proposed 
update.

///Ghyslain

--------------------------------------------------
From: "Kristofer Sandlund" <kristofer.sandlund@ericsson.com>
Sent: Thursday, February 03, 2011 8:26 AM
To: "Lars Eggert" <lars.eggert@nokia.com>; <rohc@ietf.org>
Cc: "David Harrington" <ietfdbh@comcast.net>; <carl.knutsson@effnet.com>
Subject: RE: [Technical Errata Reported] RFC5225 (2703)

> Ongoing discussion? I'm no longer subscribed to the rohc list (and I'm 
> quite sure my co-author doesn't read it either), so I don't know of 
> anything that has been discussed there.
>
> But I have previously discussed the below issue with Calle and I agree 
> with his suggested update.
>
> /Kristofer
>
> at den 3 februari 2011 13:52, Lars Eggert wrote :
>> Based on the ongoing discussion, I assume the community
>> consensus is to approve this?
>>
>> On 2011-2-3, at 14:22, RFC Errata System wrote:
>>
>> >
>> > The following errata report has been submitted for
>> > RFC5225, "RObust Header Compression Version 2 (ROHCv2):
>> > Profiles for
>> RTP, UDP, IP, ESP and UDP-Lite".
>> >
>> > --------------------------------------
>> > You may review the report below and at:
>> > http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=2703
>> >
>> > --------------------------------------
>> > Type: Technical
>> > Reported by: Carl Knutsson <carl.knutsson@effnet.com>
>> >
>> > Section: 6.6.11
>> >
>> > Original Text
>> > -------------
>> > o  ip_id_behavior, one octet for each IP header in the
>> > compressible
>> >
>> >   header chain starting from the outermost header.
>> > Each octet
>> >
>> >   consists of 2 bits padded with 6 MSBs of zeroes.
>> >
>> > Corrected Text
>> > --------------
>> > o  ip_id_behavior_outer, one octet for each IPv4 header
>> > except the
>> >
>> >   innermost in the compressible header chain starting
>> > from
>> the outermost
>> >
>> >   header. Each octet consists of 2 bits padded with 6
>> > MSBs
>> of zeroes.
>> >
>> >
>> >
>> > o  ip_id_behavior_innermost, one octet if the innermost
>> header is an
>> >
>> >   IPv4 header. The octet consists of 2 bits padded with
>> > 6
>> MSBs of zeroes.
>> >
>> > Notes
>> > -----
>> > There is no control field called ip_ip_behavior in the
>> document. There are two control fields related to IP-ID
>> behavior, ip_id_behavior_innermost and
>> ip_id_behavior_outer. For IPv6, only the
>> ip_id_behavior_innermost field exists and its value is
>> always IP_ID_BEHAVIOR_RANDOM according to the FN. This
>> makes it impossible to include ip_id_behavior_outer when
>> calculating the crc for IPv6 headers. Furthermore, since
>> the ip_id_behavior_innermost is constant it makes no
>> sense to include it in the crc calculation.
>> >
>> > Instructions:
>> > -------------
>> > This errata is currently posted as "Reported". If
>> > necessary, please use "Reply All" to discuss whether it
>> > should be verified or rejected. When a decision is
>> > reached, the verifying party (IESG) can log in to
>> > change the status and edit the report, if necessary.
>> >
>> > --------------------------------------
>> > RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
>> > --------------------------------------
>> > Title               : RObust Header Compression Version
>> > 2
>> (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
>> > Publication Date    : April 2008
>> > Author(s)           : G. Pelletier, K. Sandlund
>> > Category            : PROPOSED STANDARD
>> > Source              : Robust Header Compression
>> > Area                : Transport
>> > Stream              : IETF
>> > Verifying Party     : IESG 


From pranav.savkur@gmail.com  Thu Feb 10 21:13:30 2011
Return-Path: <pranav.savkur@gmail.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 2D9513A6870 for <rohc@core3.amsl.com>; Thu, 10 Feb 2011 21:13:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.598
X-Spam-Level: 
X-Spam-Status: No, score=-3.598 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id GGxQkBuc9xMm for <rohc@core3.amsl.com>; Thu, 10 Feb 2011 21:13:29 -0800 (PST)
Received: from mail-bw0-f44.google.com (mail-bw0-f44.google.com [209.85.214.44]) by core3.amsl.com (Postfix) with ESMTP id 397B63A6857 for <rohc@ietf.org>; Thu, 10 Feb 2011 21:13:29 -0800 (PST)
Received: by bwz12 with SMTP id 12so3115827bwz.31 for <rohc@ietf.org>; Thu, 10 Feb 2011 21:13:42 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:date:message-id:subject:from:to :content-type; bh=2VToXr9WXw/t2ZZCUrZwNjqmlZ4r+QSXQB+p1INNb8c=; b=xjq+V2Cn+w8lmVOZAaaoilNUluGpUx5jbqgnrV2AOrDGra41ubJ8dTkCtJIoPngzuv clvz4kHGV6/4Cb1oRujytbSWXPi82To3AwU5FJREQ7vSRM0p5v8OBhmCxPUhJN8XAm7D rVMRWUMxijChHaTEpW0axnoyzutxj5wvMtu/s=
DomainKey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=dlAaEOeij3QFdt2Iwvolyp/WYCF5nGzee4nrJ+7b/tGno/XzeO77l0h52KFd+KMH2e KYclYDoWlnfY6H1u5q3wKE5wRdAwcKEpvt1YNw2wmpAyhRdwAQKxRFUhSZ6E4wGwHwgp 9hAcN8ZYNsyNzEdGkvOt+DfRgixLD777WZw8Y=
MIME-Version: 1.0
Received: by 10.204.119.75 with SMTP id y11mr59447bkq.18.1297401222353; Thu, 10 Feb 2011 21:13:42 -0800 (PST)
Received: by 10.204.59.147 with HTTP; Thu, 10 Feb 2011 21:13:42 -0800 (PST)
Date: Fri, 11 Feb 2011 10:43:42 +0530
Message-ID: <AANLkTi==64+w=O+SfpGLWfcVgpehWYzNM0Sn3i7VgtBA@mail.gmail.com>
From: Pranav Savkur <pranav.savkur@gmail.com>
To: rohc@ietf.org
Content-Type: multipart/alternative; boundary=0016e6d59eacfd5402049bfac271
X-Mailman-Approved-At: Thu, 10 Feb 2011 22:55:39 -0800
Subject: [rohc] RoHC for RTP/UDP/IP: significance of TSC flag
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 11 Feb 2011 05:14:21 -0000

--0016e6d59eacfd5402049bfac271
Content-Type: text/plain; charset=ISO-8859-1

hello, what is the significance of the TSC flag during
compression/decompression?
-Pranav

--0016e6d59eacfd5402049bfac271
Content-Type: text/html; charset=ISO-8859-1

hello, what is the significance of the TSC flag during compression/decompression?<br>-Pranav<br>

--0016e6d59eacfd5402049bfac271--

From r.ranjithme@gmail.com  Mon Feb 21 07:38:56 2011
Return-Path: <r.ranjithme@gmail.com>
X-Original-To: rohc@core3.amsl.com
Delivered-To: rohc@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 4CF833A7134 for <rohc@core3.amsl.com>; Mon, 21 Feb 2011 07:38:56 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.11
X-Spam-Level: 
X-Spam-Status: No, score=-2.11 tagged_above=-999 required=5 tests=[BAYES_05=-1.11, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id fzyhPw0dMi7y for <rohc@core3.amsl.com>; Mon, 21 Feb 2011 07:38:55 -0800 (PST)
Received: from mail-vw0-f42.google.com (mail-vw0-f42.google.com [209.85.212.42]) by core3.amsl.com (Postfix) with ESMTP id 64E973A713C for <rohc@ietf.org>; Mon, 21 Feb 2011 07:38:55 -0800 (PST)
Received: by vws10 with SMTP id 10so1742974vws.15 for <rohc@ietf.org>; Mon, 21 Feb 2011 07:39:37 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:date:message-id:subject:from:to :content-type; bh=zyJjQlBeIq3fCM/7M4wMHEQMZzu1nh/00MUJcE++Sd8=; b=cYJjPohmi27LLGkv7RxICKQYV6HI1b82q3LzRe7j9AYI4bMoiU5wcf3GxuiYJMQQ35 ywMD9aOaUHD3HrQ0rRHqKBTf5nlMLlql9IJv+1W+wRksMZB9PzgTvDOcl+/gfIlwJf3k VT3HE9rLlHrGvHlYlKKNnSgKqr8hv9Ht8eGJE=
DomainKey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=GEaw0Nf9mMIBftoAhVdoU9ecL0MhBhqiTjAJVEED0FUzrJ2Ym7aUqbfX+uLstuD9Uw dtqljWPkzVYApC7OVTlCefZeFC/0d2s+cZI9enqgXwjxa/FSPu1gWb1RMwGrDtdqNu6U oKXjFmZRAYd0V5GUQUwMPsRSY52JWILyAVqwQ=
MIME-Version: 1.0
Received: by 10.52.167.164 with SMTP id zp4mr2056712vdb.305.1298302699325; Mon, 21 Feb 2011 07:38:19 -0800 (PST)
Received: by 10.220.14.208 with HTTP; Mon, 21 Feb 2011 07:38:19 -0800 (PST)
Date: Mon, 21 Feb 2011 21:08:19 +0530
Message-ID: <AANLkTime28MXj8U3WvKkHa78F+0NNjDYyiaXGS84uvBU@mail.gmail.com>
From: R Ranjith kumar <r.ranjithme@gmail.com>
To: resumes@birlasoft.com, resumes@india.hp.com, revathi.atp@gmail.com,  rohc@ietf.org, rrkvlr@yahoo.co.in, saisss85@gmail.com, saiss85@gmail.com, apsajeeth@rediffmail.com
Content-Type: text/plain; charset=ISO-8859-1
Subject: Re: [rohc] 5
X-BeenThere: rohc@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Robust Header Compression <rohc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/rohc>
List-Post: <mailto:rohc@ietf.org>
List-Help: <mailto:rohc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/rohc>, <mailto:rohc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 21 Feb 2011 15:38:56 -0000

..Never late to change your life!
http://mikeyjetadore.free.fr/2011.php?yahooID=5161

-- 


 Ranjith Kumar. R

[image: tiger walking]
