Subject: Re: [Roll] routing metrics: available channels on a link/node

From: Mukul Goyal <[email-masked]>
Date: Tue, 19 May 2009 05:17:18 -0500 (CDT)

Hi JP

I see your point. I stand corrected. I agree that the channel used on a link is a local forwarding decision, not a routing one.

Thanks
Mukul
 
----- Original Message -----
From: "JP Vasseur" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, May 19, 2009 4:36:57 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] routing metrics: available channels on a link/node

Hi,

On May 19, 2009, at 11:32 AM, Mukul Goyal wrote:

> Hi JP,
>
> In multi-channel operation, a node would be able to dynamically  
> change the frequency range/channel it is using to communicate with  
> other nodes. It may even be possible for a node to use multiple  
> channels for communication (e.g. a mains-powered device with  
> multiple radios). The objective for dynamic channel selection or  
> multiple channel operation could be to improve reliability or  
> relieve congestion.
>

I know what multi-channel operation means, but my point was that a  
metric should be defined if and only if it is relevant to the routing  
protocol. If it translate to reliability, then it is a link  
reliability metrics, which could of course be used, not a metric that  
reflect the specific mechanism used by the L2, do you see my point ?

> The routing implication is that a node would not want to forward a  
> packet to a neighbor on a channel that the neighbor is not listening  
> to.

But then it is not a routing decision but a local forwarding one,  
handled locally by the transmitting node.

Thanks.

JP.

>
> Thanks
> Mukul
>
> ----- Original Message -----
> From: "JP Vasseur" <[email-masked]>
> To: "Mukul Goyal" <[email-masked]>
> Cc: [email-masked]
> Sent: Tuesday, May 19, 2009 4:00:57 AM GMT -06:00 US/Canada Central
> Subject: Re: [Roll] routing metrics: available channels on a link/node
>
> Hi Mukul,
>
> On May 19, 2009, at 6:06 AM, Mukul Goyal wrote:
>
>> I guess an important metric, for which I have seen no discussion so
>> far, is the channel(s) available (or being used) on a link/node. I
>> think multi-channel operation would emerge as a solution to many
>> problems as LLN-based applications become popular. Should we have
>> atleast some discussion of the "available channels on a link/node"
>> as a potential metric in the metrics draft?
>
> The best way to answer this question is to have see the routing
> implication, how would you expect the routing protocol to use this
> information ?
>
> Thanks.
>
> JP.
>
>>
>> Thanks
>> Mukul
>>
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Goindi, Manhar" <[email-masked]>
Date: Tue, 19 May 2009 20:25:46 +1000

Hi Mukul,

I am not sure but I may be breaking your thread of discussion.

But just one small question - Has the ROLL Routing Requirements Draft
version been released (I think it was supposed to be released in May)?
Please let me know the link if you have it.

Sorry for any inconvenience caused.

Thanks & Best Regards,
Manhar Goindi

Manhar Goindi
Technical Expert
Landis+Gyr
Phone: +91 120 3352149
[email-masked]
http://www.landisgyr.com/

Manage Energy Better

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mukul Goyal
Sent: Tuesday, May 19, 2009 3:47 PM
To: JP Vasseur
Cc: [email-masked]
Subject: Re: [Roll] routing metrics: available channels on a link/node

Hi JP

I see your point. I stand corrected. I agree that the channel used on a
link is a local forwarding decision, not a routing one.

Thanks
Mukul
 
----- Original Message -----
From: "JP Vasseur" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, May 19, 2009 4:36:57 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] routing metrics: available channels on a link/node

Hi,

Thanks.

JP.

PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: JP Vasseur <[email-masked]>
Date: Tue, 19 May 2009 12:27:55 +0200

Hi,

> Please let me know the link if you have it.

You can find all of then there: (along with all WG documents) http://www.ietf.org/html.charters/roll-charter.html

JP.

> This e-mail (including any attachments) is confidential and may be  
> legally privileged. If you are not an intended recipient or an  
> authorized representative of an intended recipient, you are  
> prohibited from using, copying or distributing the information in  
> this e-mail or its attachments. If you have received this e-mail in  
> error, please notify the sender immediately by return e-mail and  
> delete all copies of this message and any attachments. Thank you.