Subject: [Roll] 14kb 8-bit micro-controllers...

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 14 May 2009 22:24:04 +0200

At several points the sringent node characteristics were expressed such as:

-14kb of RAM
-8-bit controller
-no floating point
-etc.

This should be clarified.

There are node requirements which can be so strict they couldn't even 
memorize a Neighbor Cache of IPv6 addresses, let alone a TCPv6 
implementation.

Querying a temperature value on 6 bits with an IPv6 message of mandatory 
40bytes of base header...

Or the program of the wireless link layer, which was never questioned 
whether it fits or not the stringent node requirements of 14kb.

Or the program doing AES key security.

Would all these assumed programs fit in a 14kb of RAM of an 8-bit 
controller?

There should be a reality check here...

Alex

---

From: [email-masked]
Date: Thu, 14 May 2009 16:32:42 -0500

Yep.  Completely agree here.

We are in a new world where processing power is orders of magnitude less 
that the smallest devices typically considered in the IETF.  The real 
'kick in the pants' is that these requirements are not just marketing 
hype.  These devices have been built and in production for decades in the 
wired world and years in the wireless world. 

The IEEE folks realized this when they developed 802.15.4.  They actually 
defined two different classes of devices (i.e. Full-function Devices and 
Reduced Function Devices) which allowed for different specifications for 
each class.   We may have to follow suit to be sure the different 
gradations of devices can play well in the architecture yet still meet 
their cost/functionality requirements.

Jerry

Alexandru Petrescu <[email-masked]> 
Sent by: [email-masked]
05/14/2009 03:24 PM

To
ROLL WG <[email-masked]>
cc

Subject
[Roll] 14kb 8-bit micro-controllers...

At several points the sringent node characteristics were expressed such 
as:

-14kb of RAM
-8-bit controller
-no floating point
-etc.

Alex
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 15 May 2009 10:32:06 +0200

On May 14, 2009, at 23:32, [email-masked] wrote:

> Full-function Devices and Reduced Function Devices

We've had that distinction in the Internet for a while:

Routers and Hosts.

(I'm only 15 % joking.)

Gruesse, Carsten

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Fri, 15 May 2009 12:44:13 +0200

Hi all,
 
my input as implementer:
 
1 about RAM requirements
There are protocols for which we know what they require (I give rough
values as it is implementation, compiler, platform dependant):
- IPv6 core protocols (as defined by the IPv6 ready logo program, more
or less RFC4294 minus IPSec) can be implemented on less than 2K RAM.
The important point is that protocol related data structures, namely a
packet buffer, neighbor cache, prefix list, address list, routing table,
require around 1.6K. The non protocol related code (pointers, integers
for loops) can be made to use less than 150 bytes. 
- UDP/TCP: there are implementation using roughly 100 bytes
 
The point about the cost of non protocol related code is important
because it allows to estimate the RAM cost of other protocols. 
- In 99% cases, I anticipate that the cost of non protocol related code
will be of few 100 bytes maximum. 
- Regarding protocol data structures, IPv6 is probably more demanding
than most other, just because it needs 1.3K for the packet buffer.
 
If the requirement is 14K for RAM, because of the argument above , I am
convinced you can fit a very large number of protocols in there. 
 
2 Code size
Depends on protocol complexity. IPv6 core protocols (IPv6 ready version)
uses roughly 10K. Note that IPv6 core protocols are not trivial (ND
especially). A web server does not use more than 10K.
 
3 What we could do
As said I am convinced most protocols will fit on a sensor, but we need
to evaluate every one in details, because there will be some areas where
modifications to usual protocols may be needed (routing is the first
piece) in IETF
Regarding security (AES was mentionned), encryption is usually done on
sensors using hardware accelerators. AES-128, Triple DES are supported,
but I cannot say for all. I am confident IPSec is light enough, key
management may be more demanding.
 
Best,
Julien  

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: jeudi 14 mai 2009 23:33
To: Alexandru Petrescu
Cc: ROLL WG; [email-masked]
Subject: Re: [Roll] 14kb 8-bit micro-controllers...

We are in a new world where processing power is orders of magnitude less
that the smallest devices typically considered in the IETF.  The real
'kick in the pants' is that these requirements are not just marketing
hype.  These devices have been built and in production for decades in
the wired world and years in the wireless world.   

The IEEE folks realized this when they developed 802.15.4.  They
actually defined two different classes of devices (i.e. Full-function
Devices and Reduced Function Devices) which allowed for different
specifications for each class.   We may have to follow suit to be sure
the different gradations of devices can play well in the architecture
yet still meet their cost/functionality requirements. 

Jerry 

05/14/2009 03:24 PM 

To
ROLL WG <[email-masked]> 
cc
Subject

-14kb of RAM
-8-bit controller
-no floating point
-etc.

Alex

---

From: <[email-masked]>
Date: Fri, 15 May 2009 14:10:58 +0100

From: [email-masked] on behalf of Carsten Bormann

> We've had that distinction in the Internet for a while:

Which is which?

L.

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Mon, 18 May 2009 11:14:56 +0200

Hi L.,
 
from RFC4294 for example (the same definition is present in many other
RFCs): 
- a router is "a node that forwards IPv6 packets not explicitly
addressed to itself". 
- a host is "any node that is not a router"
 
Best,
Julien

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: vendredi 15 mai 2009 15:11
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Roll] 14kb 8-bit micro-controllers...

Which is which?

L.

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 18 May 2009 12:03:01 +0200

Julien Abeille (jabeille) a écrit :
> Hi L.,
> 
> from RFC4294 for example (the same definition is present in many 
> other RFCs): - a router is "a node that forwards IPv6 packets not 
> explicitly addressed to itself". - a host is "any node that is not a
>  router"

Host and Router - both run TCP/IP stacks.

Further back in time is RFC 7 Host-IMP Interface (Interface
Message Processor).  Only the Host would run a TCP/IP stack, I suppose.

This would make for:

Full-function device: the RFC7 "Host", runs TCP/IP;
Reduced-function device: the RFC7 "IMP", runs the link layer.

I am not sure what Carsten and Lloyd meant.

Alex

> 
> Best, Julien
> 
> ------------------------------------------------------------------------
>  *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of [email-masked] *Sent:* vendredi 15 mai 2009 15:11 
> *To:* [email-masked]; [email-masked] *Cc:* 
> [email-masked]; [email-masked] *Subject:* Re: [Roll] 14kb 8-bit
>  micro-controllers...
> 
> 
> ------------------------------------------------------------------------
> 
> 
> 
> 
> 
> 
> _______________________________________________ Roll mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/roll

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 May 2009 12:10:47 +0200

> - a host is "any node that is not a router"

Julien,

I'm pretty sure Lloyd knows that :-)

He might have been alluding to the fact the hosts may have pretty  
significant functions on their own.

In the original 802.15.4 context, however, it is pretty clear that the  
FFDs were meant to be the routers, and that RFDs play the equivalent  
of a host-only node (think battery-operated sensor).  In the context  
of ROLL, participating in a routing protocol may be something that  
relates to 802.15.4's FFD concept, and there may be RFDs just smart  
enough to talk to the next router.  (Of course, even in an "all nodes  
are routers" scenario, there may be a class of less functional  
devices, which may map to specific roles in the routing protocol; that  
was the 15 % I referred to.)

Gruesse, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 May 2009 12:12:02 +0200

> Reduced-function device: the RFC7 "IMP", runs the link layer.

No, that's not it.
See my previous message.

Gruesse, Carsten

---

From: <[email-masked]>
Date: Mon, 18 May 2009 13:31:56 +0100

My brief question was:

Which of (router or host) is the full-function device?
Which of (router or host) is the reduced-functionality device?

hope that's clear. By the RFC4294 definition, any multihomed host
has the potential to be a router.

L.

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>

-----Original Message-----
From: Julien Abeille (jabeille) [mailto:[email-masked]]
Sent: Mon 2009-05-18 10:14
To: Wood L Dr (Electronic Eng); [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Roll] 14kb 8-bit micro-controllers...
 
Hi L.,

Best,
Julien

Which is which?

L.

---

From: "Burnett, Peter" <[email-masked]>
Date: Mon, 18 May 2009 14:46:45 +0200

In 15.4 an RFD only talks via its (FFD) parent so it is not multihomed. So cannot be a router. But presumably an FFD can be a router or a host.
Peter
________________________________
From: [email-masked] [[email-masked]] On Behalf Of [email-masked] [[email-masked]]
Sent: 18 May 2009 13:31
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Roll] 14kb 8-bit micro-controllers...

My brief question was:

L.

-----Original Message-----
From: Julien Abeille (jabeille) [mailto:[email-masked]]
Sent: Mon 2009-05-18 10:14
To: Wood L Dr (Electronic Eng); [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Roll] 14kb 8-bit micro-controllers...

Hi L.,

Best,
Julien

Which is which?

L.

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 18 May 2009 14:55:22 +0200

Could FFD have 2 interfaces?  Or is it typically having a single interface?

Alex

Burnett, Peter a écrit :
> In 15.4 an RFD only talks via its (FFD) parent so it is not multihomed. 
> So cannot be a router. But presumably an FFD can be a router or a host.
> Peter
> *From:* [email-masked] [[email-masked]] On Behalf Of 
> [email-masked] [[email-masked]]
> *Sent:* 18 May 2009 13:31
> *To:* [email-masked]; [email-masked]; [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Roll] 14kb 8-bit micro-controllers...
> 
> 
> My brief question was:
> 
> The information contained in this message may be confidential and 
> legally protected under applicable law. The message is intended solely 
> for the addressee(s). If you are not the intended recipient, you are 
> hereby notified that any use, forwarding, dissemination, or reproduction 
> of this message is strictly prohibited and may be unlawful. If you are 
> not the intended recipient, please contact the sender by return e-mail 
> and destroy all copies of the original message.
> 
>

---

From: "Burnett, Peter" <[email-masked]>
Date: Mon, 18 May 2009 15:02:20 +0200

Typically only one interface but that doesnt stop it being a router because links are non-transitive on WPANs. Back to that....
Peter

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Alexandru Petrescu [[email-masked]]
Sent: 18 May 2009 13:55
To: Burnett, Peter
Cc: [email-masked]; [email-masked]
Subject: Re: [Roll] 14kb 8-bit micro-controllers...

Alex

---

From: JP Vasseur <[email-masked]>
Date: Mon, 18 May 2009 17:06:18 +0200

On May 18, 2009, at 2:46 PM, Burnett, Peter wrote:

> In 15.4 an RFD only talks via its (FFD) parent so it is not  
> multihomed. So cannot be a router. But presumably an FFD can be a  
> router or a host.

Just to make sure that we are on the same page, ROLL is not L2  
specific. The notion of FFD, ... is 15.4 specific.
The routing protocol may allow a router to announce specific  
capability of course.

Thanks.

JP.

> legally protected under applicable law. The message is intended  
> solely for the addressee(s). If you are not the intended recipient,  
> you are hereby notified that any use, forwarding, dissemination, or  
> reproduction of this message is strictly prohibited and may be  
> unlawful. If you are not the intended recipient, please contact the  
> sender by return e-mail and destroy all copies of the original  
> message.