Subject: [Roll] Energy Parameter in ROLL routin

From: "Theodore Zahariadis" <[email-masked]>
Date: Thu, 11 Jun 2009 15:42:09 +0300

Dear all,

Attached please find an informal document showing the energy consumption 

effects in WSN routing.

We have proposed a trust and energy aware routing protocol (ATSR) 

(included in the ietf draft I have submitted), which succeeds in avoiding 

the malicious nodes (based on the incorporated trust model) and at the 

same time it decreases the energy consumption of stressed nodes (based 

on energy knowledge). 

The simulation results show that significant energy is consumed for routing 

and trust purposes and thus the frequency of exchange of this information 

should be very well considered. Our protocol guides the sensor nodes 

select for forwarding the neighbour that is not only closer to the destination but 

also has enough remaining energy, leading to better load balancing and energy savings.

Looking forward to hearing your comments,

Best Regards,

Theodore

---

From: "Theodore Zahariadis" <[email-masked]>
Date: Mon, 22 Jun 2009 13:30:24 +0300

Dear Manhar,

We describe it at the following draft:
http://tools.ietf.org/html/draft-zahariad-roll-trust-framework-00

We look forward to hear any news or comments from you.

Best Regards,
Theodore Zahariadis

  ----- Original Message ----- 
  From: Goindi, Manhar 
  To: Theodore Zahariadis 
  Sent: Monday, June 22, 2009 1:05 PM
  Subject: RE: [Roll] Energy Parameter in ROLL routin

  Dear Mr. Theodore,

  Thanks a lot for sharing the document as it provided a very interesting reading.

  I also enjoyed reading about the Secure Routing Protocol in Section 1 of the same document.

  I am really sorry about this but I wish to inquire if there is any draft which describes this routing protocol in further detail.

  I already referenced the link:  http://www.ietf.org/html.charters/roll-charter.html but could not find any such document there.

  Thanks & Best Regards,

  Manhar Goindi

  Manhar Goindi
  Technical Expert
  Landis+Gyr        

  Phone: +91 120 3352149
  [email-masked]
  www.landisgyr.com

  manage energy better

  From: [email-masked] [mailto:[email-masked]] On Behalf Of Theodore Zahariadis
  Sent: Thursday, June 11, 2009 6:12 PM
  To: [email-masked]
  Cc: PANOS TRAKADAS; Sotiris Maniatis; Karkazis Panagiotis
  Subject: [Roll] Energy Parameter in ROLL routin

  Dear all,

  effects in WSN routing.

  on energy knowledge). 

  Best Regards,

  Theodore

  P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

  This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: "Goindi, Manhar" <[email-masked]>
Date: Tue, 23 Jun 2009 12:34:33 +1000

Dear Mr. Theodore,

Thanks a lot!

I did get a chance to look the draft describing the protocol.  It is a
very good protocol to account for trusted nodes and not use malicious
node for routing/forwarding packets.

I just have a query - is it possible to also use some sort of energy
metrics on similar basis to route packets based on left over energy in
nodes?  Presently this protocol is independent from that and might have
to be enhanced from that perspective.

Thanks & Best Regards,

Manhar Goindi

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Theodore Zahariadis
Sent: Monday, June 22, 2009 4:00 PM
To: Goindi, Manhar
Cc: [email-masked]
Subject: Re: [Roll] Energy Parameter in ROLL routin

Dear Manhar,

Best Regards,

Theodore Zahariadis

Manhar Goindi
Technical Expert
Phone: +91 120 3352149

----- Original Message ----- 

	From: Goindi, Manhar <mailto:[email-masked]>  

	To: Theodore Zahariadis <mailto:[email-masked]>  

	Dear Mr. Theodore,

	Thanks a lot for sharing the document as it provided a very
interesting reading.

	I also enjoyed reading about the Secure Routing Protocol in
Section 1 of the same document.

	I am really sorry about this but I wish to inquire if there is
any draft which describes this routing protocol in further detail.

	I already referenced the link:
http://www.ietf.org/html.charters/roll-charter.html but could not find
any such document there.

	Thanks & Best Regards,

	Manhar Goindi

	Manhar Goindi
	Technical Expert
	Landis+Gyr        

	Phone: +91 120 3352149

	[email-masked] <mailto:[email-masked]>

	www.landisgyr.com
	<http://www.landisgyr.com/> 
	manage energy better

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Theodore Zahariadis
	Sent: Thursday, June 11, 2009 6:12 PM
	To: [email-masked]
	Cc: PANOS TRAKADAS; Sotiris Maniatis; Karkazis Panagiotis
	Subject: [Roll] Energy Parameter in ROLL routin

	Dear all,

	Attached please find an informal document showing the energy
consumption 

	effects in WSN routing.

	We have proposed a trust and energy aware routing protocol
(ATSR) 

	(included in the ietf draft I have submitted), which succeeds in
avoiding 

	the malicious nodes (based on the incorporated trust model) and
at the 

	same time it decreases the energy consumption of stressed nodes
(based 

	on energy knowledge). 

	The simulation results show that significant energy is consumed
for routing 

	and trust purposes and thus the frequency of exchange of this
information 

	should be very well considered. Our protocol guides the sensor
nodes 

	select for forwarding the neighbour that is not only closer to
the destination but 

	also has enough remaining energy, leading to better load
balancing and energy savings.

	Best Regards,

	Theodore

	
	This e-mail (including any attachments) is confidential and may
be legally privileged. If you are not an intended recipient or an
authorized representative of an intended recipient, you are prohibited
from using, copying or distributing the information in this e-mail or
its attachments. If you have received this e-mail in error, please
notify the sender immediately by return e-mail and delete all copies of
this message and any attachments. Thank you.

---

From: "Theodore Zahariadis" <[email-masked]>
Date: Tue, 23 Jun 2009 09:01:45 +0300

Dear Manhar,

We have already done some work on this direction. 
Actually the trust protocol has already been extended
with another metric, which describes the remaining energy 
at the node. Energy value may be another parameter 
distributed via beacons.

By using a weight factor for the remaining energy value, you 
may select if you would like to have the protocol more energy 
aware or more secure.

We have recently submitted a paper (still under evaluation), where 
you may find the following text:

·         Remaining Energy: Systematically selecting a highly trusted node for forwarding the packets may lead to the exhaustion of its energy. Additionally, fixed traffic flows are vulnerable to traffic analysis attacks. In this view, we have enriched our trust model with energy information. In our novel routing protocol, the basic routing message indicating the node availability and position (the Beacon message defined in all location-based routing protocols) is extended to include the "remaining energy" field of the source node based on which the energy-knowledge is built. Although it is possible to infer the remaining energy of a neighboring node counting the interactions it has been involved in ([21]), their implementation consumes significant processing power. 

Best Regards,
Theodore

  ----- Original Message ----- 
  From: Goindi, Manhar 
  To: Theodore Zahariadis 
  Cc: [email-masked] 
  Sent: Tuesday, June 23, 2009 5:34 AM
  Subject: RE: [Roll] Energy Parameter in ROLL routin

  Dear Mr. Theodore,

  Thanks a lot!

  I did get a chance to look the draft describing the protocol.  It is a very good protocol to account for trusted nodes and not use malicious node for routing/forwarding packets.

  I just have a query - is it possible to also use some sort of energy metrics on similar basis to route packets based on left over energy in nodes?  Presently this protocol is independent from that and might have to be enhanced from that perspective.

  Thanks & Best Regards,

  Manhar Goindi

  Manhar Goindi
  Technical Expert
  Phone: +91 120 3352149

  Dear Manhar,

  Best Regards,

  Theodore Zahariadis

    ----- Original Message ----- 

    From: Goindi, Manhar 

    To: Theodore Zahariadis 

    Dear Mr. Theodore,

     

    Thanks & Best Regards,

    Manhar Goindi

    Manhar Goindi
    Technical Expert
    Landis+Gyr        

    Phone: +91 120 3352149

    manage energy better

    Dear all,

    effects in WSN routing.

    on energy knowledge). 

    Best Regards,

    Theodore

---

From: "Goindi, Manhar" <[email-masked]>
Date: Tue, 23 Jun 2009 19:56:01 +1000

Dear Mr. Theodore,

Is this paper that has been submitted available for the forum members as
yet or would it be available later (after evaluation)?

Thanks & Best Regards,

Manhar Goindi

From: Theodore Zahariadis [mailto:[email-masked]] 
Sent: Tuesday, June 23, 2009 11:32 AM
To: Goindi, Manhar
Cc: [email-masked]
Subject: Re: [Roll] Energy Parameter in ROLL routin

Dear Manhar,

distributed via beacons.

aware or more secure.

 

*         Remaining Energy: Systematically selecting a highly trusted
node for forwarding the packets may lead to the exhaustion of its
energy. Additionally, fixed traffic flows are vulnerable to traffic
analysis attacks. In this view, we have enriched our trust model with
energy information. In our novel routing protocol, the basic routing
message indicating the node availability and position (the Beacon
message defined in all location-based routing protocols) is extended to
include the "remaining energy" field of the source node based on which
the energy-knowledge is built. Although it is possible to infer the
remaining energy of a neighboring node counting the interactions it has
been involved in ([21]), their implementation consumes significant
processing power. 

Best Regards,

Theodore

 

Manhar Goindi
Technical Expert
Phone: +91 120 3352149

----- Original Message ----- 

	Cc: [email-masked] 

	Dear Mr. Theodore,

	Thanks a lot!

	I did get a chance to look the draft describing the protocol.
It is a very good protocol to account for trusted nodes and not use
malicious node for routing/forwarding packets.

	I just have a query - is it possible to also use some sort of
energy metrics on similar basis to route packets based on left over
energy in nodes?  Presently this protocol is independent from that and
might have to be enhanced from that perspective.

	Thanks & Best Regards,

	Manhar Goindi

	Manhar Goindi
	Technical Expert
	Phone: +91 120 3352149

	Dear Manhar,

	Best Regards,

	Theodore Zahariadis

		----- Original Message ----- 

		From: Goindi, Manhar
<mailto:[email-masked]>  

		Dear Mr. Theodore,

		Thanks a lot for sharing the document as it provided a
very interesting reading.

		I also enjoyed reading about the Secure Routing Protocol
in Section 1 of the same document.

		I am really sorry about this but I wish to inquire if
there is any draft which describes this routing protocol in further
detail.

		 

		Thanks & Best Regards,

		Manhar Goindi

		Manhar Goindi
		Technical Expert
		Landis+Gyr        

		Phone: +91 120 3352149

		[email-masked]
<mailto:[email-masked]> 
		www.landisgyr.com
		<http://www.landisgyr.com/> 
		manage energy better

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Theodore Zahariadis
		Sent: Thursday, June 11, 2009 6:12 PM
		To: [email-masked]
		Cc: PANOS TRAKADAS; Sotiris Maniatis; Karkazis
Panagiotis
		Subject: [Roll] Energy Parameter in ROLL routin

		Dear all,

		Attached please find an informal document showing the
energy consumption 

		effects in WSN routing.

		We have proposed a trust and energy aware routing
protocol (ATSR) 

		(included in the ietf draft I have submitted), which
succeeds in avoiding 

		the malicious nodes (based on the incorporated trust
model) and at the 

		same time it decreases the energy consumption of
stressed nodes (based 

		on energy knowledge). 

		The simulation results show that significant energy is
consumed for routing 

		and trust purposes and thus the frequency of exchange of
this information 

		should be very well considered. Our protocol guides the
sensor nodes 

		select for forwarding the neighbour that is not only
closer to the destination but 

		Best Regards,

		Theodore

		P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS
EMAIL.
		
		This e-mail (including any attachments) is confidential
and may be legally privileged. If you are not an intended recipient or
an authorized representative of an intended recipient, you are
prohibited from using, copying or distributing the information in this
e-mail or its attachments. If you have received this e-mail in error,
please notify the sender immediately by return e-mail and delete all
copies of this message and any attachments. Thank you.

---

From: Rob Alexander <[email-masked]>
Date: Thu, 25 Jun 2009 15:48:53 -0400

Hi Theodore,

I read through your draft and had a question about one of the methods
for gathering Direct Trust Metrics.

  1. Packet forwarding: To detect nodes that deny or selectively
        forward packets, each time a source node transmits a packet that
        has to be forwarded it MAY enter the promiscuous mode and
        overhear the wireless medium to check whether the packet was
        actually forwarded by the selected neighbor. If positive, this
        is accounted as a successful interaction; otherwise, it is 
        counted as a failure.

In a dense or busy network it may be possible that messages are lost due
to various failures unrelated to a security attack.  How would a node
differentiate between a neighbor that temporarily lacks the resources to
forward a message and a malicious neighbor that is selectively
forwarding them?  

 - Rob

On Mon, 2009-06-22 at 13:30 +0300, Theodore Zahariadis wrote:
>         http://www.ietf.org/html.charters/roll-charter.html but could
>         not find any such document there.
>         
>          
>         
>          
>         
>         Thanks & Best Regards,
>         
>         Manhar Goindi
>         
>         
>         
>         Manhar Goindi
>         Technical Expert
>         Landis+Gyr        
>         
>         Phone: +91 120 3352149
>         This e-mail (including any attachments) is confidential and
>         may be legally privileged. If you are not an intended
>         recipient or an authorized representative of an intended
>         recipient, you are prohibited from using, copying or
>         distributing the information in this e-mail or its
>         attachments. If you have received this e-mail in error, please
>         notify the sender immediately by return e-mail and delete all
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
***

Robert Alexander
Ember, Inc.
47 Farnsworth Street
Boston, MA 02210
T: 617-951-1244
F: 617-951-0999

---

From: Richard Kelsey <[email-masked]>
Date: Fri, 26 Jun 2009 10:14:17 -0400

From: Rob Alexander <[email-masked]>
   Date: Thu, 25 Jun 2009 15:48:53 -0400

It may also be that the neighbor forwared the message
via a different interface, either a different wireless
PHY or a wired one.

A truly malicious neighbor, as opposed to a merely
lazy or incompetent one, would forward the message
to a non-existant next hop.  This would give the
illusion of being helpful while actually dropping
the packet.

                         -Richard Kelsey