Subject: [Roll] collision avoidance in draft-dt-roll-rpl-00.txt

From: Richard Kelsey <[email-masked]>
Date: Mon, 06 Jul 2009 14:15:29 -0400

I do not understand the need for the collision avoidance
mechanism.  The draft says:

   5.4.3.3.  Collision

   A race condition occurs if 2 nodes send Router Advertisement - DAG
   Information Option at the same time and wish to join each other.
   This might happen between nodes at a same depth, or nodes which act
   as DAG root of their own DAGs.  [...]

Section 5.2 states that candidate neighbors at the same
depth cannot be considered as candidate parents.  If two
nodes at the same depth transmit DIOs at the same time there
are no new candidate parents and however much they may wish
to join each other, such moves are prohibited.  Joining to
another node at the same level requires leaving the DAG,
waiting for the DAG sequence number to change, and then
rejoining.  Two devices cannot collide while doing this
because they cannot advertise the new sequence number
without first rejoining to someone that already has it.

Am I missing something?
                               -Richard Kelsey

---

From: Tim Winter <[email-masked]>
Date: Mon, 06 Jul 2009 19:00:00 -0400

Richard,

Good catch, it does seem we ought to remove the "at a same depth" case.

In the other case, two nodes rooting their own floating DAGs might still
have a collision if they at the same time decide to join each other's DAG.

Thanks,

-Tim

Richard Kelsey wrote:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 7 Jul 2009 12:08:42 +0200

Hi Richard:

This is not for siblings but for inter DAG jumps.

This is a very old thing, the first snag you hit when you simulate but
mostly never happens in real life. You need A and B boot synchronously
and send their RAs at the very same time so they cross. In that case,
they might attach to one another and form a sticky loop.

Pascal

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Richard Kelsey
>Sent: lundi 6 juillet 2009 20:15
>To: [email-masked]
>Subject: [Roll] collision avoidance in draft-dt-roll-rpl-00.txt
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 7 Jul 2009 14:27:09 +0200

I had read that too quickly. Sure, you're both correct, thanks Richard
:)

Pascal

>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tim Winter
>Sent: mardi 7 juillet 2009 01:00
>To: Richard Kelsey
>Cc: ROLL WG
>Subject: Re: [Roll] collision avoidance in draft-dt-roll-rpl-00.txt
>
>Richard,
>