Subject: Re: [Roll] RPL: why not base a DAG on the min hop distance from theroot?

From: Mukul Goyal <[email-masked]>
Date: Wed, 1 Jul 2009 23:11:17 -0500 (CDT)

Phil

Experimental/engineering experience is not really "facts". Experimental/engineering experience depends to a large extent on the particular network topology etc. Change in the topology and other related factors can change the experimental results.

I am still waiting for a strong argument in favor of parents at multiple depths. I have provided one in favor of same depth parents - it makes the term "depth" meaningful as the number of hops the packet would travel to reach the root.

Mukul 
----- Original Message -----
From: "Philip Levis" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "Omprakash Gnawali" <[email-masked]>, "roll" <[email-masked]>
Sent: Wednesday, July 1, 2009 11:01:37 PM GMT -06:00 US/Canada Central
Subject: Re: [Roll] RPL: why not base a DAG on the min hop distance from theroot?

On Jul 1, 2009, at 8:38 PM, Mukul Goyal wrote:

> I don't think that selecting parents with multiple depths provides  
> any fundamental advantage when a node needs to select a new parent.

Well, "think" is a belief. On the other hand, there's experimental  
evidence and engineering experience to the contrary, that such a  
constraint is disadvantageous. I'd rather follow hard facts.

Phil

---

From: Jonathan Hui <[email-masked]>
Date: Wed, 1 Jul 2009 21:13:21 -0700

On Jul 1, 2009, at 9:11 PM, Mukul Goyal wrote:
> I am still waiting for a strong argument in favor of parents at  
> multiple depths. I have provided one in favor of same depth parents  
> - it makes the term "depth" meaningful as the number of hops the  
> packet would travel to reach the root.

But depth is often not what we really care about... ETX is just one  
example.

--
Jonathan Hui

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 1 Jul 2009 23:19:21 -0500 (CDT)

It is possible that I will be surprised.

But I will be really surprised if people dont care about how many hops their packets travel before they reach the root.

Thanks
Mukul

----- Original Message -----
From: "Jonathan Hui" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "Philip Levis" <[email-masked]>, "roll" <[email-masked]>, "Omprakash Gnawali" <[email-masked]>
Sent: Wednesday, July 1, 2009 11:13:21 PM GMT -06:00 US/Canada Central
Subject: Re: [Roll] RPL: why not base a DAG on the min hop distance from theroot?

--
Jonathan Hui