Subject: Re: [Roll] RPL: why not base a DAG on the min hop distance from theroot?

From: Mukul Goyal <[email-masked]>
Date: Wed, 1 Jul 2009 22:38:04 -0500 (CDT)

I don't think that selecting parents with multiple depths provides any fundamental advantage when a node needs to select a new parent.

In both cases (all parents at same depth and parents with multiple depths), selecting a new parent may require  a node to change its depth.

Similarly, in both cases, a node may be able to choose a new parent _quickly_ from the set of neighbors it already knows without changing its depth.

Thanks
Mukul

----- Original Message -----
From: "Omprakash Gnawali" <[email-masked]>
To: "d sturek" <[email-masked]>
Cc: "Mukul Goyal" <[email-masked]>, "roll" <[email-masked]>
Sent: Wednesday, July 1, 2009 9:39:27 PM GMT -06:00 US/Canada Central
Subject: Re: [Roll] RPL: why not base a DAG on the min hop distance from  theroot?

On Wed, Jul 1, 2009 at 4:16 PM, <[email-masked]> wrote:
> Hi Mukul,
>
> I think a feature where a device can elect on its own (absent any topological knowledge of the network) to downgrade itself in depth is questionable.
>
> Phil:  Under what circumstances could you see a device making such an election?

When the selected parent is unreachable, the ability to select a new
parent quickly?

- om_p

---

From: Philip Levis <[email-masked]>
Date: Wed, 1 Jul 2009 21:01:37 -0700

On Jul 1, 2009, at 8:38 PM, Mukul Goyal wrote:

> I don't think that selecting parents with multiple depths provides  
> any fundamental advantage when a node needs to select a new parent.

Well, "think" is a belief. On the other hand, there's experimental  
evidence and engineering experience to the contrary, that such a  
constraint is disadvantageous. I'd rather follow hard facts.

Phil