Subject: Re: [Roll] An alternative to RPL

From: Mukul Goyal <[email-masked]>
Date: Thu, 30 Jul 2009 09:39:51 -0500 (CDT)

Hi Umair,

The basic idea is to limit the scope of route discovery. 

It may be possible to identify natural physical or logical partitions in the network such that good routes among the nodes in a partition can be found within the partition itself. Such partitions, if they exist, are natural routing domains.

Also, consider the case where we have multiple independent, small LLNs and there is a need to integrate them to allow cross-LLN communication among selected nodes. Thus, most communication still takes place within the old LLN boundaries but there is a desire to allow further communication across boundaries. Such small LLN units may be configured as separate routing domains with nodes involved in cross-unit communication marked as "universal" destinations. Ofcourse, separation of LLN nodes in routing domains may result in sacrifice of route redundancy if the domain boundaries have significant physical overlap.

There is a clear need for scalability in ROLL protocols since LLNs may have 1000's of nodes. Routing domains is one way of achieving this.

Thanks
Mukul 

> 
> >p4: Routing domains 
> 
> >I am not sure why we would want to define routing
> domains.  This is extra configuration effort that doesn't
> necessarily add any value.  I wouldn't know a priori how to
> define the logical entities. 
> 
> The routing domains are required to limit the scope of
> route discovery. We do not want all 10K nodes in the network
> to know that A wants to find a route to B. The idea is that
> if we could define routing domains such that most
> source-destination pairs lie in the same domain, route
> discovery can be restricted to nodes within the domain.
> Ofcourse, some destinations can be universal, i.e. route
> discovery for these destinations have network-wide scope.
> Also, for small networks, it may be OK to not have routing
> domains at all. My hope is that, most of the times, routing
> domains can be defined using natural divisions in the
> network.

I am unable to realize the idea. What logic is going to be used. Will it be dependent on physical arrangemnet and going to be configured after deployment.

---

From: Mukul Goyal <[email-masked]>
Date: Thu, 30 Jul 2009 10:04:45 -0500 (CDT)

Hi Jerry,

>>>Also there seems to be cases (see p7) where you temporally eliminate route discovery requests.  Not sure why this is needed.   

>>Not sure what you mean. There seems to be some misunderstanding. The route discovery requests are never eliminated. 

>I'm probably misreading the text.  Here's the paragraph... 

>   o  An existing route discovery table entry is refreshed, i.e. allowed 
      to exist for a certain additional time duration, if it was created 
      in response to an RA from this router and the current RA includes 
      in its route discovery list the destination corresponding to this 
      entry. 
  
>The phrase "allowed to exist for a certain additional time duration" implies to me that route discovery entries are temporal.  I would think that as long as the route is valid, it would be kept. 

The route discovery table entries are meant to exist only while route discovery is going on. Once the routes have been discovered, the routers on the routes, and the routers in their "vicinity", maintain state about the destination in their "Route Maintenance" tables.

Hope this clarifies your doubt.

Thanks
Mukul