Subject: [Roll] An alternative to RPL (Mukul Goyal)

From: Inza Bamba <[email-masked]>
Date: Tue, 28 Jul 2009 14:21:29 +0200

Hi M. every body, I'm a new comer on this mailing list and also a beginner
in LLN. I read the draft describing an alternate solution for LLN it is the
interesting however I need some explaination:

* what is the interest to disable packet forwarding on host?
* In what case a loop could occur?

Thank you for your clarification.

---

From: Mukul Goyal <[email-masked]>
Date: Tue, 28 Jul 2009 07:39:21 -0500 (CDT)

Hello,

An LLN host may not want to participate in routing for a number of reasons including the need to save battery. I think it should be OK to allow a node to alternate between host and router roles. Obviously, when a router switches to the host role, existing routes passing through it would be disrupted. Perhaps, a router could allow a transition period during which it informs neighbor nodes of its intention to switch to the host mode but continues to act as a router.

Loops occur in distance vector routing when the cost to reach the destination via the current next hop deteriorates so much that node A selects a new next hop, some one whose advertised cost is actually based on the old cost of node A. This new next hop may end up routing the packets back to node A.

Thanks
Mukul

----- Original Message -----
From: "Inza Bamba" <[email-masked]>
To: [email-masked]
Sent: Tuesday, July 28, 2009 7:21:29 AM GMT -06:00 US/Canada Central
Subject: [Roll] An alternative to RPL (Mukul Goyal)

Hi M. every body, I'm a new comer on this mailing list and also a beginner in LLN. I read the draft describing an alternate solution for LLN it is the interesting however I need some explaination: 

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll