Subject: [Roll] DAO packet format and timers

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Mon, 19 Oct 2009 11:31:07 +0200

Hi All,
 
I have several comments/questions/possible simplifications on Section 5.9.
 
- Concerning the DAO packet format
-- Do we need the Route Tag in the core DAO option? Isn't it more likely that nodes would decide which prefixes to store based on a local policy (e.g. MRU). This could potentially save 32bits per DAO.
-- Would it make sense to make the Reverse Route Stack + RRCount a sub-option?
-- The variable length Prefix might break the byte alignment. Is that desirable?
-- The storage of the variable length reverse route stack in environment without dynamic memory will be problematic. I guess it is thus expected that such nodes do not keep DAO state and use solely source routing.
 
- 5.9.2.1.1 Destination Advertisement Timers
-- Are DAO sent only on trigger from RA-DIO (with D bit set)? What does 'propagation' of DAO means concretely? If you receive a DAO do you also need to relay it right away?
-- I have the impression that the sending NA-DAOs in response to RA-DIOs (with D bit set) is really only testing the reachability of the neighbor advertising the prefix not the reachability of the destination owning the prefix. Does this justify the cost of having a  DelayNA timer / reported flag per DAO prefix per DA parent?
-- Is the RemoveTimer related to the DAO lifetime associated with the prefixes at all?
 
I would of appreciate if these 3 last points could be clarified in the next revision of RPL.
 
Best,
Mathilde
 	
Durvy Mathilde
Software Engineer
Technology center

[email-masked]
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

Cisco Systems International Sàrl
Av. des Uttins, 5
CH-1180 Rolle

Cisco home page <http://www.cisco.com/> 

  Think before you print.	
This e-mail may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 19 Oct 2009 09:32:45 -0400

>>>>> "Mathilde" == Mathilde Durvy <(mdurvy)" <[email-masked]>> writes:
    Mathilde> -- Do we need the Route Tag in the core DAO option? Isn't
    Mathilde> it more likely that nodes would decide which prefixes to
    Mathilde> store based on a local policy (e.g. MRU). This could
    Mathilde> potentially save 32bits per DAO.
  
  My recommendation is not to count bits in savings in this way.
  Figure out what is sufficient, encode it as a base structure, and then
figure out what the optional parts might be, and how often they are
optional, and then do that.  
  *THEN* do the PDU size calculation. If it is too big, ask what zlib
with a static dictionary can do for the packet size, and only then
decide to "remove" things.

  insert quote abut premature optimization and evil.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: JP Vasseur <[email-masked]>
Date: Mon, 19 Oct 2009 08:04:49 -0700

Hi Mathilde,

On Oct 19, 2009, at 2:31 AM, Mathilde Durvy (mdurvy) wrote:

> -- Do we need the Route Tag in the core DAO option? Isn't it more  
> likely that nodes would decide which prefixes to store based on a  
> local policy (e.g. MRU). This could potentially save 32bits per DAO.

I think so since it could be very useful in a number of situation. We  
could certainly make it shorter and optional.

> -- Would it make sense to make the Reverse Route Stack + RRCount a  

Good idea.

> -- The variable length Prefix might break the byte alignment. Is  

Do you see this as a real issue ?

> -- The storage of the variable length reverse route stack in  
> environment without dynamic memory will be problematic. I guess it  
> is thus expected that such nodes do not keep DAO state and use  
> solely source routing.
>
> -- Are DAO sent only on trigger from RA-DIO (with D bit set)? What  
> does 'propagation' of DAO means concretely? If you receive a DAO do  
> you also need to relay it right away?
> -- I have the impression that the sending NA-DAOs in response to RA- 
> DIOs (with D bit set) is really only testing the reachability of the  
> neighbor advertising the prefix not the reachability of the  
> destination owning the prefix. Does this justify the cost of having  
> a  DelayNA timer / reported flag per DAO prefix per DA parent?

Yes it must and will be clarified although some aspect (first point  
for example) may be left to implementation.

Thanks.

JP.

> Cisco home page
> This e-mail may contain confidential and privileged material for the  
> sole use of the intended recipient. Any review, use, distribution or  
> disclosure by others is strictly prohibited. If you are not the  
> intended recipient (or authorized to receive for the recipient),  
> please contact the sender by reply e-mail and delete all copies of  
> this message.
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll