Subject: [Roll] minor comments on rpl-02

From: Michael Richardson <[email-masked]>
Date: Fri, 02 Oct 2009 10:38:50 -0400

re: 5.3.1.  DAG Discovery Rules

There are 11 rules. I think we have spent some significant time
discussing some of the rules.  I wonder if it might be worth naming the
rules in some way. i.e.

   7.   (Freedom to Jump Rule)
	A node may jump from its current DAG into any different DAG if
	....

   8.	(Nodes are Unstable When Jumping Rule)	
	If a node has selected a new set of DAG parents but has not
        moved yet (because it is waiting for DAG Hop timer to elapse),
        the node is unstable MUST NOT send RA-DIOs for that DAG.
                            ^AND

{Q: for which DAG? the one it is leaving, or the one it is joining?}

or perhaps:

   7.   A node may jump from its current DAG into any different DAG if
	...

   7.1. A node may have to wait for a DAG Hop timer to elapse before
	it jumps to another DAG.
	This allows the new higher parts (closer to the sink) of
        the DAG to move first, thus allowing stepped DAG
	....

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: "Anders Brandt" <[email-masked]>
Date: Mon, 5 Oct 2009 13:50:53 +0200

Thanks Michael!

Adding these small headers (Freedom to Jump Rule), (Nodes are Unstable
When Jumping Rule)
just increases the readability so much.

I really think we should consider such sub-headers for every rule.
We should be able to make this so simple that the reader gets the
big picture from scanning the table of contents.

Cheers,
  Anders

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Richardson
Sent: 2. oktober 2009 16:39
To: ROLL WG
Subject: [Roll] minor comments on rpl-02

or perhaps:

-- 
]       He who is tired of Weird Al is tired of life!           |
firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net
architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device
driver[
   Kyoto Plus: watch the video
<http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition. 

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll