Subject: [Roll] one DAG per RPL instance

From: Mukul Goyal <[email-masked]>
Date: Sat, 3 Oct 2009 16:05:09 -0500 (CDT)

Hi all,

I was wondering if people with experience in writing code for memory/CPU constrained devices can comment on this: If a device has to join multiple DAGs, does it make a difference (from the perspective of memory requirement and execution efficiency) whether the device runs a single RPL process (supporting all the DAGs) or multiple RPL processes (each supporting just one DAG).

Thanks
Mukul

---

From: JP Vasseur <[email-masked]>
Date: Sun, 4 Oct 2009 09:06:43 +0200

Hi,

On Oct 3, 2009, at 11:05 PM, Mukul Goyal wrote:

> Hi all,
>
> I was wondering if people with experience in writing code for memory/ 
> CPU constrained devices can comment on this: If a device has to join  
> multiple DAGs, does it make a difference (from the perspective of  
> memory requirement and execution efficiency) whether the device runs  
> a single RPL process (supporting all the DAGs) or multiple RPL  
> processes (each supporting just one DAG).
>

It does make a difference but if coded right, a very minor difference.

Thanks,

JP.

> Thanks
> Mukul
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 5 Oct 2009 07:51:10 +0200

>It does make a difference but if coded right, a very minor difference.

Agreed. Instances are contexts that run the same code and operate as
ship in the night. The additional work will have to do with instance
transition policies, but policies are already present in the OCP for a
single instance.

The price to pay will probably be more in terms of:
- battery. It appears that the control cost (memory, protocol exchanges)
is multiplied by the number of instances.
- admin. As soon as you have multiple instances, you have to distribute
your instance IDs, policies, etc...
As opposed to implementation complexity.

Note: We've had a lot of confusion mentioning multiple DAGs. There can
be multiple DAGs within an instance (mutually exclusive) or serving
different instances. It appears that your question is really about
serving multiple instances and it will certainly help if we adopt a
common language for the concept.

Cheers,

Pascal

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 7 Oct 2009 15:25:46 -0500 (CDT)

Pascal,

Quoting from your post:

"(RPL) Instances are contexts that run the same code and operate as
ship in the night."

Could you please explain what do you mean by "ship in the night". I have never heard this phrase before.

Thanks
Mukul

----- Original Message -----
From: "Pascal Thubert (pthubert)" <[email-masked]>
To: "JP Vasseur (jvasseur)" <[email-masked]>, "Mukul Goyal" <[email-masked]>
Cc: "roll" <[email-masked]>
Sent: Monday, October 5, 2009 12:51:10 AM GMT -06:00 US/Canada Central
Subject: RE: [Roll] one DAG per RPL instance

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 8 Oct 2009 13:20:33 +0200

Sorry Mukul:

I meant that the instances live like 2 ships crossing in the night and never realizing that the other ship passed by. This is what 2 different protocols, say RIP and OSPF would do. Whether the result of one instance gets redistributed in another is a matter of deployment policy and outside the scope of RPL.

Pascal

>-----Original Message-----
>From: Mukul Goyal [mailto:[email-masked]]
>Sent: mercredi 7 octobre 2009 22:26
>To: Pascal Thubert (pthubert)
>Cc: roll; JP Vasseur (jvasseur)
>Subject: Re: [Roll] one DAG per RPL instance
>
>Pascal,
>
>Quoting from your post:
>