Subject: [Roll] Need Clarification: DA Parents

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Wed, 28 Oct 2009 14:40:54 +0100

Hi JP, All,
 
I see conflicting messages in the draft concerning DA parents (section 5.10.1.1).
 
"  If destination advertisements are activated in the DIO message as
   indicated by the `D' bit, the node sends unicast destination
   advertisements to one of its DA parents, that is selected as most
   favored for incoming outwards traffic."
--> so the node does not necessarily send the unicast DAO to the parent who sent the DIO? This seems to contradict section 5.10.1.1.1 where you actually use a DelayDAO timer per "particular DA parent".
--> Why would we keep a DA parent set if we send DAO only to the most preferred one?
 
"  The node only accepts unicast
   destination advertisements from any nodes but those contained in the
   DA parent subset."
--> should a node accept DAO from nodes the are not in its sub-dag?

More generally do we really need the concept of 'DA parents' in addition to 'parents'. Could we maybe mandate the DA parents = the Parents or alternatively that the DA parent = the most preferred parent. 
Note that having a single DA parent could save a lot of state in terms of DelayDAO timers and reported flags.
 
Best,
Mathilde

Durvy Mathilde
Software Engineer
Technology center

[email-masked]
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

Cisco Systems International Sàrl
Av. des Uttins, 5
CH-1180 Rolle

Cisco home page <http://www.cisco.com/> 

  Think before you print.	
This e-mail may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 29 Oct 2009 16:30:08 +0100

Hi Mathilde

Pascal => The sentence should say that the node might use that parent as most favored parent for incoming outwards traffic and thus send it sDAOs to that parent.

Pascal -> That is in fact a subset of the parent set. In the parent set, you have a preferred parent for DIOs, the one you inherit metrics from. You also have a preferred parent for DAO, that might or might not be the same.

Pascal -> The receiver does not know that the source is in its subDAG, that but from the fact that it gets DAOs from it. Being in the subDAG is a decision from that source. 

Pascal -> could be. That simplifies but limits. 

Yes, we are taking that path. Also the complexity of fanning out seemed overkill at this point.

Cheers, 

Pascal

Best,

Mathilde

Durvy Mathilde
Software Engineer
Technology center

[email-masked] <mailto:[email-masked]> 
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

 

 Think before you print.

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Fri, 30 Oct 2009 08:53:17 +0100

Hi Pascal, 
 
>From your answer I think we are pretty much aligned.
Just one clarification...

"  The node only accepts unicast   destination advertisements from any nodes but those contained in the   DA parent subset."

[Mathilde] What I meant is that a node should anyway only receive unicast DAO from it's child. No?
 
Best,
Mathilde

Durvy Mathilde
Software Engineer
Technology center

 

 Think before you print.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 31 Oct 2009 13:59:22 +0100

You're right, Mathilde. 

A node only sends DAO to its parents, so a router only receives DAO from a child of his.

You will note that the parent has no way to assert this at this point.

Pascal

From: Mathilde Durvy (mdurvy) 
Sent: vendredi 30 octobre 2009 08:53
To: Pascal Thubert (pthubert); 'roll'
Subject: RE: [Roll] Need Clarification: DA Parents

Hi Pascal, 

 

Best,

Mathilde

Durvy Mathilde
Software Engineer
Technology center

 

 Think before you print.