Subject: Re: [Roll] terminology

From: Philip Levis <[email-masked]>
Date: Tue, 3 Nov 2009 11:20:54 -0800

On Oct 30, 2009, at 6:18 AM, Julien Abeille (jabeille) wrote:

> Hi all,
>
> I am getting headackes with up the tree, to a lower rank, inward vs  
> down the tree, to a higher rank, outwards.
> Could the text only use up and down (direction), higher node, lower  
> node (nodes/parents),  and mention rank only when needed.
>

This seems like an excellent simplification to me.

The one weird thing that occurs is that people often talk about going  
"up" the tree as towards the root, which is the opposite of a real  
world tree. E.g., depth first search. So I'd suggest we say

Up: towards the root, decreasing rank
Down: towards the leaves, increasing rank
Higher node: lower rank
Lower node: higher rank

I think it's important to define higher and lower in terms of Rank  
since Rank is what's actually used. Otherwise you get into a weird  
situation comparing disjoint subtrees.

Parent -> higher node.
Child -> lower node.

Thoughts?

Phil

---

From: Jonathan Hui <[email-masked]>
Date: Tue, 3 Nov 2009 11:57:47 -0800

On Nov 3, 2009, at 11:20 AM, Philip Levis wrote:

> The one weird thing that occurs is that people often talk about  
> going "up" the tree as towards the root, which is the opposite of a  
> real world tree. E.g., depth first search. So I'd suggest we say
>

If we want to be precise about the terms, then "sequence number" needs  
to appear somewhere.  For example, A may be "higher" than B because it  
has a newer sequence number - which trumps any difference in rank.

--
Jonathan Hui

---

From: [email-masked]
Date: Wed, 4 Nov 2009 09:26:10 -0600

The misunderstanding appears to be created
due to the conversion from a physical position to a numeric position.  The
LBR is

the reference point for all relative
positions.

The higher numeric rank being a relative
position farther from the LBR

the lower the numeric rank being a relative
position closer to the LBR

Is a higher rank (numerically or position
as physically drawn)  closer to the top?  This depends how in
your mind you draw the DAG

For example many people draw a DAG with
the LBR  at the top (typical example shown in the rpl-04 document)

A      (ROOT)   (rank
0)

- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - -

B
C
(rank 1)

- - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - -

D
E
F     (rank 2)

but when you consider a normal physical
tree - the roots  (LBR) of the tree are at the bottom and the leaves
are at the top

Should the RPL DAG samples  be
drawn with the LBR at the bottom versus the top to avoid this confusion
?

If you use the terms closer to (lower
rank)  or further away (higher rank)  from the LBR - the up and
down, inward / outward of the DAG is less confusing

Use  the term further from the
LBR ( to a relative higher rank device)

Use the term closer to the LBR (to a
relative lower rank device)

Outward means further from the LBR  (
to a relative higher rank device)

Inward means closer to the LBR  (to
a relative lower rank device)

Ted

From:

Philip Levis <[email-masked]>

To:

Julien Abeille (jabeille) <[email-masked]>

Cc:

roll ROLL <[email-masked]>

Date:

11/03/2009 01:21 PM

Subject:

Re: [Roll] terminology

"up" the tree as towards the root, which is the opposite of a
real

Higher node: lower rank

Lower node: higher rank

Parent -> higher node.

Child -> lower node.

Thoughts?

Phil

_______________________________________________

Roll mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/roll

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Wed, 4 Nov 2009 17:35:59 +0100

Hi all,

I am inline with Philip. Thanks for the precisions by the way. 
Regarding sequence numbers, for me 2 nodes with 2 different seq numbers
are in different DAGs, hence we do not need to compare them as far as
height is concerned.

Best,
Julien

> -----Original Message-----
> From: Jonathan Hui [mailto:[email-masked]] 
> Sent: mardi 3 novembre 2009 20:58
> To: Philip Levis
> Cc: Julien Abeille (jabeille); roll ROLL
> Subject: Re: [Roll] terminology
> 
> 
> > Down: towards the leaves, increasing rank Higher node: lower rank 
> > Lower node: higher rank
> >
> If we want to be precise about the terms, then "sequence 
> number" needs to appear somewhere.  For example, A may be 
> "higher" than B because it has a newer sequence number - 
> which trumps any difference in rank.
> 
> --
> Jonathan Hui
> 
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 Nov 2009 13:34:35 +0100

Agreed. 

Rank is scoped within a sequence.

A node cannot use a passed parent (a parent that exposed a passed
sequence). 

A node may use a future parent (a parent with a future sequence) but it
has to appear as a leaf to that parent in that DODAG instance by setting
the rank to infinite. This is done to avoid a false positive detection
if the rank relationship changes with the sequence.

Cheers,

Pascal

>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Julien Abeille (jabeille)
>Sent: mercredi 4 novembre 2009 17:36
>To: Jonathan Hui; Philip Levis
>Cc: roll ROLL