Subject: [Roll] Role of the OF

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Wed, 18 Nov 2009 16:24:08 +0100

Hi all,
 
for me an OF is a logic used to compare parents, i.e. from 2 parents A,
A a is better than B. This can be used for a full sort (from a list of x
parents, order them) or a best paret election (from a list of x parents,
which is the best)
an OF should not know what RPL states mean (preferred or backup has no
meaning for an OF). 
In short the OF is equivalent to the > sign, but for parents 
 
Is this correct? If yes the text in the OF0 description should not have
any reference to "prefered/backup..."
 
Best,
Julien

---

From: JP Vasseur <[email-masked]>
Date: Wed, 18 Nov 2009 17:20:26 +0100

Hi Julien,

On Nov 18, 2009, at 4:24 PM, Julien Abeille (jabeille) wrote:

> Hi all,
>
> for me an OF is a logic used to compare parents, i.e. from 2 parents  
> A, A a is better than B. This can be used for a full sort (from a  
> list of x parents, order them) or a best paret election (from a list  
> of x parents, which is the best)
> an OF should not know what RPL states mean (preferred or backup has  
> no meaning for an OF).
> Is this correct? If yes the text in the OF0 description should not  
> have any reference to "prefered/backup..."

There are scenario where this might be useful, in addition to the  
"preferred" relationship. For example the OF may tell you to  
systematically to connect to N parents so as to increase the degree of  
meshing to improve P2P paths for example.

>
> Best,
> Julien
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Wed, 18 Nov 2009 17:22:56 +0100

if i understand this it is about choosing the DAG which has more
parents? If yes I agree, but still this removes the backup parent
selection section?
Julien

________________________________

	From: JP Vasseur (jvasseur) 
	Sent: mercredi 18 novembre 2009 17:20
	To: Julien Abeille (jabeille)
	Cc: ROLL WG
	Subject: Re: [Roll] Role of the OF

	Hi Julien, 

		Hi all,
		 
		for me an OF is a logic used to compare parents, i.e.
from 2 parents A, A a is better than B. This can be used for a full sort
(from a list of x parents, order them) or a best paret election (from a
list of x parents, which is the best)
		an OF should not know what RPL states mean (preferred or
backup has no meaning for an OF). 
		In short the OF is equivalent to the > sign, but for
parents 
		 
		Is this correct? If yes the text in the OF0 description
should not have any reference to "prefered/backup..."

	There are scenario where this might be useful, in addition to
the "preferred" relationship. For example the OF may tell you to
systematically to connect to N parents so as to increase the degree of
meshing to improve P2P paths for example.

		Best,
		Julien

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 19 Nov 2009 08:50:34 +0100

Hi Julien:

The OF selects the ordered list, not just the best. Some pearl of OCP
awareness might also influence the packet forwarding time to use that
list.

The text for OCP0 will be separated but the text about OCPs in general
will stay.

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Julien Abeille (jabeille)
Sent: mercredi 18 novembre 2009 16:24
To: ROLL WG
Subject: [Roll] Role of the OF

Hi all,

Best,

Julien