Subject: [Roll] Clarification on the objective function

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Tue, 3 Nov 2009 11:28:43 +0100

Hi All,

Section 5.9.1 says

     "When the scan is complete, the preferred parent is elected and
      self's rank is computed as the preferred parent rank plus the step
      in rank with that parent."
Does this mean that the rank of a node is only based on the rank of its most preferred parent?

Shouldn't the rank of the node also depend on the non-preferred parents?

Or is it assumed that the node always forward traffic via its most preferred parent? 

Best,

Mathilde

Durvy Mathilde
Software Engineer
Technology center

[email-masked]
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

Cisco Systems International Sàrl
Av. des Uttins, 5
CH-1180 Rolle

Cisco home page <http://www.cisco.com/> 

  Think before you print.	
This e-mail may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message.

---

From: JP Vasseur <[email-masked]>
Date: Tue, 3 Nov 2009 12:30:02 +0100

Hi,

> Or is it assumed that the node always forward traffic via its most  

A node may indeed choose to send traffic to an alternate parent and  
not the most preferred.
But do you think that this should change the way its computes its rank ?

JP.

> Cisco home page
> This e-mail may contain confidential and privileged material for the  
> sole use of the intended recipient. Any review, use, distribution or  
> disclosure by others is strictly prohibited. If you are not the  
> intended recipient (or authorized to receive for the recipient),  
> please contact the sender by reply e-mail and delete all copies of  
> this message.
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Mathilde Durvy (mdurvy)" <[email-masked]>
Date: Tue, 3 Nov 2009 13:30:09 +0100

Hi JP,
 
I guess it is ok as long as you ensure that all your parents have rank lower than yours by other means. This is currently done by reevaluating all parents when you change your rank. Parents with rank larger than the node's rank are removed. I don't know why but I add the impression that at some point we considered all parents in the rank computation, my mistake probably.
 
Best,
Mathilde

________________________________

From: JP Vasseur (jvasseur) 
Sent: mardi, 3. novembre 2009 12:30
To: Mathilde Durvy (mdurvy)
Cc: roll
Subject: Re: [Roll] Clarification on the objective function

Hi, 

	
	Hi All,

	Section 5.9.1 says

A node may indeed choose to send traffic to an alternate parent and not the most preferred.
But do you think that this should change the way its computes its rank ?

JP.

	Best,
	Mathilde
	 
 <http://www.cisco.com/swa/i/logo.gif> 	
Durvy Mathilde
Software Engineer
Technology center

[email-masked]
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

 	
 Think before you print.<http://www.cisco.com/global/EMEA/brand/signature/capital/green.gif> Think before you print.	
This e-mail may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 Nov 2009 13:39:00 +0100

Hi Mathilde,

If that parent is preferred, it is probably because that's where most of the traffic should land.

This is why rank and metrics are expected to be propagated from that of that preferred parent.

Allowing other parents to impact the rank is opening the door to greediness. So we picked the simple path of accepting parents that are upwards once the rank is selected from the honest-to-God preferred parent.

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of JP Vasseur (jvasseur)
Sent: mardi 3 novembre 2009 12:30
To: Mathilde Durvy (mdurvy)
Cc: roll
Subject: Re: [Roll] Clarification on the objective function

Hi,

Hi All,

Section 5.9.1 says

JP.

Best,

Mathilde

Durvy Mathilde
Software Engineer
Technology center

[email-masked] <mailto:[email-masked]> 
Phone: +41 21 822 1725
Mobile: +41 76 396 8116

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Mon, 9 Nov 2009 13:57:27 +0100

Hi Pascal,
 
just to be sure I understand: 
- I have a preferred parent at rank 1, my rank is 5, I receive a DIO for a parent rank 2, must i ignore it? I would say no as this node is useful as backup parent, but if i lose my preferred parent, choosing the backup as preferred will make my rank increase (this is ok because if i compute rank based on all parents, I would have to increase rank at reception of the second DIO anyway)
- At boot time, I receive two DIOs (rank 1 and 2) before computing OCP. If I calculate rank based on preferred only, if at some point I would like to switch to the other parent, I will have to move down.
 
Still I think it is preferable to calculate rank based on preferred only, but what do other think?
Julien

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
	Sent: lundi 9 novembre 2009 13:39
	To: JP Vasseur (jvasseur); Mathilde Durvy (mdurvy)
	Cc: roll
	Subject: Re: [Roll] Clarification on the objective function

	Hi Mathilde,

	Pascal

	Hi,

	

	Hi All,

	Section 5.9.1 says

	JP.

	 

	Best,

	Mathilde

Durvy Mathilde
Software Engineer
Technology center

---

From: Philip Levis <[email-masked]>
Date: Mon, 9 Nov 2009 09:00:05 -0800

On Nov 9, 2009, at 4:57 AM, Julien Abeille (jabeille) wrote:

> - I have a preferred parent at rank 1, my rank is 5, I receive a DIO  
> for a parent rank 2, must i ignore it? I would say no as this node  
> is useful as backup parent, but if i lose my preferred parent,  
> choosing the backup as preferred will make my rank increase (this is  
> ok because if i compute rank based on all parents, I would have to  
> increase rank at reception of the second DIO anyway)
> - At boot time, I receive two DIOs (rank 1 and 2) before computing  
> OCP. If I calculate rank based on preferred only, if at some point I  
> would like to switch to the other parent, I will have to move down.
>

Julien,

Question 1: In -04, you MUST process the DIO. Section 5.4.2.1:

	If the rank of SRC as reported in the DIO message is lesser
         than that of the node within the DAG, then the DIO message MUST
         be considered for further processing

Question 2: The draft is unclear.

Phil

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Mon, 9 Nov 2009 19:32:54 +0100

Phil, 

Are you in favor of computing rank based on all parents, or only
preferred?

Julien

> -----Original Message-----
> From: Philip Levis [mailto:[email-masked]] 
> Sent: lundi 9 novembre 2009 18:00
> To: Julien Abeille (jabeille)
> Cc: Pascal Thubert (pthubert); JP Vasseur (jvasseur); 
> Mathilde Durvy (mdurvy); roll
> > for a parent rank 2, must i ignore it? I would say no as 
> this node is 
> > useful as backup parent, but if i lose my preferred parent, 
> choosing 
> > the backup as preferred will make my rank increase (this is 
> ok because 
> > if i compute rank based on all parents, I would have to 
> increase rank

---

From: Philip Levis <[email-masked]>
Date: Mon, 9 Nov 2009 10:58:00 -0800

> Are you in favor of computing rank based on all parents, or only

It's not clear to me what a "preferred" parent is. Is it the exact  
parent at time T? A node may wish to change which next hop it uses  
very quickly (albeit under constraints that keep the topology  
consistent). Jonathan Hui's IP layer does this: it chooses an  
alternate parent after three consecutive link delivery failures (no  
acks).

The way I see it, a node has a neighbor set, which is an unconstrained  
set of link-local neighboring nodes. Its parent set is a subset of its  
neighbor set, and these parents can be used arbitrarily (an  
implementation could just cycle through them for each transmission, if  
it wanted). The only time when a node has *a* parent is the instant it  
transmits a packet to a particular next hop.

Given this, Rank should be computed based on the parent set. I'd say  
that

A node MUST NOT advertise a Rank that is less than or equal to any  
member of its parent set.

Phil

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Mon, 9 Nov 2009 20:39:45 +0100

Hi Phil,

> Sent: lundi 9 novembre 2009 19:58
> It's not clear to me what a "preferred" parent is. Is it the 
For me the preferred parent is the one you send DAOs to. 

> exact parent at time T? A node may wish to change which next 
> hop it uses very quickly (albeit under constraints that keep 
> the topology consistent). Jonathan Hui's IP layer does this: 
> it chooses an alternate parent after three consecutive link 
> delivery failures (no acks).
agree
> 
> The way I see it, a node has a neighbor set, which is an 
> unconstrained set of link-local neighboring nodes. Its parent 
> set is a subset of its neighbor set, and these parents can be 
> used arbitrarily (an implementation could just cycle through 
> them for each transmission, if it wanted). 
agree

> The only time when 
> a node has *a* parent is the instant it transmits a packet to 
> a particular next hop.
> 

> Given this, Rank should be computed based on the parent set. 
> I'd say that
> 
> A node MUST NOT advertise a Rank that is less than or equal 
> to any member of its parent set.
> 
Agree. 
The issue is when you lose your prefererred parent, you may want to
choose a backup one to send DAOs to. The fact that its rank is lower
than yours does not guarantee that your new rank will not change. e.g.
if OF says my rank is preffered parent's + 2, and I have parents at rank
1 and 2, mine is 3. if my parent at rank 1 dies, and I choose the other
parent as preferred, my rank would become 4, which implies moving lower.
Does anybody want to avoid this by computing continuesly rank based on
the parent set instead of just the preferred one (this is not optimal
but helps if you compute your rank when you get several DIOs)? 

Julien

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 10 Nov 2009 02:45:29 +0100

Hi Phil and Julien:

For 1) agreed with Phil. Any node with rank less than self in the DODAG
iteration can be a parent.

For 2) RPL has the concept of preferred parent to deal with this.

The preferred parent determines the node rank whether the second (not as
good) parent is already seen or not.
The second (not as good) parent does not influence the rank. 
This is done to avoid greedy behaviors and to simplify the metrics
inheritance.

Pascal

>Cc: Pascal Thubert (pthubert); JP Vasseur (jvasseur); Mathilde Durvy
(mdurvy); roll

---

From: JP Vasseur <[email-masked]>
Date: Tue, 10 Nov 2009 08:45:01 +0100

> The second (not as good) parent does not influence the rank.

=> used as a back up (similarly to siblings)

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Tue, 10 Nov 2009 09:40:01 +0100

Hi Pascal 

> From: Pascal Thubert (pthubert) 
> Sent: mardi 10 novembre 2009 02:45
> To: Philip Levis; Julien Abeille (jabeille)
> Cc: JP Vasseur (jvasseur); Mathilde Durvy (mdurvy); roll
> Subject: RE: [Roll] Clarification on the objective function
> 
> Hi Phil and Julien:
> 
> For 1) agreed with Phil. Any node with rank less than self in 
> the DODAG iteration can be a parent.
> 
> The preferred parent determines the node rank whether the 
> second (not as good) parent is already seen or not.
> This is done to avoid greedy behaviors and to simplify the 
> metrics inheritance.
> 
I got this some time ago. This is what I am questionning, because of the
behavior I detailed twice. 

Julien
> >> useful as backup parent, but if i lose my preferred 
> parent, choosing 
> >> the backup as preferred will make my rank increase (this is ok 
> >> because if i compute rank based on all parents, I would have to 
> >> Still I think it is preferable to calculate rank based on 
> preferred 
> >> only, but what do other think?
> >> Julien
> >
> >Julien,
> >