Subject: Re: [Roll] multicast DAO

From: Philip Levis <[email-masked]>
Date: Fri, 20 Nov 2009 10:30:57 -0800

On Oct 28, 2009, at 9:29 AM, Julien Abeille (jabeille) wrote:

> Hi all,
>
> regarding usage of multicast DAO: in the following scenario:
>   A
>  /  \
> B  C
>
> if the purpose is to to allow B and C to talk to each other  
> directly, the multicast DAO is equivalent to an unsolicited NA.
>
> In the scenarios like:
>
>    A
>   /  \
> B   C
>       |
>       D
> if the purpose is to have B talk to D through C (instead of A then  
> C), then the multicast DAO (including destination prefix option)  
> makes sense.
> Is this scenario needed by some applications?

Julien,

The text in -04 reads:

"The objective [of multicast DAOs] is to enable direct P2P  
communication, between destinations directly supported by neighboring  
nodes, without needing the RPL routing structure to relay the packets."

So the case it's concerned with is the latter one: B to C to D.  
Clearly one could use NA for the B-C case.

Point-to-point communication between nodes is needed by some  
applications. Section 5.2.2 of draft-ietf-roll-building-routing-reqs-07:

"A network device MUST be able to communicate in a point-to-point  
manner with any other device on the network."

Do you agree? Is it OK to resolve this ticket?

Phil

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Wed, 25 Nov 2009 10:43:41 +0100

Hi Phil, 

Sorry for the delayed response. 
> -----Original Message-----
> From: Philip Levis [mailto:[email-masked]] 
> Sent: vendredi 20 novembre 2009 19:31
> To: Julien Abeille (jabeille)
> Cc: ROLL WG
> Subject: Re: [Roll] multicast DAO
> 
> 
> directly, 
> > the multicast DAO is equivalent to an unsolicited NA.
> >
> > In the scenarios like:
> >
> >    A
> >   /  \
> > B   C
> >       |
> >       D
> > if the purpose is to have B talk to D through C (instead of 
> A then C), 
> > then the multicast DAO (including destination prefix option) makes 
> > sense.
> communication, between destinations directly supported by 
> neighboring nodes, without needing the RPL routing structure 
> to relay the packets."
> 
Two questions: is it really a scenario (B to C to D) that happens a lot.
I feel it is not generic at all, hence we should focus on a more generic
way to solve the P2P problem. 
> applications. Section 5.2.2 of 
> draft-ietf-roll-building-routing-reqs-07:
> 
> "A network device MUST be able to communicate in a 
> point-to-point manner with any other device on the network."
> 
Sure, and DAOs (whether stored only at root are not) solve this issue.
May not be the most efficient, but the sceanrios multicast DAOs solve
are so limited that we will end up with 10 solutions for 10 scenarios if
we go that path.

I would personaly drop multicast DAOs

Best,
Julien

---

From: Richard Kelsey <[email-masked]>
Date: Wed, 25 Nov 2009 08:39:03 -0500

> Date: Wed, 25 Nov 2009 10:43:41 +0100
> From: "Julien Abeille (jabeille)" <[email-masked]>

> I would personaly drop multicast DAOs

I agree.  As we have done with unicasts, we need to look
carefully at the multicast requirements and find ways to
solve the easy and/or common cases first.  I do not think
that there is a workable one-size-fits-all multicast
solution.
                                     -Richard Kelsey

---

From: Philip Levis <[email-masked]>
Date: Mon, 30 Nov 2009 08:57:04 -0800

> that there is a workable one-size-fits-all multicast

Because the current mandate is for greater simplicity, it makes sense  
to remove RPL features/mechanisms that don't have strong proponents.

Does anyone think multicast DAOs should remain? If so, it would help  
if you could explain your reasoning on the tradeoff between the  
benefits and drawbacks (increased complexity).

Phil

---

From: JP Vasseur <[email-masked]>
Date: Tue, 1 Dec 2009 08:33:58 +0100

On Nov 30, 2009, at 5:57 PM, Philip Levis wrote:

> Because the current mandate is for greater simplicity, it makes  
> sense to remove RPL features/mechanisms that don't have strong  
> proponents.
>

I do think so. It makes little sense to remove something just because  
it makes it more simpler. Multicast DAO does help to come up with  
shorter path, which is quite important for P2P and the level of  
complexity is close to 0.

Thanks.

JP.

>
> Phil
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Tue, 1 Dec 2009 08:35:27 +0100

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Tue, 1 Dec 2009 08:37:25 +0100

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Tue, 1 Dec 2009 08:39:24 +0100

Thanks.

JP.