Subject: Re: [Roll] I-D Action:draft-ietf-roll-rpl-04.txt

From: Sung Lee <[email-masked]>
Date: Mon, 02 Nov 2009 18:03:20 -0500

> You're quite right that the results were for a limited topology size.
> I would vote for making it
> configurable 3-bit flag that could be adjusted according to the
> network topology.

JP,

Does this mean that one can have up to 2^3 sibling transmissions
(configurable parameter)?
Did I understand you correctly?

This might work and I am willing to take this as an initial point
although we would evaluate this value further to make sure that this is
adequate number.

Thanks.
Sung

[email-masked] wrote:
> Message: 1
> Date: Thu, 29 Oct 2009 17:18:26 +0100
> From: JP Vasseur <[email-masked]>
> Subject: Re: [Roll] I-D Action:draft-ietf-roll-rpl-04.txt
> To: Sung Lee <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=US-ASCII; format=flowed; delsp=yes
>
>
> On Oct 29, 2009, at 5:08 PM, Sung Lee wrote:
>
>
>> Tim and WG members,
>>
>> I was reviewing v04 and have some concerns about current proposal.
>> In particular, the restriction on 2 sibling hops in a row.
>>
>>
>>> 5.11.4.  Sibling Loop Avoidance
>>>
>>>  When a packet is forwarded along siblings, it cannot be checked for
>>>  forward progress and may loop between siblings.  Experimental
>>>  evidence has shown that one sibling hop can be very useful but is
>>>  generally sufficient to avoid loops.  Based on that evidence, this
>>>  specification enforces the simple rule that a packet may not make 2
>>>  sibling hops in a row.
>>>
>> I recall that the experiment result was presented at the interim
>> meeting.
>> However, it was also pointed out that if the selected sibling is not
>> the
>> right one, then you risk a packet loss.
>> If the network topology is simple enough, this may be sufficient
>> restriction to avoid sibling loops.
>> Without much coordinated effort of trying to figure out the "right"
>> next
>> hop sibling, this simple restriction will cause many packet drops if
>> the
>> network topology is complicated.
>>
>> My understanding is that ROLL is targeting for a large scale network.
>> And I have concerns about this.
>> I would like to hear about what others think about this.
>>
>
> You're quite right that the results were for a limited topology size.
> I would vote for making it
> configurable 3-bit flag that could be adjusted according to the
> network topology.
>
> Thoughts ?
>
> JP.
>
>
>> Regards,
>> Sung
>>
>>

---

From: JP Vasseur <[email-masked]>
Date: Tue, 3 Nov 2009 08:16:06 +0100

Hi Sung,

> although we would evaluate this value further to make sure that this  

The idea would be to make it n bits so indeed you would get 2^n mac  
number of sibling hops.
Then you could configure the value of n for each network, possibly  
advertise it from the DAG root, ....

Thanks.

JP.

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Sung Lee <[email-masked]>
Date: Tue, 03 Nov 2009 15:30:54 -0500

Hi JP,

I like the idea of flexible n-bit magic number.
Thank you,
Sung