Subject: Re: [Roll] RPL clarification needed: moving down the DAG

From: Mukul Goyal <[email-masked]>
Date: Wed, 4 Nov 2009 17:32:05 -0600 (CST)

Hi Pascal, Julien,

Two points:

1. Regarding the scenario Julien listed, A can safely choose C as the most preferred parent and increase its rank to 6 immediately. The rank increase can not lead to routing loops if:
a) no new parent is selected (as in case of scenario Julien listed; C was already a parent for A)
b) a new parent is selected but has a smaller rank (than the node's current rank; hence it can not be in the node's sub-DAG)

2. Now, lets suppose that new parent (B) has a higher rank than the node's current rank and is infact in the node's sub-DAG. The node (A) chooses it as a parent and consequently increases its rank. Now, we have a routing loop. But this loop should be quickly resolved if nodes in the loop have alternate parents. e.g. in our example, when A increases its rank, its children will kick it out of the parent set if they have alternate parents. It may cause an increase in B's rank and hence a further increase in A's rank but we wont have "count to infinity" situation. We will have "count to infinity" situation only when nodes in the loop are isolated from rest of the network. In that case, they will do "count to infinity" and produce lot of DIOs but we should not really care about these nodes (and their DIOs) since they are isolated any way.

So, perhaps, we should allow a node to freely move down a DAG? Any resulting routing loops will be quickly resolved (in order of I_min*(length of loop) time). If that is not fast enough, DAG hop timers may be used.

Am I missing some thing?

Thanks
Mukul
  
----- Original Message -----
From: "Pascal Thubert (pthubert)" <[email-masked]>
To: "Julien Abeille (jabeille)" <[email-masked]>, [email-masked]
Sent: Tuesday, November 3, 2009 10:34:01 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] RPL clarification needed: moving down the DAG

Hi Julien: 

The response used to be in early versions, start a small timer that’s an order of magnitude longer than RA propagation, and when it elapses, loose memory and do what you like. 

The Dag Hop Timer being gone down the simplifier sink, we are in a sad situation where the node cannot move down anymore. It has to wait for a new sequence. 

Maybe this timer was removed a bit too enthusiastically? 

Pascal 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Julien Abeille (jabeille) 
Sent: mardi 3 novembre 2009 17:09 
To: [email-masked] 
Subject: [Roll] RPL clarification needed: moving down the DAG 

Hi all, 

when does a node move down a DAG? 5.4.1.4 says a node must not, but if it does it must poison down. so when does it move down? 

example 1; if node A has two parents, B and C, rank 1 and 2. A rank is 5 (let's say OCP 0 is used) for some reason B is not available anymore, A new rank if it goes with C would be 6. Is A allowed to move to C? 

Julien 
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Richard Kelsey <[email-masked]>
Date: Thu, 05 Nov 2009 06:31:16 -0500

Date: Wed, 4 Nov 2009 17:32:05 -0600 (CST)
   From: Mukul Goyal <[email-masked]>

   2. Now, lets suppose that new parent (B) has a higher rank than the
   node's current rank and is infact in the node's sub-DAG. The node (A)
   chooses it as a parent and consequently increases its rank. Now, we
   have a routing loop. [...] We will have "count to infinity" situation only
   when nodes in the loop are isolated from rest of the network. In that
   case, they will do "count to infinity" and produce lot of DIOs but we
   should not really care about these nodes (and their DIOs) since they
   are isolated any way.

Hi Mukul,

Remember that there may be multiple DAG instances.  Being
isolated from one DAG root does not mean that a node has
nothing useful to do.  It may just mean that it will use
a different DAG for the moment.
                                     -Richard Kelsey