Subject: Re: [Roll] RPL clarification needed: moving down the DAG

From: Mukul Goyal <[email-masked]>
Date: Thu, 5 Nov 2009 06:05:22 -0600 (CST)

Hi Richard

If the node is in a "count to infinity" situation in DAG1 and is a part of DAG2 as well (or can join DAG2 quickly if it wants to):

1) it will start using DAG2 for packet forwarding once DAG2 becomes more attractive than DAG1.

2) But how does the "count to infinity" the node is doing in DAG1 affect DAG2 otherwise? I can see that frequent generation of DAG1 DIOs by the in-loop DAG1 nodes will cause extra contention for the radio channel, but what else may happen? 

Thanks
Mukul
 
----- Original Message -----
From: "Richard Kelsey" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: [email-masked], [email-masked]
Sent: Thursday, November 5, 2009 5:31:16 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] RPL clarification needed: moving down the DAG

   Date: Wed, 4 Nov 2009 17:32:05 -0600 (CST)
   From: Mukul Goyal <[email-masked]>

   2. Now, lets suppose that new parent (B) has a higher rank than the
   node's current rank and is infact in the node's sub-DAG. The node (A)
   chooses it as a parent and consequently increases its rank. Now, we
   have a routing loop. [...] We will have "count to infinity" situation only
   when nodes in the loop are isolated from rest of the network. In that
   case, they will do "count to infinity" and produce lot of DIOs but we
   should not really care about these nodes (and their DIOs) since they
   are isolated any way.

Hi Mukul,

Remember that there may be multiple DAG instances.  Being
isolated from one DAG root does not mean that a node has
nothing useful to do.  It may just mean that it will use
a different DAG for the moment.
                                     -Richard Kelsey

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 Nov 2009 12:05:35 +0100

Hi Mukul:

We currently have a rule NOT TO follow a parent that falls down a current DODAG iteration. This was added to avoid count to infinity very early in RPL. A node still can and should IMHO follow a parent that jumps if that node looses all parents in its current iteration.

Pascal

>-----Original Message-----
>From: Mukul Goyal [mailto:[email-masked]]
>Sent: jeudi 5 novembre 2009 13:05
>To: Richard Kelsey
>Cc: Pascal Thubert (pthubert); [email-masked]
>2) But how does the "count to infinity" the node is doing in DAG1 affect DAG2 otherwise? I can see that
>frequent generation of DAG1 DIOs by the in-loop DAG1 nodes will cause extra contention for the radio channel,
>but what else may happen?
>
>Thanks
>Mukul
>