Subject: Re: [Roll] [roll] #12: DIS

From: Mukul Goyal <[email-masked]>
Date: Wed, 9 Dec 2009 09:13:55 -0600 (CST)

Hi Jerry, Dominique,

I am not sure if a node, that has just arrived in this world, would know what desired rank range to advertize in its DIS.

I really like Pascal's proposal that a trickle style mechanism decides whether a node advertises itself as a router or not.

Thanks
Mukul

----- Original Message -----
From: "Jerald P Martocci" <[email-masked]>
To: "dominique barthel" <[email-masked]>
Cc: [email-masked], [email-masked]
Sent: Wednesday, December 9, 2009 9:02:45 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] [roll] #12: DIS

Hey Dominique, 

+1 for me.  I like it. 

<[email-masked]> 
Sent by: [email-masked] 

12/09/2009 07:40 AM 	
To 	<[email-masked]>, <[email-masked]>, <[email-masked]> 

cc 	

Subject 	Re: [Roll] [roll] #12: DIS 

Hello all, 

Where there is a high density of nodes/routers, we want to be more selective as to who shall respond to a multicast DIS. 
DIS currently has no message body. Would it be possible to have the message body indicate a range of ranks and a maximal link cost for nodes requested to respond ? (default would be a catch all). 
It's much better to have to send a few selective DIS'es, lowering the requirements as needed, rather than have all neighbors respond irrespective of their quality to becoming a parent/sibling. 
And I guess the magic sentence is : there are sensor networks in the field, with millions of devices deployed, that do it today and need it in the future. 
Your comments ? 
Thanks 

Dominique 

-----Message d'origine----- 
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker 
Envoyé : jeudi 3 décembre 2009 15:59 
À : [email-masked]; [email-masked] 
Cc : [email-masked] 
Objet : Re: [Roll] [roll] #12: DIS 

#12: DIS 
--------------------------------+--------------------------------------- 
--------------------------------+---- 
Reporter:  jpv@...               |        Owner:  wintert@...       
    Type:  defect              |       Status:  closed         
Priority:  trivial             |    Milestone:                 
Component:  rpl                 |      Version:                 
Severity:  Active WG Document  |   Resolution:  fixed           
Keywords:                      |   
--------------------------------+--------------------------------------- 
--------------------------------+---- 
Changes (by jpv@...): 

 * status:  new => closed 
 * resolution:  => fixed 

Comment: 

The use of Trickle serves to randomize the response to DIS messages. 
  For -05, RPL text is updated to clarify: 

  o  When a node receives a multicast DIS message, it MUST reset the 
     trickle timer to the minimum value. 

  o  When a node receives a unicast DIS message, it MUST unicast a DIO 
     message in response, and include the DAG Configuration Object.  In 
     this case the node SHOULD NOT reset the trickle timer. 

-- 
Ticket URL: <http://tools.ietf.org/wg/roll/trac/ticket/12#comment:1> 
roll <http://tools.ietf.org/wg/roll/> 

_______________________________________________ 
Roll mailing list 
[email-masked] 
https://www.ietf.org/mailman/listinfo/roll 
_______________________________________________ 
Roll mailing list 
[email-masked] 
https://www.ietf.org/mailman/listinfo/roll 

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: [email-masked]
Date: Wed, 9 Dec 2009 09:34:38 -0600

Agreed.  A newborn wouldn't know and hence would solicit without any range 
parameters set.  However, once the node is established in the DAG and 
wants to better its rank, why would it want responses from neighbor nodes 
that a already are at a lower rank.

Mukul Goyal <[email-masked]> 
12/09/2009 09:14 AM

To
Jerald P Martocci <[email-masked]>
cc
[email-masked], dominique barthel <[email-masked]>
Subject
Re: [Roll] [roll] #12: DIS

Hi Jerry, Dominique,

I am not sure if a node, that has just arrived in this world, would know 
what desired rank range to advertize in its DIS.

I really like Pascal's proposal that a trickle style mechanism decides 
whether a node advertises itself as a router or not.

Thanks
Mukul

----- Original Message -----
From: "Jerald P Martocci" <[email-masked]>
To: "dominique barthel" <[email-masked]>
Cc: [email-masked], [email-masked]
Sent: Wednesday, December 9, 2009 9:02:45 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] [roll] #12: DIS

Hey Dominique, 

+1 for me.  I like it. 

12/09/2009 07:40 AM 

cc 

Hello all, 

Where there is a high density of nodes/routers, we want to be more 
selective as to who shall respond to a multicast DIS. 
DIS currently has no message body. Would it be possible to have the 
message body indicate a range of ranks and a maximal link cost for nodes 
requested to respond ? (default would be a catch all). 
It's much better to have to send a few selective DIS'es, lowering the 
requirements as needed, rather than have all neighbors respond 
irrespective of their quality to becoming a parent/sibling. 
And I guess the magic sentence is : there are sensor networks in the 
field, with millions of devices deployed, that do it today and need it in 
the future. 
Your comments ? 
Thanks 

Dominique 

-----Message d'origine----- 
De : [email-masked] [mailto:[email-masked]] De la part de 
roll issue tracker 
Envoyé : jeudi 3 décembre 2009 15:59 
À : [email-masked]; [email-masked] 
Cc : [email-masked] 
Objet : Re: [Roll] [roll] #12: DIS 

#12: DIS 

 * status:  new => closed 
 * resolution:  => fixed 

Comment:

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 9 Dec 2009 09:58:11 -0600 (CST)

Yes, in that case, it makes sense to specify a rank range in the DIS.

Thanks
Mukul

----- Original Message -----
From: "Jerald P Martocci" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "dominique barthel" <[email-masked]>, [email-masked]
Sent: Wednesday, December 9, 2009 9:34:38 AM GMT -06:00 US/Canada Central
Subject: Re: [Roll] [roll] #12: DIS

Agreed.  A newborn wouldn't know and hence would solicit without any range parameters set.  However, once the node is established in the DAG and wants to better its rank, why would it want responses from neighbor nodes that a already are at a lower rank. 

12/09/2009 09:14 AM 	
To 	Jerald P Martocci <[email-masked]> 

cc 	[email-masked], dominique barthel <[email-masked]> 

Hi Jerry, Dominique, 

Thanks 
Mukul 

----- Original Message ----- 
From: "Jerald P Martocci" <[email-masked]> 
To: "dominique barthel" <[email-masked]> 
Cc: [email-masked], [email-masked] 
Sent: Wednesday, December 9, 2009 9:02:45 AM GMT -06:00 US/Canada Central 
Subject: Re: [Roll] [roll] #12: DIS 

Hey Dominique, 

+1 for me.  I like it. 

12/09/2009 07:40 AM                   

cc                   

Hello all, 

Dominique 

-----Message d'origine----- 
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker 
Envoyé : jeudi 3 décembre 2009 15:59 
À : [email-masked]; [email-masked] 
Cc : [email-masked] 
Objet : Re: [Roll] [roll] #12: DIS 

#12: DIS 

 * status:  new => closed 
 * resolution:  => fixed 

Comment: