Subject: [Roll] Working Last Call on draft-ietf-roll-of0-05

From: JP Vasseur <[email-masked]>
Date: Tue, 22 Feb 2011 09:03:12 +0100

Dear all,

This document has been stable for quite some time and the latest revision has addressed all comments received so far. This starts a 2-week Working Group Last call on draft-ietf-roll-of0-05, that will end on March 8 at noon ET.

Please send your comments to the authors and copy the mailing list.

Thanks.

JP.

---

From: Philip Levis <[email-masked]>
Date: Tue, 22 Feb 2011 09:05:09 -0800

> Please send your comments to the authors and copy the mailing list.

5 comments (some just grammatical, some significant)

1. "the Objective Function selects the DODAG" -> "An Objective Function selects the DODAG"

2. "OF0 uses a MinHopRankIncrease of 0x100 so that Rank value can be stored in one octet.  This allows up to at least 16 hops when each hop has the worst Rank Increment of 16."

- This worries me. It means that networks with incompatible OFs, or which have to go to the last resort OF, have a maximum hopcount of 16. I'd recommend that instead the worst Rank increment be made smaller, in order to support more hops. E.g., 4/64. When we built CTP we made sure it could support more than 16 hops because there were established deployments which were > 32 hops (e.g., the network measuring the Golden Gate Bridge). Is there any basis for this particular breakdown? Are we really going to go back to RIP? Putting the reasoning in the document isn't a good idea, but I'd like to know what it is so I can feel comfortable with it.

3. "It MAY stretch its step of Rank " -> "A node MAY stretch its step of Rank"

4. "   o  The preferred parent MUST be ignored.

   o  A Router that is not in the same DODAG as the preferred parent,
      either in the current or a subsequent iteration, MUST be ignored."

- I'd suggest writing these as "The backup next_hop MUST NOT be the preferred parent" and "The backup next_hop MUST be in the same DODAG iteration as the preferred parent." It's not 100% clear what "ignores" means in this context.

5. "   Trigger    The OF0 support may trigger the RPL core to inform it that
              a change occurred.  This indicates whether the change
              requires a new DIO to be fired, trickle timers to be
              reset, etc..."

- You probably don't want an ellipsis here.

Phil

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 22 Feb 2011 19:06:28 +0100

Hi Phil:

I'm clearly fine with the grammatical ones, thanks for this.

For 2) I am also fine with your proposal, if no one present opposition,
I'll do the change.

For 5) I am not sure I understand you. Could you please rephrase?

Thanks a bunch,

Pascal
http://www.xtranormal.com/watch/7011357/

> -----Original Message-----
> From: Philip Levis [mailto:[email-masked]]
> Sent: Tuesday, February 22, 2011 6:05 PM
> To: JP Vasseur; Pascal Thubert (pthubert)
> Cc: ROLL WG
> Subject: Re: [Roll] Working Last Call on draft-ietf-roll-of0-05
> 
> 
> > This document has been stable for quite some time and the latest
revision
> has addressed all comments received so far. This starts a 2-week
Working
> Group Last call on draft-ietf-roll-of0-05, that will end on March 8 at
noon ET.
> 1. "the Objective Function selects the DODAG" -> "An Objective
Function
> selects the DODAG"
> 
> 2. "OF0 uses a MinHopRankIncrease of 0x100 so that Rank value can be
> stored in one octet.  This allows up to at least 16 hops when each hop
has the
> worst Rank Increment of 16."
> 
> - This worries me. It means that networks with incompatible OFs, or
which
> have to go to the last resort OF, have a maximum hopcount of 16. I'd
> recommend that instead the worst Rank increment be made smaller, in
> order to support more hops. E.g., 4/64. When we built CTP we made sure
it
> could support more than 16 hops because there were established
> deployments which were > 32 hops (e.g., the network measuring the
Golden
> Gate Bridge). Is there any basis for this particular breakdown? Are we
really
> going to go back to RIP? Putting the reasoning in the document isn't a
good
> idea, but I'd like to know what it is so I can feel comfortable with
it.
> - I'd suggest writing these as "The backup next_hop MUST NOT be the
> preferred parent" and "The backup next_hop MUST be in the same DODAG
> iteration as the preferred parent." It's not 100% clear what "ignores"
means
> in this context.

---

From: Philip Levis <[email-masked]>
Date: Tue, 22 Feb 2011 10:31:23 -0800

>> - You probably don't want an ellipsis here.

The ... is an ellipsis. An ellipsis is "the omission from speech or writing of a word or words that are superfluous or able to be understood from contextual clues." (OED) It's not really suitable to have in a technical document. You should state exactly what should happen, not leave it ambiguous to contextual clues.

Phil