Subject: Re: [Roll] [Spam] DAO No-Path in a storing mode

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 17 Mar 2011 17:13:50 +0100

Hi Cedric:

When a parent has 2 children for a same target, and it gets a no-path DAO for that target from one of those children, then it should clear its adjacency for that child but keep the RIB entry for that target via the other child. As a result, it still has a route so it must not send a no-path to its own parent. OTOH, if the node loses its last child for a given destination, then it should send a no-path DAO to clean up. A no-path DAO is still a DAO though the information is 'negative'. The spec leaves some space for an node to be reactive to datapath validation for that though.

Pascal

http://www.xtranormal.com/watch/7011357/ <http://www.xtranormal.com/watch/7011357/> 

From: [email-masked] [mailto:[email-masked]] On Behalf Of C Chauvenet
Sent: Tuesday, March 08, 2011 5:08 PM
To: M Pouillot; [email-masked]'
Subject: Re: [Roll] [Spam] DAO No-Path in a storing mode

Hi all, 

As mentionned in the mail below, the no-path DAO message usage in not very clear in the RPL specification.

Though it is important to clarify this because it is an important feature for reliable and reactive downward routing.

Section 9.1.4 clearly states that DAO massages MUST be sent on a link local address, thus limiting the no-path DAO destination set to one hop neighboring. But given that this message should advertise that a downward path is no longer usable, how do you propagate this information in the upward direction to erase that path ?

For instance how do you prevent the DAGroot (located several hop away) to use a broken downward path if you can send the no-path DAO to you link local scope only ?

Some papers says that the no-path DAO must be sent to the root, but this seems contradictory with the 9.1.4 section I pointed out (DAO are link local only in storing mode).

I would appreciate that people shed some light on this ..

Thanks 

Cédric.

De : [email-masked] [mailto:[email-masked]] De la part de Mathieu Pouillot
Envoyé : lundi 10 janvier 2011 09:09
À : [email-masked]
Objet : [Spam] [Roll] DAO No-Path in a storing mode

Hello ,

In the specification, for storing mode, it is specified that a device should send a DAO no-path to a node which is removed from the DAO parent set (9.8.4). For me a node is removed from the DAO parent set if it is unreachable on link-local and so I can't send a DAO no-path to this node. A solution to inform the old DAO parent should be to send the No-path on the global address but it is not allowed by the specification  (9.1.4-in storing mode DAO message MUST be link-local-). So only the lifetime will remove the route from the old DAO parent, that can take few minutes depends of the DAO lifetime setting.
What do you think about that?

best regards,

Mathieu

-- 

Mathieu POUILLOT 
R&D Engineer 

[email-masked] <mailto:[email-masked]>  

Direct line : +33(0)4 98 01 60 05 

Tel : +33(0)4 98 01 60 05
Fax : +33(0)4 94 14 10 80

1766 Chemin de la Planquette
83130 LA GARDE - France 
www.watteco.com <http://www.watteco.com> 

 Before printing think about environment and costs 

This Message may contain confidential information intended only for the use of the addressee named above. If you are not the intended recipient of this message you are hereby notified that any use, dissemination, distribution or reproduction of this message is prohibited. If you received this message by mistake, please notify the sender by reply email immediately. Please conduct your own virus checks before opening any attachment as Watteco does not guarantee the integrity of this email or attached files has been maintained nor this communication is free of viruses, interceptions or interference. Any views expressed in this message are those of the individual sender and may not necessarily reflect the views of Watteco. Watteco shall not be responsible nor liable for the improper and incomplete transmission of the information contained in this communication nor for any delay in its receipt or damage to your system.

---

From: M Pouillot <[email-masked]>
Date: Fri, 18 Mar 2011 03:15:59 -0700

Hi Pascal,

Thank you for your answer. Our problem is more on the 9.8.4, where it is specified that a node should send a No-path DAO to its parent when this is removed from the DAO parent set. In the case where the parent is removed from the DAO parent set  because the link is broken, then the node can't send anymore frame to it...

regards,

Mathieu

De : Pascal Thubert (pthubert) [mailto:[email-masked]]
Envoyé : jeudi 17 mars 2011 17:14
À : C Chauvenet; M Pouillot; [email-masked]
Objet : RE: [Roll] [Spam] DAO No-Path in a storing mode

Hi Cedric:

Pascal
http://www.xtranormal.com/watch/7011357/

Hi all,

Thanks

Cédric.

Hello ,

best regards,

Mathieu
--

Mathieu POUILLOT
R&D Engineer

[email-masked]<mailto:[email-masked]>

1766 Chemin de la Planquette
83130 LA GARDE - France
www.watteco.com<http://www.watteco.com>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Mar 2011 11:51:21 +0100

Bonjour Mathieu:

There are multiple causes for removing a parent.

In the case of a broken link, depending on the medium, there's a chance that the other end hears but you don't know. So it may make sense to give it a try but maybe not insist.

Nevertheless, the SHOULD is not a MUST for a number of reasons; people in particular insisted that in a number of constrained cases, a path that's not being used should not cost in control, even to  break it down; so being reactive to traffic might be what you really want.

- if the path is still used and the child can no more reach the target or does not want to serve that ex-parent anymore, then the child can use the datapath reactive action based on the HbH header.

- if the child can still reach the destination and agrees to serve that ex-parent for that packet, it can forward the packet still schedule a nopath DAO to clean up the parent states.

Cheers,

Pascal

From: M Pouillot [mailto:[email-masked]] 
Sent: Friday, March 18, 2011 11:16 AM
To: Pascal Thubert (pthubert); C Chauvenet; [email-masked]
Subject: RE: [Roll] [Spam] DAO No-Path in a storing mode

Hi Pascal, 

regards,

Mathieu

Hi Cedric:

Pascal

Hi all, 

Thanks 

Cédric.

Hello ,

best regards,

Mathieu

-- 

Mathieu POUILLOT 
R&D Engineer