Subject: [Roll] I flag inconsistency in rpl-metrics-19 ?

From: C Chauvenet <[email-masked]>
Date: Wed, 16 Mar 2011 02:39:19 -0700

Hi all,

Reading the routing-metrics-19 draft I noticed something odd about the I flag in the NE and the LC sub-Object :

In the NE sub Object (Section 3.2) : " I (Included): the I bit is only relevant when the node type is
used as a constraint. [...]. When set, this indicates that nodes of the type
specified in the node type field MUST be included. Conversely,
when cleared, this indicates that nodes of type specified in the
node type field MUST be excluded."

In the LC object (section 4.4.1)  : " I Bit: The I bit is only relevant when the Link Color is used as a
constraint. When cleared, this indicates that links with the
specified color must be included. When set, this indicates that
links with the specified color must be excluded."

I guess there an inversion in the latter definition.

Furthermore at the end of the section 3.2 : " If the NE object comprises several sub-objects when used as a
constraint, each sub-object adds or subtracts node subsets as the
sub-objects are parsed in order. The initial set (full or empty) is
defined by the I bit of the first sub-object: full if that I bit is
an exclusion, empty if that I bit is an inclusion."

Behavior of the I flag in this case seems conflitcting with the wording, or I missed something ?

Maybe editors of the document could clarify this.

Cédric.

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 17:21:05 +0100

Hello Cedric,
 
Good catch !
A quick response : just looking at your mail and the quoted text, my take is that 4.4.1 is wrong, as you suspected.
We'll probably have to do an erratum after RFC publication, because I don't think this mistake justifies for a complete document respin including WG last call, etc.
 
However, regarding section 3.2, I think it is correct. The idea is that, if the first sub-object is an EXCLUDE (resp. INCLUDE), it should exclude from (resp. add to) an initially FULL (resp. EMPTY) set. It does not make sense to exclude a subset of a empty set, or to add a subset to a full set, does it?
 
I'll give it a more thorough look shortly.
Thanks a lot
 
Dominique

________________________________

De : [email-masked] [mailto:[email-masked]] De la part de C Chauvenet
Envoyé : mercredi 16 mars 2011 10:39
À : [email-masked]'
Objet : [Roll] I flag inconsistency in rpl-metrics-19 ?

Hi all, 

Cédric.

---

From: C Chauvenet <[email-masked]>
Date: Wed, 16 Mar 2011 09:41:28 -0700

Hi Dominique,

Agree on the erratum.

Your explication on the meaning of the I flag in section 3.2 is very clear. I didn't understood it correctly, so the text is correct in the draft.
Thank's for you reply.

Cédric.

De : [email-masked] [mailto:[email-masked]]
Envoyé : mercredi 16 mars 2011 17:21
À : C Chauvenet; [email-masked]
Objet : RE: [Roll] I flag inconsistency in rpl-metrics-19 ?

Hello Cedric,

Good catch !

Dominique

Cédric.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 17 Mar 2011 08:08:22 +0100

Hi Dominique:

Don't worry about RFC erratum, we still have to go to RFC editor, and the chairs can still provide an editor note with the fix...

Pascal

http://www.xtranormal.com/watch/7011357/

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, March 16, 2011 5:21 PM
To: [email-masked]; [email-masked]
Subject: Re: [Roll] I flag inconsistency in rpl-metrics-19 ?

Hello Cedric,

Good catch !

Thanks a lot

Dominique

Hi all, 

Cédric.