Subject: [Roll] a status for draft-ietf-roll-of0

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Mar 2011 11:15:22 +0100

Hi Adrian and all:

Here's a quick summary on the latest activity on OF0 draft. OF0-05 passed last call but has pending issues.

06 addresses:
- issues with the range of the step of Rank and the number of hops in the worst case scenario.
- issues with the recommendation WRT wireless links

Thanks to Om and Phil's quick TAT this weekend, I could publish an 07 back to back with the 06. 07 additionally addresses:

- lack of clarity that the backup next_hop is not necessary a parent
- lack of clarity on what paying attention to Rank stability could mean.

Now we need to review the changes in 06 and 07 and see if they address the open issues properly. In particular:

- To compensate the smaller range for the step of rank, a new factor was added. The factor has a default of 1. Maybe we should recommend a different default for wired-powered (say 1) wireless or battery (say 2 or 3) and wireless and battery (say 4 or 5). Since this is a parameter, it is always possible for a deployment to override the defaults to get more hops, still up to 256 best case and 28 worst case, but that proposal would yield by default only 5 to 7 hops that combine wireless and battery and worst case link  properties.

Also:
- OF0 still mentions siblings that are not discussed anymore in the main spec. The question is what to do with them in this spec. We could on paper:
1)  remove the notion of sibling and the rank stretch that goes with it altogether. That might be touchy since the text made last call, and I can't discuss that aspect.
2)  keep the text. But then we probably need to provide a minimum guidance for loop avoidance (e.g. unless further guidance, do not forward to a sibling a packet from a leaf or a sibling).

I think I did all the editorial work I could and I need guidance to move forward.

What do you think?

Pascal
http://www.xtranormal.com/watch/7011357/

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Monday, March 14, 2011 10:37 AM
To: Pascal Thubert (pthubert)
Subject: New Version Notification for draft-ietf-roll-of0-07 

A new version of I-D, draft-ietf-roll-of0-07.txt has been successfully submitted by Pascal Thubert and posted to the IETF repository.

Filename:	 draft-ietf-roll-of0
Revision:	 07
Title:		 RPL Objective Function 0
Creation_date:	 2011-03-14
WG ID:		 roll
Number_of_pages: 10

Abstract:
The Routing Protocol for Low Power and Lossy Networks (RPL) defines a generic Distance Vector protocol for Low Power and Lossy Networks (LLNs).  RPL is instantiated to honor a particular routing objective/ constraint by the adding a specific Objective Function (OF) that is designed to solve that problem.  This specification defines a basic OF, OF0, that uses only the abstract properties exposed in RPL messages with no metric container.

The IETF Secretariat.

---

From: JP Vasseur <[email-masked]>
Date: Mon, 14 Mar 2011 16:47:25 +0100

Hi Pascal,

Thanks for this summary.

See in line,

> I think I did all the editorial work I could and I need guidance to move forward.
I would vote for 1) since there was an agreement do remove the notion of siblings from the core specification.

Thanks.

JP.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: JP Vasseur <[email-masked]>
Date: Mon, 14 Mar 2011 16:50:28 +0100

Dear Working Group,

Since some of changes took place at the very last minute, I would like to start another WG Last Call on the
revision 07 of draft-ietf-roll-of0 that end on March 21 at noon ET. Please send your comments to the Author
and copy the mailing list.

Thanks.

JP.

Begin forwarded message:

> From: "Pascal Thubert (pthubert)" <[email-masked]>
> Date: March 14, 2011 11:15:22 AM GMT+01:00
> To: "Adrian Farrel" <[email-masked]>, <[email-masked]>
> Cc: "ROLL WG" <[email-masked]>
> Subject: [Roll] a status for draft-ietf-roll-of0
> 
> Hi Adrian and all:
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Mar 2011 17:03:03 +0100

Hi JP

My memory is that there was no agreement, so the shepherd made the
decision. That decision applies to the main RPL spec.

OF0 is a different beast so it is fair IMHO to ask the question again. 

Pascal

From: JP Vasseur [mailto:[email-masked]] 
Sent: Monday, March 14, 2011 4:47 PM
To: Pascal Thubert (pthubert)
Cc: Adrian Farrel; [email-masked]; ROLL WG
Subject: Re: [Roll] a status for draft-ietf-roll-of0

Hi Pascal,

Thanks for this summary.

See in line,

Hi Adrian and all:

Here's a quick summary on the latest activity on OF0 draft. OF0-05
passed last call but has pending issues.

06 addresses:
- issues with the range of the step of Rank and the number of hops in
the worst case scenario.
- issues with the recommendation WRT wireless links

Thanks to Om and Phil's quick TAT this weekend, I could publish an 07
back to back with the 06. 07 additionally addresses:

Now we need to review the changes in 06 and 07 and see if they address
the open issues properly. In particular:

- To compensate the smaller range for the step of rank, a new factor was
added. The factor has a default of 1. Maybe we should recommend a
different default for wired-powered (say 1) wireless or battery (say 2
or 3) and wireless and battery (say 4 or 5). Since this is a parameter,
it is always possible for a deployment to override the defaults to get
more hops, still up to 256 best case and 28 worst case, but that
proposal would yield by default only 5 to 7 hops that combine wireless
and battery and worst case link  properties.

Also:
- OF0 still mentions siblings that are not discussed anymore in the main
spec. The question is what to do with them in this spec. We could on
paper:
1)  remove the notion of sibling and the rank stretch that goes with it
altogether. That might be touchy since the text made last call, and I
can't discuss that aspect.
2)  keep the text. But then we probably need to provide a minimum
guidance for loop avoidance (e.g. unless further guidance, do not
forward to a sibling a packet from a leaf or a sibling).

I think I did all the editorial work I could and I need guidance to move
forward.

What do you think?

I would vote for 1) since there was an agreement do remove the notion of
siblings from the core specification.

Thanks.

JP.

	Pascal

	-----Original Message-----
	From: IETF I-D Submission Tool [mailto:[email-masked]]
	Sent: Monday, March 14, 2011 10:37 AM
	To: Pascal Thubert (pthubert)
	Subject: New Version Notification for draft-ietf-roll-of0-07

	A new version of I-D, draft-ietf-roll-of0-07.txt has been
successfully submitted by Pascal Thubert and posted to the IETF
repository.

	Abstract:
	The Routing Protocol for Low Power and Lossy Networks (RPL)
defines a generic Distance Vector protocol for Low Power and Lossy
Networks (LLNs).  RPL is instantiated to honor a particular routing
objective/ constraint by the adding a specific Objective Function (OF)
that is designed to solve that problem.  This specification defines a
basic OF, OF0, that uses only the abstract properties exposed in RPL
messages with no metric container.

	
	The IETF Secretariat.