Subject: Re: [Roll] [Spam] DAO No-Path in a storing mode

From: C Chauvenet <[email-masked]>
Date: Tue, 8 Mar 2011 08:07:53 -0800

Hi all,

As mentionned in the mail below, the no-path DAO message usage in not very clear in the RPL specification.
Though it is important to clarify this because it is an important feature for reliable and reactive downward routing.

Section 9.1.4 clearly states that DAO massages MUST be sent on a link local address, thus limiting the no-path DAO destination set to one hop neighboring. But given that this message should advertise that a downward path is no longer usable, how do you propagate this information in the upward direction to erase that path ?

For instance how do you prevent the DAGroot (located several hop away) to use a broken downward path if you can send the no-path DAO to you link local scope only ?

Some papers says that the no-path DAO must be sent to the root, but this seems contradictory with the 9.1.4 section I pointed out (DAO are link local only in storing mode).

I would appreciate that people shed some light on this ..

Thanks

Cédric.

De : [email-masked] [mailto:[email-masked]] De la part de Mathieu Pouillot
Envoyé : lundi 10 janvier 2011 09:09
À : [email-masked]
Objet : [Spam] [Roll] DAO No-Path in a storing mode

Hello ,

In the specification, for storing mode, it is specified that a device should send a DAO no-path to a node which is removed from the DAO parent set (9.8.4). For me a node is removed from the DAO parent set if it is unreachable on link-local and so I can't send a DAO no-path to this node. A solution to inform the old DAO parent should be to send the No-path on the global address but it is not allowed by the specification  (9.1.4-in storing mode DAO message MUST be link-local-). So only the lifetime will remove the route from the old DAO parent, that can take few minutes depends of the DAO lifetime setting.
What do you think about that?

best regards,

Mathieu
--

Mathieu POUILLOT
R&D Engineer

[email-masked]<mailto:[email-masked]>

Direct line : +33(0)4 98 01 60 05

Tel : +33(0)4 98 01 60 05
Fax : +33(0)4 94 14 10 80

1766 Chemin de la Planquette
83130 LA GARDE - France
www.watteco.com<http://www.watteco.com>

Before printing think about environment and costs
This Message may contain confidential information intended only for the use of the addressee named above. If you are not the intended recipient of this message you are hereby notified that any use, dissemination, distribution or reproduction of this message is prohibited. If you received this message by mistake, please notify the sender by reply email immediately. Please conduct your own virus checks before opening any attachment as Watteco does not guarantee the integrity of this email or attached files has been maintained nor this communication is free of viruses, interceptions or interference. Any views expressed in this message are those of the individual sender and may not necessarily reflect the views of Watteco. Watteco shall not be responsible nor liable for the improper and incomplete transmission of the information contained in this communication nor for any delay in its receipt or damage to your system.

---

From: C Chauvenet <[email-masked]>
Date: Fri, 11 Mar 2011 08:08:09 -0800

Any Guidelines on this ?

Cédric.

De : [email-masked] [mailto:[email-masked]] De la part de C Chauvenet
Envoyé : mardi 8 mars 2011 17:08
À : M Pouillot; [email-masked]'
Objet : Re: [Roll] [Spam] DAO No-Path in a storing mode

Hi all,

Thanks

Cédric.

Hello ,

best regards,

Mathieu
--

Mathieu POUILLOT
R&D Engineer