Subject: Re: [Roll] FW: Status of ROLL RPL related drafts in 6man (please note point on trickle multicast draft)

From: David Culler <[email-masked]>
Date: Thu, 7 Apr 2011 09:23:08 -0700

I am in support of considering this draft and would like to hear WG comments.  

One note - the trickle work is partly rooted in the work on scalable reliable multicast (SRM), with the additional influence of wireless communication.  It would be good to see the informational references touch on some of the related use of suppression techniques in the specific context of multicast.

On Apr 7, 2011, at 6:34 AM, Don Sturek wrote:

> Hi JP,
> 
> Could we consider adding the draft below:   Trickle Multicast   to the ROLL
> group as a working group document?
> 
> As you can see from below, the 6MAN group does not believe the scope of the
> draft is appropriate for 6MAN and suggest ROLL as a better home.
> 
> We are using the Trickle Multicast draft in our ZigBee IP work.
> 
> Thanks,
> 
> Don Sturek
> 
> 
> -----Original Message-----
> From: Don Sturek [mailto:[email-masked]] 
> Sent: Friday, March 11, 2011 8:26 AM
> To: [email-masked]'
> Subject: FW: Status of ROLL RPL related drafts in 6man (please note point on
> trickle multicast draft)
> 
> In checking on the status of 6MAN drafts related to ROLL RPL, I asked about
> the trickle multicast draft currently in 6MAN.  Here is a link to the draft:
> http://datatracker.ietf.org/doc/draft-hui-6man-trickle-mcast/ 
> 
> Have a look below at the response from Brian Haberman.  What does the group
> think about adopting this draft into ROLL RPL?
> 
> Don 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Brian Haberman
> Sent: Friday, March 11, 2011 8:18 AM
> To: [email-masked]
> Subject: Re: Status of ROLL RPL related drafts in 6man
> 
> On 3/11/11 11:03 AM, Don Sturek wrote:
>> Can I ask about the current WG status of the following drafts:
>> 
>> http://datatracker.ietf.org/doc/draft-ietf-6man-rpl-routing-header/
>> 
>> http://datatracker.ietf.org/doc/draft-ietf-6man-rpl-option/
>> 
> 
> The WG Last Call completed for these documents.  There were some
> comments that, according to the authors, have been resolved but not
> incorporated into the document(s).
> 
>> 
>> 
>> Also, the following draft has not been adopted by WG (can it?):
>> 
>> http://datatracker.ietf.org/doc/draft-hui-6man-trickle-mcast/
>> 
> 
> No one has made a request for the WG to adopt it.
> 
>> 
>> We would also like to see the trickle multicast draft adopted by the
> group.
>> 
> 
> From my brief read of the draft, I am not sure it belongs in 6MAN.  It
> describes a multicast forwarding paradigm specific to low-power
> networks. It would seem like ROLL is a better fit for this draft.
> 
> Regards,
> Brian
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

David Culler
[email-masked]
Chair Computer Science
Associate Chair EECS

---

From: Daniel Gavelle <[email-masked]>
Date: Thu, 7 Apr 2011 18:42:14 +0200

I support the adoption of this draft in the working group.  I implemented the draft. I am interested in optimising the suppression to minimise traffic whilst maintaining a good level of reliability.

Daniel.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Culler
Sent: 07 April 2011 17:23
To: [email-masked]; Philip Levis
Cc: [email-masked]
Subject: Re: [Roll] FW: Status of ROLL RPL related drafts in 6man (please note point on trickle multicast draft)

David Culler
[email-masked]
Chair Computer Science
Associate Chair EECS