Subject: Re: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a ROLL WG document

From: Mukul Goyal <[email-masked]>
Date: Fri, 1 Apr 2011 20:34:33 -0500 (CDT)

Hi all

I favor adapting this draft as a WG document. The mechanism specified in this document is necessary to decide whether to invoke P2P route discovery and to determine the constraints that the P2P route must satisfy.

Thanks
Mukul

----- Original Message -----
From: "JP Vasseur" <[email-masked]>
To: "ROLL WG" <[email-masked]>
Sent: Thursday, March 31, 2011 11:56:43 PM
Subject: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a ROLL WG	document

Dear all,

draft-goyal-roll-p2p-measurement has been discussed on the mailing list and is a normative
reference of the P2P document.

Could you tell us if you are in favor/opposed to adopt draft-goyal-roll-p2p-measurement-01 as 
a ROLL Working Group document ?

Thanks.

JP.
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 4 Apr 2011 16:17:40 +0200

+1

Pascal
http://www.xtranormal.com/watch/7011357/

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Mukul Goyal
> Sent: Saturday, April 02, 2011 3:35 AM
> To: JP Vasseur
> Cc: ROLL WG
> Subject: Re: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a
ROLL
> WG document
> 
> Hi all
> 
> I favor adapting this draft as a WG document. The mechanism specified
in
> this document is necessary to decide whether to invoke P2P route
discovery
> and to determine the constraints that the P2P route must satisfy.
> 
> Thanks
> Mukul
> 
> Subject: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a ROLL
WG
> 	document
> 
> Dear all,
> 
> draft-goyal-roll-p2p-measurement has been discussed on the mailing
list and
> is a normative reference of the P2P document.
> 
> Could you tell us if you are in favor/opposed to adopt
draft-goyal-roll-p2p-
> measurement-01 as a ROLL Working Group document ?
> 
> Thanks.
> 
> JP.

---

From: "Anders Brandt" <[email-masked]>
Date: Tue, 5 Apr 2011 16:07:42 +0200

+1

> > measurement-01 as a ROLL Working Group document ?

- Anders

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Pascal Thubert (pthubert)
> Sent: Monday, April 04, 2011 16:18
> To: Mukul Goyal; JP Vasseur
> Cc: ROLL WG
> Subject: Re: [Roll] Adoption 
> draft-goyal-roll-p2p-measurement-01 as a ROLLWG document
> 
> +1
> 
> Pascal
> > Subject: [Roll] Adoption 
> draft-goyal-roll-p2p-measurement-01 as a ROLL
> WG
> > 	document
> > 
> > Dear all,
> >

---

From: C Chauvenet <[email-masked]>
Date: Fri, 8 Apr 2011 05:43:09 -0700

+1

Cédric.

---

From: Jonathan Hui <[email-masked]>
Date: Fri, 8 Apr 2011 08:29:15 -0700

+1

--
Jonathan Hui

---

From: Nicolas DEJEAN <[email-masked]>
Date: Mon, 11 Apr 2011 12:08:32 +0200

Dear all,

RPL-P2P is a must for several markets (HBA fr instance).
This measurement method is necessary for finding "good enough" routes
and this draft deserves to be normative for RPL-P2P.

So, Yes, it should become a working group document.

Cheers,

Nicolas.

---

From: Philip Levis <[email-masked]>
Date: Mon, 11 Apr 2011 12:21:16 +0200

> a ROLL Working Group document ?

I support making draft-goyal-roll-p2p-measurement a ROLL WG document.

Phil

---

From: Zach Shelby <[email-masked]>
Date: Wed, 13 Apr 2011 11:37:59 +0300

JP,

Although I agree that route metric measurement is necessary for p2p, why in the world is this a separate document from the base p2p specification? Furthermore there seems to be plenty of inefficiency in creating a separate mechanism, and it should be explored how this could be integrated into the same message exchange for setting up the p2p DAG. 

Therefore I would be opposed to have a separate WG document for the measurement mechanism, instead I think this work should be better integrated into the base p2p specification. 

Authors, please kick me if I missed something here.

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: JP Vasseur <[email-masked]>
Date: Wed, 13 Apr 2011 10:41:06 +0200

Hi Zach,

> Therefore I would be opposed to have a separate WG document for the measurement mechanism, instead I think this work should be better integrated into the base p2p specification. 

This is clearly an option. I'll answer with my point of view, but I'd like the authors to first chime in.

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 13 Apr 2011 10:48:38 +0200

> Therefore I would be opposed to have a separate WG document for the measurement mechanism, instead I think this work should be better integrated into the base p2p specification. 

+1 from me, I have been asking myself this question too...

Thomas

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 13 Apr 2011 20:37:40 +0900

Hi,

I also do not see the point in having an additional specification, rather than integrating the mechanism in the p2p draft. Maybe the authors could explain why this is required.

Ulrich

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 13 Apr 2011 07:16:42 -0500 (CDT)

Zach

As I tried to convey to you in an earlier message, the measurement draft specifies a mechanism to measure the cost of an "existing" route between two nodes. Before I invoke the P2P mechanism to discover a "new" route between two nodes, I may want to measure the cost of any "existing" route (this could be a DAG-based route or an earlier established P2P route) between those nodes. I will invoke potentially expensive P2P route discovery only if I am not happy with the cost of the existing route. Also, the cost of the existing route will tell me what constraints must/should be satisfied by the route to be discovered.

My understanding is that you would like the cost measurement of any existing route to be integrated with the discovery of new P2P route. It will be great if you could also indicate how this should be done.

Thanks
Mukul

----- Original Message -----
From: "Zach Shelby" <[email-masked]>
To: "JP Vasseur" <[email-masked]>
Cc: "ROLL WG" <[email-masked]>
Sent: Wednesday, April 13, 2011 3:37:59 AM
Subject: Re: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a ROLL	WG document

JP,

Zach

---

From: Philip Levis <[email-masked]>
Date: Wed, 13 Apr 2011 14:23:20 +0200

> Therefore I would be opposed to have a separate WG document for the measurement mechanism, instead I think this work should be better integrated into the base p2p specification. 

Zach,

I agree that currently the two seem tightly entwined, in that p2p needs the measurement mechanism. But it might be that measurement is useful independently of p2p, and so keeping their specifications separate will prevent false coupling. It might be that once we are further along it makes sense to merge them, but in my opinion keeping them separate for now will lead to simpler and cleaner designs.

Phil

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 13 Apr 2011 07:37:49 -0500 (CDT)

Phil

>I agree that currently the two seem tightly entwined, in that p2p needs the measurement mechanism. But it might be that measurement is useful independently of p2p, and so keeping their specification…

The measurement mechanism was originally in the P2P draft itself. It was suggested to us that this mechanism should be its own draft precisely for the reasons you have described above. However, it could be that Zach is not referring to simply putting the two mechanisms together in the same draft.

Thanks
Mukul

----- Original Message -----
From: "Philip Levis" <[email-masked]>
To: "Zach Shelby" <[email-masked]>
Cc: "ROLL WG" <[email-masked]>
Sent: Wednesday, April 13, 2011 7:23:20 AM
Subject: Re: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a ROLL	WG document

Zach,

Phil

---

From: "Anders Brandt" <[email-masked]>
Date: Wed, 13 Apr 2011 16:04:01 +0200

And then there is the option in most cost optimized environments that
one is happy with the P2P discovered routes as long as they are not
causing many retransmissions and the round-trip delay is acceptable.
The measurement mechanism is a useful optimization tool, but not
necessary for making P2P implementations work on a basic level.
Thus, they should be in separate docs.

Cheers,
  Anders
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mukul Goyal
Sent: 13. april 2011 14:38
To: Philip Levis
Cc: ROLL WG
Subject: Re: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as
aROLL WG document

Phil

>I agree that currently the two seem tightly entwined, in that p2p needs
the measurement mechanism. But it might be that measurement is useful
independently of p2p, and so keeping their specifications separate will
prevent false coupling. It might be that once we are further along it
makes sense to merge them, but in my opinion keeping them separate for
now will lead to simpler and cleaner designs.

The measurement mechanism was originally in the P2P draft itself. It was
suggested to us that this mechanism should be its own draft precisely
for the reasons you have described above. However, it could be that Zach
is not referring to simply putting the two mechanisms together in the
same draft.

Thanks
Mukul

----- Original Message -----
From: "Philip Levis" <[email-masked]>
To: "Zach Shelby" <[email-masked]>
Cc: "ROLL WG" <[email-masked]>
Sent: Wednesday, April 13, 2011 7:23:20 AM
Subject: Re: [Roll] Adoption draft-goyal-roll-p2p-measurement-01 as a
ROLL	WG document

On Apr 13, 2011, at 10:37 AM, Zach Shelby wrote:

> JP,
> 
> Although I agree that route metric measurement is necessary for p2p,
why in the world is this a separate document from the base p2p
specification? Furthermore there seems to be plenty of inefficiency in
creating a separate mechanism, and it should be explored how this could
be integrated into the same message exchange for setting up the p2p DAG.

> 
> Therefore I would be opposed to have a separate WG document for the
measurement mechanism, instead I think this work should be better
integrated into the base p2p specification. 

Zach,

I agree that currently the two seem tightly entwined, in that p2p needs
the measurement mechanism. But it might be that measurement is useful
independently of p2p, and so keeping their specifications separate will
prevent false coupling. It might be that once we are further along it
makes sense to merge them, but in my opinion keeping them separate for
now will lead to simpler and cleaner designs.

Phil

---

From: Zach Shelby <[email-masked]>
Date: Thu, 14 Apr 2011 16:47:43 +0300

Thanks Mukul and Phil for the explanation. I definitely missed that the main purpose of this mechanism is to measure the current route before invoking a P2P DAG. Anders also had a good point that P2P works just fine without the measurement mechanism.

So JP, I can support this as a WG document. But I do encourage the WG to explore better integration in cases when the mechanisms are used together. 

Zach