Subject: [Roll] A question on Trickle multicast: I-D Action:draft-ietf-roll-trickle-mcast-00.txt

From: KELLIL Mounir <[email-masked]>
Date: Thu, 19 May 2011 11:36:49 +0200

Hi Jonathan and Richard, 

I have a question regarding the trickle multicast draft. It concerns section  6.4 "Trickle ICMP Processing". Could you please explain which transmitter/receiver you are referring to? If the transmitter is the one who transmits the ICMP message, it is not clear how it can claim to have "a new multicast message to offer if the (SeedID, Sequence) pair falls within an existing sliding window for SeedID but does not have an associated entry" (BTW, the transmitter's entry ?) ?

My understanding is that a transmitter (of an ICMP message) cannot advertise a sequence number of a new message for which it has not an entry. Or maybe it can do that upon receiving the said new message (and just before forwarding it to other nodes)?

Or, maybe the transmitter/receiver is the transmitter/receiver of multicast packets...In all cases, maybe if you could clarify the terms "transmitter" and "receiver", this should provide a better comprehension of section 6.4.

Best regards

Mounir

Mounir KELLIL
CEA LIST
Ingénieur Chercheur
web : http://www-list.cea.fr

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : lundi 11 avril 2011 18:15
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Roll] I-D Action:draft-ietf-roll-trickle-mcast-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Routing Over Low power and Lossy
> networks Working Group of the IETF.
> 
> 
> 	Title           : Multicast Forwarding Using Trickle
> 	Author(s)       : J. Hui, R. Kelsey
> 	Filename        : draft-ietf-roll-trickle-mcast-00.txt
> 	Pages           : 19
> 	Date            : 2011-04-11
> 
> Low power and Lossy Networks (LLNs) are typically composed of resource
> constrained nodes communicating over links that have dynamic
> characteristics.  Memory constraints coupled with temporal variations
> in link connectivity makes the use of topology maintenance to support
> IPv6 multicast challenging.  This document describes the use of Trickle
> to efficiently forward multicast messages without the need for topology
> maintenance.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-roll-trickle-mcast-
> 00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

---

From: axel cdv <[email-masked]>
Date: Thu, 19 May 2011 15:25:40 +0200

Hi Mounir,

Please correct me if you feel I'm wrong here, but I think I have an
explanation as to what Jonathan and Richard meant in this section. I think
that the transmitter is indeed the one who transmits the ICMP message, but
it is only the receiver (i.e. the one who receives the message) who can
determine if the transmitter has a new multicast to offer. The (SeedID,
Sequence) pair refers to one listed in the ICMP message, while the "existing
sliding window" refers to one buffered by the receiver.

I think this solves your problem: a transmitter transmit an ICMP listing
every message it knows, and only the receiver can determine whether one of
the two nodes has any new message to offer to the other.

Best regards,

Axel Colin de Verdière

2011/5/19 KELLIL Mounir <[email-masked]>

> Hi Jonathan and Richard,
>
> I have a question regarding the trickle multicast draft. It concerns
> section  6.4 "Trickle ICMP Processing". Could you please explain which
> transmitter/receiver you are referring to? If the transmitter is the one who
> transmits the ICMP message, it is not clear how it can claim to have "a new
> multicast message to offer if the (SeedID, Sequence) pair falls within an
> existing sliding window for SeedID but does not have an associated entry"
> (BTW, the transmitter's entry ?) ?
>
> My understanding is that a transmitter (of an ICMP message) cannot
> advertise a sequence number of a new message for which it has not an entry.
> Or maybe it can do that upon receiving the said new message (and just before
> forwarding it to other nodes)?
>
> Or, maybe the transmitter/receiver is the transmitter/receiver of multicast
> packets...In all cases, maybe if you could clarify the terms "transmitter"
> and "receiver", this should provide a better comprehension of section 6.4.
>
> Best regards
>
> Mounir
>
>
> Mounir KELLIL
> CEA LIST
> Ingénieur Chercheur
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: KELLIL Mounir <[email-masked]>
Date: Thu, 19 May 2011 16:59:56 +0200

Hi Axel,

Thanks for your explanations. That makes sense. And, this was my understanding as well.  But, again I feel that section 6.4 text is a bit misleading. Well, for instance, the first paragraph can be slightly modified as follows:

The transmitter has new multicast messages to offer if any (SeedID,

   Sequence) pair falls within an existing *receiver's* sliding window for SeedID but

   does not have an associated entry *on the receiver's side*.

Just a suggestion...

Best regards

Mounir KELLIL

CEA LIST

Ingénieur Chercheur

web : http://www-list.cea.fr <http://www-list.cea.fr/> 

De : axel cdv [mailto:[email-masked]] 
Envoyé : jeudi 19 mai 2011 15:26
À : KELLIL Mounir
Cc : [email-masked]; [email-masked]; [email-masked]
Objet : Re: [Roll] A question on Trickle multicast: I-D Action:draft-ietf-roll-trickle-mcast-00.txt

Hi Mounir,

Please correct me if you feel I'm wrong here, but I think I have an explanation as to what Jonathan and Richard meant in this section. I think that the transmitter is indeed the one who transmits the ICMP message, but it is only the receiver (i.e. the one who receives the message) who can determine if the transmitter has a new multicast to offer. The (SeedID, Sequence) pair refers to one listed in the ICMP message, while the "existing sliding window" refers to one buffered by the receiver.

I think this solves your problem: a transmitter transmit an ICMP listing every message it knows, and only the receiver can determine whether one of the two nodes has any new message to offer to the other.

Best regards,

Axel Colin de Verdière

Hi Jonathan and Richard,

Best regards

Mounir

Mounir KELLIL
CEA LIST
Ingénieur Chercheur