Subject: [Roll] I-D Action: draft-ietf-roll-applicability-ami-00.txt

From: [email-masked]
Date: Mon, 25 Jul 2011 09:41:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : Applicability Statement for the Routing Protocol for Low Power and Lossy Networks (RPL) in AMI Networks
	Author(s)       : Daniel Popa
                          Jorjeta Jetcheva
                          Nicolas Dejean
                          Ruben Salazar
                          Jonathan W. Hui
	Filename        : draft-ietf-roll-applicability-ami-00.txt
	Pages           : 13
	Date            : 2011-07-25

   This document discusses the applicability of RPL in Advanced Metering
   Infrastructure (AMI) networks.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-roll-applicability-ami-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-applicability-ami-00.txt

---

From: JP Vasseur <[email-masked]>
Date: Mon, 25 Jul 2011 13:09:12 -0400

Dear all,

As discussed during the last IETF meeting, we have several important WG items in our charter,
and in particular the "applicability statement". draft-ietf-roll-applicability-ami-00.txt is the first one,
please comment on the mailing list. Needless to say that the document is now under the control 
of the WG and additions/changes can be made through dicussion on the mailing list.

Thanks.

JP.

Begin forwarded message:

> From: <[email-masked]>
> Subject: [Roll] I-D Action: draft-ietf-roll-applicability-ami-00.txt
> Date: July 25, 2011 12:41:30 PM EDT
> To: <[email-masked]>
> Cc: <[email-masked]>
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 25 Jul 2011 14:45:34 -0400

Hi,

I must have missed the decision of the WG to adopt
draft-popa-roll-applicability-ami-00 as a WG document, at least I did not
see any discussion about it on the mailing list. Could you please point me
to that discussion in the archives?

Thanks
Ulrich

On Mon, Jul 25, 2011 at 1:09 PM, JP Vasseur <[email-masked]> wrote:

> and in particular the "applicability
> statement". draft-ietf-roll-applicability-ami-00.txt is the first one,
> *From: *<[email-masked]>
> *Subject: **[Roll] I-D Action: draft-ietf-roll-applicability-ami-00.txt*
> *Date: *July 25, 2011 12:41:30 PM EDT
> *To: *<[email-masked]>
> *Cc: *<[email-masked]>
>
>  A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Routing Over Low power and
> Lossy networks Working Group of the IETF.
>
>         Title           : Applicability Statement for the Routing Protocol
> for Low Power and Lossy Networks (RPL) in AMI Networks
>         Author(s)       : Daniel Popa
>                           Jorjeta Jetcheva
>                           Nicolas Dejean
>                           Ruben Salazar
>                           Jonathan W. Hui

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 25 Jul 2011 20:52:39 +0200

I have precisely the same concern.

It seems the Chairs are confident this WG accepts that item without asking.

Alex

Le 25/07/2011 20:45, Ulrich Herberg a écrit :
> draft-popa-roll-applicability-ami-00 as a WG document, at least I did
> not see any discussion about it on the mailing list. Could you please
> point me to that discussion in the archives?
>
> Thanks
> Ulrich
>
> On Mon, Jul 25, 2011 at 1:09 PM, JP Vasseur <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Dear all,
>
>>     *From: *<[email-masked] <mailto:[email-masked]>>
>>     *Subject: **[Roll] I-D Action:
>>     draft-ietf-roll-applicability-ami-00.txt*
>>     *To: *<[email-masked] <mailto:[email-masked]>>
>>     *Cc: *<[email-masked] <mailto:[email-masked]>>
>>
>>     directories. This draft is a work item of the Routing Over Low
>>     power and Lossy networks Working Group of the IETF.
>>
>>             Title           : Applicability Statement for the Routing
>>     Protocol for Low Power and Lossy Networks (RPL) in AMI Networks
>>             Author(s)       : Daniel Popa
>>                               Jorjeta Jetcheva
>>                               Nicolas Dejean
>>                               Ruben Salazar
>>                               Jonathan W. Hui
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: JP Vasseur <[email-masked]>
Date: Mon, 25 Jul 2011 15:09:49 -0400

Hi,

As you may know, there is nothing unusual in making an ID a WG document. Please see a good 
presentation from Adrian Farrel Routing AD IETF-78 on the WG adoption process. In this case, 
this fits one of our WG item. OF COURSE, this is the document of the WG and your comments
are very much welcome; more work is of course needed. You may want to refer to RFC4677
and other presentations on the process. I'm happy to provide you more information if needed.

Thanks.

JP.

On Jul 25, 2011, at 2:45 PM, Ulrich Herberg wrote:

> Hi,
> 
> I must have missed the decision of the WG to adopt draft-popa-roll-applicability-ami-00 as a WG document, at least I did not see any discussion about it on the mailing list. Could you please point me to that discussion in the archives?
> 
> Thanks
> Ulrich
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 26 Jul 2011 00:25:06 +0200

JP - I CC the group, I hope you dont mind.

I checked the slides you sent below, and in its slide 8 the process 
[supposedly a Chair  to follow] is:

- notify the wg
- tell Secretariat
- tell authors do 00

A number of other things in that set of slides make me think WG should 
somehow approve prior to do 00.

It is strange to see a draft-ietf without having been individual 
submission first.  I wish I were that lucky Author to get a wg item that 
easily - practically an rfc :-)

Maybe there  is a misunderstanding somewhere - has this draft been an 
individual proposal first, and I missed it?

Alex

Le 25/07/2011 21:22, JP Vasseur a écrit :
> Alex, please read:
> http://wiki.tools.ietf.org/group/edu/attachment/wiki/IETF78/IETF78-WGchairs-Adrian-Farrel.ppt?format=raw
>
> On Jul 25, 2011, at 2:52 PM, Alexandru Petrescu wrote:
>
>> <mailto:[email-masked]>
>> >> *From: *<[email-masked] <mailto:[email-masked]>
>> <mailto:[email-masked]>>
>> >> *To: *<[email-masked] <mailto:[email-masked]>
>> <mailto:[email-masked]>>
>> >> *Cc: *<[email-masked] <mailto:[email-masked]> <mailto:[email-masked]>>
>> >>
>> >> [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>
>> > [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 26 Jul 2011 00:48:08 +0200

> http://wiki.tools.ietf.org/group/edu/attachment/wiki/IETF78/IETF78-WGchairs-Adrian-Farrel.ppt?format=raw

Its slide 10 "Going straight to wg id" has a bullet saying important to 
keep this open.  I believe this was not open, because I have only seen 
this wg id 0 announcement.

Moreover I thought the applicability drafts (already 4) were done.

You have to be aware - please be aware - that this kind of work is 
sometimes over-advertised outside ietf, with negative effects.

Alex

---

From: JP Vasseur <[email-masked]>
Date: Mon, 25 Jul 2011 19:52:37 -0400

> this wg id 0 announcement.
Answer two of your questions: you missed it but there was an individual submission.
And yes this is *open*, as I said just the base work … 
> Moreover I thought the applicability drafts (already 4) were done.
Ah ? No … 
> sometimes over-advertised outside ietf, with negative effects.
Let me clarify a bit more. 
1) As you know, producing applicability statements is on our charter:
2) There was no alternative draft for this WG item,
3) To answer your question, yes you missed it, but there was an individual submission
and make it a WG document does not violate any process,
4) The IESG asked the chairs to deliver on that particular milestone

Note also that this was not a contentious protocol work with several documents being discussed
by the WG, simply the base for further work on an applicability statement addressing a WG item.

Now, this document is also yours (this is a WG document), feel free to provide comments. The more
comments we have the better to make this document as relevant as possible for our community.

Thanks.

JP.

---

From: Ulrich Herberg <[email-masked]>
Date: Tue, 26 Jul 2011 00:18:32 -0400

JP,

> 2) There was no alternative draft for this WG item,

Well, that may well be true, but the individual document was just submitted
a few weeks ago, and has only be announced on the ROLL mailing list today
(unless I have missed a discussion on that on the mailing list, in which
case I beg for pardon).

> and make it a WG document does not violate any process,

Yes, it is formally not incorrect, but leaving only 12 hours from announcing
an individual draft on the list to adopting it as WG document without
discussing it in the WG is pretty fast.

> comments we have the better to make this document as relevant as possible

As you mentioned the slides from Adrian, I just would like to point out that
the slide "criteria for adoption" mentions:
 - (citing RFC 4677) "Working Group drafts are usually reviewed by the
Working Group before being accepted as a WG item, although the chairs have
the final say."

So I would like to know what the reason was for not asking the WG (and that
only 12 hours after announcing the individual draft on the mailing list).

- "There is good support to work on the I-D" and "The level of technical (or
other) objections is low"

My 2cts on the draft: I do not think this draft has the necessary level of
quality for a WG document, and my personal opinion is that it should not
have been adopted in its current form. I could go into technical details
here now, but in this email, I just wanted to argue on the procedure.

Regards
Ulrich

> >> <mailto:[email-masked] <[email-masked]>>
> >> > <mailto:[email-masked] <[email-masked]>>> wrote:
> >> >
> >> > Dear all,
> >> >
> >> >> *From: *<[email-masked] <mailto:[email-masked]<[email-masked]>
> >
> >> <mailto:[email-masked] <[email-masked]>>>
> >> >> *To: *<[email-masked] <mailto:[email-masked]<[email-masked]>
> >
> >> <mailto:[email-masked] <[email-masked]>>>
> >> >> *Cc: *<[email-masked] <mailto:[email-masked] <[email-masked]>> <
> mailto:[email-masked] <[email-masked]>>>
> >> >>

---

From: JP Vasseur <[email-masked]>
Date: Tue, 26 Jul 2011 10:01:38 -0400

Hi,

Good, we have a discussion on the process, to which I hope that I answered.
Now time to discuss the document, which once again is in our charter and the IESG
asked us to deliver … Your comments are welcome.

Thanks.

JP.

On Jul 26, 2011, at 12:18 AM, Ulrich Herberg wrote:

> Well, that may well be true, but the individual document was just submitted a few weeks ago, and has only be announced on the ROLL mailing list today (unless I have missed a discussion on that on the mailing list, in which case I beg for pardon). 
> 
>  
> Yes, it is formally not incorrect, but leaving only 12 hours from announcing an individual draft on the list to adopting it as WG document without discussing it in the WG is pretty fast.
> 
>  
> As you mentioned the slides from Adrian, I just would like to point out that the slide "criteria for adoption" mentions:
>  - (citing RFC 4677) "Working Group drafts are usually reviewed by the Working Group before being accepted as a WG item, although the chairs have the final say." 
> 
> So I would like to know what the reason was for not asking the WG (and that only 12 hours after announcing the individual draft on the mailing list).
> 
> - "There is good support to work on the I-D" and "The level of technical (or other) objections is low"
> 
> My 2cts on the draft: I do not think this draft has the necessary level of quality for a WG document, and my personal opinion is that it should not have been adopted in its current form. I could go into technical details here now, but in this email, I just wanted to argue on the procedure.
>  
> 
> Regards
> Ulrich
> 
>  
> 
> Thanks.
> 
> JP.
>> Alex
>> 
>> >