Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

From: Nicolas DEJEAN <[email-masked]>
Date: Tue, 30 Aug 2011 10:25:51 +0200

Hello Bora,

2011/7/29 Akyol, Bora A <[email-masked]>:
> I think the statement about AMI networks being used as an almost general
> purpose backhaul network for all other devices
> is overreaching. I know there are some utilities that are looking into
> this, but a lot more that have shied away from
> this vision. Secondly, there are a lot more AMI deployments not using
> wireless mesh networks, e.g. using cellular modem,
> powerline carrier, etc.

I agree that all utilities are not looking into it.
However this is one possible case that should be considered, isn't it?
Could you please precise what you are expecting to be in the draft?

>
> Is it possible to tone this "marketing" text Section 1.1. down and also
> potentially
> remove Gas & Water meters from the scope of this document.
>

On our point of view, Gas and Water metering are part of AMI.
Could you please elaborate?
According to you, why should Gas and Water be removed from the draft?

Thank you in advance,

Nicolas.

> Regards
>
> --
> Bora Akyol, Pacific Northwest National Laboratory
> +1 509 371 6682, [email-masked], www.pnnl.gov
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Akyol, Bora A" <[email-masked]>
Date: Tue, 30 Aug 2011 10:36:49 -0700

Hi Nicolas

Thank you for your response.

Please see my comments within
-- 
Bora Akyol, Pacific Northwest National Laboratory
+1 509 371 6682, [email-masked], www.pnnl.gov

>Could you please precise what you are expecting to be in the draft?

I think the draft should be focusing on the applicability of ROLL from a
technical front
without siting this one case as the only justification.

>On our point of view, Gas and Water metering are part of AMI.

This is not the widely-held view at least within the US electric utility
community.
The gas and water meters have capabilities which are quite different from
electric power meters.
For example, while the electric meter has easy access to mains power, the
gas/water meters don't.
In most instances, the gas/water service may be provided by a completely
different entity than the electric
power utility.

At least within the US NIST SGIP CSWG, the gas/water meters and AMI
backhaul were considered out of scope.

Would the document lose technical integrity if the gas/water meter were
either removed or included as an optional.

Regards

---

From: "Jetcheva, Jorjeta" <[email-masked]>
Date: Tue, 30 Aug 2011 12:32:12 -0700

Hello Bora,

> backhaul were considered out of scope.

Actually AMI backhaul for gas and water meters is very much in scope as per the NIST Wireless Guidelines (PAP2) work and the related SG-Communications/SG-Net work.  CSWG coordinates with the PAPs so they should be aware of this.   

Jorjeta

Jorjeta Jetcheva, Ph.D.
Principal Engineer, Architecture & Standards
CTO Office
Itron, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Akyol, Bora A
Sent: Tuesday, August 30, 2011 10:37 AM
To: Nicolas DEJEAN
Cc: [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Nicolas

Regards

---

From: Nicolas DEJEAN <[email-masked]>
Date: Wed, 31 Aug 2011 13:23:31 +0200

Hello Bora,

Did Jorjeta answered your concerns about an AMI network considered as
a backhaul for Gas and Water?

Thank you in advance,

Nicolas.

---

From: "Akyol, Bora A" <[email-masked]>
Date: Wed, 31 Aug 2011 08:09:10 -0700

Hi Nicolas

Yes, we had a private email exchange off-list.

I would like to suggest alternate wording for this paragraph as follows:

ORIGINAL:

 Electric meters are often interconnected into multi-hop mesh
   networks, each of which is connected to a backhaul network leading to
   the utility network through a network aggregation point (NAP).  These
   kinds of networks increase coverage and reduce installation cost,
   time and complexity, as well as operational costs, as compared to
   single-hop wireless networks, relying on a wireline or cellular
   backhaul.  Each electric meter mesh typically has on the order of
   several thousand wireless endpoints, with densities varying based on
   the area and the terrain.  Apartment buildings in urban centers may
   have hundreds of meters in close proximity, whereas rural areas may
have sparse node distributions and include nodes that only have one   or
two network neighbors.  Paths in the mesh between a network device
   and the nearest aggregation point may be composed of several hops or
   even tens of hops.

ALTERNATE WORDING:

In one type of AMI network, electric meters are interconnected into
multi-hop mesh
networks, each of which is connected to a backhaul network leading to
the utility network through a network aggregation point (NAP).

<remove unsubstantiated assertion regarding cost benefits of multi-hop
mesh>

In a multi-hop mesh network, each electric meter mesh may have up to
several thousand wireless endpoints, with densities varying based on
the area and the terrain. Apartment buildings in urban centers may
have hundreds of meters in close proximity, whereas rural areas may
have sparse node distributions and include nodes that only have one or two
network neighbors. 
Paths in the mesh between a network device
and the nearest aggregation point may be composed of several hops or
even tens of hops.

What do you think?

Thanks

On 8/31/11 4:23 AM, "Nicolas DEJEAN" <[email-masked]>
wrote:

>> Actually AMI backhaul for gas and water meters is very much in scope as
>>per the NIST Wireless Guidelines (PAP2) work and the related
>>SG-Communications/SG-Net work.  CSWG coordinates with the PAPs so they
>>should be aware of this.
>>
>> Jorjeta
>>
>> Jorjeta Jetcheva, Ph.D.

---

From: "Jetcheva, Jorjeta" <[email-masked]>
Date: Wed, 31 Aug 2011 08:34:43 -0700

Hello Bora,

The paragraph you cited does not reference anything related to water or gas meters which was the topic of your earlier comment and the discussion that followed.  Is this perhaps not the right paragraph or is this the beginning of a new discussion?

As far as the benefits of multi-hop networks over wireline or cellular backhaul, I think that lower cost and deployment complexity are pretty commonly cited.  Do you disagree with this statement?

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 8:09 AM
To: Nicolas DEJEAN
Cc: Jetcheva, Jorjeta; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Nicolas

ORIGINAL:

ALTERNATE WORDING:

What do you think?

Thanks

---

From: "Akyol, Bora A" <[email-masked]>
Date: Wed, 31 Aug 2011 08:40:03 -0700

Hi Jorjeta

Sorry, I had two comments in my original email. One was regarding gas/power meters and the second regarding the non-technical slant in the introduction.
The modified paragraph that I proposed is related to the second point.

To answer your question, I disagree with the unbsubstantiated statement that multi-hop wireless mesh networks have substantial cost benefits
compared to either powerline or single-hop (e.g. cellular modems) networks. 
I am not saying this is completely wrong, I am saying that this statement does not belong in an IETF document since it has no relevance to ROLL
or the applicability of ROLL to AMI networks. I think the paragraph I proposed is clear-cut and technically accurate without having a bias towards the use of wireless mesh networks.

Regards

Bora

-----Original Message-----
From: Jetcheva, Jorjeta [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 8:35 AM
To: Akyol, Bora A
Cc: D?jean Nicolas; [email-masked]
Subject: RE: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hello Bora,

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.
Principal Engineer, Architecture & Standards CTO Office Itron, Inc.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]]
Sent: Wednesday, August 31, 2011 8:09 AM
To: Nicolas DEJEAN
Cc: Jetcheva, Jorjeta; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Nicolas

ORIGINAL:

ALTERNATE WORDING:

What do you think?

Thanks

---

From: "Jetcheva, Jorjeta" <[email-masked]>
Date: Wed, 31 Aug 2011 09:05:00 -0700

Hello Bora,

The text in this paragraph doesn't actually use the word "substantial", and I think you meant "wireline", not "powerline".  

What would you consider to be a "substantiated" statement of the applicability/benefits of mesh networks relative to other deployment paradigms?

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 8:40 AM
To: Jetcheva, Jorjeta
Cc: D?jean Nicolas; [email-masked]
Subject: RE: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Jorjeta

Regards

Bora

-----Original Message-----
From: Jetcheva, Jorjeta [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 8:35 AM
To: Akyol, Bora A
Cc: D?jean Nicolas; [email-masked]
Subject: RE: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hello Bora,

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]]
Sent: Wednesday, August 31, 2011 8:09 AM
To: Nicolas DEJEAN
Cc: Jetcheva, Jorjeta; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Nicolas

ORIGINAL:

ALTERNATE WORDING:

What do you think?

Thanks

---

From: "Akyol, Bora A" <[email-masked]>
Date: Wed, 31 Aug 2011 09:13:04 -0700

Hi again,

My point is that this statement adds no value to the document and in my
opinion subtracts value.
The alternate wording I suggested is technical and avoids "markitecture"
type statements.

I meant powerline (as in Aclara TWACS or the newer technologies) which is
essentially a single hop technology.

I believe the cost effectiveness of a particular technology highly depends
on the OPEX as well as the CAPEX,
and customer density. I don't think we should take that on in an IETF
document.

Regards

On 8/31/11 9:05 AM, "Jetcheva, Jorjeta" <[email-masked]> wrote:

>Hello Bora,
>
>The text in this paragraph doesn't actually use the word "substantial",
>and I think you meant "wireline", not "powerline".
>
>What would you consider to be a "substantiated" statement of the
>applicability/benefits of mesh networks relative to other deployment
>paradigms?
>
>Thanks, Jorjeta
>
>Jorjeta Jetcheva, Ph.D.
>Sorry, I had two comments in my original email. One was regarding
>gas/power meters and the second regarding the non-technical slant in the
>introduction.
>To answer your question, I disagree with the unbsubstantiated statement
>that multi-hop wireless mesh networks have substantial cost benefits
>I am not saying this is completely wrong, I am saying that this statement
>does not belong in an IETF document since it has no relevance to ROLL
>or the applicability of ROLL to AMI networks. I think the paragraph I
>proposed is clear-cut and technically accurate without having a bias
>towards the use of wireless mesh networks.
>
>Regards
>
>Bora
>
>The paragraph you cited does not reference anything related to water or
>gas meters which was the topic of your earlier comment and the discussion
>that followed.  Is this perhaps not the right paragraph or is this the
>beginning of a new discussion?
>
>As far as the benefits of multi-hop networks over wireline or cellular
>backhaul, I think that lower cost and deployment complexity are pretty
>commonly cited.  Do you disagree with this statement?
>
>Thanks, Jorjeta
>
>Jorjeta Jetcheva, Ph.D.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 31 Aug 2011 18:27:10 +0200

Hello Jorjeta and Bora:

About this:

<  These
   backhaul.  > assertion.

I'd think that the general benefit of meshing is the spatial reuse of the medium - same thing for any switched fabric at the end of the day -.
This benefits most to environments where the medium is a constrained or expensive resource.  This is much is very well-known and justifies the original text about cost savings.

>From there, the meshing/routing mechanism has to be designed in such a fashion that it is simple to deploy, with the classical self-* properties.
A radio meshing/routing system will indeed be simpler to deploy because as the intro says, it will be easier to guarantee an appropriate coverage, which you cannot do at all times with one hop of wire (because of movement) or cellular (because of dark zones).

So for all I know, the quoted text is not unsubstantiated and asilye justified for people of the art. I have no issue leaving the text as is and I find it relevant.

Cheers,

Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jetcheva, Jorjeta
Sent: mercredi 31 août 2011 18:05
To: Akyol, Bora A
Cc: Déjean Nicolas; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hello Bora,

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]]
Sent: Wednesday, August 31, 2011 8:40 AM
To: Jetcheva, Jorjeta
Cc: D?jean Nicolas; [email-masked]
Subject: RE: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Jorjeta

Regards

Bora

-----Original Message-----
From: Jetcheva, Jorjeta [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 8:35 AM
To: Akyol, Bora A
Cc: D?jean Nicolas; [email-masked]
Subject: RE: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hello Bora,

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]]
Sent: Wednesday, August 31, 2011 8:09 AM
To: Nicolas DEJEAN
Cc: Jetcheva, Jorjeta; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Nicolas

ORIGINAL:

ALTERNATE WORDING:

What do you think?

Thanks

---

From: "Akyol, Bora A" <[email-masked]>
Date: Wed, 31 Aug 2011 09:34:27 -0700

Hi Pascal

There is nothing in the text that substantiates lower operational costs
for the wireless mesh networks.
If the customer (meter) density is such that you have 1-2 customers/acre
(or less), then I don't think spatial reuse buys
you anything. Once you figure in the OPEX of having to run these networks
by the utilities versus having
cellular backhaul (for example), the cost savings need to be carefully
considered.

Why do you think this one sentence is substantial to the rest of the
draft? The draft is not about
wireless mesh networks being best for AMI, it is about the applicability
of ROLL working group products
to AMI networks using wireless mesh technologies, yes?

Regards

On 8/31/11 9:27 AM, "Pascal Thubert (pthubert)" <[email-masked]> wrote:

>I'd think that the general benefit of meshing is the spatial reuse of the
>medium - same thing for any switched fabric at the end of the day -.
>This benefits most to environments where the medium is a constrained or
>expensive resource.  This is much is very well-known and justifies the
>original text about cost savings.
>
>From there, the meshing/routing mechanism has to be designed in such a
>fashion that it is simple to deploy, with the classical self-* properties.
>A radio meshing/routing system will indeed be simpler to deploy because
>as the intro says, it will be easier to guarantee an appropriate
>coverage, which you cannot do at all times with one hop of wire (because
>of movement) or cellular (because of dark zones).
>
>So for all I know, the quoted text is not unsubstantiated and asilye
>justified for people of the art. I have no issue leaving the text as is
>and I find it relevant.
>
>Cheers,
>
>Pascal
>

---

From: "Jetcheva, Jorjeta" <[email-masked]>
Date: Wed, 31 Aug 2011 10:16:30 -0700

Hi Bora and all,

There were some comments on the list related to adding text about the applicability of multi-hop vs. single-hop deployments.  This paragraph attempted to distinguish between the two.  Perhaps it is not necessary to motivate the existence/use of multi-hop networks because they are already the focus of the protocol development within this group.

Does anyone else have any additional comments regarding including text about the benefits of multi-hop networks as compared to single-hop networks in the draft? 

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 9:13 AM
To: Jetcheva, Jorjeta
Cc: D?jean Nicolas; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi again,

Regards

---

From: "Salazar, Ruben" <[email-masked]>
Date: Wed, 31 Aug 2011 19:59:14 +0200

All,
The benefit of multi-hop networks is clear as it relates to geography coverage: that is why star topologies have some hidden repeat-route-relay features/mechanisms to extend coverage, which comes naturally with mesh topologies. And this statement applies to both wireless and wired networks.
Regards

Ruben Salazar
Director Research and Technology
Landis+Gyr
Energy Management Solutions
Office: +1 678 258 3165        
[email-masked]
www.landisgyr.com 
manage energy better

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jetcheva, Jorjeta
Sent: Wednesday, August 31, 2011 1:17 PM
To: Akyol, Bora A
Cc: D?jean Nicolas; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi Bora and all,

Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.

-----Original Message-----
From: Akyol, Bora A [mailto:[email-masked]] 
Sent: Wednesday, August 31, 2011 9:13 AM
To: Jetcheva, Jorjeta
Cc: D?jean Nicolas; [email-masked]
Subject: Re: [Roll] I-D Action: draft-ietf-roll-applicability-ami-01.txt

Hi again,

Regards

---

From: "Alvaro A. Cardenas" <[email-masked]>
Date: Wed, 31 Aug 2011 11:18:31 -0700

Hi Jorjeta,

While I agree with you that mesh networks have a lot of advantages in
many AMI deployments, I think Bora has made very good points. The text
on the benefits of multi-hop networks vs. single-hop networks does not
appear to be within the scope of the applicability statement of RPL to
AMI MESH networks.

I think the introduction shared by Bora is concise and clear.

Regards,
Alvaro

---

From: "Akyol, Bora A" <[email-masked]>
Date: Wed, 31 Aug 2011 13:39:05 -0700

Hi Ruben

I think if you are in rural US (think Montana), I am not sure wireless
mesh network is going to have any advantages for coverage when compared to
cellular.
Regardless, I would propose that the suggested wording below is used to
replace the existing paragraph in this draft.

In a multi-hop mesh network, each electric meter mesh may have up
toseveral thousand wireless endpoints, with densities varying based on

Do you have any objections?

Thanks

On 8/31/11 10:59 AM, "Salazar, Ruben" <[email-masked]> wrote:

>All,
>The benefit of multi-hop networks is clear as it relates to geography
>coverage: that is why star topologies have some hidden repeat-route-relay
>features/mechanisms to extend coverage, which comes naturally with mesh
>topologies. And this statement applies to both wireless and wired
>networks.
>Regards
>
>Ruben Salazar
>There were some comments on the list related to adding text about the
>applicability of multi-hop vs. single-hop deployments.  This paragraph
>attempted to distinguish between the two.  Perhaps it is not necessary to
>motivate the existence/use of multi-hop networks because they are already
>the focus of the protocol development within this group.
>
>Does anyone else have any additional comments regarding including text
>about the benefits of multi-hop networks as compared to single-hop
>networks in the draft?
>
>Thanks, Jorjeta
>
>Jorjeta Jetcheva, Ph.D.
>>two
>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>>>Of
>>>>Akyol, Bora A