Subject: [Roll] I-D Action: draft-ietf-roll-applicability-ami-02.txt

From: [email-masked]
Date: Wed, 14 Sep 2011 11:27:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : Applicability Statement for the Routing Protocol for Low Power and Lossy Networks (RPL) in AMI Networks
	Author(s)       : Daniel Popa
                          Jorjeta Jetcheva
                          Nicolas Dejean
                          Ruben Salazar
                          Jonathan W. Hui
	Filename        : draft-ietf-roll-applicability-ami-02.txt
	Pages           : 17
	Date            : 2011-09-14

   This document discusses the applicability of RPL in Advanced Metering
   Infrastructure (AMI) networks.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-roll-applicability-ami-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-applicability-ami-02.txt

---

From: Panos Trakadas <[email-masked]>
Date: Fri, 16 Sep 2011 16:54:00 +0100 (BST)

Hello Nicolas,
Following your discussion with Cedric regarding routing metrics composition for ami network deployment scenarios, i would like to remind you that in draft-zahariadis-roll-metrics-composition-01 we present a design framework for metric composition, including both theoretical and practical aspects, followed by several examples.
I think that you will find interesting information in this draft.
Furthermore, we have already started examining composition rules for several metrics used in RPL routing protocol (including HC, ETX, LQL, remaining energy) validated in an RPL simulation platform. 
The simulation platform provides multiple instances and OFs support.
Finishing debugging, we plan to distribute a beta version of the simulator code.

Best Regards,
Panos

On 16 Sep 2011, at 11:08, Nicolas DEJEAN <[email-masked]> wrote:

Hello Cédric,
 
I will answer to your second comment.
 
I completely agree with you and this is excatly what is meant by "Hop Count and Link Quality Level".
Moreover, the comment about an objective able to deal with more than one metric in section 4.1.5 follows the same idea.
However, I agree that this is not clear enough in the draft and it will be updated in the next release.
Something like a "combination of Hop Count and Link Quality Level" should appear.
 
I also agree about the energy metric.
The next release will also be updated accordingly.
 
Cheers,

Nicolas.
2011/9/15 C Chauvenet <[email-masked]>
Hi Jorjeta, 

Thank you for the update, I think the doc brings additional valuable content in this new revision.

I have 2 comments about this new version of the draft : 

In 2.2.1 : It is mentioned that the traffic in AMI networks will be highly asymmetric, and mostly narrowed to MP2P traffic. 
I agree that most of the traffic in AMI will be sent by meters to the LBR. Though, as stated a little bit above in the doc, most of meters will be polled, resulting in P2MP traffic (unicast or multicast packets). So, my understanding is that if every meters is polled before sending its data, the traffic becomes symmetrical, because you have a 1:1 ratio between downward (LBR polling) and upward (Meter reporting) traffic.
Could you please help me to understand your statement ?
I think the traffic pattern may impact significantly the Storing Vs Non-Storing design choice.

In 4.1.4 : It is mentioned that Hop Count (HC) or Link Quality Level (LQL) may be suitable for energy constrained node much as water or gas meters.
I am not sure about the efficiency of Hop Count regarding energy consumption. As we are working in lossy networks, there is a great chance that the shortest path may not be the more reliable. So the shortest path may induce many MAC level retries (thus inducing a faster energy drop of the node, and a higher congestion of the channel), and decrease significantly the reliability. This could result in a path that cannot meet the requirements of AMI (regarding reliability especially). I guess you mentioned Hop count, because you get an minimum number of forwarder, thus reducing the number of devices involved in the path, and minimizing the impact of a packet in the global energy depletion of the global networks. I think this is very true in not-so-lossy networks, but I was wondering about lossy networks.
In my opinion, LQL may be more adapted. Maybe your were thinking about mixing Hop Count and LQL?
About energy, note that a specific metric has been designed in the rpl-metric-draft. It may be worth to mention it.

Best,

Cédric.

Le 14 sept. 2011 à 20:32, Jetcheva, Jorjeta a écrit :

Hello everyone,
 
Just wanted to draw your attention to the new iteration of the RPL AMI Applicability Internet-Draft (version 02).  We’ve made a few improvements to the draft based on feedback from the group received so far.  Thank you all who sent us questions, comments and suggestions!
 
Below is a brief summary of the changes:
 
- Expanded discussion of Trickle parameter setting considerations
- Updates related to battery operated meters and routing infrastructure
- Expanded discussion related to network topology characteristics
- Updates related to traffic characteristics
- Removed text discussing the benefits of multi-hop deployments vs. single-hop deployments
- Clarification and readability improvements
 
We look forward to your feedback as we work on improving the draft further!
 
Thanks, Jorjeta

Jorjeta Jetcheva, Ph.D.
Strategic Industry Standards and Architecture
Office of the CTO
Mobile: +1.408.688.1428
Knowledge to Shape Your Future

<ATT00001..txt>

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll