Subject: Re: [Roll] PLEASE Comment on draft-alexander-roll-mikey-lln-key-mgmt

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 5 Sep 2011 16:47:19 +0200

Dear JP,

I am not sure I completely understand the question……is this the WG chair polling the group for adaptation as WG document?

If yes, when do you plan on making a decision (so as to give a target as to before when an opinion should have been formed?)

Thomas

On Aug 31, 2011, at 14:55 , JP Vasseur wrote:

> Any comment ?
> 
> Thanks.
> 
> JP.
> 
> Begin forwarded message:
> 
>> From: JP Vasseur <[email-masked]>
>> Subject: [Roll] PLEASE Comment on draft-alexander-roll-mikey-lln-key-mgmt
>> Date: August 26, 2011 9:17:42 AM GMT+02:00
>> To: roll WG <[email-masked]>
>> 
>> Dear all,
>> 
>> Several of you expressed some interest in draft-alexander-roll-mikey-lln-key-mgmt. That said, could you
>> please comment on this I-D as soon as possible ? We need a key management protocol and if it turns
>> out that the WG wants to adopt this ID, I'll poll the WG to make it a WG … Please comment.
>> 
>> Thanks.
>> 
>> JP.
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: JP Vasseur <[email-masked]>
Date: Mon, 5 Sep 2011 16:53:30 +0200

Hi Thomas,

> If yes, when do you plan on making a decision (so as to give a target as to before when an opinion should have been formed?)

I was polling the WG to get some comment since we did not get a chance to discuss it during the WG meeting,
that was not yet a poll for WG adoption.

Any opinion to share of this document ?

Thanks.

JP.

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 5 Sep 2011 18:07:41 +0200

Dear JP,

Thanks. I have read the specification a couple of times, but as I am not a key-management-expert, I have not (yet) formed any real opinions on the technical content. I am still working on that bit ;)

However as you message was cryptic, I wanted to make sure that I did not miss any last-review-before-wg-document deadline. I understand that there's no immediate deadline so I would suggest that the WG gets to consider  that when a determination has been made on the other ongoing issues currently being discussed 

[Not to belittle this document; I, for one, like most LLN routers just have limited bandwidth and processing power….trying to make sure that they are being used appropriately]

Respectfully yours,

Thomas

---

From: JP Vasseur <[email-masked]>
Date: Mon, 5 Sep 2011 18:36:05 +0200

Thanks Thomas for your feed-back.

Still, I would encourage people to read and comment; the issue of key management has been raised by several
ADs and in the security framework, so we may want to make some progress and address IESG's requests.

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 08 Sep 2011 14:17:35 +0900

Hello,

I think a cross-layer key management approach is important for
resource-constrained devices.  On the other hand, there are similar
approaches proposed in other IETF WG:

http://tools.ietf.org/id/draft-arkko-core-security-arch-00.txt
http://tools.ietf.org/id/draft-garcia-core-security-02.txt
http://tools.ietf.org/id/draft-sarikaya-core-sbootstrapping-02.txt
http://tools.ietf.org/id/draft-ohba-core-eap-based-bootstrapping-00.txt

(and I am a co-author of the last two ones.)

MIKEY-based cross-layer key management (such as described in
draft-alexander) can be an alternative, and similar solutions can be
defined using other key management protocols such as PANA, TLS,
IKEv2, GDOI and maybe HIP.

I am not trying to compare them here, but I just want to point out
that there are multiple approaches in this area.

Regards,
Yoshihiro Ohba

(2011/09/06 1:36), JP Vasseur wrote:
>> Thanks. I have read the specification a couple of times, but as I am 
>> not a key-management-expert, I have not (yet) formed any real 
>> opinions on the technical content. I am still working on that bit ;)
>>
>> However as you message was cryptic, I wanted to make sure that I did 
>> not miss any last-review-before-wg-document deadline. I understand 
>> that there's no immediate deadline so I would suggest that the WG 
>> gets to consider that when a determination has been made on the 
>> other ongoing issues currently being discussed
>>
>> [Not to belittle this document; I, for one, like most LLN routers 
>> just have limited bandwidth and processing power….trying to make 
>> sure that they are being used appropriately]
>>
>> Respectfully yours,
>>
>> Thomas
>>
>>
>>
>>>> I am not sure I completely understand the question……is this the WG 
>>>> chair polling the group for adaptation as WG document?
>>>>
>>>> If yes, when do you plan on making a decision (so as to give a 
>>>> target as to before when an opinion should have been formed?)
>>>>
>>>
>>> I was polling the WG to get some comment since we did not get a 
>>> chance to discuss it during the WG meeting,
>>>>>> *From: *JP Vasseur <[email-masked] <mailto:[email-masked]>>
>>>>>> *Subject: **[Roll] PLEASE Comment on 
>>>>>> draft-alexander-roll-mikey-lln-key-mgmt*
>>>>>> *Date: *August 26, 2011 9:17:42 AM GMT+02:00
>>>>>> *To: *roll WG <[email-masked] <mailto:[email-masked]>>
>>>>>>
>>>>>> Dear all,
>>>>>>
>>>>>> Several of you expressed some interest in 
>>>>>> draft-alexander-roll-mikey-lln-key-mgmt. That said, could you
>>>>>> [email-masked] <mailto:[email-masked]>
>>>>> [email-masked] <mailto:[email-masked]>

---

From: Robert Cragie <[email-masked]>
Date: Thu, 8 Sep 2011 13:12:25 +0100

+1.

I can see the merit in attempting to propose a generic key management
protocol but the very fact that different mechanisms exist suggests that it
is probably an unattainable target due to the distinct properties of the
underlying system the key management is being applied to.

Also, I question whether roll *needs* a key management protocol. It needs a
key management proposal, which should probably focus on abstract key
management operations relevant to roll networks rather than mandating (a)
specific key management protocol(s). Or is the desire to be more specific to
provide better interoperability?

Robert

2011/9/8 Yoshihiro Ohba <[email-masked]>