Subject: [Roll] definition of "RPL Domain"

From: Mukul Goyal <[email-masked]>
Date: Mon, 17 Oct 2011 20:05:20 -0500 (CDT)

Hi JP

I was wondering if the term "RPL Domain" could be defined in the terminology draft. 

Thanks
Mukul 

----- Forwarded Message -----
From: "Joseph Reddy" <[email-masked]>
To: [email-masked]
Sent: Friday, October 14, 2011 7:15:05 PM
Subject: Re: Fwd: I-D Action: draft-ietf-6man-rpl-option-04.txt

Hi Jonathan,

The draft uses the term "RPL domain" in several places and this is not clearly defined. 

I would imagine that it includes all nodes that are downstream of the RPL border router. But can you clarify if Host nodes that are downstream of the border router but do not implement any part of RPL ( even as RPL Leaf nodes ) should be considered part of the "RPL domain" ?

In section 5, the draft now says "..Datagrams destined to nodes outside the RPL domain are dropped if the outer-most IPv6 header contains a RPL Option..."

This text would imply that any RPL node sending packets to nodes outside should always tunnel to the Root ? Is that the intention really or am I missing something here.. 

Also note that if non-RPL Host is not considered part of the RPL domain, then I am not sure that a forwarding router can know if the destination is inside the domain or not. 

-Regards, Joseph

------------------------------

Message: 5
Date: Tue, 11 Oct 2011 22:23:10 -0700
From: Jonathan Hui <[email-masked]>
To: IETF IPv6 Mailing List <[email-masked]>
Subject: Fwd: I-D Action: draft-ietf-6man-rpl-option-04.txt
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

This update is intended to address Jari Arkko's AD review.

Summary of changes:
- Clarify when the RPL Option is used.
- Updated text on recommendations for avoiding fragmentation.
- Specify skip-over-and-continue policy for unrecognized sub-TLVs.
- Change use of IPv6-in-IPv6 tunneling from SHOULD to MUST.
- Specify RPL Border Router operations in terms of forwarding decision outcomes.
- Expand security section.

--
Jonathan Hui

Begin forwarded message:

> From: [email-masked]
> Date: October 11, 2011 10:17:15 PM PDT
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-6man-rpl-option-04.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the IPv6 Maintenance Working Group of the IETF.
> 
> 	Title           : RPL Option for Carrying RPL Information in Data-Plane Datagrams
> 	Author(s)       : Jonathan W. Hui
>                          JP Vasseur
> 	Filename        : draft-ietf-6man-rpl-option-04.txt
> 	Pages           : 14
> 	Date            : 2011-10-11
> 
>   The RPL protocol requires data-plane datagrams to carry RPL routing
>   information that is processed by RPL routers when forwarding those
>   datagrams.  This document describes the RPL Option for use within a
>   RPL domain.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-6man-rpl-option-04.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-6man-rpl-option-04.txt
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Dijk, Esko" <[email-masked]>
Date: Tue, 18 Oct 2011 14:01:07 +0200

Sounds like a good idea. I propose then to also define "RPL traffic" in the terminology draft because it can be interpreted in other ways than intended.

best regards,
Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mukul Goyal
Sent: Tuesday 18 October 2011 3:05
To: JP Vasseur
Cc: roll
Subject: [Roll] definition of "RPL Domain"

Hi JP

Thanks
Mukul

----- Forwarded Message -----
From: "Joseph Reddy" <[email-masked]>
To: [email-masked]
Sent: Friday, October 14, 2011 7:15:05 PM
Subject: Re: Fwd: I-D Action: draft-ietf-6man-rpl-option-04.txt

Hi Jonathan,

-Regards, Joseph

Message: 5

Summary of changes:

--
Jonathan Hui

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.