Subject: [Roll] parameterizing RPL for deployments

From: Omprakash Gnawali <[email-masked]>
Date: Wed, 23 Nov 2011 12:05:40 -0600

Thanks Thomas about the details of the discussions at IETF 82. I just
want to remind the WG about a draft that is collecting recommendations
and explanations on how to configure RPL:

http://tools.ietf.org/html/draft-gnawali-roll-rpl-recommendations-02

- om_p

On Wed, Nov 23, 2011 at 2:40 AM, Thomas Clausen <[email-masked]> wrote:
> Dear JP, all,
>
> I am concerned that the minutes are rather brief and high-level, and do not reflect in sufficient detail the issues that were discussed and capture the questions which were brought forward. I would suggest revising the minutes to better capture the discussions for posterity.
>
>
> For example, and I will give but one example, but it applies throughout: for item 2, the minutes do not capture the issue that was given a lot of microphone-time: whether this document is supposed to be providing deployment guidelines and parametrization of RPL so as to make it operational in a given environment - or, rather, be a "marketing document".
>
> I recall mentioning at the mike that the WG chairs previously promised the applicability documents as the place where all (e.g.) my worries about how to make RPL work in the different deployments (or, even, if RPL could work in these deployments) would be laid to rest by explaining exactly how to parametrize RPL for these deployments. I also recall expressing some disappointment that this applicability document in its present form doesn't offer any of these guidelines whatsoever - but rather satisfies itself by asserting (as Geoff Mulligan pointed out at the mike) that the protocol works.
>
> Adrian Farrel (RTG AD) suggested at the mike  that the document in its present form should aim for Informational - which, probably, is appropriate. However I also asked at the mike where, then, the "explaining exactly how to parametrize RPL for these deployments", which had been promised, would appear. (And, didn't get any answer to that question….)
>
> On the very same item, I see that the draft being discussed is indicated as "draft-popa-roll-applicability-ami-04" - whereas I see in the tools server that "draft-ietf-roll-applicability-ami-04" exists -- are they different documents? Same documents with different names? Was the draft-ietf- version withdrawn?
>
> Thank you in advance for your consideration of these comments for the minutes,
>
> Respectfully yours,
>
> Thomas
>
> On Nov 21, 2011, at 8:15 PM, JP Vasseur wrote:
>
>> Hi,
>>
>> The Minutes of the ROLL IETF-82 meetings have been uploaded: http://www.ietf.org/proceedings/82/minutes/roll.txt
>>
>> If you have any comments, please provide your comments by Nov 30 noon ET.
>>
>> Many Thanks to Dan for the minutes !
>>
>> Cheers.
>>
>> JP.
>> _______________________________________________
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: Thomas Clausen <[email-masked]>
Date: Wed, 23 Nov 2011 19:25:20 +0100

Ompra,

This I-D is actually much much closer to what I would like to see the WG produce as part of the applicability statements. I would encourage that this work be continued in the WG….

Thomas