Subject: [Roll] RPL instance as the boundary for RPL option/source route header

From: Mukul Goyal <[email-masked]>
Date: Thu, 17 Nov 2011 10:50:18 -0600 (CST)

Hi Jonathan

Couple of queries:

1) A packet with an RPL option cant cross the RPL instance it was generated in. Here, are n't you implicitly assuming that RPLInstanceID is global? What happens when RPLInstanceID is local? In that case, I wonder if a packet with an RPL option must not leave the set of DODAGs identified by RPLInstanceID and the DODAGID (same as source's IPv6 address)?

2) How do you define the RPL instance that constitutes the boundaries that a packet with RPL Source Route header must not cross? SRH does not have any field for RPLInstanceID.

Thanks
Mukul

---

From: Mukul Goyal <[email-masked]>
Date: Thu, 17 Nov 2011 10:53:43 -0600 (CST)

>2) How do you define the RPL instance that constitutes the boundaries that a packet with RPL Source Route header must not cross? SRH does not have any field for RPLInstanceID.

Further, it does not really make any sense to limit a source-routed packet to an RPL instance.

Thanks
Mukul

----- Original Message -----
From: "Mukul Goyal" <[email-masked]>
To: "Jonathan Hui" <[email-masked]>
Cc: "roll" <[email-masked]>
Sent: Thursday, November 17, 2011 10:50:18 AM
Subject: [Roll] RPL instance as the boundary for RPL option/source route	header

Hi Jonathan

Couple of queries:

Thanks
Mukul
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Jonathan Hui <[email-masked]>
Date: Thu, 17 Nov 2011 12:24:48 -0800

Hi Mukul,

> 1) A packet with an RPL option cant cross the RPL instance it was generated in. Here, are n't you implicitly assuming that RPLInstanceID is global? What happens when RPLInstanceID is local? In that…

No assumption that RPL Instance ID is global.  The tunnel exit-point must be within the same RPL Instance as the tunnel entry-point.  If the original packet needs to be forwarded outside the RPL Instance, then it must exit the tunnel and therefore strip the RPL Option.  That is true whether the instance is global or local.

> 2) How do you define the RPL instance that constitutes the boundaries that a packet with RPL Source Route header must not cross? SRH does not have any field for RPLInstanceID.

You are correct.  I guess "RPL domain" was the better terminology here.  If you agree with my proposed definition of "RPL domain", I can make the change in the next revision.

--
Jonathan Hui

---

From: Mukul Goyal <[email-masked]>
Date: Thu, 17 Nov 2011 21:25:23 -0600 (CST)

Hi Jonathan

>No assumption that RPL Instance ID is global.  The tunnel exit-point must be within the same RPL Instance as the tunnel entry-point.  If the original packet needs to be forwarded outside the RPL Ins…

This makes sense now. 

>You are correct.  I guess "RPL domain" was the better terminology here.  If you agree with my proposed definition of "RPL domain", I can make the change in the next revision.

As I mentioned I agree with the definition of "RPL domain" you mentioned earlier. So, please make the change.

Thanks
Mukul

--
Jonathan Hui