Subject: [Roll] question about working with RPL with multiple rates

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Mon, 28 Nov 2011 15:59:35 +0200

Dear Roll-ers,

I’m working on an implementation of RPL for a power-line technology. L1/L2
of the technology allows to operate at different rates at the per link (by
controlling modulation, coding parameters, tone masks, etc.).

I was wondering if anyone had any experience working with RPL using PHY/DLL
that support multiple rates?

The application is a metering application where meter polling is used for
data traffic, so P2MP and MP2P are used.

We want to use external memory for the DODAG root with non-storing mode.

I’m mostly interested to get the WG impression on the following two issues:

1.       I assume DIOs are sent at the lowest (and most robust) rate to
cover as many potential children possible. My question is since DIOs are
transmitted at robust rates to many potential children, how does the
potential children know which parent is best to choose from? Does RPL
assume capability to derive link quality information about a higher rate
from the received DIO at lower rate by L1/L2?

2.       Another question is concerning how to differentiate between links
where one direction can be used at high rate vs. the link on the other
direction can be used at a lower rate. If a network contains 100 routers
sending DIOs at robust rate that a node receives, how does this potential
child know which node to use as a preferred parent assuming potential
parents can be used on the way up at the same rate, but the downward route
can be used at higher rate by one of them (i.e. more optimal parent)?

I’d appreciate any thoughts the WG wishes to share on this issue.

Best regards,

Yoav

---

From: C Chauvenet <[email-masked]>
Date: Mon, 28 Nov 2011 06:56:14 -0800

Hi Yoav,

The "best parent" feature is all about metrics, so you have to define a metric that reflects how "good" a parent is.

In RPL you have 2 options : metrics defined in the metric related draft and OF0.

In OF0, you build you own metric to reflect an indicator of "how good is the metric".

The RPL metrics draft define particular metrics, for instance, Energy, throughput, latency…

In your case, all seems to be related to data rate, so it may be good to look at the throughput metric of the metric draft.
With the use of that metric, you could use throughput measurements on a link to determine how good a link is in you parent selection.
Note that the draft define the format of the metric container to use, but does not define how to calculate the metric.
You have to compute the metric yourself.

Best,
Cédric.

Le 28 nov. 2011 à 14:59, Yoav Ben-Yehezkel a écrit :

Dear Roll-ers,

I’m working on an implementation of RPL for a power-line technology. L1/L2 of the technology allows to operate at different rates at the per link (by controlling modulation, coding parameters, tone masks, etc.).
I was wondering if anyone had any experience working with RPL using PHY/DLL that support multiple rates?
The application is a metering application where meter polling is used for data traffic, so P2MP and MP2P are used.
We want to use external memory for the DODAG root with non-storing mode.

I’m mostly interested to get the WG impression on the following two issues:
1.       I assume DIOs are sent at the lowest (and most robust) rate to cover as many potential children possible. My question is since DIOs are transmitted at robust rates to many potential children, how does the potential children know which parent is best to choose from? Does RPL assume capability to derive link quality information about a higher rate from the received DIO at lower rate by L1/L2?
2.       Another question is concerning how to differentiate between links where one direction can be used at high rate vs. the link on the other direction can be used at a lower rate. If a network contains 100 routers sending DIOs at robust rate that a node receives, how does this potential child know which node to use as a preferred parent assuming potential parents can be used on the way up at the same rate, but the downward route can be used at higher rate by one of them (i.e. more optimal parent)?

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Mon, 28 Nov 2011 09:23:27 -0800

On Nov 28, 2011, at 5:59 AM, Yoav Ben-Yehezkel wrote:

> 1.       I assume DIOs are sent at the lowest (and most robust) rate to cover as many potential children possible. My question is since DIOs are transmitted at robust rates to many potential children, how does the potential children know which parent is best to choose from?

The objective function defines how to do so, using one or more of 
  - locally measured link properties,
  - Rank, and 
  - metric containers.

> Does RPL assume capability to derive link quality information about a higher rate from the received DIO at lower rate by L1/L2?

No. While some link/physical layers might be able to compute metrics solely from received packets, others can't. In the wireless research world they're called "asymmetric links," i.e., where A can hear B well but B cannot hear A well. The assumption is that the protocol is somehow estimating link quality. How this is done is 

> 2.       Another question is concerning how to differentiate between links where one direction can be used at high rate vs. the link on the other direction can be used at a lower rate. If a network…

You'd express this in the link metric. RPL does not assume that the metric value of AB is the same as BA. Research tackled this a bit in WiFi meshes, for example, by extending ETX (expected number of transmissions) to ETT (expected time of transmission). 

Phil

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Tue, 29 Nov 2011 08:37:08 +0200

Thanks Cédric and Philip for the clarification.
ETT seems like an interesting approach.

Best regards,
Yoav

-----Original Message-----
From: Philip Levis [mailto:[email-masked]]
Sent: Monday, November 28, 2011 7:23 PM
To: Yoav Ben-Yehezkel
Cc: [email-masked]
Subject: Re: [Roll] question about working with RPL with multiple rates

On Nov 28, 2011, at 5:59 AM, Yoav Ben-Yehezkel wrote:

> Dear Roll-ers,
>
> I’m working on an implementation of RPL for a power-line technology.
L1/L2 of the technology allows to operate at different rates at the per
link (by controlling modulation, coding parameters, tone masks, etc.).
> The application is a metering application where meter polling is used
for data traffic, so P2MP and MP2P are used.
cover as many potential children possible. My question is since DIOs are
transmitted at robust rates to many potential children, how does the
potential children know which parent is best to choose from?

> Does RPL assume capability to derive link quality information about a
higher rate from the received DIO at lower rate by L1/L2?

No. While some link/physical layers might be able to compute metrics
solely from received packets, others can't. In the wireless research world
they're called "asymmetric links," i.e., where A can hear B well but B
cannot hear A well. The assumption is that the protocol is somehow
estimating link quality. How this is done is

> 2.       Another question is concerning how to differentiate between
links where one direction can be used at high rate vs. the link on the
other direction can be used at a lower rate. If a network contains 100
routers sending DIOs at robust rate that a node receives, how does this
potential child know which node to use as a preferred parent assuming
potential parents can be used on the way up at the same rate, but the
downward route can be used at higher rate by one of them (i.e. more
optimal parent)?

You'd express this in the link metric. RPL does not assume that the metric
value of AB is the same as BA. Research tackled this a bit in WiFi meshes,
for example, by extending ETX (expected number of transmissions) to ETT
(expected time of transmission).

Phil