Subject: Re: [Roll] regarding DIS Modifications draft (draft-goyal-roll-dis-modifications-00)

From: Emmanuel Baccelli <[email-masked]>
Date: Mon, 14 Nov 2011 02:59:53 +0100

Hi Yoav,
good call. In fact the current specification interprets the randomization
range being from 0 to 2^SpreadingInterval ms. The maximum interval is thus
 0 to 2^256 ms, which is quite an astronomic number already! Do you think
we need some more fancy way to define the range from the number specified
in the SpreadingInterval field?
Cheers
Emmanuel

On Sun, Nov 13, 2011 at 5:32 PM, Yoav Ben-Yehezkel <[email-masked]> wrote:

> Hi,
>
>
>
> I went through the draft, it seems interesting.
>
>
>
> I had one concern regarding the use of the Response Spreading Option
> specified in 4.2.
>
>
>
> 8 bits specified in ms can be a too small randomization for some L2
> technologies (such as narrowband powerline).
>
>
>
> Would it be possible to increase the number of bits (although 16 seems
> like an overkill)?
>
> Another option could be to divide the field into two (first part units:
> ms, 10ms, 100ms, etc. and second part randomization range)?
>
>
>
> I expect that in order to avoid collisions this randomization is best
> achieved if the units are at the magnitude of the duration of a frame or so.
>
>
>
> Best regards,
>
> Yoav
>
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>

---

From: Yoav Ben-Yehezkel <[email-masked]>
Date: Mon, 14 Nov 2011 13:09:13 +0200

Thanks,

I didn’t notice the 2^ J

I take my comment back.

Best regards,

Yoav

*From:* [email-masked] [mailto:[email-masked]] *On
Behalf Of *Emmanuel
Baccelli
*Sent:* Monday, November 14, 2011 4:00 AM
*To:* [email-masked]
*Subject:* Re: [Roll] regarding DIS Modifications draft
(draft-goyal-roll-dis-modifications-00)

Hi Yoav,

Cheers

Emmanuel

Hi,

Would it be possible to increase the number of bits (although 16 seems like
an overkill)?

Another option could be to divide the field into two (first part units: ms,
10ms, 100ms, etc. and second part randomization range)?

Best regards,

Yoav

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 14 Nov 2011 19:37:00 +0800

Allow me to reiterate the question that I asked at the mike: why is the behavior proposed by this draft (i.e., to be not considering receipt of a DIS as an indication of inconsistency and thus not resetting trickle timers) not default behavior in RPL?

That the WG during the meeting did not have a clear answer to this leads me to believe that it should be - but I wanted to ask here as there may be a subtle reason....(and, if so, the conditions in which it applies or not should be called out in any IDs modifying the behavior).

Cheers,

Thomas

-- 
Thomas Heide Clausen
http://www.thomasclausen.org/

"Payload (noun): wasted bandwidth between headers" (C.Lavenu 2011)

On 14 Nov 2011, at 19:09, Yoav Ben-Yehezkel <[email-masked]> wrote:

> Thanks,
>  
> I didn’t notice the 2^ J
> I take my comment back.
>  
> Best regards,
> Yoav
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Emmanuel Baccelli
> Sent: Monday, November 14, 2011 4:00 AM
> To: [email-masked]
> Subject: Re: [Roll] regarding DIS Modifications draft (draft-goyal-roll-dis-modifications-00)
>  
> Hi Yoav,
> good call. In fact the current specification interprets the randomization range being from 0 to 2^SpreadingInterval ms. The maximum interval is thus  0 to 2^256 ms, which is quite an astronomic number already! Do you think we need some more fancy way to define the range from the number specified in the SpreadingInterval field?
> Cheers
> Emmanuel
>  
>  
> I had one concern regarding the use of the Response Spreading Option specified in 4.2.
>  
> 8 bits specified in ms can be a too small randomization for some L2 technologies (such as narrowband powerline).
>  
> Would it be possible to increase the number of bits (although 16 seems like an overkill)?
> Another option could be to divide the field into two (first part units: ms, 10ms, 100ms, etc. and second part randomization range)?
>  
> I expect that in order to avoid collisions this randomization is best achieved if the units are at the magnitude of the duration of a frame or so.
>  
> Best regards,
> Yoav
>  
>