Subject: [Roll] draft-ietf-6man-rpl-routing-header-07

From: Mukul Goyal <[email-masked]>
Date: Tue, 20 Dec 2011 10:14:21 -0600 (CST)

Jonathan

The IESG-approved draft refers to the RPL instance as the scope where the routing header can be used. How would this routing header be used for general source routing (across RPL instances) in an LLN? How would a node use this routing header if it wants to travel along a source route discovered using P2P-RPL?

Thanks
Mukul

---

From: Jonathan Hui <[email-masked]>
Date: Tue, 20 Dec 2011 08:27:29 -0800

Mukul,

As defined in the draft today, you cannot use a RPL routing header to cross RPL Instances.  My understanding is that roll-p2p-rpl makes use of local RPL instances.  Can you describe the issue you are concerned about?

--
Jonathan Hui

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 21 Dec 2011 11:26:42 -0600 (CST)

Jonathan

I described the problem in the message I sent just now. I think RPL Instance is not the correct scope for SRH. It has to be a RPL domain to be defined as we discussed some time back on the ROLL list.

Thanks
Mukul

----- Original Message -----
From: "Jonathan Hui" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "roll" <[email-masked]>
Sent: Tuesday, December 20, 2011 10:27:29 AM
Subject: Re: draft-ietf-6man-rpl-routing-header-07

Mukul,

--
Jonathan Hui

---

From: Jonathan Hui <[email-masked]>
Date: Wed, 21 Dec 2011 10:22:11 -0800

Personally, I am OK changing the scope to a RPL routing domain rather than a RPL Instance.  If one really wants to limit to a RPL Instance, then they can also include a RPL Option.  This is what we originally had in rpl-routing-header-05.  This change was made late during the IESG review process.

Jari, would you support reverting the scope of the RPL SRH to a RPL routing domain rather than a RPL Instance?

Thanks.

--
Jonathan Hui

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 21 Dec 2011 20:13:46 -0600 (CST)

>Personally, I am OK changing the scope to a RPL routing domain rather than a RPL Instance.  If one really wants to limit to a RPL Instance, then they can also include a RPL Option.  This is what we…

I support this.

Thanks
Mukul

----- Original Message -----
From: "Jonathan Hui" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>, "Jari Arkko" <[email-masked]>
Cc: "roll WG" <[email-masked]>, "ipv6" <[email-masked]>
Sent: Wednesday, December 21, 2011 12:22:11 PM
Subject: Re: draft-ietf-6man-rpl-routing-header-07

Thanks.

--
Jonathan Hui