Subject: [Roll] CmprI and CmprE in SRH

From: Mukul Goyal <[email-masked]>
Date: Wed, 21 Dec 2011 19:15:51 -0600 (CST)

Hi Jonathan

I think this was probably discussed earlier in your discussions with area director. But I was wondering if you could clarify again why do we need separate CmprI and CmprE? I think the last element in the Address vector specifies the ultimate destination (reachable using SRH) of the packet. Why would that destination need a separate number of elided prefix octets?

Thanks
Mukul

---

From: Jonathan Hui <[email-masked]>
Date: Wed, 21 Dec 2011 18:29:12 -0800

> I think this was probably discussed earlier in your discussions with area director. But I was wondering if you could clarify again why do we need separate CmprI and CmprE? I think the last element…

In the case that a RPL routing domain is used as a transit network.  It is important to support the case where the SRH only specifies a subset of the path (see the 3 different cases in the image on page 5 of the draft.

--
Jonathan Hui

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 21 Dec 2011 21:20:22 -0600 (CST)

>In the case that a RPL routing domain is used as a transit network.  It is important to support the case where the SRH only specifies a subset of the path (see the 3 different cases in the image on…

If RPL domain is just a transit network, why would SRH include the ultimate destination?

Thanks
Mukul  

----- Original Message -----
From: "Jonathan Hui" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: "roll" <[email-masked]>
Sent: Wednesday, December 21, 2011 8:29:12 PM
Subject: Re: CmprI and CmprE in SRH

--
Jonathan Hui

---

From: Jonathan Hui <[email-masked]>
Date: Wed, 21 Dec 2011 19:35:06 -0800

CmprI and CmprE were introduced when we allowed the use of SRH in transport mode even when the destination was not a part of the RPL network.  The way the draft morphed, we eventually removed support for that case, but forgot to remove CmprI and CmprE along with it.

Would have been nice to get this comment as part of WGLC or IETF LC...

--
Jonathan Hui