Subject: Re: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-07.txt

From: JP Vasseur <[email-masked]>
Date: Thu, 2 Feb 2012 13:13:05 +0100

Dear co-authors,

You mentioned that you had some implementations you even performed interop testing ? Anything hat you could share with the WG in order to
make progress on that front, before WG LC ?

Thanks.

JP.

On Jan 29, 2012, at 1:33 AM, [email-masked] wrote:

> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.
> 
> 	Title           : Reactive Discovery of Point-to-Point Routes in Low Power and Lossy Networks
> 	Author(s)       : Mukul Goyal
>                        Emmanuel Baccelli
>                        Matthias Philipp
>                        Anders Brandt
>                        Jerald Martocci
> 	Filename        : draft-ietf-roll-p2p-rpl-07.txt
> 	Pages           : 27
> 	Date            : 2012-01-28
> 
> This document specifies a point-to-point route discovery mechanism,
> complementary to the RPL core functionality.  This mechanism allows
> an IPv6 router to discover and establish, on demand, a route to
> another IPv6 router in the LLN such that the discovered route meets
> specified metrics constraints, without necessarily going along the
> DAG links established by core RPL.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-roll-p2p-rpl-07.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-p2p-rpl-07.txt
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 2 Feb 2012 14:28:10 +0100

Hi JP,

indeed we have. By the way, we already posted ROLL on this subject on Jan
20th (see http://www.ietf.org/mail-archive/web/roll/current/msg06625.html).

The updates to the specification from -05 to -07 were prompted by the
results of the latest P2P-RPL interop.

This interop was carried out last month with INRIA's implementation against
Sigma Design's implementation, and a report is available over here
http://hal.inria.fr/docs/00/66/16/29/PDF/RR-7864.pdf

Experiments with P2P-RPL have also taken place on the Senslab testbed
gathering boards based on MSP430 and 802.15.4 at 2.4GHz, see for instance
the experiments documented in this report
http://hal.archives-ouvertes.fr/docs/00/65/16/03/PDF/SOFTCOM-2011.pdf

The INRIA implementation is by the way available upon request.

Best regards,

Emmanuel

On Thu, Feb 2, 2012 at 1:13 PM, JP Vasseur <[email-masked]> wrote:

> Dear co-authors,
>
> You mentioned that you had some implementations you even performed interop
> testing ? Anything hat you could share with the WG in order to
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Routing Over Low power and
> Lossy networks Working Group of the IETF.
> >
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>