Subject: [Roll] MRHOF Objective function (using ETX metric)

From: Costin Michaela Catalina-B06063 <[email-masked]>
Date: Tue, 21 Feb 2012 10:17:22 +0000

Hello guys,

While reading MRHOF draft (for ETX metric),  I identified some discrepancies between the RPL and the MRHOF draft:

*         The rank of a DODAG root according to ROLL RPL draft is MinHopRankIncrease (default value = 0x100). According to MRHOF,  the rank of the DODAG root is MIN_PATH_COST (default value = 0)

*         The algorithm for computing node rank is not clearly described in the MRHOF draft. Once the path cost for all neighbors is computed and the preferred parent is selected, the node rank is calculated just by adding MinHopRankIncrease to the smallest path cost (to the preferred parent path cost)?

Do you have any comments related to these issues?

Thanks,

Catalina Costin
Freescale Semiconductor Romania
Phone: +40 21 3052217
[email-masked]<mailto:[email-masked]>
=======================================================
This e-mail, and any associated attachments have been classified as:
[x] Public
[  ] Freescale Semiconductor Internal Use Only
[  ] Freescale Semiconductor Confidential Proprietary

---

From: Dario Tedeschi <[email-masked]>
Date: Thu, 01 Mar 2012 08:26:26 +0200

Yes, how exactly is MinHopRankIncrease used for rank calculation in MRHOF?

In the case of using the ETX metric, could it be something like the 
following:
my_rank = cur_min_path_cost = parent_rank + (MinHopRankIncrease * {ETX 
of link with parent})
Where MinHopRankIncrease = 128.

Please could someone clarify.

Dario

On 12-02-21 12:17 PM, Costin Michaela Catalina-B06063 wrote:
>
> Hello guys,
>
> While reading MRHOF draft (for ETX metric),  I identified some 
> discrepancies between the RPL and the MRHOF draft:
>
> ·The rank of a DODAG root according to ROLL RPL draft is 
> MinHopRankIncrease (default value = 0x100). According to MRHOF,  the 
> rank of the DODAG root is MIN_PATH_COST (default value = 0)
>
> ·The algorithm for computing node rank is not clearly described in the 
> MRHOF draft. Once the path cost for all neighbors is computed and the 
> preferred parent is selected, the node rank is calculated just by 
> adding MinHopRankIncrease to the smallest path cost (to the preferred 
> parent path cost)?
>
> *Catalina Costin*
> [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll