Subject: Re: [Roll] Roll Digest, Vol 50, Issue 4

From: "Reddy, Joseph" <[email-masked]>
Date: Mon, 5 Mar 2012 21:42:20 +0000

Hi Phil,

I believe the Rank should be computed as the path cost from the best parent and not worst one.

We had this discussion on this topic previously on the reflector....see
http://www.ietf.org/mail-archive/web/roll/current/msg06077.html

-Regards, Joseph

------------------------------

Message: 2
Date: Sun, 4 Mar 2012 15:47:23 -0800
From: Philip Levis <[email-masked]>
To: Peter Burnett <[email-masked]>
Cc: [email-masked]
Subject: Re: [Roll] MRHOF Objective function (using ETX metric)
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

On Mar 1, 2012, at 8:42 AM, Peter Burnett wrote:

> Another related difficulty for me is that section 3.3 seems to say that the rank of a non-root node is the path cost through the worst parent. However 3.4 says that the advertised rank is the path cost through the preferred parent, the min_path_cost. How can these be reconciled?

The first is correct. I'm fixing this in -05, thanks for catching it.

Phil

---

From: Philip Levis <[email-masked]>
Date: Mon, 5 Mar 2012 14:00:57 -0800

You are absolutely right, my edits to -05 were rushed to make the deadline; I'll be sure to put this clarification in my short presentation (assuming I have a slot) and in a -06 post-IETF.

Phil

---

From: Philip Levis <[email-masked]>
Date: Tue, 6 Mar 2012 16:18:49 -0800

>> http://www.ietf.org/mail-archive/web/roll/current/msg06077.html

After going back through the email thread and the RPL specification (8.2.1), I've updated MRHOF to say:

   "A node sets its Rank to the maximum of three values:

   1.  The Rank associated with the path through the preferred parent

   2.  The Rank of the member of the parent set with the highest
       advertised Rank plus one

   3.  The Rank of the path through the member of the parent set with
       the highest path cost, minus MaxRankIncrease

   The first case is the Rank associated with the path through the
   preferred parent.  The second case covers requirement 4 of Rank
   advertisements in Section 8.2.1 of [I-D.ietf-roll-rpl].  The third
   case ensures that a node does not advertise a Rank which then
   precludes it from using members of its parent set."

"Rank associated with the path" means "Rank calculated from the metrics associated with the path."

I'm submitting an updated -06 that incorporates the comments from the WG. PARENT_SWITCH_THRESHOLD is defined in terms of cost, not metric, and the recommended parameters have been changed accordingly.

Phil