Subject: [Roll] Fwd: New Version Notification for draft-gnawali-roll-rpl-recommendations-03.txt

From: Omprakash Gnawali <[email-masked]>
Date: Sun, 11 Mar 2012 01:36:27 +0000

Dear ROLL WG,

I just refreshed this draft with comments from JP, Cedric, Joakim, and
Ulrich. Please keep your comments coming, especially those who have
implemented and deployed RPL.

Thanks.

- om_p

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Sun, Mar 11, 2012 at 1:34 AM
Subject: New Version Notification for
draft-gnawali-roll-rpl-recommendations-03.txt
To: [email-masked]
Cc: [email-masked]

A new version of I-D, draft-gnawali-roll-rpl-recommendations-03.txt
has been successfully submitted by Omprakash Gnawali and posted to the
IETF repository.

Filename:        draft-gnawali-roll-rpl-recommendations
Revision:        03
Title:           Recommendations for Efficient Implementation of RPL
Creation date:   2012-03-10
WG ID:           Individual Submission
Number of pages: 6

Abstract:
  RPL is a flexible routing protocol applicable to a wide range of Low
  Power and Lossy Networks.  To enable this wide applicability, RPL
  provides many configuration options and gives implementers choices on
  how to implement various components of RPL.  Drawing on our
  experiences, we distill the design choices and configuration
  parameters that lead to efficient RPL implementations and operations.

The IETF Secretariat

---

From: JP Vasseur <[email-masked]>
Date: Sun, 11 Mar 2012 11:13:06 +0100

New Agenda:

Agenda/admin (Chairs - 5mn) [5]

1) WG Status (Chairs - 15 mn) [20]

2) The Minimum Rank with Hysteresis Objective Function
draft-ietf-roll-minrank-hysteresis-of-06 - (Phil Levis - 5mn) [25]

3) Recommendations for Efficient Implementation of RPL (Phil - 5mn) [30]
draft-gnawali-roll-rpl-recommendations-03

4) "Applicability Statement for the Routing Protocol for Low Power and Lossy
Networks (RPL) in AMI Networks" - draft-ietf-roll-applicability-ami-05
(TBD - 10mn) [40]

5) Update on P2P (Emmanuel - 15mn) [55]
* Update on the RPL P2P Work
* Updated on draft-ietf-roll-p2p-measurement-02

6) Multicast requirements for control over LLN (Peter van der stok - 10mn) [65]
- draft-vanderstok-roll-mcreq-00

7) Experiences with RPL: IPv6 Routing Protocol for Low power and Lossy
Networks - draft-clausen-lln-rpl-experiences-01 (Thomas - 10mn) [75]

8) Discussion on Security - 45 mn (Discussion led by Michael) [120]
draft-dvir-roll-security-authentication (Amit - 10mn)
draft-alexander-roll-amikey-lln-key-mgmt (Roger Alexander - 10mn)
draft-qiu-roll-kemp-00 (QIU Ying - 10mn)
Open Mic: 15mn

JP.

On Mar 11, 2012, at 2:36 AM, Omprakash Gnawali wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Wed, 14 Mar 2012 06:14:23 +0100

Hi,

I read your draft. We have done some tests with TinyRPL (RPL implementation
in TinyOS) in container filled with fruits.
In one test, we had a situation that the border router (RPL root node) was
disconnected for several hours. The sensor nodes start sending DIS
(DIS-INTERVAL was set to 3 sec for this test). We found that this degrades
the use of  battery voltage. One alternative is to use a higher value for
DIS-INTERVAL.

In real deployment, the RPL root node should setup at the last, after
loading all the sensors. 

I would like to know ->

Why is DIS sending at a constant interval (I am not sure this is set
constant only in the implementation)? Should it be adaptive if it does not
receive a DIO? 
Is this an issue ("setting of DIS INTERVAL for different cases") that your
draft should address?

Kind regards

Koojana  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Omprakash Gnawali
> Sent: Sunday, March 11, 2012 2:36 AM
> To: ROLL WG
> Subject: [Roll] Fwd: New Version Notification for draft-gnawali-roll-
> rpl-recommendations-03.txt
> 
> Dear ROLL WG,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 16 Mar 2012 09:52:49 +0100

Hello Koojana  

I hope you're doing well : )

In your case an exponential backoff seems to make a lot of sense.

There is work about DIS tuning in http://tools.ietf.org/html/draft-goyal-roll-dis-modifications-00 

Maybe you can contribute?

Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Koojana Kuladinithi
Sent: mercredi 14 mars 2012 06:14
To: 'ROLL WG'; 'Omprakash Gnawali'
Subject: Re: [Roll] Fwd: New Version Notificationfor draft-gnawali-roll-rpl-recommendations-03.txt

Hi,

I read your draft. We have done some tests with TinyRPL (RPL implementation in TinyOS) in container filled with fruits.
In one test, we had a situation that the border router (RPL root node) was disconnected for several hours. The sensor nodes start sending DIS (DIS-INTERVAL was set to 3 sec for this test). We found that this degrades the use of  battery voltage. One alternative is to use a higher value for DIS-INTERVAL.

In real deployment, the RPL root node should setup at the last, after loading all the sensors. 

I would like to know ->

Why is DIS sending at a constant interval (I am not sure this is set constant only in the implementation)? Should it be adaptive if it does not receive a DIO? 
Is this an issue ("setting of DIS INTERVAL for different cases") that your draft should address?

Kind regards

Koojana  

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Omprakash Gnawali
> Creation date:   2012-03-10 WG ID:           Individual Submission 
> Number of pages: 6
> 
> Abstract:

---

From: Philip Levis <[email-masked]>
Date: Fri, 16 Mar 2012 08:29:41 -0700

> Maybe you can contribute?

Well, to be precise, the above document is not at all about DIS tuning; it's about tuning the responses to DIS messages.

That being said, it's probably useful to engage the TinyRPL developers to ask about their choice of DIS timing, and also ask other developers.

Phil

---

From: JeongGil Ko <[email-masked]>
Date: Fri, 16 Mar 2012 17:12:28 -0400

Koojana,

In terms of why the DIS is sent at different intervals is rather simple to explain. A Trickle Timer is typically used when the network is stable and nothing needs to happen. At least this is the philosophy I tried to follow when implementing TinyRPL. However, when a node is NOT connected, this indicates that the network is not stable AT ALL. Therefore, it should try to aggressively find a next hop node rather than to save power. The goal of the node should be, at this point, to connect to a DODAG. 

Furthermore, it is not really necessary to install the root last in a RPL deployment. I don't see why this HAS TO be the case. If you install the root first, then nodes will quickly connect to the network and the Trickle Timer for DIO packets will start operating. 

Thanks!

-John

------
JeongGil Ko
Ph.D. Candidate
Department of Computer Science
Johns Hopkins University
http://www.cs.jhu.edu/~jgko

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Mon, 19 Mar 2012 07:13:09 +0100

Hi John,

> 
> Koojana,
> 
> In terms of why the DIS is sent at different intervals is rather simple
> to explain. A Trickle Timer is typically used when the network is
> stable and nothing needs to happen. At least this is the philosophy I
> tried to follow when implementing TinyRPL. However, when a node is NOT
> connected, this indicates that the network is not stable AT ALL.
> Therefore, it should try to aggressively find a next hop node rather
> than to save power. The goal of the node should be, at this point, to
> connect to a DODAG.
>

[koo] Yes
 
> Furthermore, it is not really necessary to install the root last in a
> RPL deployment. I don't see why this HAS TO be the case. 

[koo] Unfortunately, this is not the case for our scenario in reality. E.g.,
Fruits will be placed in boxes together with sensor nodes (at the field) and
will be loaded to a container (at the harbor) later. The DODAG root (the BR)
will be attached to the container. Until the sensor nodes see any reachable
DODAG root, it may takes 1 - 2 days. 
Therefore, the sending of DIS messages periodically is not a good option.

As Pascal pointed out, the use of exponential back-off would be an
alternative to reduce numbers of DIS generated. I am not very familiar with
RPL draft. I think, there is no possibility to let a sensor node know to
trigger sending of DIS messages after a certain time. This may helpful for
some scenarios like ours to save the power during the setup time. 

Thanks

Koojana

If you install
> the root first, then nodes will quickly connect to the network and the
> Trickle Timer for DIO packets will start operating.
> 
> Thanks!
> 
> -John
> 
> ------
> JeongGil Ko
> Ph.D. Candidate
> Of