Subject: Re: [Roll] New Version Notification - draft-ietf-roll-minrank-hysteresis-of-07.txt

From: Philip Levis <[email-masked]>
Date: Fri, 9 Mar 2012 10:09:55 -0800

On Mar 9, 2012, at 10:04 AM, [email-masked] wrote:

> New version (-07) has been submitted for draft-ietf-roll-minrank-hysteresis-of-07.txt.
> http://www.ietf.org/internet-drafts/draft-ietf-roll-minrank-hysteresis-of-07.txt
> 
> 
> Diff from previous version:
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-roll-minrank-hysteresis-of-07
> 
> IETF Secretariat.
> 

Significant changes:

1. Reworded Rank calculation text so it is clearly max(calculated Rank, (advertised Rank + MinHopRankIncrease))

2. Clarified "Rank associated with path" to "Rank calculated for path"

3. Added note about how case 3 of Rank advertisement places a tradeoff between parent set size and Rank advertisement precision

4. Clarified text about the ETX case based on feedback: this added some BOLD requirements; feedback greatly appreciated.

Phil

---

From: Philip Levis <[email-masked]>
Date: Fri, 16 Mar 2012 14:29:15 -0700

On Mar 16, 2012, at 1:44 PM, Matteo Paris wrote:

> 
> Hi Phil.  These changes were helpful.  But I am still unclear on the rank computation in section 3.3.  From the RPL draft:
> 
>  RPL Section 3.5.1:  "DAGRank(rank) = floor(rank/MinHopRankIncrease)"
>  RPL Section 3.5.1:  "A node A has a rank less than the rank of a node B if DAGRank(A) is less than DAGRank(B)."
>  RPL Section 3.5.2:  "[F]or a node N, all parents in the DODAG parent set must be of rank less than DAGRank(N)."
>  RPL Section 8.2.1:  "A node's rank MUST be greater than all elements of its DODAG parent set."
> 
> The rank computation in MRHOF section 3.3 can result in parents P for which DAGRank(P) is not less than DAGRank(N),
> which would seem to violate the third and fourth clauses above, given the definitions in the first two clauses.

How? I intended case 2 in 3.3 to cover this. Can you explain the edge case you see where it does not?

> 
> One other minor question.  In the sentence, "The second case covers requirement 4..." of MRHOF section 3.3, do you mean requirement 5?

Yes! It should be requirement 5. I will fix this in the next revision. Thank you for catching it.

Phil