Subject: Re: [Roll] MRHOF Objective function (using ETX metric)

From: "Peter Burnett" <[email-masked]>
Date: Thu, 1 Mar 2012 16:42:33 -0000

Another related difficulty for me is that section 3.3 seems to say that the
rank of a non-root node is the path cost through the worst parent. However
3.4 says that the advertised rank is the path cost through the preferred
parent, the min_path_cost. How can these be reconciled?

Thanks

Peter Burnett

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dario Tedeschi
Sent: 01 March 2012 06:26
To: [email-masked]
Subject: Re: [Roll] MRHOF Objective function (using ETX metric)

Yes, how exactly is MinHopRankIncrease used for rank calculation in MRHOF?

In the case of using the ETX metric, could it be something like the
following:
my_rank = cur_min_path_cost = parent_rank + (MinHopRankIncrease * {ETX of
link with parent})
Where MinHopRankIncrease = 128.

Please could someone clarify.

Dario

On 12-02-21 12:17 PM, Costin Michaela Catalina-B06063 wrote: 

Hello guys,

While reading MRHOF draft (for ETX metric),  I identified some discrepancies
between the RPL and the MRHOF draft:

The rank of a DODAG root according to ROLL RPL draft is MinHopRankIncrease
(default value = 0x100). According to MRHOF,  the rank of the DODAG root is
MIN_PATH_COST (default value = 0)

The algorithm for computing node rank is not clearly described in the MRHOF
draft. Once the path cost for all neighbors is computed and the preferred
parent is selected, the node rank is calculated just by adding
MinHopRankIncrease to the smallest path cost (to the preferred parent path
cost)?

Do you have any comments related to these issues?

Thanks,

Catalina Costin
Freescale Semiconductor Romania
Phone: +40 21 3052217
[email-masked]
=======================================================
This e-mail, and any associated attachments have been classified as:
[x] Public
[  ] Freescale Semiconductor Internal Use Only
[  ] Freescale Semiconductor Confidential Proprietary

 
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Sun, 4 Mar 2012 15:45:50 -0800

On Feb 21, 2012, at 2:17 AM, Costin Michaela Catalina-B06063 wrote:

> Hello guys,
>  
> While reading MRHOF draft (for ETX metric),  I identified some discrepancies between the RPL and the MRHOF draft:
> ·         The rank of a DODAG root according to ROLL RPL draft is MinHopRankIncrease (default value = 0x100). According to MRHOF,  the rank of the DODAG root is MIN_PATH_COST (default value = 0)

This is an error -- the RPL specification is correct.

> ·         The algorithm for computing node rank is not clearly described in the MRHOF draft. Once the path cost for all neighbors is computed and the preferred parent is selected, the node rank is calculated just by adding MinHopRankIncrease to the smallest path cost (to the preferred parent path cost)?

No -- it is rank calculated the preferred parent path cost. MinHopRankIncrease sets a minimum value it must increase by. So if the node's Rank is less than its worst parent + MinHopRankIncrease, then its Rank is worst parent + MinHopRankIncrease.

I'm clearing these things up in -05; I greatly appreciate the pointers and questions.

Phil

---

From: Philip Levis <[email-masked]>
Date: Sun, 4 Mar 2012 15:47:23 -0800

On Mar 1, 2012, at 8:42 AM, Peter Burnett wrote:

> Another related difficulty for me is that section 3.3 seems to say that the rank of a non-root node is the path cost through the worst parent. However 3.4 says that the advertised rank is the path cost through the preferred parent, the min_path_cost. How can these be reconciled?

The first is correct. I'm fixing this in -05, thanks for catching it.

Phil

---

From: Costin Michaela Catalina-B06063 <[email-masked]>
Date: Tue, 6 Mar 2012 12:09:18 +0000

Hello Phil,

  Thanks for updating the draft!

Now, regarding the PARENT_SWITCH_THRESHOLD parameter:
  1. in chapter 5 the PARENT_SWITCH_THRESHOLD is defined as the difference between two metrics
  2. in chapter 3.2 the PARENT_SWITCH_THRESHOLD parameter is seen as a difference between two path costs.

We need to clarify how we are going to use it based on the method used for computing the rank (whether we use the best parent or worst parent in rank calculation).

Catalina Costin

-----Original Message-----
From: Philip Levis [mailto:[email-masked]] 
Sent: Monday, March 05, 2012 1:46 AM
To: Costin Michaela Catalina-B06063
Cc: [email-masked]
Subject: Re: [Roll] MRHOF Objective function (using ETX metric)

On Feb 21, 2012, at 2:17 AM, Costin Michaela Catalina-B06063 wrote:

> *         The rank of a DODAG root according to ROLL RPL draft is MinHopRankIncrease (default value = 0x100). According to MRHOF,  the rank of the DODAG root is MIN_PATH_COST (default value = 0)

> *         The algorithm for computing node rank is not clearly described in the MRHOF draft. Once the path cost for all neighbors is computed and the preferred parent is selected, the node rank is calculated just by adding MinHopRankIncrease to the smallest path cost (to the preferred parent path cost)?

Phil

---

From: Philip Levis <[email-masked]>
Date: Tue, 6 Mar 2012 08:05:00 -0800

> We need to clarify how we are going to use it based on the method used for computing the rank (whether we use the best parent or worst parent in rank calculation).

Catalina -- thanks for the catch. In making the edits for -05 it became clear to me that the document needs a good editing pass to clean up inconsistencies like these that have creeped in (as well as a few inconsistencies with the RPL specification). I'll add this to the list for a -06.

Phil