Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-08.txt

From: [email-masked]
Date: Fri, 02 Mar 2012 06:24:56 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : Reactive Discovery of Point-to-Point Routes in Low Power and Lossy Networks
	Author(s)       : Mukul Goyal
                          Emmanuel Baccelli
                          Matthias Philipp
                          Anders Brandt
                          Jerald Martocci
	Filename        : draft-ietf-roll-p2p-rpl-08.txt
	Pages           : 30
	Date            : 2012-03-02

   This document specifies a point-to-point route discovery mechanism,
   complementary to the RPL core functionality.  This mechanism allows
   an IPv6 router to discover "on demand" routes to one or more IPv6
   routers in the LLN such that the discovered routes meets specified
   metrics constraints.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-roll-p2p-rpl-08.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-p2p-rpl-08.txt

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 3 Mar 2012 16:23:02 -0600 (CST)

Hi all,

The main changes in P2P-RPL-08 over the previous version are as follows:

1) allow P2P-RPL to discover routes to multiple targets at the same time:
    - The target address in P2P-RDO can specify either a unicast address or a multicast one.
    - Additional target addresses (unicast or multicast) can be specified by including one or more RPL Target options inside the P2P mode DIO.

2) Defined a new Data option to piggyback time-critical application data in DIOs and DROs. The origin (the target) can include one or more Data Options inside the DIO (DRO) to deliver time-critical application data to the targets (origin).

3) The origin now explicitly states in the P2P-RDO whether the target(s) should generate DRO replies or not. Removed the Direction flag from the P2P-RDO.

4) Made it clear that on receiving a DRO with stop flag set, a router should not send or receive any more DIOs for this temporary DAG. The router should continue to process DROs and maintain its membership in the temporary DAG until its life time is over.

5) Allow the inclusion of Route Information and Prefix Information options inside a P2P mode DIO.

Thanks
Mukul

----- Original Message -----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Sent: Friday, March 2, 2012 8:24:56 AM
Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-08.txt

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Mon, 05 Mar 2012 15:35:47 -0500

>>>>> "Mukul" == Mukul Goyal <[email-masked]> writes:
    Mukul> Hi all,

    Mukul> The main changes in P2P-RPL-08 over the previous version are
    Mukul> as follows:

    Mukul> 1) allow P2P-RPL to discover routes to multiple targets at
    Mukul> the same time: - The target address in P2P-RDO can specify
    Mukul> either a unicast address or a multicast one.  

When it's a multicast address, is the idea that all stations which are
member of that group respond?   Or 

Also, a question about:
      "upto four source"

why the number four?

How does a sender know how to send time-critical messages to the target
if the target doesn't send back DROs:
  "By not allowing the generation of DRO messages,
   an origin can use P2P-RPL as purely a mechanism to deliver time-	
   critical application data to the target(s)."

I'm guessing that the info is piggy backed into the RPL message itself,
using these Data Options.  Do we need to specify what is in these Data
Options?  (My opinion... it's an IPv6 Upper-Layer Protocol...)

re the H-flag:
   The origin sets this flag to 1 if it desires hop-by-hop routes.	
   The origin sets this flag to 0 if it desires source routes.  

It might be worth giving an example of each.
I think I'm not sure what a hop-by-hop route is, exactly.

Your glossary says:
   Hop-by-hop Route: The route characterized by each router on the route
   using its routing table to determine the next hop on the route.

but I think that I don't understand what's going on.  
I'm not sure I know how to use this information on the origin node.
Well... wait... is this only useful for storing nodes?

maybe I need to read: I-D.ietf-6man-rpl-option , which I haven't yet.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 5 Mar 2012 16:13:18 -0600 (CST)

[Michael]

[Mukul]
Any node that belongs to the multicast group and receives the DIO. There is no guarantee that all nodes in the multicast group would received the DIO.

[Michael]
      "upto four source"
why the number four?

[Mukul]
Because we have just 2 bits available for the purpose. Redundant source routes are mighty useful in many scenarios.
 
[Michael]

[Mukul]
Yes, the data is piggy backed on RPL message itself via Data Options. I think we need not specify whats inside the data options. RPL would simply pass the contents to the higher layer. Its the higher layer's headache to interpret this information.

[Michael] 
re the H-flag:

Your glossary says:

[Mukul]
Indeed the hop-by-hop route would require the use of RPL option to specify the RPLInstanceID of the route. A router would use:
1) RPLInstanceID
2) Source IPv6 Address (since RPLInstanceID will be a local value)
3) Destination IPv6 Address
to identify the next hop for the packet.

Thanks
Mukul

----- Original Message -----
From: "Michael Richardson" <[email-masked]>
To: "roll" <[email-masked]>
Cc: "Mukul Goyal" <[email-masked]>
Sent: Monday, March 5, 2012 2:35:47 PM
Subject: Re: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-08.txt

    Mukul> Hi all,

Also, a question about:
      "upto four source"

why the number four?

re the H-flag:

Your glossary says: