Subject: Re: [Roll] Scalability of P2P-RPL

From: Mukul Goyal <[email-masked]>
Date: Thu, 5 Apr 2012 00:01:17 -0500 (CDT)

Hi Ulrich

[cedric]
>
> As discussed today during the meeting, numbers need to be placed given a
> particular context.
> So, if we put explicitly "4-5 hops" in the requirements, this has to be in
> regards to the total number of nodes, the topology, the technology used, the
> environment, and other numerous parameters that could justify this "4-5"
> value for a particular case.

[Ulrich]
I am aware that the precise number of hops depends on a number of
things. However, I think it should be spelled out that the draft has
limitations in terms of scope and is not always applicable in general
LLNs of thousands of nodes (at least that's what I infer from the talk
yesterday).

[Mukul]
I dont think what you are suggesting is correct. P2P routes are likely to be better than global DAG based routes when origin and target are only few hops away. As the distance between origin and target increases, P2P routes are likely to be only marginally better than global-DAG-based routes (P2P routes possibly have the advantage that they avoid congested region near the DAG root). But, P2P-RPL can certainly be used in an LLN of thousands of nodes. Just limit the scope of discovery appropriately. Infact, I would argue that P2P-RPL would work very well in an LLN of thousands of nodes because:
1) you can limit the scope of discovery;
2) trickle based propagation of discovery messages allows you to control the pace of spread of discovery messages.

[Cedric]
> So people working over the 2.4 Ghz may use the 4-5 hops boundary, whereas
> people running over sub Ghz may be happy within a single hop boundary.

[Ulrich]
Sure, I never doubted that depending on the link layer / the topology
/ the traffic patterns etc there are differences in scope. I just
request to add one sentence to make it clear to the reader what the
applicability of the draft is.

[Mukul]
The draft's applicability is certainly not restricted by the size of the network. It is reactive route discovery protocol with a great level of control over how you want to discover routes.

[cedric]
>
> There is a section in the P2P draft that is quite generic, so applicable to
> most of the use case,
> and shed some light on the tradeoff regarding using
> or not the P2P extension, and limit the scope of the flooding :
>
> A network designer may take into consideration both the benefits
> (potentially better routes;
> no need to maintain routes proactively) and costs (control messages
> generated during the route discovery process) when using P2P-RPL.
>
>
> We may expand this sentence to be more precise on the flooding region.
>
> What do you think ?

[Ulrich]
That can be done. But I also think that the Use Cases section should
be more specific in which scenarios the draft can be used.

[Mukul]
What do you have in mind? The use cases section already lists the key scenarios we had in mind while designing this protocol.
 
[cedric]
>
> I think numbers are always dangerous in documents that need to be frozen at
> some point.

[Ulrich]
I do not insist on fixed numbers, I am aware that the number 4 or 5
was just named as example. But it was clear from them that the draft
is limited to small-size networks ...

[Mukul]
I certainly object to this characterization.

[Ulrich]
(or at least close peers in a larger
network). 

[Mukul]

Look, there are two different questions:
1) can P2P-RPL be used to discover route to a far away target?
2) would such route be much better than the route along a global dag?

The answer to first question is "absolutely yes" and that to second question is "probably not (if the root's neighborhood is not congested) and probably yes (if the root's neighborhood is congested)".

Thanks
Mukul

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 8 Apr 2012 11:13:05 -0500 (CDT)

Hi JP, Richard

Should this be made a ticket? This is the only comment for which we dont have a ticket yet.

Thanks
Mukul

----- Original Message -----
From: "Mukul Goyal" <[email-masked]>
To: "Ulrich Herberg" <[email-masked]>
Cc: "roll WG" <[email-masked]>
Sent: Thursday, April 5, 2012 12:01:17 AM
Subject: Re: [Roll] Scalability of P2P-RPL

Hi Ulrich

[cedric]

[Ulrich]

[Mukul]

[Cedric]

[Ulrich]

[Mukul]

[cedric]

[Ulrich]

[Mukul]
 
[cedric]

[Ulrich]

[Mukul]

[Ulrich]

[Mukul]

Thanks
Mukul

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll