Subject: [Roll] MRHOF draft-09 comments

From: Federico Consoli <[email-masked]>
Date: Mon, 23 Apr 2012 10:11:04 +0200

Hi, I'm sorry but I think that it's still wrong. I think that you missed 
the "MRHOF draft-07 comments" post where you said:

"I think the issue here is the MRHOF draft is not clear: A (a root) 
should advertise a Rank of 256, and B, following 3.3, would advertise a 
Rank of 256 + MinHopRankIncrease (case 3 of 3.3)."

Infact now:
MHROF-09 section 6.1
"RPL's Rank advertisement rules can require a DODAG Root to advertise a 
Rank higher than its corresponding ETX value, as a DODAG Root advertises 
a Rank of MinHopRankIncrease. "

That it's correct.

But
MHROF-09 Section 3.4
" DODAG Roots advertise a metric value which computes to a cost of 
MIN_PATH_COST."
And
MHROF-09 Section 5.
" MIN_PATH_COST: 0. At root, the expected transmission count is 0."

I think that to be compliant with 6.1. MIN_PATH_COST variable should be 
removed and "DODAG Roots advertise a metric value which computes to a 
cost of MinHopRankIncrease".

-- 
Regards
Consoli Federico

---

From: Philip Levis <[email-masked]>
Date: Mon, 23 Apr 2012 10:23:16 -0700

On Apr 23, 2012, at 1:11 AM, Federico Consoli wrote:

> Hi, I'm sorry but I think that it's still wrong. I think that you missed the "MRHOF draft-07 comments" post where you said:
> 
> "I think the issue here is the MRHOF draft is not clear: A (a root) should advertise a Rank of 256, and B, following 3.3, would advertise a Rank of 256 + MinHopRankIncrease (case 3 of 3.3)."
> 
> Infact now:
> MHROF-09 section 6.1
> "RPL's Rank advertisement rules can require a DODAG Root to advertise a Rank higher than its corresponding ETX value, as a DODAG Root advertises a Rank of MinHopRankIncrease. "
> 
> That it's correct.
> 
> But
> MHROF-09 Section 3.4
> " DODAG Roots advertise a metric value which computes to a cost of MIN_PATH_COST."
> And
> MHROF-09 Section 5.
> I think that to be compliant with 6.1. MIN_PATH_COST variable should be removed and "DODAG Roots advertise a metric value which computes to a cost of MinHopRankIncrease".

I think these edits are the best resolution to the MinHopRankIncrease/DODAG metric issue. If there are no objections then I will apply them in the (hopefully final) edit. Federico, your detailed feedback has be invaluable. Thank you.

Phil

---

From: Federico Consoli <[email-masked]>
Date: Tue, 24 Apr 2012 09:54:40 +0200

Il 23/04/2012 19.23, Philip Levis ha scritto:
>> "RPL's Rank advertisement rules can require a DODAG Root to advertise a Rank higher than its corresponding ETX value, as a DODAG Root advertises a Rank of MinHopRankIncrease."
>>
>> That it's correct.
>>
>> But
>> MHROF-09 Section 3.4
Hi,
I got no objections. You're Welcome.

-- 
Regards
Consoli Federico