Subject: [Roll] I-D Action: draft-ietf-roll-minrank-hysteresis-of-08.txt

From: [email-masked]
Date: Fri, 20 Apr 2012 20:50:03 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : The Minimum Rank with Hysteresis Objective Function
	Author(s)       : Omprakash Gnawali
                          Philip Levis
	Filename        : draft-ietf-roll-minrank-hysteresis-of-08.txt
	Pages           : 13
	Date            : 2012-04-20

   The Routing Protocol for Low Power and Lossy Networks (RPL) uses
   objective functions to construct routes that optimize or constrain
   the routes it selects and uses.  This specification describes the
   Minimum Rank with Hysteresis Objective Function (MRHOF), an objective
   function that selects routes that minimize a metric, while using
   hysteresis to reduce churn in response to small metric changes.
   MRHOF works with metrics that are additive along a route, and the
   metric it uses is determined by the metrics RPL Destination
   Information Object (DIO) messages advertise.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-roll-minrank-hysteresis-of-08.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-minrank-hysteresis-of-08.txt

---

From: Philip Levis <[email-masked]>
Date: Sat, 21 Apr 2012 08:53:58 -0700

> 	Filename        : draft-ietf-roll-minrank-hysteresis-of-08.txt

Om and I have submitted a version of the draft (-08) that now addresses all of the comments that arose during IETF last call, including:

- Clear Rank vs DAGRank confusion cleared through a note in the
terminology section

- A node setting its Rank to next higher Integral Rank rather than
plus one of the parent's Rank

Phil

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Apr 2012 09:53:38 -0400

http://tools.ietf.org/rfcdiff?url1=draft-ietf-roll-minrank-hysteresis-of-07&difftype=--html&submit=Go%21&url2=draft-ietf-roll-minrank-hysteresis-of-09

This shows differences between -07 and -08/-09.

80% of the differences are due to ietf-roll-routing-metrics becoming
RFC6551, and this is in 08 to 09 mostly.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.