Subject: [Roll] [roll] #94: Why does DRO travel by multicast.

From: "roll issue tracker" <[email-masked]>
Date: Thu, 05 Apr 2012 11:01:53 -0000

#94: Why does DRO travel by multicast.

 Resolution: Because we want the stop flag in DRO to reach as many nodes as
 possible.

 Discussion:

 p14 :  A DRO message travels from the target to the origin via link-local
 multicast along the
   route specified inside the Address vector in the P2P-RDO.

 [Cedric]
 Why using multicast if you know every destinators ?
 Could we unicast packets to each destinators in the address vector ?

 [Mukul]
 DRO travels by link local multicast so that the nodes, that are on the
 temporary DAG but not necessarily on a discovered route, may know that the
 route discovery is over (via the stop flag) and there is no need to
 generate any more DIOs. This may lead to a significant reduction in the
 (unnecessary) DIOs generated. Only the routers on the discovered route do
 the multicast-based forwarding though.

-- 
-----------------------------------+---------------------
 Reporter:  jpv@…                  |      Owner:  mukul@…
     Type:  defect                 |     Status:  new
 Priority:  major                  |  Milestone:
Component:  p2p-rpl                |    Version:
 Severity:  Submitted WG Document  |   Keywords:
-----------------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/94>
roll <http://tools.ietf.org/wg/roll/>

---

From: C Chauvenet <[email-masked]>
Date: Thu, 5 Apr 2012 14:20:08 +0000

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker
Envoyé : jeudi 5 avril 2012 13:02
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Roll] [roll] #94: Why does DRO travel by multicast.

 Resolution: Because we want the stop flag in DRO to reach as many nodes as  possible.

 Discussion:

 p14 :  A DRO message travels from the target to the origin via link-local  multicast along the
   route specified inside the Address vector in the P2P-RDO.

 [Cedric]

 [Mukul]
 DRO travels by link local multicast so that the nodes, that are on the  temporary DAG but not necessarily on a discovered route, may know that the  route discovery is over (via the stop flag) and there is no need to  generate any more DIOs. This may lead to a significant reduction in the
 (unnecessary) DIOs generated. Only the routers on the discovered route do  the multicast-based forwarding though.

[Cedric2]
Makes sense, thank's for clarification.
This ticket can be closed.

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 11 Apr 2012 18:23:59 -0500 (CDT)

Resolution:
--------------
 Because we want the stop flag in DRO to reach as many nodes as  possible.

Discussion:
---------------

 [Cedric]

 [Mukul]

[Cedric2]

---

From: "roll issue tracker" <[email-masked]>
Date: Fri, 13 Apr 2012 13:33:24 -0000

Changes (by jpv@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Resolution:
 --------------

 Discussion:
 ---------------

 [Cedric]

 [Mukul]

 [Cedric2]
 ______________________

-- 
-----------------------------------+----------------------
 Reporter:  jpv@…                  |       Owner:  mukul@…
     Type:  defect                 |      Status:  closed
 Priority:  major                  |   Milestone:
Component:  p2p-rpl                |     Version:
 Severity:  Submitted WG Document  |  Resolution:  fixed
 Keywords:                         |
-----------------------------------+----------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/94#comment:1>
roll <http://tools.ietf.org/wg/roll/>