Subject: Re: [Roll] [roll] #86: G flag: do we need that text?

From: Michael Richardson <[email-masked]>
Date: Wed, 04 Apr 2012 12:28:08 -0400

I think we need to determine what a grounded DODAG is.
Does it mean that a node announcing such a thing is attached to the Internet? (In which case P2P usage should G=0)
Or does it mean that a node is attached to the resource named in the DIO? (In which case origin P2P should G=1)

Richard Kelsey <[email-masked]> wrote:

>> Date: Wed, 4 Apr 2012 08:54:52 -0500
>> From: Mukul Goyal <[email-masked]>
>> 
>> >The G flag is 0 if and only if the DODAG is floating.
>> 
>> I think that the G flag is 1 if and only if the DODAG is grounded.
>
>I agree.  G = 0 means floating, G = 1 means grounded.
>
>> The temporary DAGs used in P2P-RPL are not grounded, they are
>> temporary. I think that all transient/temporary DAGs are
>> floating by their very nature.
>
>This I don't follow at all.  If a device has a temporary need to
>send or receive data from many other devices, it makes perfect
>sense for it to create a a temporary, grounded DODAG.  If there
>is a lot of P2P traffic, it makes perfect sense to have permanent,
>floating DODAGs for routing that traffic.  
>
>                                         -Richard Kelsey
>
>> ----- Original Message -----
>> From: "Richard Kelsey" <[email-masked]>
>> To: [email-masked]
>> Cc: [email-masked], [email-masked], [email-masked]
>> Sent: Wednesday, April 4, 2012 8:36:50 AM
>> Subject: Re: [Roll] [roll] #86: G flag: do we need that text?
>> 
>> > From: roll issue tracker <[email-masked]>
>> > Date: Wed, 4 Apr 2012 13:08:50 +0000
>> > 
>> > #86: G flag: do we need that text?
>> > 
>> >  Problem (resolition is proposed)
>> >  ------------------------------
>> >  Disagreement on the meaning of 'G' bit and imposed setting to 0;
>> > 
>> >  Proposed resolution
>> >  ---------------------------
>> >  The origin sets the G flag based on its perception of whether joining
>> >  how the flag's value would affect the rank calculation under the OF
>> >  being used. By default, the G flag is set to zero given the temporary
>> >  nature of the DAG being created.
>> 
>> I disagree with the proposed resolution.  It adds needless
>> confusion.  The G flag is 0 if and only if the DODAG is floating.
>> There is no point to allowing floating DODAGs with a P2P-RDO
>> option.  I suggest that the G bit be set to 1 and that routers be
>> explicitly prohibited from creating floating DODAGs with a
>> P2P-RDO option.
>>                                    -Richard Kelsey
>> 
>_______________________________________________
>Roll mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Wed, 4 Apr 2012 14:49:04 -0700

> Or does it mean that a node is attached to the resource named in the DIO? (In which case origin P2P should G=1)

The text in 6550 is pretty clear: 

   Goal: The Goal is an application-specific goal that is defined
         outside the scope of RPL.  Any node that roots a DODAG will
         need to know about this Goal to decide whether or not the Goal
         can be satisfied.  A typical Goal is to construct the DODAG
         according to a specific Objective Function and to keep
         connectivity to a set of hosts (e.g., to use an Objective
         Function that minimizes a metric and is connected to a specific
         database host to store the collected data).

   Grounded: A DODAG is grounded when the DODAG root can satisfy the
         Goal.

   Floating: A DODAG is floating if it is not grounded.  A floating
         DODAG is not expected to have the properties required to
         satisfy the goal.  It may, however, provide connectivity to
         other nodes within the DODAG.

The common case of the Goal is "has connectivity to the Internet" but that's not the only case. I think given the Goal for P2P traffic, I agree with Pascal and Richard that it should be 1.

Phil