Subject: [Roll] [roll] #92: Is it possible to make P2P-RPL independent of trickle algorithm

From: "roll issue tracker" <[email-masked]>
Date: Thu, 05 Apr 2012 11:00:28 -0000

#92: Is it possible to make P2P-RPL independent of trickle algorithm

 Discussion:

 [Cedric]
 Another point that has been discussed today during the ROLL meeting, is
 that some people may find other mechanisms than trickle more efficient to
 flood the RDO.
 Could we let the door opened to other flooding optimization mechanism, or
 explicitly say that the trickle mechanism MUST be used ?

 [Mukul]
 I think inherent dependence on the trickle mechanism is apparent because
 of the fact that the route discovery takes place by forming a temporary
 DAG. DAG creation (or DIO generation) depends on trickle algorithm. So,
 P2P-RPL also depends on trickle algorithm. P2P-RPL being an extension of
 core RPL, I dont think there is a way to separate P2P-RPL from trickle
 algorithm.

-- 
-----------------------------------+---------------------
 Reporter:  jpv@…                  |      Owner:  mukul@…
     Type:  defect                 |     Status:  new
 Priority:  major                  |  Milestone:
Component:  p2p-rpl                |    Version:
 Severity:  Submitted WG Document  |   Keywords:
-----------------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/92>
roll <http://tools.ietf.org/wg/roll/>

---

From: C Chauvenet <[email-masked]>
Date: Thu, 5 Apr 2012 13:33:14 +0000

See inline.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker
Envoyé : jeudi 5 avril 2012 13:00
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Roll] [roll] #92: Is it possible to make P2P-RPL independent of trickle algorithm

 Discussion:

 [Cedric]
 Another point that has been discussed today during the ROLL meeting, is  that some people may find other mechanisms than trickle more efficient to  flood the RDO.
 Could we let the door opened to other flooding optimization mechanism, or  explicitly say that the trickle mechanism MUST be used ?

 [Mukul]
 I think inherent dependence on the trickle mechanism is apparent because  of the fact that the route discovery takes place by forming a temporary  DAG. DAG creation (or DIO generation) depends on trickle algorithm. So,  P2P-RPL also depends on trickle algorithm. P2P-RPL being an extension of  core RPL, I dont think there is a way to separate P2P-RPL from trickle  algorithm.

[Cedric2]
Fine. If this is needed for RPL compliancy, then I agree.

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Thu, 5 Apr 2012 08:56:15 -0500 (CDT)

Ticket resolved.

Resolution text: P2P-RPL, being an extension of core RPL, cannot be separated from trickle algorithm.

Thanks
Mukul 

----- Original Message -----
From: "C Chauvenet" <[email-masked]>
To: [email-masked], [email-masked], [email-masked]
Sent: Thursday, April 5, 2012 8:33:14 AM
Subject: RE: [Roll] [roll] #92: Is it possible to make P2P-RPL independent of trickle algorithm

See inline.

-----Message d'origine-----

 Discussion:

 [Cedric]

 [Mukul]

[Cedric2]

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 8 Apr 2012 11:11:13 -0500 (CDT)

Hi JP, Richard

Please mark this ticket as closed.

Thanks
Mukul

----- Original Message -----
From: "C Chauvenet" <[email-masked]>
To: [email-masked], [email-masked], [email-masked]
Sent: Thursday, April 5, 2012 8:33:14 AM
Subject: RE: [Roll] [roll] #92: Is it possible to make P2P-RPL independent of trickle algorithm

See inline.

-----Message d'origine-----

 Discussion:

 [Cedric]

 [Mukul]

[Cedric2]

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 11 Apr 2012 18:29:30 -0500 (CDT)

Resolution:
----------------
No. P2P-RPL depends on DAG creation for route discovery which inturn inherently depends on trickle algorithm.

Discussion:
-----------------

 [Cedric]

 [Mukul]

[Cedric2]

---

From: "roll issue tracker" <[email-masked]>
Date: Fri, 13 Apr 2012 13:32:14 -0000

Changes (by jpv@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Resolution:
 ----------------
 No. P2P-RPL depends on DAG creation for route discovery which inturn
 inherently depends on trickle algorithm.

 Discussion:
 -----------------

 [Cedric]

 [Mukul]

 [Cedric2]

-- 
-----------------------------------+----------------------
 Reporter:  jpv@…                  |       Owner:  mukul@…
     Type:  defect                 |      Status:  closed
 Priority:  major                  |   Milestone:
Component:  p2p-rpl                |     Version:
 Severity:  Submitted WG Document  |  Resolution:  fixed
 Keywords:                         |
-----------------------------------+----------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/92#comment:1>
roll <http://tools.ietf.org/wg/roll/>