Subject: [Roll] [roll] #87: Can't we split the target from the RDO ?

From: "roll issue tracker" <[email-masked]>
Date: Wed, 04 Apr 2012 13:09:56 -0000

#87: Can't we split the target from the RDO ?

 Problem (proposed resolution)
 ------------------------------
 The RDO is a garbage option will all sorts of data in it. The advocated
 reason for that is conciseness since separate options mean overhead.
 OTOH, it makes more sense to have all the targets expresses as target
 options as opposed to having one target in the DRO and then all other
 targets listed after. Having the target separate would allow for a DIO
 with no RDO but only a target, which would be useful to poll a device on
 an existing DAG. Currently the draft MUST a RDO and MAY and target
 option. The suggestion is to allow for a target in DIO without a RDO.

 Proposed resolution
 -------------------------
 Keep it at that since 1) there are implementations and 2) it's
 experimental . This resolution implies that the issue will be reopened
 should the work go for standard track

 Discussion
 -------------

 [Pascal]" MAY carry one or more RPL Target Options to specify additional
 unicast/multicast addresses for the target."
 Now here I would have a MUST carry at least one target. That is indeed
 what makes is a lookup DIO...

 [Mukul]
 As I stated in the previous message, we need to include the target in
 the P2P-RDO to save bytes for the common case (discover route to one
 unicast/multicast target). So, we cannot make using the target option a
 MUST.

 [Pascal2] Certainly. I prefer the split, in which case the MUST IMHO
 goes to the target as opposed to the RDO. In a case where the RDO is not
 needed, the target only message is actually shorter...

 [Mukul2] As I said before, I think a P2P mode DIO always needs to have
 one P2P-RDO. I guess, in this case, we agree to disagree!

 [Pascal3] Certainly. And there's nothing blocking with that
 disagreement, mostly if the draft targets experimental.
 I think it's OK to keep your response as the proposed resolution for
 the issue. Still I'd like advice from others so exposing the issue as LC
 will help. Let's see on which side the coin falls.

 [Mukul3] OK. I will be happy to hear additional opinions.

 [Pascal4] Fine, let's keep that as the proposed resolution

 [Mukul4] OK.
 Pascal

-- 
-----------------------------------+---------------------
 Reporter:  jpv@…                  |      Owner:  mukul@…
     Type:  defect                 |     Status:  new
 Priority:  major                  |  Milestone:
Component:  p2p-rpl                |    Version:
 Severity:  Submitted WG Document  |   Keywords:
-----------------------------------+---------------------

Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/87>
roll <http://tools.ietf.org/wg/roll/>

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 8 Apr 2012 10:56:18 -0500 (CDT)

Hi JP

Please mark this ticket as closed.

Thanks
Mukul

----- Original Message -----
From: "roll issue tracker" <[email-masked]>
To: [email-masked], [email-masked]
Cc: [email-masked]
Sent: Wednesday, April 4, 2012 8:09:56 AM
Subject: [roll] #87: Can't we split the target from the RDO ?

 Proposed resolution

 Discussion
 -------------

 [Mukul]

 [Mukul4] OK.
 Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 10 Apr 2012 11:47:39 +0200

JP

I Agree to close for an experimental and I suggest we revisit should the work go standard track.

Cheers
Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mukul Goyal
Sent: dimanche 8 avril 2012 17:56
To: [email-masked]
Subject: Re: [Roll] [roll] #87: Can't we split the target from the RDO ?

Hi JP

Thanks
Mukul

----- Original Message -----
From: "roll issue tracker" <[email-masked]>
To: [email-masked], [email-masked]
Cc: [email-masked]
Sent: Wednesday, April 4, 2012 8:09:56 AM
Subject: [roll] #87: Can't we split the target from the RDO ?

 Problem (proposed resolution)
 ------------------------------
 The RDO is a garbage option will all sorts of data in it. The advocated  reason for that is conciseness since separate options mean overhead.
 OTOH, it makes more sense to have all the targets expresses as target  options as opposed to having one target in the DRO and then all other  targets listed after. Having the target separate would allow for a DIO  with no RDO but only a target, which would be useful to poll a device on  an existing DAG. Currently the draft MUST a RDO and MAY and target  option. The suggestion is to allow for a target in DIO without a RDO.

 Proposed resolution
 -------------------------
 Keep it at that since 1) there are implementations and 2) it's  experimental . This resolution implies that the issue will be reopened  should the work go for standard track

 Discussion
 -------------

 [Pascal]" MAY carry one or more RPL Target Options to specify additional  unicast/multicast addresses for the target."
 Now here I would have a MUST carry at least one target. That is indeed  what makes is a lookup DIO...

 [Mukul]
 As I stated in the previous message, we need to include the target in  the P2P-RDO to save bytes for the common case (discover route to one  unicast/multicast target). So, we cannot make using the target option a  MUST.

 [Pascal2] Certainly. I prefer the split, in which case the MUST IMHO  goes to the target as opposed to the RDO. In a case where the RDO is not  needed, the target only message is actually shorter...

 [Mukul2] As I said before, I think a P2P mode DIO always needs to have  one P2P-RDO. I guess, in this case, we agree to disagree!

 [Pascal3] Certainly. And there's nothing blocking with that  disagreement, mostly if the draft targets experimental.
 I think it's OK to keep your response as the proposed resolution for  the issue. Still I'd like advice from others so exposing the issue as LC  will help. Let's see on which side the coin falls.

 [Mukul4] OK.
 Pascal

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 11 Apr 2012 21:44:11 -0500 (CDT)

Problem 

 Proposed resolution

 Discussion
 -------------

 [Mukul]

---

From: "roll issue tracker" <[email-masked]>
Date: Thu, 12 Apr 2012 14:27:21 -0000

Changes (by jpv@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 JP

 I Agree to close for an experimental and I suggest we revisit should the
 work go standard track.

 Cheers
 Pascal

 -----Original Message-----
 From: [email-masked] [mailto:[email-masked]] On Behalf Of
 Mukul Goyal
 Sent: dimanche 8 avril 2012 17:56
 To: [email-masked]
 Subject: Re: [Roll] [roll] #87: Can't we split the target from the RDO ?

 Hi JP

 Thanks
 Mukul

 ----- Original Message -----
 From: "roll issue tracker" <[email-masked]>
 To: [email-masked], [email-masked]
 Cc: [email-masked]
 Sent: Wednesday, April 4, 2012 8:09:56 AM
 Subject: [roll] #87: Can't we split the target from the RDO ?

 Proposed resolution

 Discussion
 -------------

 [Mukul]
 As I stated in the previous message, we need to include the target in  the
 P2P-RDO to save bytes for the common case (discover route to one
 unicast/multicast target). So, we cannot make using the target option a
 MUST.

 [Pascal2] Certainly. I prefer the split, in which case the MUST IMHO  goes
 to the target as opposed to the RDO. In a case where the RDO is not
 needed, the target only message is actually shorter...

 [Pascal3] Certainly. And there's nothing blocking with that  disagreement,
 mostly if the draft targets experimental.
 I think it's OK to keep your response as the proposed resolution for  the
 issue. Still I'd like advice from others so exposing the issue as LC  will
 help. Let's see on which side the coin falls.

 [Mukul4] OK.
 Pascal

-- 
-----------------------------------+----------------------
 Reporter:  jpv@…                  |       Owner:  mukul@…
     Type:  defect                 |      Status:  closed
 Priority:  major                  |   Milestone:
Component:  p2p-rpl                |     Version:
 Severity:  Submitted WG Document  |  Resolution:  fixed
 Keywords:                         |
-----------------------------------+----------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/87#comment:1>
roll <http://tools.ietf.org/wg/roll/>