Subject: [Roll] [roll] #97: A fixed value for DRO_ACK_WAIT_TIME not OK for all P2P-RPL deployments.

From: "roll issue tracker" <[email-masked]>
Date: Thu, 05 Apr 2012 11:03:15 -0000

#97: A fixed value for DRO_ACK_WAIT_TIME not OK for all P2P-RPL deployments.

 Resolution: Make DRO_ACK_WAIT_TIME as well as MAX_DRO_RETRANSMISSIONS
 configurable parameters.

 Discussion:

 p25 :  o DRO_ACK_WAIT_TIME: The time duration a target waits for the DRO-
 ACK before retransmitting a DRO message. DRO_ACK_WAIT_TIME has a
      value of 1 second.

 [Cedric]
 I'm not sure it is compliant with all RPL deployments.
 Could we adapt it to the characteristics of the network used ?

 [Mukul]
 I am OK with making DRO_ACK_WAIT_TIME as well as MAX_DRO_RETRANSMISSIONS
 configurable parameters.

-- 
-----------------------------------+---------------------
 Reporter:  jpv@…                  |      Owner:  mukul@…
     Type:  defect                 |     Status:  new
 Priority:  major                  |  Milestone:
Component:  applicability-ami      |    Version:
 Severity:  Submitted WG Document  |   Keywords:
-----------------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/97>
roll <http://tools.ietf.org/wg/roll/>

---

From: C Chauvenet <[email-masked]>
Date: Thu, 5 Apr 2012 14:21:38 +0000

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker
Envoyé : jeudi 5 avril 2012 13:03
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Roll] [roll] #97: A fixed value for DRO_ACK_WAIT_TIME not OK for all P2P-RPL deployments.

 Resolution: Make DRO_ACK_WAIT_TIME as well as MAX_DRO_RETRANSMISSIONS  configurable parameters.

 Discussion:

 p25 :  o DRO_ACK_WAIT_TIME: The time duration a target waits for the DRO-  ACK before retransmitting a DRO message. DRO_ACK_WAIT_TIME has a
      value of 1 second.

 [Cedric]

 [Mukul]
 I am OK with making DRO_ACK_WAIT_TIME as well as MAX_DRO_RETRANSMISSIONS  configurable parameters.

[Cedric2]
Safe enough.

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 8 Apr 2012 17:16:41 -0500 (CDT)

Hi JP, Michael

Kindly close this ticket.

Thanks
Mukul

----- Original Message -----
From: "C Chauvenet" <[email-masked]>
To: [email-masked], [email-masked], [email-masked]
Sent: Thursday, April 5, 2012 9:21:38 AM
Subject: RE: [Roll] [roll] #97: A fixed value for DRO_ACK_WAIT_TIME not OK for all P2P-RPL deployments.

-----Message d'origine-----

 Discussion:

 [Cedric]

 [Mukul]

[Cedric2]
Safe enough.

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 11 Apr 2012 18:14:41 -0500 (CDT)

Resolution:
------------------------
 Make DRO_ACK_WAIT_TIME as well as MAX_DRO_RETRANSMISSIONS  configurable parameters.

Discussion:
-------------------------
 p25 :  o DRO_ACK_WAIT_TIME: The time duration a target waits for the DRO-  ACK before retransmitting a DRO message. DRO_ACK_WAIT_TIME has a
      value of 1 second.

 [Cedric]

 [Mukul]

[Cedric2]
Safe enough.

---

From: "roll issue tracker" <[email-masked]>
Date: Fri, 13 Apr 2012 09:06:19 -0000

Changes (by jpv@…):

 * component:  applicability-ami => p2p-rpl

-- 
-----------------------------------+----------------------
 Reporter:  jpv@…                  |       Owner:  mukul@…
     Type:  defect                 |      Status:  new
 Priority:  major                  |   Milestone:
Component:  p2p-rpl                |     Version:
 Severity:  Submitted WG Document  |  Resolution:
 Keywords:                         |
-----------------------------------+----------------------

Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/97#comment:1>
roll <http://tools.ietf.org/wg/roll/>

---

From: "roll issue tracker" <[email-masked]>
Date: Fri, 13 Apr 2012 13:34:30 -0000

Changes (by jpv@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Resolution:
 ------------------------
 Make DRO_ACK_WAIT_TIME as well as MAX_DRO_RETRANSMISSIONS  configurable
 parameters.

 Discussion:

 [Cedric]

 [Mukul]

 [Cedric2]
 Safe enough.

-- 
-----------------------------------+----------------------
 Reporter:  jpv@…                  |       Owner:  mukul@…
     Type:  defect                 |      Status:  closed
 Priority:  major                  |   Milestone:
Component:  p2p-rpl                |     Version:
 Severity:  Submitted WG Document  |  Resolution:  fixed
 Keywords:                         |
-----------------------------------+----------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/97#comment:2>
roll <http://tools.ietf.org/wg/roll/>