Subject: [Roll] [roll] #91: Is it possible for an origin to get an error message in case the P2P-RPL route discovery fails.

From: "roll issue tracker" <[email-masked]>
Date: Thu, 05 Apr 2012 10:59:40 -0000

#91: Is it possible for an origin to get an error message in case the P2P-RPL
route discovery fails.

 Discussion:
 [Cedric]
 On big question that rise my mind is, what happened if the route discovery
 fail ?
 Some protocols sends out an error message when the route discovery fails
 or get stuck.
 Do authors think that it could be relevant to add a "discovery-error"
 message as defined in other route discovery protocols ?

 [Mukul]
 I dont think it is possible to detect the failure of a P2P-RPL route
 discovery. No node knows if a P2P-RPL route discovery has failed.

 P2P-RPL forms a temporary DAG and the route discovery (well, at least the
 first half) succeeds when a target joins the DAG. Only the target knows
 whether it joined the DAG or not. So, no node knows if the (first half of
 the) route discovery failed.

 Second half involves the target sending DRO to the origin. If the DRO does
 not reach the origin, (the second half of) the route discovery fails. The
 target can ensure (or at least increase the probability of) success by
 asking for DRO-ACK and retransmitting the DRO if the DRO-ACK is not
 received within certain time duration. DRO message travels by multicast,
 so an intermediate router, that forwards a DRO further, has no idea
 whether the next hop on the route received the DRO or not. Again, no node
 knows if the (second half of the) there is no one to generate the
 discovery-error message.

 I think an origin might infer the route discovery to have failed, if the
 DAG's life time has expired but no DRO is received. But I am not sure we
 should mandate this to be the way failure is inferred. We have just 4
 values for the DAG life time. So, I think we should leave it to origin how
 much to wait for a DRO before admitting failure.

-- 
-----------------------------------+---------------------
 Reporter:  jpv@…                  |      Owner:  mukul@…
     Type:  defect                 |     Status:  new
 Priority:  major                  |  Milestone:
Component:  p2p-rpl                |    Version:
 Severity:  Submitted WG Document  |   Keywords:
-----------------------------------+---------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/91>
roll <http://tools.ietf.org/wg/roll/>

---

From: C Chauvenet <[email-masked]>
Date: Thu, 5 Apr 2012 13:31:35 +0000

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker
Envoyé : jeudi 5 avril 2012 13:00
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Roll] [roll] #91: Is it possible for an origin to get an error message in case the P2P-RPL route discovery fails.

#91: Is it possible for an origin to get an error message in case the P2P-RPL route discovery fails.

 Discussion:
 [Cedric]
 On big question that rise my mind is, what happened if the route discovery  fail ?
 Some protocols sends out an error message when the route discovery fails  or get stuck.
 Do authors think that it could be relevant to add a "discovery-error"
 message as defined in other route discovery protocols ?

 [Mukul]
 I dont think it is possible to detect the failure of a P2P-RPL route  discovery. No node knows if a P2P-RPL route discovery has failed.

 P2P-RPL forms a temporary DAG and the route discovery (well, at least the  first half) succeeds when a target joins the DAG. Only the target knows  whether it joined the DAG or not. So, no node knows if the (first half of
 the) route discovery failed.

 Second half involves the target sending DRO to the origin. If the DRO does  not reach the origin, (the second half of) the route discovery fails. The  target can ensure (or at least increase the probability of) success by  asking for DRO-ACK and retransmitting the DRO if the DRO-ACK is not  received within certain time duration. DRO message travels by multicast,  so an intermediate router, that forwards a DRO further, has no idea  whether the next hop on the route received the DRO or not. Again, no node  knows if the (second half of the) there is no one to generate the  discovery-error message.

 I think an origin might infer the route discovery to have failed, if the  DAG's life time has expired but no DRO is received. But I am not sure we  should mandate this to be the way failure is inferred. We have just 4  values for the DAG life time. So, I think we should leave it to origin how  much to wait for a DRO before admitting failure.

[Cedric2]

I was thinking about an error message if the delivery of a message fails when using a route established by the P2P-RPL mechanism.
When a node included in the discovered route cannot be reached, then an error message could initiate a new route discovery using the P2P-RPL mechanism.

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Thu, 5 Apr 2012 08:52:53 -0500 (CDT)

Discussion:
 [Cedric]

 [Mukul]

[Cedric2]

[Mukul2]
P2P-RPL routes are used in exactly the same manner as core RPL routes, that is you use an RPL Source Routing Header (RFC6554) or an RPL Option (RFC6553) to send a packet to its destination. These RFCs specify what ICMP error messages could be generated if the route is broken.

---

From: C Chauvenet <[email-masked]>
Date: Thu, 5 Apr 2012 14:47:34 +0000

-----Message d'origine-----
De : Mukul Goyal [mailto:[email-masked]] 
Envoyé : jeudi 5 avril 2012 15:53
À : C Chauvenet
Cc : [email-masked]; [email-masked]
Objet : Re: [Roll] [roll] #91: Is it possible for an origin to get an error message in case the P2P-RPL route discovery fails.

 Discussion:
 [Cedric]

 [Mukul]

[Cedric2]

[Mukul2]

[Cedric3]
Ok.
If the route error detection is alredy handled, I think an additional error message is not necessary.

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 8 Apr 2012 11:10:13 -0500 (CDT)

Hi JP, Richard

Kindly mark this ticket as closed.

Thanks
Mukul

----- Original Message -----
From: "C Chauvenet" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: [email-masked], [email-masked]
Sent: Thursday, April 5, 2012 9:47:34 AM
Subject: RE: [Roll] [roll] #91: Is it possible for an origin to get an error message in case the P2P-RPL route discovery fails.

-----Message d'origine-----

 Discussion:
 [Cedric]

 [Mukul]

[Cedric2]

[Mukul2]

[Cedric3]
Ok.

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 11 Apr 2012 19:03:45 -0500 (CDT)

Resolution:
-------------
No. Because no intermediate router knows whether a DIO reached the target or not.

 Discussion:
--------------
 [Cedric]

 [Mukul]

[Cedric2]

[Mukul2]

[Cedric3]
Ok.

---

From: "roll issue tracker" <[email-masked]>
Date: Thu, 12 Apr 2012 07:52:40 -0000

Changes (by jpv@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Resolution:
 -------------
 No. Because no intermediate router knows whether a DIO reached the target
 or not.

 Discussion:
 --------------
 [Cedric]

 [Mukul]

 [Cedric2]

 I was thinking about an error message if the delivery of a message fails
 when using a route established by the P2P-RPL mechanism.
 When a node included in the discovered route cannot be reached, then an
 error message could initiate a new route discovery using the P2P-RPL
 mechanism.

 [Mukul2]
 P2P-RPL routes are used in exactly the same manner as core RPL routes,
 that is you use an RPL Source Routing Header (RFC6554) or an RPL Option
 (RFC6553) to send a packet to its destination. These RFCs specify what
 ICMP error messages could be generated if the route is broken.

 [Cedric3]
 Ok.
 If the route error detection is alredy handled, I think an additional
 error message is not necessary.

-- 
-----------------------------------+----------------------
 Reporter:  jpv@…                  |       Owner:  mukul@…
     Type:  defect                 |      Status:  closed
 Priority:  major                  |   Milestone:
Component:  p2p-rpl                |     Version:
 Severity:  Submitted WG Document  |  Resolution:  fixed
 Keywords:                         |
-----------------------------------+----------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/91#comment:1>
roll <http://tools.ietf.org/wg/roll/>