Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-10 comments

From: Federico Consoli <[email-masked]>
Date: Sat, 05 May 2012 11:04:09 +0200

Hi,
I disagree with the default value of trickle timer, especially for 
Imin=6 and K=1.
If you got a dense network it could lead to a very long time to build DAG.

Eg. Suppose you got 2 node A, B.
Node A got about 15-20 neighbor
Node B got only A as a neighbor.

When node A receive its first DIO it resets trickle to Imin and it 
starts trickle timer. Since A got a lot of neighbor its probably receive 
another consistent DIO so it will suppress the DIO message and it will 
increase its Imin to 7. So if node A suppress 6-8 times its DIO node B 
will receive it after a long time. Finally if the link A-B got an ETX of 
2 or 3 (or more) this time doubles.

These situations are not uncommon, especially in the routers at the edge 
of dense networks.

-- 
Regards
Consoli Federico

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 5 May 2012 09:34:15 -0500 (CDT)

On the other hand, if Imin/K are set less conservatively, you might see too many DIOs generated. There is no silver bullet. No single setting would work well in all situations. We do provide some guidance on how to set trickle timer in Section 9.2 of the draft. The trickle parameter values in default configuration option are a conservative estimate based on the desire to avoid too many DIOs. If these settings are not OK for a particular deployment, well then the default configuration option should not be used. The connectivity variance you described is indeed a tricky situation and would require a tradeoff with the need to avoid generating too many DIOs. I imagine one possible solution could be to allow a node to set its k based on its position (rank) in the DAG (k increases as you move closer to the edge). But, again there might be cases where this (or any other fix) wont work.

Thanks
Mukul

----- Original Message -----
From: "Federico Consoli" <[email-masked]>
To: [email-masked]
Sent: Saturday, May 5, 2012 4:04:09 AM
Subject: [Roll]  I-D Action: draft-ietf-roll-p2p-rpl-10 comments

Hi,

-- 
Regards
Consoli Federico

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Federico Consoli <[email-masked]>
Date: Sat, 05 May 2012 17:23:21 +0200

Yes but even if you got a small Imin value, network congestion may be 
only in a small initial period because Imin is incremented at each 
submission.
IMHO I think that K=1 is too conservative.
The situation that I describedcan be seen from another point of view.

Suppose now that A and B got about 15-20 neighbor.
A got a rank of 500
B got a rank of 3000

A suppresses DIOs for the reason described previously so node B will 
continue to use a bad path for a very long time because it does "not 
know" that node A "exists". I think that K should be at least =2 or more.
> From: "Federico Consoli"<[email-masked]>
> To: [email-masked]

-- 
Regards

Consoli Federico

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 5 May 2012 11:05:58 -0500 (CDT)

[Federico]

[Mukul]
In smart home environment, you care a lot about extra DIO packets (to save on battery). So, even though network congestion might be for a small time duration during one particular route discovery, the overall life time of a device might take a big hit over the course of multiple discoveries over time.

[Federico]   
>IMHO I think that K=1 is too conservative.

[Mukul]
It is indeed conservative and that is because smart home needs it to be conservative. And smart home is the application environment that cares most about using the default configuration option in order to save on bytes (and hence battery).

[Federico]

[Mukul]
Continue using bad path? The route discovery is still going on! In the scenario you described, B probably will take a long time to be "discovered" or perhaps not be discovered at all within the specified DAG lifetime.

Thanks
Mukul 

-- 
Regards

Consoli Federico

---

From: Federico Consoli <[email-masked]>
Date: Sat, 05 May 2012 18:31:39 +0200

> Continue using bad path? The route discovery is still going on! In the scenario you described, B probably will take a long time to be "discovered" or perhaps not be discovered at all within the spe…
[Federico]
Exactly, do not you think that the fact that node B take a long time to 
discover node Ais a problem? Suppose that node B wants to communicate 
with a neighbor of node A, it could lead to sending many unnecessary DIOs.

-- 
Regards
Consoli Federico

---

From: Mukul Goyal <[email-masked]>
Date: Sat, 5 May 2012 11:51:00 -0500 (CDT)

> Continue using bad path? The route discovery is still going on! In the scenario you described, B probably will take a long time to be "discovered" or perhaps not be discovered at all within the spe…

[Federico2]
Exactly, do not you think that the fact that node B take a long time to 
discover node Ais a problem?

[Mukul2]
No, it is not if B also has 15-20 neighbors like A. As long as the origin discovers a path to B that meets the specified constraints, there is no problem. It does not matter if the discovered path is through A or not.

[Federico2]
 Suppose that node B wants to communicate 
with a neighbor of node A, it could lead to sending many unnecessary DIOs.

[Mukul2]
You described two separate scenarios:
1) A has 15 neighbors, B has just A as the neighbor.
2) Both A and B have 15 neighbors including each other.

In the second scenario, K=1 definitely makes sense because there are many candidate paths and one such path to B would probably be discovered even though many of B's neighbors would end up suppressing their DIOs. It is possible that the discovered route wont pass through A.

In the first scenario, discovery of a route to B depends on A making a DIO transmission and B receiving it. This would be delayed if A ends up suppressing its DIO again and again. The route discovery would fail if DAG lifetime is over before B could receive the A's DIO. If that is very likely to happen in a particular deployment, K should not be 1. No doubt about it. But, we cannot set the K value in default configuration option to account for this case, which is certainly not the common case.

Thanks
Mukul

-- 
Regards
Consoli Federico

---

From: Federico Consoli <[email-masked]>
Date: Sat, 05 May 2012 19:11:15 +0200

> In the second scenario, K=1 definitely makes sense because there are many candidate paths and one such path to B would probably be discovered even though many of B's neighbors would end up suppress…
[Federico3]
I think this is the problem, the fact that the node B does not have full 
information about the status of his neighborhood. In the second scenario 
node B will use a path almost certainly worse to reach a neighbor of the 
node A.

-- 
Regards
Consoli Federico