Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-11.txt

From: [email-masked]
Date: Sun, 06 May 2012 10:07:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : Reactive Discovery of Point-to-Point Routes in Low Power and Lossy Networks
	Author(s)       : Mukul Goyal
                          Emmanuel Baccelli
                          Matthias Philipp
                          Anders Brandt
                          Jerald Martocci
	Filename        : draft-ietf-roll-p2p-rpl-11.txt
	Pages           : 33
	Date            : 2012-05-06

   This document specifies a point-to-point route discovery mechanism,
   complementary to the RPL core functionality.  This mechanism allows
   an IPv6 router to discover "on demand" routes to one or more IPv6
   routers in the LLN such that the discovered routes meet specified
   metrics constraints.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-roll-p2p-rpl-11.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-p2p-rpl-11.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-roll-p2p-rpl/

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 6 May 2012 12:27:35 -0500 (CDT)

Based on the discussion with Federico and suggestion by Adrian, this version has the following changes:

1) Section 9.2 (Trickle Operation For P2P Mode DIOs) has more text on how to set Imin and the redundancy constant. The text now points out that Imin setting has an impact on the lifetime of the temporary DAG and redundancy constant value 1 may not be suitable in deployments where specific destinations are reachable only through specific intermediate routers.

2) Section 6.1 (Setting a P2P Mode DIO) has little more text regarding the rationale behind settings in the default configuration option. I guess trickle parameter settings needed explanation and I just referred the reader to Section 9.2. But, I also added some text for other parameters (e.g. lifetime parameters) to make the intention clear.

3) There was already some discussion in Section 7.1 (P2P Route Discovery Option) regarding how to set the lifetime of the temporary DAG. I added one sentence that made it clear that the lifetime of the temporary DAG has a dependence on the Trickle parameters (Imin and redundancy constant). This sentence is actually a repetition of what is already mentioned in Section 9.2.

Thanks
Mukul  

----- Original Message -----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Sent: Sunday, May 6, 2012 12:07:58 PM
Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-11.txt

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll