Subject: [Roll] I-D Action: draft-ietf-roll-p2p-measurement-05.txt

From: [email-masked]
Date: Wed, 09 May 2012 16:11:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : A Mechanism to Measure the Quality of a Point-to-point Route in a Low Power and Lossy Network
	Author(s)       : Mukul Goyal
                          Emmanuel Baccelli
                          Anders Brandt
                          Jerald Martocci
	Filename        : draft-ietf-roll-p2p-measurement-05.txt
	Pages           : 20
	Date            : 2012-05-09

   This document specifies a mechanism that enables an RPL router to
   measure the quality of an existing route towards another RPL router
   in a low power and lossy network, thereby allowing the router to
   decide if it wants to initiate the discovery of a better route.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-roll-p2p-measurement-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-roll-p2p-measurement-05.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-roll-p2p-measurement/

---

From: Mukul Goyal <[email-masked]>
Date: Wed, 9 May 2012 18:27:18 -0500 (CDT)

This version takes care of ticket #98 (created in response to LC comment by Phil Levis) and has the following changes:

1) Updated the overview section. This section now has better explanation of the mechanism and explicitly clarifies the following:
1.1) The route being measured is from the origin to the target.
1.2) The origin decides what metrics are measured.

2) Section 4 (Originating a Measurement Request) now clearly says:

"The Origin MUST also include the routing metric objects of
   interest inside one or more Metric Container options inside the MO.
"

3) Section 5 (Processing a Measurement Request at an Intermediate Router) now clearly says:

"An Intermediate Router can
   only update the existing metric objects and MUST NOT add any new
   routing metric object to the Metric Container.  An Intermediate
   Router MUST drop the MO if it cannot update a routing metric object
   specified inside the Metric Container."

4) Updated the IANA section to include the correct language as per RFC5226.

These modifications should remove the perceived ambiguity (regarding who decides which metrics would be measured) reported in Ticket #98. 

Thanks
Mukul 
----- Original Message -----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Sent: Wednesday, May 9, 2012 6:11:01 PM
Subject: [Roll] I-D Action: draft-ietf-roll-p2p-measurement-05.txt

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Wed, 9 May 2012 17:31:39 -0700

The new draft addresses all of my comments. The overview section is much clearer and unambiguous.

Phil

> https://datatracker.ietf.org/doc/draft-ietf-roll-p2p-measurement/

Phil