Subject: [Roll] RPLInstanceID parameter from Source Routing Header is missing in RFC6554

From: Tecuceanu Andreea-Dana-B10623 <[email-masked]>
Date: Wed, 30 May 2012 08:58:23 +0000

Hello,

I have observed that the RPLInstanceID field from Source Routing header (present in  draft-ietf-6man-rpl-routing-header-07) was removed in RFC6554.
Are there particular reasons for this? This field is necessary at the DODAG Root when it receives a  Destination Unreachable with code "Error in Source Routing Header" to identify the instance with the problem (only if there are two instances with the same prefix and if the node is Root in both of them).

Andreea Tecuceanu
(Freescale Semiconductor)

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 30 May 2012 10:44:06 +0100

Hi,
 
There seems to be a thread on this at
http://www.ietf.org/mail-archive/web/ipv6/current/thrd2.html#15124
 
It looks like there was some form of agreement on the 6man list (where I suppose
the discussion belonged).
 
There was also a related thread on the Roll list at
http://www.ietf.org/mail-archive/web/roll/current/msg06579.html
 
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tecuceanu Andreea-Dana-B10623
Sent: 30 May 2012 09:58
To: [email-masked]
Subject: [Roll] RPLInstanceID parameter from Source Routing Header is missing in
RFC6554
 
Hello,
 
I have observed that the RPLInstanceID field from Source Routing header (present
in  draft-ietf-6man-rpl-routing-header-07) was removed in RFC6554. 
Are there particular reasons for this? This field is necessary at the DODAG Root
when it receives a  Destination Unreachable with code "Error in Source Routing
Header" to identify the instance with the problem (only if there are two
instances with the same prefix and if the node is Root in both of them).

Andreea Tecuceanu