Subject: [Roll] draft-bormann-ghc

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Jun 2012 15:28:10 -0400

I would like to propose that draft-bormann-6lowpan-ghc-04 be adopted as
a WG item.  I think that 6lowpan should adopt it, but I'm willing to
discuss alternatives.

Some analysis in 2011 showed that even a modest application of GHC
to ROLL RPL control messages resulted in sufficient compression to
make ROLL RPL packets regularly fit into a single 802.15.4 payload.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works 
speaking for myself

---

From: Zach Shelby <[email-masked]>
Date: Tue, 12 Jun 2012 22:36:33 +0300

+1 - I also would find this useful! And at least as a starting point this is a solid I-D.

On Jun 12, 2012, at 10:28 PM, Michael Richardson wrote:

> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 13 Jun 2012 13:46:46 +0100

+1

AB

---

From: Daniel Gavelle <[email-masked]>
Date: Wed, 13 Jun 2012 15:17:04 +0200

+1

__________________________________________________

Daniel Gavelle, Software Team Leader
Low Power RF Solutions (formerly Jennic Ltd.)
NXP Semiconductors Furnival Street,
Sheffield,
S1 4QT, UK
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Comp Reg No: 3191371 - Registered In England
http://www.nxp.com http://www.jennic.com
__________________________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 13 June 2012 13:47
To: Michael Richardson
Cc: [email-masked]; [email-masked]
Subject: Re: [Roll] [6lowpan] draft-bormann-ghc

+1

AB
On Tue, Jun 12, 2012 at 8:28 PM, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works
speaking for myself

_______________________________________________
6lowpan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: M Pouillot <[email-masked]>
Date: Wed, 13 Jun 2012 15:30:33 +0000

+1

De : [email-masked] [mailto:[email-masked]] De la part de Daniel Gavelle
Envoyé : mercredi 13 juin 2012 15:17
À : Michael Richardson
Cc : [email-masked]; [email-masked]
Objet : Re: [6lowpan] [Roll] draft-bormann-ghc

+1

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Abdussalam Baryun
Sent: 13 June 2012 13:47
To: Michael Richardson
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Roll] [6lowpan] draft-bormann-ghc

+1

AB

---

From: Pascal Thubert <[email-masked]>
Date: Wed, 13 Jun 2012 16:55:00 -0700

+1

Pascal

Le 12 juin 2012 à 12:28, Michael Richardson <[email-masked]> a écrit :

> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Laurent Toutain <[email-masked]>
Date: Thu, 14 Jun 2012 09:31:03 +0200

+1, but I thought the 6LP working group was closed !

Laurent

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: C Chauvenet <[email-masked]>
Date: Thu, 14 Jun 2012 09:54:26 +0000

+1 to adopt this doc as a WG item.
Saving bytes is the key. 
Go for it !

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 14 Jun 2012 12:19:13 +0200

On Jun 14, 2012, at 09:31, Laurent Toutain wrote:

> but I thought the 6LP working group was closed

...>>>>>...
Changing to WG chair mode for a moment:

The 6LoWPAN WG is alive and well and is in the process of closing its remaining two work items (6LoWPAN-ND, 6LoWPAN for BTLE).

However, you are right in that the 6LoWPAN WG no longer takes new work on.
The chairs, with the ADs and the chairs of other WGs, will ensure that interesting work finds an appropriate home.

Indicating whether you are interested in GHC is therefore important input.

Another comment:
Beyond the +1s, it would be useful to know, whether you (I'm addressing the WG here) would be interested in

-- reviewing versions of the draft as they progress
-- implementing the draft and relaying feedback.

...<<<<<...
I'm back to personal contributor mode now.

(Luckily, we won't have this hat-changing going on any more when we find the new home.)

I'm just in the process of receiving some more packet captures.
I would like to take this opportunity to remind people that the more packet captures we have to look at, the better we will be able to optimize this scheme before nailing it down.

A collection of packets I looked at is in

	http://svn.tools.ietf.org/svn/wg/6lowpan/packets

(and, of course, there is the discussion of these in the draft itself).

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 14 Jun 2012 09:43:13 -0400

>>>>> "Laurent" == Laurent Toutain <[email-masked]> writes:
    Laurent> +1, but I thought the 6LP working group was closed !

    >> adopted as a WG item.  I think that 6lowpan should adopt it,
    >> but I'm willing to discuss alternatives.

Thus my statement including: "discuss alternatives"
this includes going to 6man or roll or independant submission.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works 
IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/