Subject: Re: [Roll] Use P2P-RPL to repair DAO routes

From: "Reddy, Joseph" <[email-masked]>
Date: Mon, 4 Jun 2012 04:50:53 +0000

Hi Mukul,

Thanks for the clarification. I agree with your suggestion to consider this as subject for a separate document.

-Regards, Joseph

----- Forwarded Message -----
[Joseph]   
Section 12:
..In general, P2P-RPL operation does not affect core RPL operation.."
I think this is unfortunate as P2P can be used to fix issues with core rpl. For example, in core RPL, there is no way to repair a downward route until the actual Target sends another DAO, which can take a long time. It would be very nice if the DoDag root can use P2P-RPL to discover a route to a Target node that is unreachable and then use the resulting source route as the downward route.  

[Mukul]
What the text you quoted means is that it does not break core RPL operation. P2P-RPL can certainly be used in the manner you specified. The root of a global DODAG can certainly use P2P-RPL to discover a source route to any target. Just that it will involve creation of a separate temporary DAG. If you want to do this route discovery within the scope of the existing global permanent DAG, it can be done but needs to be written up in a separate document. I dont think this provision should be inside P2P-RPL document. This is because, for RPL deployments that would not otherwise support P2P-RPL, it may be more efficient to simply use an RPL Target Option inside a DIO to trigger DAOs that would allow desired route to be discovered. Ofcourse, this needs to be written up to (since currently Target Option cannot sit inside a non-P2P mode DIO).

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 4 Jun 2012 01:30:13 -0500 (CDT)

Thanks Joseph. I guess this issue is closed too as far as P2P-RPL is concerned.

Mukul

----- Original Message -----
From: "Joseph Reddy" <[email-masked]>
To: "Mukul Goyal" <[email-masked]>
Cc: [email-masked]
Sent: Sunday, June 3, 2012 11:50:53 PM
Subject: RE: Use P2P-RPL to repair DAO routes

Hi Mukul,

-Regards, Joseph

----- Forwarded Message -----
[Joseph]   
Section 12:

[Mukul]