Subject: [Roll] "Node energy" as a metric for MRHOF

From: Ralph Droms <[email-masked]>
Date: Fri, 1 Jun 2012 15:53:14 -0400

I came across a new puzzle while re-reading draft-ietf-roll-minrank-hysteresis-of.

"Node energy" doesn't appear to be listed as an additive metric in RFC 6551.  Reading the description of the node energy metric, which carries remaining battery capacity as a percentage of initial capacity, I have no clue how a node using MRHOF would compute a path cost based on node energy.  Does node energy really fit as one of the metrics that MRHOF can use?

- Ralph

---

From: Omprakash Gnawali <[email-masked]>
Date: Sat, 2 Jun 2012 04:13:02 -0500

> "Node energy" doesn't appear to be listed as an additive metric in RFC 6551.  Reading the description of the node energy metric, which carries remaining battery capacity as a percentage of initial…

One could certainly add up the node energy for all the links, however,
it is probably better to use the path that maximized the minimum
energy along the path as suggested in RFC 6551. If so, MRHOF would not
be the best OF to use when one uses node energy as the metric.

- om_p

---

From: JP Vasseur <[email-masked]>
Date: Sat, 2 Jun 2012 16:22:00 +0200

Thanks Ralph. When you say "path cost based on node energy", you refer to using a cumulative metric where node metric are inversely 
proportional to the remaining energy ? I am asking since there are several approaches to compute the metric, it could be coupled with 
the remaining energy used as a constraint, …
Thanks.

JP.

On Jun 1, 2012, at 9:53 PM, Ralph Droms wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Ralph Droms <[email-masked]>
Date: Mon, 4 Jun 2012 12:48:52 -0400

> the remaining energy used as a constraint, …

JP - I'm trying to relate the path cost computation in MRHOF using "node energy" as the selected metric.  I infer from section 3 and table 1 that node energy is OK to use as the selected metric for MRHOF.  I don't see how simply adding node energy, defined as "estimated percentage of remaining battery capacity" [RFC 6551], is viable as a metric for MRHOF.  If it is viable, I think the way in which it is used to compute path cost and rank needs to be explained in more detail.

- Ralph