Subject: Re: [Roll] knowing which multiple metrics matter: MRHOF related questions

From: Ralph Droms <[email-masked]>
Date: Mon, 4 Jun 2012 12:36:19 -0400

On May 26, 2012, at 2:00 AM 5/26/12, Mukul Goyal wrote:

> Hi Michael
> 
> Here is my take:
> 
> [MCR]
> - do the nodes of a DODAG have to use the same metrics to pick a parent,
>  (and if so, how do they agree)
>  I think that they do not, so long as they use an algorithm (such as
>  MRHOF) which has certain properties.
> 
> [Mukul]
> Yes, the nodes in a DODAG have to use the same metrics. Otherwise, it is not possible for an OF to map the aggregated (from root till this node) values of the metrics to a rank.

"metrics" or "metric"?  Can different nodes use different metrics in a RPL instance that specifies MRHOF?  I would think the answer is "no"; i.e., all nodes in a RPL instance MUST use the same metric as the "selected metric".

> [MCR] 
> - if we had multiple RPL instances in an LLN, using different metrics,
>  then we would have multiple RPL Instances and DODAGs.  The different
>  set of metrics would not co-exist in the same RPL Instance.
> [Mukul]
> Not sure what does the first sentence mean. About the second, different sets of metrics can certainly coexist in the same RPL instance. An RPL Instance is associated with a particular OF but different DODAGs in the RPL Instance can certainly use different routing metrics.

Perhaps I am confused.  Do all the nodes in a single DODAG use the same metric while nodes in different DODAGs (in the same RPL instance) can use different metrics?  I.e., for a RPL instance with tow DODAGs, all the nodes in DODAG1 use ETX while all the nodes in DODAG2 use hop count?

- Ralph

> 
> Thanks
> Mukul
> 
> ----- Original Message -----
> From: "Michael Richardson" <[email-masked]>
> To: "Pascal Thubert (pthubert)" <[email-masked]>
> Cc: [email-masked]
> Sent: Friday, May 25, 2012 2:29:49 PM
> Subject: Re: [Roll] knowing which multiple metrics matter: MRHOF related	questions
> 
> 
>>>>>> "Pascal" == Pascal Thubert <(pthubert)" <[email-masked]>> writes:
>    Pascal> I think RPL does not want to take party there. The OF is a
>    Pascal> piece of logic to tie metrics and policies together.  
> 
> My question is:
> 
> - do the nodes of a DODAG have to use the same metrics to pick a parent,
>  (and if so, how do they agree)
>  I think that they do not, so long as they use an algorithm (such as
>  MRHOF) which has certain properties.
> 
> - if we had multiple RPL instances in an LLN, using different metrics,
>  then we would have multiple RPL Instances and DODAGs.  The different
>  set of metrics would not co-exist in the same RPL Instance.
> 
> 
> -- 
> Michael Richardson <[email-masked]>, Sandelman Software Works 
> IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/
> 
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Mukul Goyal <[email-masked]>
Date: Tue, 5 Jun 2012 03:55:36 -0500 (CDT)

Hi Ralph

*****************************************************************************
[MCR]

[Mukul]

[Ralph2]
"metrics" or "metric"?

[Mukul2]
"Metrics" if we are talking about OF in general. "Metric" if we are talking about MRHOF in particular.

[Ralph2]
  Can different nodes use different metrics in a RPL instance that specifies MRHOF?  I would think the answer is "no"; i.e., all nodes in a RPL instance MUST use the same metric as the "selected metric".

[Mukul2]
You are right.

**********************************************************************************

[MCR] 

[Mukul]
> Not sure what does the first sentence mean. About the second, different sets of metrics can certainly coexist in the same RPL instance. An RPL Instance is associated with a particular OF but differ…

[Ralph2]

[Mukul2]
I thought so until Pascal told me today that this is not correct. The reason is that a node may want to jump from one DAG to another (e.g. if both DAGs provide connectivity to a particular prefix and the node will have a better rank in the other DAG). But, in order to allow a node to compare its rank in different DAGs, both OF and metrics in use should be same for both DAGs.

Thanks
Mukul