Subject: [Roll] Some LLNs are NOT MANETs

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 1 Aug 2012 09:21:54 +0200

Hi Henning,

I am about to say many LLNs are NOT MANETs but it seems like the
market or community will decide the outcome, but surly that some LLNs
are NOT MANETs.

> Could you state an example what would be considered a LLN but not a
> MANET. I normally consider LLNs a subset of what we call MANETs.

I not totally agree with that, because we need to be considering both
NETs use case and applicability in the vision of the different WGs
(MANET and ROLL). There are many examples we can find them in the
[RFC2501] for MANETs characteristics and applicability, and for LLNs
characteristics in [RFC5548], [RFC5673], [RFCRFC5826], and [RFC5867]
including LLNs requirements. That is why I suggested before that
OLSRv2 and AODVv2 should mention their applicability to LLN if they
do. They just refer to RFC2501, but RFC2501 is OLD and does not
mention LLN but describes the meaning. The authors of RFC2501 still
not responded to my update suggestions.

I understood from one discussion in MANET WG that few don't have time
to read many pages of documents, so that is why I suggested to have
terminology I-D [1] as we have ROLL terminology [ROLL] . I also taken
initiative to make new draft of  MANET subnet technologies which
include only related LLNs [AB2].

Therefore, I will add the definition for MANET and LLN into my
manet-terminology draft [AB1] (propose that authors of [ROLL] define
LLN more details) to assist discussions as it is proved now in the
list that there still is problems in definitions in MANET WG or in
some I-D editorial content.

[AB1] http://www.ietf.org/id/draft-baryun-manet-terminology-00.txt
[AB2] http://www.ietf.org/id/draft-baryun-manet-technology-00.txt
[ROLL] http://tools.ietf.org/id/draft-ietf-roll-terminology-06.txt

Best Wishes

Abdussalam Baryun
University of Glamorgan, UK

====================================================
On 7/31/12, Henning Rogge <[email-masked]> wrote:
> On Tue, Jul 31, 2012 at 6:45 AM, Abdussalam Baryun
> subject: Re: [manet] Discussing LOADng suggestions
> <[email-masked]> wrote:
>> IMHO this protocol was intended as for ROLL WG not for MANET WG, but
>> then changed its direction to MANET [3]. However, please note that
>> *ONLY* some LLNs are MANETs, and *ONLY* some MANETs are LLNs. That
>> said, LOADng SHOULD specfy where is its limits. Then we can discuss
>> adoption.
>
> Could you state an example what would be considered a LLN but not a
> MANET. I normally consider LLNs a subset of what we call MANETs.
>
> Henning Rogge
>
> --
> Steven Hawkings about cosmic inflation: "An increase of billions of
> billions of percent in a tiny fraction of a second. Of course, that
> was before the present government."
>

---

From: C Chauvenet <[email-masked]>
Date: Wed, 1 Aug 2012 09:14:25 +0000

Hi, 

This is an interesting discussion.

My understanding is that both MANET and ROLL considers lossy/dynamic links in the way described in the MANET charter :  "static and dynamic topologies with increased dynamics due to node motion or other factors." I also agree that dynamicity of links is not hard wired to node mobility.

So, in the LLN Vs MANET debate, I think they share the "N" for Networks, and the 2nd "L" for Lossy.
So the remaining point is the first L, meaning Low Power.

Low Power requirements is explicit in the ROLL charter and not mentioned at all in the MANET charter.
Is the power efficiency consideration the big difference between ROLL and MANET ?

Cédric.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Abdussalam Baryun
Envoyé : mercredi 1 août 2012 09:22
À : Henning Rogge
Cc : roll; manet
Objet : [Roll] Some LLNs are NOT MANETs

Hi Henning,

I am about to say many LLNs are NOT MANETs but it seems like the market or community will decide the outcome, but surly that some LLNs are NOT MANETs.

> MANET. I normally consider LLNs a subset of what we call MANETs.

I not totally agree with that, because we need to be considering both NETs use case and applicability in the vision of the different WGs (MANET and ROLL). There are many examples we can find them in the [RFC2501] for MANETs characteristics and applicability, and for LLNs characteristics in [RFC5548], [RFC5673], [RFCRFC5826], and [RFC5867] including LLNs requirements. That is why I suggested before that
OLSRv2 and AODVv2 should mention their applicability to LLN if they do. They just refer to RFC2501, but RFC2501 is OLD and does not mention LLN but describes the meaning. The authors of RFC2501 still not responded to my update suggestions.

I understood from one discussion in MANET WG that few don't have time to read many pages of documents, so that is why I suggested to have terminology I-D [1] as we have ROLL terminology [ROLL] . I also taken initiative to make new draft of  MANET subnet technologies which include only related LLNs [AB2].

Therefore, I will add the definition for MANET and LLN into my manet-terminology draft [AB1] (propose that authors of [ROLL] define LLN more details) to assist discussions as it is proved now in the list that there still is problems in definitions in MANET WG or in some I-D editorial content.

Best Wishes

Abdussalam Baryun

> MANET. I normally consider LLNs a subset of what we call MANETs.
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 1 Aug 2012 13:41:39 +0200

Hi Cédric,

I think the RFC2501 is more important than the WG charter, because the
charter MAY change but RFCs never changes (only can be updated,
obsoleted or replaced). So far now all MANET-protocols are refering to
RFC2501 which is good and SHOULD continue, and I like this referencing
to documents (even if they are old or expired) not referencing to
charters, because for example, if in a journal paper we reference to
the charter of MANET WG or ROLL WG the information is not solid like
if you reference a published document (publisher date), but still we
can reference the charter as web reference sited date.

I read some paper that reference sited web documents but they may be
not valid and cannot be read for some reason. Therefore, IMHO, we need
to stick to the following document to make a right decision in
definitions:

1) [RFC2501] for MANETs. (published in 1999)
2) [RFC5548], [RFC5673], [RFCRFC5826], and [RFC5867] for LLNs.
(published in 2009)

Low power was indicated in RFC2501 in section 5.1 as <possibly power
constraints> and also the word *sink*, in page 7 you read <sleep mode
for energy conservation>. IMHO, as long we have a ROLL WG in IETF we
need to forward work to it which has no mobility behavior. Delegation
will help make work flowing and more focused.

Regards
AB
=======

On 8/1/12, C Chauvenet <[email-masked]> wrote:
> My understanding is that both MANET and ROLL considers lossy/dynamic links
> in the way described in the MANET charter :  "static and dynamic topologies
> with increased dynamics due to node motion or other factors." I also agree
> that dynamicity of links is not hard wired to node mobility.
>
> I am about to say many LLNs are NOT MANETs but it seems like the market or
> community will decide the outcome, but surly that some LLNs are NOT MANETs.
>
> I not totally agree with that, because we need to be considering both NETs
> use case and applicability in the vision of the different WGs (MANET and
> ROLL). There are many examples we can find them in the [RFC2501] for MANETs
> characteristics and applicability, and for LLNs characteristics in
> [RFC5548], [RFC5673], [RFCRFC5826], and [RFC5867] including LLNs
> requirements. That is why I suggested before that
> OLSRv2 and AODVv2 should mention their applicability to LLN if they do. They
> just refer to RFC2501, but RFC2501 is OLD and does not mention LLN but
> describes the meaning. The authors of RFC2501 still not responded to my
> update suggestions.
>
> I understood from one discussion in MANET WG that few don't have time to
> read many pages of documents, so that is why I suggested to have terminology
> I-D [1] as we have ROLL terminology [ROLL] . I also taken initiative to make
> new draft of  MANET subnet technologies which include only related LLNs
> [AB2].
>
> manet-terminology draft [AB1] (propose that authors of [ROLL] define LLN
> more details) to assist discussions as it is proved now in the list that
> there still is problems in definitions in MANET WG or in some I-D editorial
> content.
>

---

From: C Chauvenet <[email-masked]>
Date: Wed, 1 Aug 2012 12:46:25 +0000

Hi, 

Thank you for your answer, 

See inline.

Le 1 août 2012 à 13:41, Abdussalam Baryun a écrit :

> obsoleted or replaced).

Good Point, 100% agree.

> So far now all MANET-protocols are refering to

I think they are good references to build some arguments into this discussion.

> will help make work flowing and more focused.

When you say "IMHO, as long we have a ROLL WG in IETF we need to forward work to it which has no mobility behavior", do you mean that the difference between ROLL and MANET is limited to mobility considerations ?

Based on the docs you mentioned, I see that RFC5548, RFC5826, and RFC5867 all include the usual IoT constraints : Memory, Processing, Power, Battery, Cost and Size of device.
RFC5673 does not mention explicitly processing and size constraints, but mention all the others.

RFC 2501 speak about energy and power, as you previously mentioned, but does not say something on the following constraints :  Memory, Processing, Cost and Size.

Do you think that these constraints are in the MANET scope ?
I guess that they may be (obviously for Cost), but not in the same order of magnitude as the type of devices described in the requirements RFC of ROLL.

Regards,

Cédric.