Subject: Re: [Roll] Comments For ROLL terminology-06

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 4 Aug 2012 07:46:41 +0200

Hi JP and All,

I need your comments/feedback on the below, and want to know if there
will be update to the expired document.

Regards
AB

On 7/5/12, Abdussalam Baryun <[email-masked]> wrote:
> Hi Vasseur, and All,
>
> Comments:
> +++++++++
>
> AB>general comment> ROLL is about routers/nodes/hosts Why not defined
> :  Host, Node, Link, Interface
>
> In the body of draft-06:-
>
> Closed Loop Control: A process whereby a device controller controls
> an actuator based on information sensed by one or more field devices.
>
> AB>suggest> replace [process] with [procedure]
> AB>suggest> replace [information] with [input information]
>
> Downstream: Data direction traveling from outside of the LLN (e.g.
> traffic coming from a LAN, WAN or the Internet) via a LBR.
>
> AB> suggest> remove the example, because first, ROLL is inside LLN not
> outside, and second, most of the data-traffic MAY go from the LLN to
> the Internet/LBR. IMHO downstream is in the direction of the havier
> unit-flow.
>
> AB> please note that if we use word [data] is different than
> [message]. While using [message] we may mean all traffic includes data
> and control messages, so the use of downstream and upstream as in
> draft-06 will be ok, but if we mention data-direction IMHO the use
> downstream-upstream will be the other way around.
>
> AB> suggest> replace [data] with [message]
>
> Field Device:
>
> AB> delete word> field
>
> MP2P: Multipoint-to-Point is used to describe a particular traffic
> pattern (e.g. MP2P flows collecting information from many nodes
> flowing inwards towards a collecting sink or an LBR).
>
> AB>opinion> MP2P is not a traffic pattern it is a transmission method
>
> I am not sure if the draft covers all terms used in ROLL protocols, I
> will check and post on the same thread after. Thanking you,
>
> Best Regards
>
> Abdussalam Baryun
> University of glamorgan, UK
> +++++++++++++++++++++++++++++++++++++++++++++++++
> I may be wrong, or may be right, but it does not matter if we work together
>  as a group to discuss and resolve all issues. WGs are always right.
> *****************************************************************************
> This email and any attachments are confidential to the intended recipient
> and may also be privileged. If you are not the intended recipient please
> delete it from your system and notify the sender. The contents are comply
> to the IETF regulations, and WG procedures. You should not copy the
> email nor use it for any other purpose, nor disclose, nor distribute its
> contents to any other person.
> *****************************************************************************
>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 4 Aug 2012 13:55:53 +0000

A new version of the document will be posted, thanks for the comments! Just note that some of these terms are not
related to RPL but to LLNs in general though.
Thanks.

JP.

On Aug 3, 2012, at 10:46 PM, Abdussalam Baryun wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 5 Aug 2012 10:01:16 +0100

Hi JP,

thanks, I agree and looking forward for new draft, but I think defining LLN
is important so other WGs in IETF understand what is LLNs, I already asked
the question to one WG and many have different definiotions. While the
future internet will see a big grow/use in LLNs, it will be useful to
define LLNs and in the end RPL is routing over LLNs.

Another point, which I think very important, in the meeting one input
comment was surprised that ROLL WG had a presentation with using
devices scenario of 1 W transmission power. Which still means some don't
define "Low Power" in the same way, I will write my opinion on this in a
separate thread, however, I suggest to define *Low Power* in the ROLL
terminology draft, because LowPower is first/one important character of LLN
and Lossy is the other.

Regards
AB
============
On Sat, Aug 4, 2012 at 2:55 PM, JP Vasseur (jvasseur) <[email-masked]>wrote:

> A new version of the document will be posted, thanks for the comments!
> Just note that some of these terms are not

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sun, 5 Aug 2012 19:18:54 +0000

On Aug 5, 2012, at 2:01 AM, Abdussalam Baryun wrote:

Hi JP,

thanks, I agree and looking forward for new draft, but I think defining LLN is important so other WGs in IETF understand what is LLNs, I already asked the question to one WG and many have different definiotions. While the future internet will see a big grow/use in LLNs, it will be useful to define LLNs and in the end RPL is routing over LLNs.

Another point, which I think very important, in the meeting one input comment was surprised that ROLL WG had a presentation with using devices scenario of 1 W transmission power. Which still means some don't define "Low Power" in the same way, I will write my opinion on this in a separate thread, however, I suggest to define *Low Power* in the ROLL terminology draft, because LowPower is first/one important character of LLN and Lossy is the other.

See also the comment about the duty cycle of course.

Thanks.

JP.

Regards
AB
============
On Sat, Aug 4, 2012 at 2:55 PM, JP Vasseur (jvasseur) <[email-masked]<mailto:[email-masked]>> wrote:
A new version of the document will be posted, thanks for the comments! Just note that some of these terms are not
related to RPL but to LLNs in general though.
Thanks.

JP.

On Aug 3, 2012, at 10:46 PM, Abdussalam Baryun wrote:

> On 7/5/12, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
>> Hi Vasseur, and All,
>>
>> Comments:
>> +++++++++
>>
> [email-masked]<mailto:[email-masked]>