Subject: [Roll] Fwd: New Version Notification for draft-ko-roll-mix-network-pathology-00.txt

From: JeongGil Ko <[email-masked]>
Date: Fri, 17 Aug 2012 20:22:33 +0900

Hi ROLL WG!

Please review and provide me comments regarding the document submitted below in which we discuss about a hybrid downwards routing mode where storing and non-storing mode nodes can interoperate! :)

Looking forward to some exciting discussions! :)

Thanks!

-John

------
JeongGil Ko, Ph.D.
Researcher
Electronics and Telecommunications Research Institute (ETRI)
http://sites.google.com/site/jeonggilko/

Begin forwarded message:

> From: <[email-masked]>
> Subject: New Version Notification for draft-ko-roll-mix-network-pathology-00.txt
> Date: August 17, 2012 8:07:41 PM GMT+09:00
> To: <[email-masked]>
> Cc: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
> 
> 
> 
> A new version of I-D, draft-ko-roll-mix-network-pathology-00.txt
> has been successfully submitted by JeongGil Ko and posted to the
> IETF repository.
> 
> Filename:	 draft-ko-roll-mix-network-pathology
> Revision:	 00
> Title:		 RPL Routing Pathology In a Network With a Mix of Nodes Operating in Storing and Non-Storing Modes
> Creation date:	 2012-08-17
> WG ID:		 Individual Submission
> Number of pages: 8
> URL:             http://www.ietf.org/internet-drafts/draft-ko-roll-mix-network-pathology-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-ko-roll-mix-network-pathology
> Htmlized:        http://tools.ietf.org/html/draft-ko-roll-mix-network-pathology-00
> 
> 
> Abstract:
>   Nodes can run RPL in storing or non-storing modes for downward
>   routing.  When a downward-bound packet traverses a node running in
>   storing to a node running in non-storing mode, there is a routing
>   pathology that makes the packet bounce between the two nodes.  Due to
>   this pathology, the packet never reaches the destination if it lies
>   beyond these nodes in the multi-hop path.  The solution is to mandate
>   that all the nodes parse and interpret source routing headers and
>   storing nodes to sometimes act like non-storing mode root.
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: JeongGil Ko <[email-masked]>
Date: Fri, 17 Aug 2012 20:32:39 +0900

Hi ROLL WG!

Please review and provide me with any comments regarding the document submitted below in which we discuss about a hybrid downwards routing mode where storing mode and non-storing mode nodes can interoperate! :)

Thanks!

-John

------
JeongGil Ko, Ph.D.
Researcher