Subject: Re: [Roll] MRHOF draft-11 comments

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 4 Aug 2012 07:40:57 +0200

Hi Omprakash and Philip

Could we get a reply to the below comments, I am interested to know if
they are true and if not why,

AB

> In section 3.3, it seems that the rank value using the case 3 is
> always less than the one calculated in case 2; then it is useless to
> have it. (if my understanding is true!)  This is basically because the
> highest “rank increase” that would be possible is equal to
> MaxRankIncrese.
>
>
>
> As an example imagine that a node (say N) has 3 father F1, F2 and F3
> with respectively the ranks 50, 40 and 30. Imagine that MaxRankIncrese
> is 20 and MinRankIncrease is 2. Then imagine that:
>
>
>
> Link  N à F1 gives a rank increase = 6
>
> Link N à F2  gives a rank increase = MaxRankIncrese = 20
>
> Link N à F3  gives a rank increase = 10
>
>
>
> Case 2 gives:
>
>
>
> Rank=52 (Worst Father rank belongs to F1)
>
>
>
> Case 3 gives:
>
> 40+20-20=40 (Since the highest rank is through F2)
>
>
>
> Now consider the same example but with this changes (this is the worst
> case where the link to the father with worst rank gives also the
> highest rank increase):
>
>
>
> Link  N à F1 gives a rank increase = MaxRankIncrese = 20
>
> Link N à F2  gives a rank increase = 8
>
> Link N à F3  gives a rank increase = 10
>
>
>
>
>
> Case 2 gives:
>
> Rank=52
>
>
>
> Case 3 gives:
>
> 50+20-20=50 (Since the highest rank is through F1)
>
>
>
> Thanks
>
> -Mehdi
>

---

From: Philip Levis <[email-masked]>
Date: Sun, 5 Aug 2012 15:06:11 -0700

On Jul 25, 2012, at 7:02 AM, Mani, Mehdi wrote:

> In section 3.3, it seems that the rank value using the case 3 is always less than the one calculated in case 2; then it is useless to have it. (if my understanding is true!)  This is basically because the highest “rank increase” that would be possible is equal to MaxRankIncrese.

I think that #3 can be higher than #2 when a link cost is much higher than MaxRankIncrease. Here's a parent set:

Parent A advertises a Rank of 40, link cost is 10.
Parent B advertises a Rank of 50, link cost is 250

Let's suppose MaxRankIncrease is 5 and MinHopRankIncrease is 15. Following rule 2, the advertised rank must be 60. Following rule 3, the advertised rank must be 245. I realize this is a pretty extreme case (why is parent B in the parent set?!?!), but there are less extreme ones and these rules are for correctness, not performance.

Does this sound right to you?

Phil