Subject: Re: [Roll] Fwd: New Version Notification for draft-ko-roll-mix-network-pathology-00.txt

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 17 Aug 2012 15:06:01 +0100

Hi John,

I like the work, as I always beleive that LLN is has mixed nodes of
different  capabilities,
the work I am doing has in the routing aspects similar which is about node
ability NAP [*]. However, I support your work as well,

Comments on your draft 00:
----------------------------------------------------------------------------------------------------------------------------
section 4>N is operating in non-storing mode so without a source routing
header, it will forward the packet back to S. Thus the packet bounces
between N and S.

A node should not forward to prefered next-hop towice, or it should never
forward (while it doesn't know the path to destination) to a node which
already send the packet to it.
----------------
section 5>A new mode of operation (MOP) that allows a node to choose either
   to implement the storing or non-storing features, or both.  The
   changes below are made compared to the original storing and non-
   storing modes.

you may add, that there are alot of LLN possibility of it nodes non-store
and store modes, as destinations maybe store or/and non-store and the root
also maybe store and/or non-store. IMO, this section is still not complete
to cover all possibilities.

-------------------------------------------------------------------------------------------------------------------------------

In my work [*] I name this operation mode you refer, as node ability. The
node will choose the mode depending on the ability metric. However, your
draft is interesting because this pathology function will be within the
routing RPL function and depending on OF.

[*] http://tools.ietf.org/id/draft-baryun-roll-nap-00.txt

Best Regards

Abdussalam Baryun
University of Glamorgan, UK
======================

---

From: JeongGil Ko <[email-masked]>
Date: Fri, 17 Aug 2012 23:17:16 +0900

Hi Abdussalam,

Thanks for your quick comments :)

My comments in-line.

On Aug 17, 2012, at 11:06 PM, Abdussalam Baryun wrote:

> Hi John,
>  
> I like the work, as I always beleive that LLN is has mixed nodes of different  capabilities,
> the work I am doing has in the routing aspects similar which is about node ability NAP [*]. However, I support your work as well,
>  
> A node should not forward to prefered next-hop towice, or it should never forward (while it doesn't know the path to destination) to a node which already send the packet to it.

I can improve the text in -01 so that eventually an ICMPv6 error message is initiated.

> you may add, that there are alot of LLN possibility of it nodes non-store and store modes, as destinations maybe store or/and non-store and the root also maybe store and/or non-store. IMO, this section is still not complete to cover all possibilities.

I see your point (partially). We need to add to the draft that the root of the DODAG in a MOP 5 operation should have route storing capabilities. What's really important, as the draft indicates is if the next hop has route storing capabilities or not. With this determined, if the next hop is a route storing node the sender can just transmit the packet right away. On the other hand if the next hop does not have this capability, a SRH needs to be attached. 

> In my work [*] I name this operation mode you refer, as node ability. The node will choose the mode depending on the ability metric. However, your draft is interesting because this pathology function will be within the routing RPL function and depending on OF.
>  

Not sure here but for sure the proposed draft does not require a specific OF (if this is what you are implying). As long as there is a DODAG (constructed with any OF) the proposal is a small addition to the original storing and non-storing mode implementations. 

Thanks!

-John

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 17 Aug 2012 15:29:41 +0100

Hi John,

Thanks, also I want to see more examples of pathology advantages. I just
have read quickly through, but happy to discuss the draft in more details
when I get more time.

AB
===

On Fri, Aug 17, 2012 at 3:17 PM, JeongGil Ko <[email-masked]> wrote:

> > the work I am doing has in the routing aspects similar which is about
> node ability NAP [*]. However, I support your work as well,
> >
> > A node should not forward to prefered next-hop towice, or it should
> never forward (while it doesn't know the path to destination) to a node
> which already send the packet to it.
>
> > you may add, that there are alot of LLN possibility of it nodes
> non-store and store modes, as destinations maybe store or/and non-store and
> the root also maybe store and/or non-store. IMO, this section is still not
> complete to cover all possibilities.
>
> I see your point (partially). We need to add to the draft that the root of
> the DODAG in a MOP 5 operation should have route storing capabilities.
> What's really important, as the draft indicates is if the next hop has
> route storing capabilities or not. With this determined, if the next hop is
> a route storing node the sender can just transmit the packet right away. On
> the other hand if the next hop does not have this capability, a SRH needs
> to be attached.
>
> >
> >
> > In my work [*] I name this operation mode you refer, as node ability.
> The node will choose the mode depending on the ability metric. However,
> your draft is interesting because this pathology function will be within
> the routing RPL function and depending on OF.
> >
>
> Not sure here but for sure the proposed draft does not require a specific
> OF (if this is what you are implying). As long as there is a DODAG
> (constructed with any OF) the proposal is a small addition to the original
> storing and non-storing mode implementations.
>
> Thanks!
>
> -John
>