Subject: Re: [Roll] Draft Agenda

From: Jon Black <[email-masked]>
Date: Tue, 30 Oct 2012 13:41:56 -0700 (PDT)

>From looking at the drafts - one has a cisco author and the other doesn't - hmmm.

    Jon

Phill Levis said on October 30, 2012 at 8:19 am:

I'm a little worried that the one draft which is based on a real, documented problem encountered in a deployment is considered to have "no traction on the mailing list", despite several discussions, while "Industrial Deterministic Routing Extension for Low-Power and Lossy Networks," which I have never seen mentioned on the mailing list (can someone point out that I'm wrong) does have a slot. This doesn't mean that the other draft shouldn't have a slot; I just don't understand the process by which slots are being decided.

Phil

On Oct 29, 2012, at 11:44 PM, JP Vasseur (jvasseur) wrote: 
Dear all, Many Thanks for your email - we did discuss about it but there pretty much no traction on the mailing list on this item.
Please continue to use the mailing at will. This is why the item is not part of the agenda indeed. Many Thanks. JP and Michael. On Oct 30, 2012, at 3:14 AM, JeongGil Ko wrote: 
>Dear WG Chairs, For some reason... this email seems to be ignored… any responses?  -John ------
JeongGil Ko, Ph.D.
Researcher
Electronics and Telecommunications Research Institute (ETRI) http://sites.google.com/site/jeonggilko/ On Oct 26, 2012, at 9:39 PM, 정종수 <[email-masked]> wrote: 
>>JP, John has requested a slot. But we've not been replied anything. Is the agenda already fixed? Regards,
-Jongsoo 2012. 10. 25., 오전 6:41, JeongGil Ko <[email-masked]> 작성: 
>>>JP, I've also put in a request for a slot at the meeting in Atlanta for presenting "draft-ko-roll-mix-network-pathology" but I do not see this on the agenda. This draft discusses about a critical and practical performance issue of RPL networks (both collection and downwards) when they are intentionally or accidentally deployed with devices of different MOPs. I believe that such an issue is important to discuss as a group. Thanks. -John ------
JeongGil Ko, Ph.D.
Researcher
Electronics and Telecommunications Research Institute (ETRI) http://sites.google.com/site/jeonggilko/ On Oct 25, 2012, at 3:06 AM, JP Vasseur (jvasseur) wrote: 
>>>>Dear all, please find bellow the draft agenda for ROLL's WG meeting in Atlanta - let us know if you have any comment: 1) Agenda/admin (Chairs - 5mn) [5] 2) WG Status (Chairs - 10 mn) [15] 3) Security Framework and Applicability Statement template
(Michael - 10m) [25]
draft=draft-richardson-roll-applicability-template-00 4) RPL applicability in industrial networks
draft-phinney-roll-rpl-industrial-applicability-01
(Pascal - 10mn) [35] 5) Industrial Deterministic Routing Extension for Low-Power
and Lossy Networks (M. Wei - 10mn) [45] 6) RPL deployment experience in large scale networks
draft-hui-vasseur-roll-rpl-deployment (TBD - 5mn) [50] 7) RPL applicability in industrial networks
draft-phinney-roll-rpl-industrial-applicability-01
(Pascal - 10mn) [60] 8) Loop Free DODAG Local Repair (Jianlin Guo - 10mn) [70]
draft-guo-roll-loop-free-dodag-repair Thanks. JP and Michael.
_______________________________________________
Roll mailing list [email-masked] https://www.ietf.org/mailman/listinfo/roll 
>>>>_______________________________________________
Roll mailing list [email-masked] https://www.ietf.org/mailman/listinfo/roll 
>>>_______________________________________________
Roll mailing list [email-masked] https://www.ietf.org/mailman/listinfo/roll 
>_______________________________________________
Roll mailing list [email-masked] https://www.ietf.org/mailman/listinfo/roll 
_______________________________________________
Roll mailing list [email-masked] https://www.ietf.org/mailman/listinfo/roll

---

From: JeongGil Ko <[email-masked]>
Date: Thu, 1 Nov 2012 00:20:32 +0900

Hmmm... Looks like this question on the clarification of the slot decision process is also lacking a reply?

-John

------
JeongGil Ko, Ph.D.
Researcher
Electronics and Telecommunications Research Institute (ETRI)
http://sites.google.com/site/jeonggilko/

On Oct 31, 2012, at 5:41 AM, Jon Black wrote:

>> Dear all,
>> Many Thanks for your email - we did discuss about it but there pretty much no traction on the mailing list on this item.
>> Please continue to use the mailing at will. This is why the item is not part of the agenda indeed.
>> 
>> Many Thanks.
>> 
>> JP and Michael.
>> 
>> On Oct 30, 2012, at 3:14 AM, JeongGil Ko wrote:
>> 
>> 
>>> Dear WG Chairs,
>>> 
>>> For some reason... this email seems to be ignored… any responses? 
>>> 
>>> -John
>>> 
>>> ------
>>> JeongGil Ko, Ph.D.
>>> Researcher
>>> Electronics and Telecommunications Research Institute (ETRI)
>>> 
>>> http://sites.google.com/site/jeonggilko/
>>> 
>>> 
>>> On Oct 26, 2012, at 9:39 PM, 정종수 
>>> <[email-masked]>
>>>  wrote:
>>> 
>>> 
>>>> JP,
>>>> 
>>>> John has requested a slot. But we've not been replied anything. Is the agenda already fixed?
>>>> 
>>>> Regards,
>>>> -Jongsoo
>>>> 
>>>> 2012. 10. 25., 오전 6:41, JeongGil Ko 
>>>> <[email-masked]>
>>>>  작성:
>>>> 
>>>> 
>>>>> JP,
>>>>> 
>>>>> I've also put in a request for a slot at the meeting in Atlanta for presenting "draft-ko-roll-mix-network-pathology" but I do not see this on the agenda. This draft discusses about a critical and practical performance issue of RPL networks (both collection and downwards) when they are intentionally or accidentally deployed with devices of different MOPs. I believe that such an issue is important to discuss as a group.
>>>>> 
>>>>> Thanks.
>>>>> 
>>>>> -John
>>>>> 
>>>>> ------
>>>>> JeongGil Ko, Ph.D.
>>>>> Researcher
>>>>> Electronics and Telecommunications Research Institute (ETRI)
>>>>> 
>>>>> http://sites.google.com/site/jeonggilko/
>>>>> 
>>>>> 
>>>>> On Oct 25, 2012, at 3:06 AM, JP Vasseur (jvasseur) wrote:
>>>>> 
>>>>> 
>>>>>> Dear all,
>>>>>> 
>>>>>> please find bellow the draft agenda for ROLL's WG meeting in Atlanta - let us know if you have any comment:
>>>>>> 
>>>>>> 1) Agenda/admin (Chairs - 5mn) [5]
>>>>>> 
>>>>>> 2) WG Status (Chairs - 10 mn) [15]
>>>>>> 
>>>>>> 3) Security Framework and Applicability Statement template
>>>>>> (Michael - 10m) [25]
>>>>>> draft=draft-richardson-roll-applicability-template-00
>>>>>> 
>>>>>> 4) RPL applicability in industrial networks
>>>>>> (Pascal - 10mn) [35]
>>>>>> 5) Industrial Deterministic Routing Extension for Low-Power
>>>>>> and Lossy Networks (M. Wei - 10mn) [45]
>>>>>> 
>>>>>> 6) RPL deployment experience in large scale networks
>>>>>> draft-hui-vasseur-roll-rpl-deployment (TBD - 5mn) [50]
>>>>>> 
>>>>>> 7) RPL applicability in industrial networks
>>>>>> (Pascal - 10mn) [60]
>>>>>> 8) Loop Free DODAG Local Repair (Jianlin Guo - 10mn) [70]
>>>>>> draft-guo-roll-loop-free-dodag-repair
>>>>>> 
>>>>>> Thanks.
>>>>>> 
>>>>>> JP and Michael.
>>>>>> Roll mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/roll
>>>>> Roll mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/roll
>>>> Roll mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/roll
>> Roll mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/roll
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Philip Levis <[email-masked]>
Date: Wed, 31 Oct 2012 16:17:12 -0700

On Oct 31, 2012, at 11:39 AM, Michael Richardson wrote:

> 
> Please be aware that among JP and I, I'm the one pushing loudest to 
> restrict our meeting slot time to (in order of priority):
> 
> 1) things in our charter.
> 2) things with activity on the mailing list.
> 3) things with reproduceable problem statements that might need
>   to go into the charter.
> 
> You may have noticed how incredibly full the IETF meetings are.
> 
> The Area Directors have been pushing very hard on the WG chairs 
> to make sure that we understand that the IETF sessions are *not* for
> presentations, but for discussion.

This makes a lot of sense -- the goal of the presentation is to clearly state the points for discussion. That being said, it does seem a little weird that drafts which haven't been mentioned on the mailing list are going to be discussed.

> So, again: If there is work that you think has relevance to the
> ROLL WG, then please bring it up on the list.  
> If it's not controversial, then we don't need to discuss it.
> 
> If it's very controversial, then we need to pin down the set of concerns
> we have with it, so that, next week, when are together, we can focus
> on the actual issues.  We aren't there to watch powerpoints.

Whether RPL should support mixed mode operation seems pretty controversial to me.

Phil

---

From: JeongGil Ko <[email-masked]>
Date: Thu, 1 Nov 2012 10:18:06 +0900

Michael,

Thanks for the clarification. However, this information still doesn't explain why Industrial Deterministic Routing Extension for Low-Power and Lossy Networks is on the agenda and draft-ko-roll-mix-network-pathology is not on the agenda. I believe draft-ko-roll-mix-network-pathology had more discussions that the other on the mailing list on whether or not this feature was needed in RPL.

-John

------
JeongGil Ko, Ph.D.
Researcher

On Nov 1, 2012, at 3:39 AM, Michael Richardson <[email-masked]>
wrote:

> -- 
> Michael Richardson <[email-masked]>, Sandelman Software Works 
> IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/
>