Subject: [Roll] Is there comparisons reported between RPL and LOADng

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 14 Oct 2012 10:32:33 +0200

Hi Henning,

Related to discussion in MANET WG list> Sub: Re: [manet] MANET meeting
at IETF85.

Read in line
>On 10/14/12, Henning Rogge <[email-masked]> wrote:
>>On Sun, Oct 14, 2012 at 10:00 AM, Abdussalam Baryun
<abdussalambaryun at gmail.com> wrote:
>> It is not right to think that
>> authors just will change words from LLN to be replaced by MANET as if
>> they are the same networks.
>
>> Also we should notice that LOADng is not
>> better performance than RPL for specific networks as *LLNs*. If it is
>> we report the facts.
>
> Are you aware of some comparison between RPL and LOADng based on
> testing? If not, this makes absolutely no sense.
>

I already listened to many discussions in ROLL WG and with results
presented in the IETF meeting regarding RPL performance. Please note
that I have not seen any LOADng results presented, I already called
for it but no respond within the IETF. Yes I agree we base things on
testing but only testing that are translated in engineering
documents/reports to make sense. Do you have a pointer to a LOADng
report for LLN tests? please help or respond because I am interested
to make things make sense in IETF.

AB

> Henning Rogge
>
> --
> Steven Hawkings about cosmic inflation: "An increase of billions of
> billions of percent in a tiny fraction of a second. Of course, that
> was before the present government."
>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sun, 14 Oct 2012 11:54:13 +0000

Note that we are chartered for one routing protocol, RPL. 
I am aware of a number of comparisons, and would enrage the authors to get back to you.
Thanks.

JP.

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 14 Oct 2012 13:07:02 +0100

Hi JP,

Do you mean that IETF ROLL WG is not allowed to have another routing
protocol for LLN. Why is the WG constrained to that, while the
Internet industry are more free/flexible? Not forgetting that we get
answers from participants in the WG that companies are not allowed to show
their testing-results of our RPL in the IETF.

AB
On Sun, Oct 14, 2012 at 12:54 PM, JP Vasseur (jvasseur)

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sun, 14 Oct 2012 16:17:07 +0000

Hi AB,

On Oct 14, 2012, at 2:07 PM, Abdussalam Baryun wrote:

Hi JP,

Do you mean that IETF ROLL WG is not allowed to have another routing protocol for LLN. Why is the WG constrained to that, while the Internet industry are more free/flexible?

JP> Happy to explain: ROLL was chartered for ONE protocol. Actually we were initially chartered t without protocol (show first that a new protocol was needed).
Then we came up with RPL (RFC6550 and companion documents). ROLL may at some point design another routing protocol, after re-chartering if agreed by the
IESG, if we need to.

Not forgetting that we get answers from participants in the WG that companies are not allowed to show their testing-results of our RPL in the IETF.

JP> This is the contrary ! Please share your results, they are VERY welcome !

Thanks.

JP.

AB
On Sun, Oct 14, 2012 at 12:54 PM, JP Vasseur (jvasseur) <[email-masked]<mailto:[email-masked]>> wrote:
Note that we are chartered for one routing protocol, RPL.
I am aware of a number of comparisons, and would enrage the authors to get back to you.
Thanks.

JP.

On Oct 14, 2012, at 10:32 AM, Abdussalam Baryun wrote:

>> On 10/14/12, Henning Rogge <[email-masked]<mailto:[email-masked]>> wrote:
> <abdussalambaryun at gmail.com<http://gmail.com/>> wrote:

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 15 Oct 2012 12:01:45 +0200

Hi Michael,

I support the decision to have one for now, and others after we
complete the milestones and recharter, but don't want to think that we
are unable to discuss how to improve that one protocol, or think we
are unable to show its testing-results. IF we are unable to show
results we will never progress in IETF, and only Industry
Organisations can progress because they have no regulation to stop new
protocol ideas and discussions.

I am happy to show my results when ready, and I am doing my
investigation when completed I will present the results within IETF
(not only outside) so we can go in progress. Please note that there
was discussions in IETF WG meetings about RPL results and I like to
clear that noise with more results in IETF. I seen so far good results
in IETF ROLL WG but would like to see more scalable ones if possible.
IF the claims are true that RPL is not scalable THEN we need to look
into this matter.

Thanks
AB

On 10/14/12, Michael Richardson <[email-masked]> wrote:
>
>>>>>> "Abdussalam" == Abdussalam Baryun <[email-masked]>
>>>>>> writes:
>     Abdussalam> Do you mean that IETF ROLL WG is not allowed to have
>     Abdussalam> another routing
>     Abdussalam> protocol for LLN. Why is the WG constrained to that, while
> the
>     Abdussalam> Internet industry are more free/flexible? Not forgetting
>     Abdussalam> that we get
>
> That's correct: we are not allowed to consider other protocols anymore.
> There was a time and a place for that, and it's over.
>
> If you try to do everything, you wind up doing nothing,
> So, IETF working groups have a charter of what is in scope and what is not:
>     http://datatracker.ietf.org/wg/roll/charter/
>
> Back in 2008, the WG adopted a specific proposal.
>
> Anyone else who has results that they want to publish are encouraged to
> do so in appropriate place, and send a link to this mailing list.
>
> End of thread.
>
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works
> IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/
>
>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Mon, 15 Oct 2012 10:46:39 +0000

Dear AB,

> protocol ideas and discussions.

JP> As pointed out by Michael and I, the ROLL WG can definitely improve 
the protocol *and* results are very welcome !

> IF the claims are true that RPL is not scalable THEN we need to look

JP> Definitely.

Thanks for your participation.

JP.

> [email-masked]

---

From: "Dijk, Esko" <[email-masked]>
Date: Mon, 15 Oct 2012 13:49:46 +0000

Hi AB, JP,

I'm confused on this discussion - just wondering whether draft-ietf-roll-trickle-mcast-01 counts as a second routing protocol then?
It is not part of RPL in any way but still an accepted WG draft.

regards,
Esko

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of JP Vasseur (jvasseur)
Sent: Monday 15 October 2012 12:47
To: Abdussalam Baryun
Cc: roll
Subject: Re: [Roll] Is there comparisons reported between RPL and LOADng

Dear AB,

JP> Definitely.

JP.

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 16 Oct 2012 12:38:16 +0200

Hi Esko,

It is a protocol technique not a routing protocol, So the one Router
for LLNs which is RPL. IMO, Trickle is needed in LLNs.

AB

On 10/15/12, Dijk, Esko <[email-masked]> wrote:
> Hi AB, JP,
>
> I'm confused on this discussion - just wondering whether
> draft-ietf-roll-trickle-mcast-01 counts as a second routing protocol then?
> The information contained in this message may be confidential and legally
> protected under applicable law. The message is intended solely for the
> addressee(s). If you are not the intended recipient, you are hereby notified
> that any use, forwarding, dissemination, or reproduction of this message is
> strictly prohibited and may be unlawful. If you are not the intended
> recipient, please contact the sender by return e-mail and destroy all copies
> of the original message.
>
>

---

From: "Dijk, Esko" <[email-masked]>
Date: Tue, 16 Oct 2012 10:47:56 +0000

Hi,

Ok, I agree that Trickle Multicast Forwarding does not do any routing in the sense of route selection or route maintenance. The document itself calls it "forwarding" which is implemented by "forwarders", which are also defined to be IPv6 routers. (It's also called flooding at some points in the draft.)

So there should be room for a flooding/forwarding technique in ROLL, then :)

Esko

-----Original Message-----
From: Abdussalam Baryun [mailto:[email-masked]]
Sent: Tuesday 16 October 2012 12:38
To: Dijk, Esko
Cc: JP Vasseur (jvasseur); roll
Subject: Re: [Roll] Is there comparisons reported between RPL and LOADng

Hi Esko,

AB

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Tue, 16 Oct 2012 11:14:23 +0000

THis is indeed the case.

Thanks.

JP.