Subject: Re: [Roll] I-D Action: draft-ietf-roll-trickle-mcast-03.txt

From: Don Sturek <[email-masked]>
Date: Fri, 25 Jan 2013 17:14:18 -0600

Hi Abdulsalam,

Unfortunately, the ZigBee Alliance is a commercial standards group so we cannot provide copies of the test plan

I believe we can summarize the tests and provide a summarized report.

Don Sturek

From my Android phone on T-Mobile. The first nationwide 4G network.

-------- Original message --------
From: Abdussalam Baryun <[email-masked]> 
Date:  
To: "Reddy, Joseph" <[email-masked]> 
Cc: [email-masked] 
Subject: Re: [Roll] I-D Action: draft-ietf-roll-trickle-mcast-03.txt 
 
Hi Joseph,

That is good news, please inform us with the test results, because I
don't know what was the test (steps or metrics) and what was the
success in what, the interop has a large meaning which I may not
understand, please advise,

AB

On 1/25/13, Reddy, Joseph <[email-masked]> wrote:
>
> Thanks Jonathan and Richard for the updated draft. It looks good and
> addressed all my previous comments.
>
> I should also mention that we have been performing interoperability testing
> within the ZigBee IP community this week. We have 6 independent
> implementations of the MPL protocol (running over 802.15.4 radios) and were
> able to successfully interop among all of them. We tested MPL protocol with
> and without the tunneling options.
>
>
> -Regards, Joseph
>
> ------------------------------
>
> Message: 5
> Date: Thu, 24 Jan 2013 08:09:07 -0800
> From: [email-masked]
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Roll] I-D Action: draft-ietf-roll-trickle-mcast-03.txt
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the Routing Over Low power and Lossy networks
> Working Group of the IETF.
>
> Title           : Multicast Protocol for Low power and Lossy Networks
> (MPL)
> Author(s)       : Jonathan W. Hui
>                           Richard Kelsey
> Filename        : draft-ietf-roll-trickle-mcast-03.txt
> Pages           : 29
> Date            : 2013-01-24
>
> Abstract:
>    This document specifies the Multicast Protocol for Low power and
>    Lossy Networks (MPL) that provides IPv6 multicast forwarding in
>    constrained networks.  MPL avoids the need to construct or maintain
>    any multicast forwarding topology, disseminating messages to all MPL
>    forwarders in an MPL domain.  MPL uses the Trickle algorithm to
>    manage message transmissions for both control and data-plane
>    messages.  Different Trickle parameter configurations allow MPL to
>    trade between dissemination latency and transmission efficiency.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-roll-trickle-mcast
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-roll-trickle-mcast-03
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-roll-trickle-mcast-03
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 26 Jan 2013 02:05:03 +0100

Hi Don,

A summary is good. I think the test/result summary or answer to the
questions will help, or even better an I-D submitted. comments in
line;

> cannot provide copies of the test plan

I don't request to know every thing, just when this organisation uses
an I-D specification it will be benefit to WG to know the
test+method+results otherwise it will be just notification of
external-events
> I believe we can summarize the tests and provide a summarized report.

No problem. Usually I did not start the discussion just reflecting. As
this is a discussion list of ROLL, and I received a notification of an
event in this list, made me starting discussing, and want to continue
if the thread poster still likes to continue. A summary will make a
very big difference, thanks. Waiting for the summary :)

AB