Subject: [Roll] Adoption of draft-brandt-roll-rpl-applicability-home-building as a new ROLL WG document

From: Anders Brandt <[email-masked]>
Date: Wed, 6 Feb 2013 08:52:06 +0000

Dear WG,

The applicability statement document for home and building has been updated:
http://tools.ietf.org/html/draft-brandt-roll-rpl-applicability-home-building-03

At this time, the authors would like to ask that the document as adopted as a working group document.

Thanks,
  Anders Brandt

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 6 Feb 2013 12:14:37 +0100

Hi Anders,

Why you change the aim of the draft? from RPL to RPL-P2P, was there a
discussion about this please advise,

AB

On 2/6/13, Anders Brandt <[email-masked]> wrote:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 6 Feb 2013 12:33:08 +0100

Why you discuss peer-to-multipeer that it is in building use, while
you make the aim for RPL-P2P as only peer-to-peer for building
applicability?

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 6 Feb 2013 19:18:11 +0100

I suggest you leave the aim as it was in previous version RPL
applicability in home and building,  sections of RPL-P2P and RPL-P2MP
should be in the scope,

AB

On 2/6/13, Abdussalam Baryun <[email-masked]> wrote:
>> At this time, the authors would like to ask that the document as adopted
>> as
>> a working group document.
>>
>> Thanks,
>>   Anders Brandt
>>
>>

---

From: Robert Cragie <[email-masked]>
Date: Wed, 06 Feb 2013 21:59:34 +0000

The applicability statement, when it was originally produced, identified 
issues with RPL as it stood then for applicability in home and building 
automation. This kicked off the development of the RPL-P2P work, which 
is more or less complete. Therefore it is logical to refer to this work 
in the updated document.

Robert

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 7 Feb 2013 11:56:59 +0000

On Wed, Feb 6, 2013 at 9:59 PM, Robert Cragie
<[email-masked]>wrote:

> automation. This kicked off the development of the RPL-P2P work, which is
> more or less complete. Therefore it is logical to refer to this work in the
> updated document.
>
>
I agree that it is logical *to refer* and discuss applicability of RPL-P2P,
but don't agree to change the aim of the draft from RPL to RPL-P2P. Do you
think both protocols are similar, or do you think that RPL is not
applicabile for home applications, just RPL-P2P?

AB

---

From: Anders Brandt <[email-masked]>
Date: Fri, 8 Feb 2013 09:56:12 +0000

Abdussalam,

>I agree that it is logical *to refer* and discuss applicability of RPL-P2P, but don't agree to change the aim
>of the draft from RPL to RPL-P2P.
>Do you think both protocols are similar, or do you think that RPL is not applicabile for home applications, just RPL-P2P?

I think that the protocols are not similar and I think that P2P-RPL is applicable for home applications.
Restating Robert's comment, the draft in its original form was a sort of problem statement which helps nobody designing anything.
The natural evolution of the draft was to describe how one could meet the requirements for home applications; and to the authors
of the draft, P2P-RPL seems to be the best choice for home applications.

I have no intention of preventing others from evaluating the applicability of RPL for home applications.

Thanks,
  Anders

From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 7. februar 2013 12:57
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Roll] Adoption of draft-brandt-roll-rpl-applicability-home-building as a new ROLL WG document

On Wed, Feb 6, 2013 at 9:59 PM, Robert Cragie <[email-masked]<mailto:[email-masked]>> wrote:
The applicability statement, when it was originally produced, identified issues with RPL as it stood then for applicability in home and building automation. This kicked off the development of the RPL-P2P work, which is more or less complete. Therefore it is logical to refer to this work in the updated document.

I agree that it is logical *to refer* and discuss applicability of RPL-P2P, but don't agree to change the aim of the draft from RPL to RPL-P2P. Do you think both protocols are similar, or do you think that RPL is not applicabile for home applications, just RPL-P2P?

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 8 Feb 2013 18:52:00 +0100

Hi Anders,

So I understand draft change title/aim from RPL to P2P reason; the
authors found that P2P-RPL is the best choice for home applications.
My comments below,

On 2/8/13, Anders Brandt <[email-masked]> wrote:
>> but don't agree to change the aim
>>Do you think both protocols are similar, or do you think that RPL is not

So I understand from your reply that you think RPL MAY NOT be
applicabale for home and building application,

> Restating Robert's comment, the draft in its original form was a sort of
> problem statement which helps nobody designing anything.
> The natural evolution of the draft was to describe how one could meet the
> requirements for home applications; and to the authors

why it is best choice? this was not mentioned clearly in draft,

> of RPL for home applications.

I prefered discuss both in draft, so that RPL and RPL are protocols of
ROLL and to describe how to meet the applicability for them in
buildings and home,

or describe P2P in this draft and leave others as P2MP and RPL in
other draft if you like

AB

---

From: peter van der Stok <[email-masked]>
Date: Mon, 11 Feb 2013 15:07:02 +0100

Hi Anders,

I do miss a discussion on the reliability of the P2P communication 
coupled to timeliness.
LLN have the property that links are lost during unknown periods. The 
path using the link is unusable during that period.
It takes some time before alternative paths are found and established.
Using multiple paths avoiding link duplication is essential to provide 
reliability with timeliness.

A simple frequently occurring example is the one-hop path from A to B.
The link can fail during seconds. Having an alternative two hop path 
routing a copy "simultaneously" will make quite a difference.

I understood that P2P routing includes multipath routing, and hope you 
will put some more emphasis on this aspect.

Greetings,

peter

---

From: Anders Brandt <[email-masked]>
Date: Mon, 18 Feb 2013 07:51:19 +0000

Hi Peter

> I understood that P2P routing includes multipath routing, and hope you will put some more emphasis on this aspect.

Thanks for the input - Good point!
I will make sure to get that into the next version.

- Anders

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of peter van der Stok
Sent: 11. februar 2013 15:07
To: [email-masked]
Subject: Re: [Roll] Adoption of draft-brandt-roll-rpl-applicability-home-building as a new ROLL WG document

Hi Anders,

I do miss a discussion on the reliability of the P2P communication coupled to timeliness.
LLN have the property that links are lost during unknown periods. The path using the link is unusable during that period.
It takes some time before alternative paths are found and established.
Using multiple paths avoiding link duplication is essential to provide reliability with timeliness.

A simple frequently occurring example is the one-hop path from A to B.
The link can fail during seconds. Having an alternative two hop path routing a copy "simultaneously" will make quite a difference.

I understood that P2P routing includes multipath routing, and hope you will put some more emphasis on this aspect.

Greetings,

peter