Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-16.txt

From: [email-masked]
Date: Sun, 03 Feb 2013 12:49:32 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : Reactive Discovery of Point-to-Point Routes in Low Power and Lossy Networks
	Author(s)       : Mukul Goyal
                          Emmanuel Baccelli
                          Matthias Philipp
                          Anders Brandt
                          Jerald Martocci
	Filename        : draft-ietf-roll-p2p-rpl-16.txt
	Pages           : 36
	Date            : 2013-02-03

Abstract:
   This document specifies a point-to-point route discovery mechanism,
   complementary to the RPL core functionality.  This mechanism allows
   an IPv6 router to discover "on demand" routes to one or more IPv6
   routers in the LLN such that the discovered routes meet specified
   metrics constraints.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-roll-p2p-rpl

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-roll-p2p-rpl-16

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-roll-p2p-rpl-16

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mukul Goyal <[email-masked]>
Date: Sun, 3 Feb 2013 15:13:31 -0600 (CST)

Hi all

This version incorporates some editorial changes made in response to the comments we received as part of the IESG review. The only real change is the following:

The Life Time field in the P2P Route Discovery Option inside a DIO now indicates the _exact_ life time of the temporary DAG created for a P2P-RPL route discovery. Earlier, this field indicated the _minimum_ life time of the temporary DAG. This change means that a router MUST detach from the temporary DAG once the duration of its membership in the temporary DAG has reached the Life Time duration listed in the P2P Route Discovery Option.

This change was required because there was a need to know precisely when does a route discovery complete so that the RPLInstanceID used in this route discovery can be reused in another route discovery.

Thanks
Mukul

----- Original Message -----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Sent: Sunday, February 3, 2013 2:49:32 PM
Subject: [Roll] I-D Action: draft-ietf-roll-p2p-rpl-16.txt

Abstract:

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 6 Feb 2013 13:40:13 +0100

On 2/3/13, Mukul Goyal <[email-masked]> wrote:
>This change means that a router MUST detach from the
> temporary DAG once the duration of its membership in the temporary DAG has
> reached the Life Time duration listed in the P2P Route Discovery Option.
>
I read meaning in draft:
that the origin MUST detach from the temporary DAG......

> This change was required because there was a need to know precisely when
> does a route discovery complete so that the RPLInstanceID used in this route
> discovery can be reused in another route discovery.

So I understand that the need has been solved and by the update, the
origin knows precisely the time,

AB