Subject: [Roll] Heads up : Last Call: <draft-cardenas-dff-09.txt> (Depth-First Forwarding in Unreliable Networks (DFF)) to Experimental RFC

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 7 Feb 2013 13:47:35 -0000

This could affect you.
Please comment (if you want to) on the IETF list as described.

Thanks,
Adrian

> -----Original Message-----
> From: [email-masked] [mailto:ietf-announce-
> [email-masked]] On Behalf Of The IESG
> Sent: 07 February 2013 13:22
> To: IETF-Announce
> Subject: Last Call: <draft-cardenas-dff-09.txt> (Depth-First Forwarding in
> Unreliable Networks (DFF)) to Experimental RFC
> 
> 
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Depth-First Forwarding in Unreliable Networks (DFF)'
>   <draft-cardenas-dff-09.txt> as Experimental RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2013-02-24. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>    This document specifies the "Depth-First Forwarding" (DFF) protocol
>    for IPv6 networks, a data forwarding mechanism that can increase
>    reliability of data delivery in networks with dynamic topology and/or
>    lossy links.  The protocol operates entirely on the forwarding plane,
>    but may interact with the routing plane.  DFF forwards data packets
>    using a mechanism similar to a "depth-first search" for the
>    destination of a packet.  The routing plane may be informed of
>    failures to deliver a packet or loops.  This document specifies the
>    DFF mechanism both for IPv6 networks (as specified in RFC2460) and in
>    addition also for LoWPAN "mesh-under" networks (as specified in
>    RFC4944).
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-cardenas-dff/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-cardenas-dff/ballot/
> 
> 
> The following IPR Declarations may be related to this I-D:
> 
>    http://datatracker.ietf.org/ipr/1645/
>    http://datatracker.ietf.org/ipr/1646/
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 7 Feb 2013 22:47:17 +0100

I didn't understand what kind of affect it can make. This draft was
not submitted to ROLL, but to IETF. Was this draft before
discussed/presented in 6LowPAN or ROLL? However, IMO all drafts old
and new may affect each other in IETF for progress, which is good.

AB

On 2/7/13, Adrian Farrel <[email-masked]> wrote:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 7 Feb 2013 17:31:20 -0800

AB,

this draft is an individual draft, not going through a working group. The
document specifies a data forwarding mechanism that can improve data
delivery reliability, and thus is relevant in the Internet Area of the
IETF, more than the Routing Area (of which ROLL is part). The 6lowpan WG
does not accept any new work items.
The DFF mechanism can use information from different routing protocols.
There are several implementations and deployments, as described in the
draft.

Best regards
Ulrich

---

From: Ralph Droms <[email-masked]>
Date: Fri, 22 Feb 2013 09:26:12 -0500

Following up on Adrian's announcement of Feb 7...

draft-cardenas-dff is under consideration for publication as an AD-sponsored individual submission Experimental RFC.  I agreed to sponsor it for publication because it doesn't really fit in any existing working groups and the requested publication status is Experimental.  As part of the review process, the document is in a 2-week IETF last call.  To ensure the quality of the document, it would be helpful to get reviews from roll WG participants (posted to the [email-masked] discussion list).

Expressions of an opinion about whether or not to publish the document, in addition to technical input to the authors, would be useful.

Thanks.

- Ralph

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 25 Feb 2013 07:05:41 +0100

Hi Ralph,

I ended my comments today with the last input, hope that is ok,
because it mention 24 Feb and today is 25 Feb, however, thanks for
reminder,

AB

On 2/22/13, Ralph Droms <[email-masked]> wrote:
> draft-cardenas-dff is under consideration for publication as an AD-sponsored
> individual submission Experimental RFC.  I agreed to sponsor it for
> publication because it doesn't really fit in any existing working groups and
> the requested publication status is Experimental.  As part of the review
> process, the document is in a 2-week IETF last call.  To ensure the quality
> of the document, it would be helpful to get reviews from roll WG
> participants (posted to the [email-masked] discussion list).
>
> Expressions of an opinion about whether or not to publish the document, in
> addition to technical input to the authors, would be useful.
>
> Thanks.
>
> - Ralph
>
>

---

From: Ulrich Herberg <[email-masked]>
Date: Sun, 24 Feb 2013 23:15:12 -0800

AB,

I have received the comments and will reply to all comments (and update the
draft where necessary) starting next week. I apologize for the delay, but I
am currently on a business trip outside the country.

Regards
Ulrich