Subject: [Roll] I-D Action: draft-ietf-roll-trickle-mcast-04.txt

From: [email-masked]
Date: Mon, 25 Feb 2013 08:23:15 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : Multicast Protocol for Low power and Lossy Networks (MPL)
	Author(s)       : Jonathan W. Hui
                          Richard Kelsey
	Filename        : draft-ietf-roll-trickle-mcast-04.txt
	Pages           : 31
	Date            : 2013-02-25

Abstract:
   This document specifies the Multicast Protocol for Low power and
   Lossy Networks (MPL) that provides IPv6 multicast forwarding in
   constrained networks.  MPL avoids the need to construct or maintain
   any multicast forwarding topology, disseminating messages to all MPL
   Forwarders in an MPL Domain.  MPL uses the Trickle algorithm to
   manage message transmissions for both control and data-plane
   messages.  Different Trickle parameter configurations allow MPL to
   trade between dissemination latency and transmission efficiency.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-roll-trickle-mcast

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-roll-trickle-mcast-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-roll-trickle-mcast-04

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Jonathan Hui (johui)" <[email-masked]>
Date: Mon, 25 Feb 2013 16:27:54 +0000

Thanks again for the comments on draft-ietf-roll-trickle-mcast-03.

draft-ietf-roll-trickle-mcast-04 addresses the following items:

- Request ALL_MPL_FORWARDERS to have a multicast group ID in the range 0x01-0xff to support 6LoWPAN compression.

- Specify use of PROACTIVE_FORWARDING and SEED_SET_ENTRY_LIFETIME parameters.

- Specify that an MPL Forwarder maintains a Seed Set and Buffered Message Set for each MPL Domain.

- Allow MPL Control Message to carry zero MPL Seed Info entries.

- Allow IPv6 Source Address of MPL Control Messages to be global, allowing the use of S=0.

- Editorial changes.

--
Jonathan Hui

On Feb 25, 2013, at 8:23 AM, [email-masked] wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll