Subject: [Roll] I-D Action: draft-ietf-roll-p2p-measurement-10.txt

From: [email-masked]
Date: Mon, 01 Apr 2013 11:00:07 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Routing Over Low power and Lossy networks Working Group of the IETF.

	Title           : A Mechanism to Measure the Routing Metrics along a Point-to-point Route in a Low Power and Lossy Network
	Author(s)       : Mukul Goyal
                          Emmanuel Baccelli
                          Anders Brandt
                          Jerald Martocci
	Filename        : draft-ietf-roll-p2p-measurement-10.txt
	Pages           : 28
	Date            : 2013-04-01

Abstract:
   This document specifies a mechanism that enables an RPL router to
   measure the aggregated values of given routing metrics along an
   existing route towards another RPL router, thereby allowing the
   router to decide if it wants to initiate the discovery of a better
   route.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-roll-p2p-measurement

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-roll-p2p-measurement-10

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-roll-p2p-measurement-10

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 1 Apr 2013 14:13:36 -0500 (CDT)

Hi all

This version contains the following changes made in response to IESG comments:

1. The Address vector must now consist of global or unique local IPv6 addresses only. Further, we now explicitly require the addresses in the Address vector to be the ones with same (elided) prefix as the Start Point Address and End Point Address.
 
2. The Start Point Address and End Point Address now have to be global or unique local.

3. Section 3.2 (Secure MO): The Start Point decides whether Secure MOs should be used and the Security Configuration to be used for the purpose. All the Intermediate Points and the End Point MUST use the same Security Configuration as the one used by the Start Point.

4. Section 4.4: Previously, we required the use of binary 10000000 as the RPLInstanceID value whenever the route being measured was a Source Route. But, there was no real reason to do so. So, the new version explicitly states that RPLInstanceID "field does not have any significance when a Source Route is being measured and hence can be set to any value."

5. Section 8 (Security Considerations) has been updated based on the changes done in Section 3.2.

6. Minor editorial changes.

In my opinion, these changes do not affect how this mechanism is to be used in real use-cases.

Thanks
Mukul

----- Forwarded Message -----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Sent: Monday, April 1, 2013 1:00:07 PM
Subject: [Roll] I-D Action: draft-ietf-roll-p2p-measurement-10.txt

Abstract:

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll