Subject: [Roll] [Editorial Errata Reported] RFC6550 (3895)

From: RFC Errata System <[email-masked]>
Date: Mon, 17 Feb 2014 01:20:28 -0800 (PST)

The following errata report has been submitted for RFC6550,
"RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6550&eid=3895

--------------------------------------
Type: Editorial
Reported by: Lei Mou <[email-masked]>

Section: 9.8

Original Text
-------------
1.  The DODAG Parent Address subfield of a Transmit Information
    option MUST be empty.

5. ...

   When a storing node generates a DAO, it uses the stored state of DAOs
   it has received to produce a set of RPL Target options and their
   associated Transmit Information options.

Corrected Text
--------------
1.  The DODAG Parent Address subfield of a Transit Information
    option MUST be empty.

5. ...

   When a storing node generates a DAO, it uses the stored state of DAOs
   it has received to produce a set of RPL Target options and their
   associated Transit Information options.

Notes
-----
There is no "Transmit Information option", It should be Transit Information option. I believe it's quite possible caused by a typo.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6550 (draft-ietf-roll-rpl-19)
--------------------------------------
Title               : RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks
Publication Date    : March 2012
Author(s)           : T. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander
Category            : PROPOSED STANDARD
Source              : Routing Over Low power and Lossy networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Ines Robles <[email-masked]>
Date: Fri, 21 Feb 2014 11:49:07 -0300

Hello,

Yes, it is a typo.

Thanks Lei Mou for report it.

Thanks and Regards,

Michael & Ines.

2014-02-17 6:20 GMT-03:00 RFC Errata System <[email-masked]>:

> There is no "Transmit Information option", It should be Transit
> Information option. I believe it's quite possible caused by a typo.
>
> Instructions:
> -------------
> Author(s)           : T. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui,
> R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander