Subject: [Roll] interest in mixed network topology

From: Michael Richardson <[email-masked]>
Date: Tue, 11 Feb 2014 14:38:00 -0500

draft-ko-roll-mix-network-pathology, which expires on Friday from:
   http://datatracker.ietf.org/doc/draft-ko-roll-mix-network-pathology/

describes a way to do mixed storing/non-storing topologies.   My first
question is to the authors:
  1) do you continue to pursue this work?  What is your intent for this
     document?
  2) will you update with any new results?

To the WG:
  3) is there interest in persuing this line of investigation at this time?
     We had previously put investigation of this on hold until we figured out
     a number of other things.   Please read this document, and consider
     whether this document would help advance this, or if we need one or a
     number of approaches.
     Do we have a good enough problem statement?

If we recharter in Toronto, I would expect that solving this problem will among the most
important reasons to re-charter.

(again, please recall that absence of comments implies disinterest. +1 are welcome)

Abstract

   The RPL specification allows nodes running with storing or non-
   storing modes to operate in the same network.  We describe how such a
   mix can result in network partitioning even when there are plenty of
   physical links available in the network.  The partitioning affects
   both upwards (nodes to root) and downwards (root to leaf) traffic.
   This routing pathology stems from a recommendation made in the RPL
   specification forcing nodes with different modes of operation to join
   the RPL network as leaf nodes only.  We propose a solution that
   modifies RPL by mandating that all the nodes parse and interpret
   source routing headers and storing mode nodes to sometimes act like a
   non-storing mode root by attaching source routing headers.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 12 Feb 2014 00:06:31 +0100

The draft problem is interesting but the solution approach needs more
investigation.

AB

>      Do we have a good enough problem statement?

Sorry I am not sure what is the statement?

> Michael Richardson <[email-masked] <javascript:;>>, Sandelman
> Software Works

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Feb 2014 15:40:59 -0500

Abdussalam Baryun <[email-masked]> wrote:
    mcr>      Do we have a good enough problem statement?

    > Sorry I am not sure what is the statement?

if, having read the document, you aren't sure what problem is being solved,
then there might not be a good enough problem statement.  Or, it may be
obvious to everyone what problem we are solving, and there is isn't anything
else to say.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 12 Feb 2014 21:46:45 +0100

To me it seems a more viable course of action is to treat RPL's storing modes as an interesting experimental protocol and focus on the non-storing mode for deployment.
If both (or all, as there are multiple storing modes) were actually needed, the draft’s contributions should be of great interest to implementers.

But that conclusion is of course just my perception:  There may be this one compelling application of storing mode outside research systems that escaped me.

Grüße, Carsten

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 13 Feb 2014 12:34:36 +0100

I am sorry for my misunderstandning, but I ment is the question
related to WG recharter, as recharter problem statement, or did you
mean the draft only. I understood it as the WG recharter problem
statement, so I want to know what is it, or where is it to read.

AB

---

From: Michael Richardson <[email-masked]>
Date: Thu, 13 Feb 2014 12:33:10 -0500

Carsten Bormann <[email-masked]> wrote:
    > To me it seems a more viable course of action is to treat RPL's storing
    > modes as an interesting experimental protocol and focus on the
    > non-storing mode for deployment.

people whose equipment has power, and are therefore not as limited in the
footprint of their code, prefer storing mode as it reduces the distance of
the some traffic, and maximizes the bandwidth available.

The metering people (AMI) specified storing mode in the applicability
statement.  Traffic distance doesn't matter as it's almost all p2mp.

I understand your statement to be disinterest in new partial storing modes.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting for hire =-

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Feb 2014 21:36:08 +0100

Well,

> statement.  Traffic distance doesn't matter as it's almost all p2mp.

It’s easy to “leave the door open” in an applicability statement.
(BTW, is that document alive?  I haven’t been paying attention.)

I would be more interested in hearing about people who actually build things that way.

> I understand your statement to be disinterest in new partial storing modes.

No, I find the problem intriguing.  It just seems to me that storing mode isn’t actually being used outside research.
If a hybrid mode could make the introduction of storing nodes a more useful proposition, that would be an interesting result of this work.

Grüße, Carsten

---

From: "Gillmore, Matthew" <[email-masked]>
Date: Thu, 13 Feb 2014 22:17:42 +0000

I agree with Carsten,  a solution for a hybrid of storing mode and non-storing mode is very interesting.

Matthew Gillmore
Strategic Standards Architect, Office of the CTO
Mobile: +1.517.745.7350
Knowledge to Shape Your Future

-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Thursday, February 13, 2014 3:36 PM
To: Routing Over Low power and Lossy networks
Cc: Ines Robles; [email-masked]
Subject: Re: [Roll] interest in mixed network topology

Well,

> statement.  Traffic distance doesn't matter as it's almost all p2mp.

It's easy to "leave the door open" in an applicability statement.
(BTW, is that document alive?  I haven't been paying attention.)

> I understand your statement to be disinterest in new partial storing modes.

No, I find the problem intriguing.  It just seems to me that storing mode isn't actually being used outside research.
If a hybrid mode could make the introduction of storing nodes a more useful proposition, that would be an interesting result of this work.

Grüße, Carsten

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 13 Feb 2014 23:45:07 +0100

On Thursday, February 13, 2014, Carsten Bormann wrote:
> No, I find the problem intriguing.  It just seems to me that storing mode
> isn't actually being used outside research.
> If a hybrid mode could make the introduction of storing nodes a more
> useful proposition, that would be an interesting result of this work.

There is an interesting problem. I agree that the solution of the draft
may not  be interesting but the hybrid modes can be.  I think of the
solution is to provide a protocol of node ability which I discussed
before (my work in progress draft) within the network to help RPL within
network of mix nodes capabilities.

AB

---

From: 정종수 <[email-masked]>
Date: Fri, 14 Feb 2014 05:08:39 +0000

Thanks for your interests.

I also wonder the method for mixing storing and non-storing modes that we described in the draft is feasible or not.
We suggested a new MOP that requires a few minor changes from existing storing mode and non-storing mode.

Thanks.
-Jongsoo

---

From: 정종수 <[email-masked]>
Date: Fri, 14 Feb 2014 05:36:41 +0000

Hi Abdussalam,

Exchanging node abilities with each other may enhance performance. But I think how it can enhance is not clear.
I think that the RPL’s MOP advertisement mechanism is enough to construct networks.

Thank you for your comment.
-Jongsoo

On Feb 14, 2014, at 7:45 AM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:

There is an interesting problem. I agree that the solution of the draft may not  be interesting but the hybrid modes can be.  I think of the solution is to provide a protocol of node ability which I discussed before (my work in progress draft) within the network to help RPL within network of mix nodes capabilities.

AB

---

From: "Mani, Mehdi" <[email-masked]>
Date: Tue, 18 Feb 2014 10:55:34 +0000

I believe that it is an interesting subject to peruse. There are certainly some usecases for storing mode and mixed storing/non-storing modes. 
-Mehdi 

-----Original Message-----
From: Roll [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: mardi 11 février 2014 20:38
To: [email-masked]
Cc: [email-masked]; Ines Robles
Subject: [Roll] interest in mixed network topology

To the WG:

If we recharter in Toronto, I would expect that solving this problem will among the most important reasons to re-charter.

Abstract

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Feb 2014 12:20:25 +0100

> We suggested a new MOP that requires a few minor changes from existing storing mode and non-storing mode.

Again, I would suggest designing for no changes to non-storing modes at all plus a completely new class of hybrid nodes (just forget about the old storing mode).

Grüße, Carsten