Subject: [Roll] RPL-MIB

From: peter van der Stok <[email-masked]>
Date: Fri, 07 Feb 2014 11:31:12 +0100

Dear authors,

Is it possible to extend the RPL MIB with MPL parameters?

Easy suggestions are per interface the parameters:
DATA_MESSAGE_IMIN, DATA_MESSAGE_IMAX, 
DATA_MESSAGE_K,DATA_MESSAGE_TIMER_EXPIRATIONS
CONTROL_MESSAGE_IMIN, CONTROL_MESSAGE_IMAX, 
CONTROL_MESSAGE_K,CONTROL_MESSAGE_TIMER_EXPIRATIONS

per interface: the enabled MC addresses.

Measured values per seed and MC address: low seq nr, high seq nr
the number of messages received, number of messages repeated, number of 
messages rejected because c>k.

Looking forward to your reply,

Peter

-- 
Peter van der Stok
mailto: [email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 7 Feb 2014 11:52:53 +0100

On Fri, Feb 07, 2014 at 11:31:12AM +0100, peter van der Stok wrote:
> the number of messages received, number of messages repeated, number
> of messages rejected because c>k.
> 

Sure. I have not closely followed draft-ietf-roll-trickle-mcast.  It
is probably time to read it in detail.

I do not think I get to look into this before the cutoff so one option
might be to work this out in London.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ralph Droms <[email-masked]>
Date: Sun, 9 Feb 2014 08:33:19 -0500

> Is it possible to extend the RPL MIB with MPL parameters?

Why would MPL parameters be added to the RPL MIB?  MPL and RPL share very little, if any, protocol or operational considerations.

- Ralph

> DATA_MESSAGE_IMIN, DATA_MESSAGE_IMAX, DATA_MESSAGE_K,DATA_MESSAGE_TIMER_EXPIRATIONS
> CONTROL_MESSAGE_IMIN, CONTROL_MESSAGE_IMAX, CONTROL_MESSAGE_K,CONTROL_MESSAGE_TIMER_EXPIRATIONS
> 
> the number of messages received, number of messages repeated, number of messages rejected because c>k.
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: peter van der Stok <[email-masked]>
Date: Mon, 10 Feb 2014 09:19:19 +0100

The expectation is that MPL is used where RPL is used as well.

Otherwise a second document is suggested.

Peter

Ralph Droms schreef op 2014-02-09 14:33:
> Why would MPL parameters be added to the RPL MIB?  MPL and RPL share
> very little, if any, protocol or operational considerations.
> 
> - Ralph
> 
>>

---

From: Ralph Droms <[email-masked]>
Date: Wed, 12 Feb 2014 20:53:48 -0500

> Otherwise a second document is suggested.

I think separate MIBs would be the appropriate architecture as MPL and RPL are separate protocols and may be deployed independently.

- Ralph

---

From: peter van der Stok <[email-masked]>
Date: Thu, 13 Feb 2014 09:13:11 +0100

Hi Ralph,

thanks for your opinion on this.
I was hoping to minimize work, but you are probably right.
I will discuss with Juergen.

Peter

Ralph Droms schreef op 2014-02-13 02:53:
> I think separate MIBs would be the appropriate architecture as MPL and
> RPL are separate protocols and may be deployed independently.
> 
> - Ralph
> 
>> 
>> Peter
>>