Subject: [Roll] Open topics for discussion in ROLL

From: Ines Robles <[email-masked]>
Date: Wed, 16 Apr 2014 16:54:23 -0300

*Hi,We would like to let you know a summary about the open topics for
discussion in the WG: 1. draft-ietf-roll-mpl-parameter-configuration.
<https://datatracker.ietf.org/doc/draft-ietf-roll-mpl-parameter-configuration/>
- last thread- 1.
[http://www.ietf.org/mail-archive/web/roll/current/msg08604.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08604.html>]“...
Typical open topics are:1) Effect of inconsistent parameter set among nodes
  (transitional state / update failure)2) Add/Remove of new MPL domain3)
Format to encode timers  (-> DHC wg)...” 1. DHC wg opinion:
[http://www.ietf.org/mail-archive/web/roll/current/msg08609.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08609.html>] 2.
Additional thread:
[http://www.ietf.org/mail-archive/web/roll/current/msg08384.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08384.html>] 1.
draft-ietf-roll-admin-local-policy
<https://datatracker.ietf.org/doc/draft-ietf-roll-admin-local-policy/>-
last thread -
[http://www.ietf.org/mail-archive/web/roll/current/msg08623.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08623.html>] “...the
following points have been changed: - terminology and description text have
been improved.- The concept of a MPL4 router is introduced which
automatically finds all interfaces belonging to the zone in which MPL scope
4 messages are distributed…” 1. draft-ietf-roll-applicability-template
<https://datatracker.ietf.org/doc/draft-ietf-roll-applicability-template/>
- last thread
-[http://www.ietf.org/mail-archive/web/roll/current/msg08566.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08566.html>]“...Some
specific todo:     1) applicability documents need to reference
roll-security-threats,        (some still reference security-framework
document)     2) some (common) text in the applicability document needs to
explain how        the applicability document relates to other
documents....”4. draft-doi-roll-mpl-nan-requirements
<https://datatracker.ietf.org/doc/draft-doi-roll-mpl-nan-requirements/> -
thread:  [http://www.ietf.org/mail-archive/web/roll/current/msg08377.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08377.html>]“...The
issue I have is how to deploy a mesh network over even larger network,
maybe up to 10,000 nodes, with very low application traffic. At the same
time, we need communication channels for relatively-low latency (few
seconds) broadcast for commanding and enough reliable broadcast file
transfer. The draft draft-doi-roll-mpl-nan-requirements-00 introduces the
requirement….”5. draft-ko-roll-mix-network-pathology
<https://datatracker.ietf.org/doc/draft-ko-roll-mix-network-pathology/>[first
thread: http://www.ietf.org/mail-archive/web/roll/current/msg08494.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08494.html>]“...is
there interest in pursuing this line of investigation at this time? We had
previously put investigation of this on hold until we figured out a number
of other things.   Please read this document, and consider whether this
document would help advance this, or if we need one or a      number of
approaches. Do we have a good enough problem statement?...”[ additional
thread: http://www.ietf.org/mail-archive/web/roll/current/msg08522.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08522.html> ]“...I
also wonder the method for mixing storing and non-storing modes that we
described in the draft is feasible or not. We suggested a new MOP that
requires a few minor changes from existing storing mode and non-storing
mode...”Additional Topics 1. 6. Interest in opportunistic routing? 1.
[http://www.ietf.org/mail-archive/web/roll/current/msg08574.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08574.html>] “...If
there is interest, we can come up with a simplified version of the design
presented in the paper, and propose a way to integrate it in RPL through
only a few minor additions. To be more specific, the simplified version
would use the existing RPL routing tables rather than Bloom filters, and
would be MAC-layer agnostic (the only assumption being that the MAC layer
supports anycast)....” 1. 7. draft on selective DIS?*

* [http://www.ietf.org/mail-archive/web/roll/current/msg08594.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08594.html>] “...here
is an expired draft that I intend to revive
http://tools.ietf.org/html/draft-goyal-roll-dis-modifications-01.
<http://tools.ietf.org/html/draft-goyal-roll-dis-modifications-01>It
basically consists in enriching the DIS a little bit, by allowing it to be
more selective.  One benefit is that it saves a lot of energy in a dense
environment when a new node joins an established network. …”8. Interest in
asymmetrical links support?
[http://www.ietf.org/mail-archive/web/roll/current/msg08596.html
<http://www.ietf.org/mail-archive/web/roll/current/msg08596.html>]“...The
work was triggered by a discussion with Don Sturek, but failed to attract
WG attention at the time. I can revive it if interests grows? ...”*9.
Multiple PIO payloads in a single DIO

[http://www.ietf.org/mail-archive/web/roll/current/msg08399.html]

“...As far as I can see, there is nothing in RFC6550 to forbid multiple
PIO options in a DIO, and therefore in a single DODAG.
Other than renumbering, it seems that most use cases where there could be
multiple prefixes present in an LLN will use multiple DODAGs.
If renumbering is the only use for mutiple PIO options, then it seems that
supporting at most 2 or 3 prefixes per DODAG seems reasonable….”

10. Open tickets: [http://trac.tools.ietf.org/wg/roll/trac/report/2]

*We would appreciate your comments about it.Happy Easter! :-)Thanks and
Regards,Michael & Ines.*

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 17 Apr 2014 13:57:17 +0000

Thanks a bunch for this great summary Ines! I for one realize that I missed a train or two.

I find that the discussion on item5 (the mixed mode) is a promising one and worth continuing.
Same goes for the item 7, the selective DIS, which roots in experimental facts and yields energy savings.
Let me come back to the list with some review asap.

Cheers,

Pascal

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: mercredi 16 avril 2014 21:54
To: roll
Cc: Michael Richardson
Subject: [Roll] Open topics for discussion in ROLL

Hi,

We would like to let you know a summary about the open topics for discussion in the WG:

1.  draft-ietf-roll-mpl-parameter-configuration.<https://datatracker.ietf.org/doc/draft-ietf-roll-mpl-parameter-configuration/> - last thread-

a.     [http://www.ietf.org/mail-archive/web/roll/current/msg08604.html]

“... Typical open topics are:
1) Effect of inconsistent parameter set among nodes
  (transitional state / update failure)
2) Add/Remove of new MPL domain
3) Format to encode timers  (-> DHC wg)...”

b.  DHC wg opinion: [http://www.ietf.org/mail-archive/web/roll/current/msg08609.html]

c.            Additional thread: [http://www.ietf.org/mail-archive/web/roll/current/msg08384.html]

2.            draft-ietf-roll-admin-local-policy <https://datatracker.ietf.org/doc/draft-ietf-roll-admin-local-policy/> - last thread -

[http://www.ietf.org/mail-archive/web/roll/current/msg08623.html]

         “...the following points have been changed:

- terminology and description text have been improved.

- The concept of a MPL4 router is introduced which automatically finds all interfaces belonging to the zone in which MPL scope 4 messages are distributed…”

3.            draft-ietf-roll-applicability-template<https://datatracker.ietf.org/doc/draft-ietf-roll-applicability-template/> - last thread -

[http://www.ietf.org/mail-archive/web/roll/current/msg08566.html]

“...Some specific todo:
    1) applicability documents need to reference roll-security-threats,
       (some still reference security-framework document)

    2) some (common) text in the applicability document needs to explain how
       the applicability document relates to other documents....”

4. draft-doi-roll-mpl-nan-requirements<https://datatracker.ietf.org/doc/draft-doi-roll-mpl-nan-requirements/> - thread:

 [http://www.ietf.org/mail-archive/web/roll/current/msg08377.html]

“...The issue I have is how to deploy a mesh network over even larger network, maybe up to 10,000 nodes, with very low application traffic. At the same time, we need communication channels for relatively-low latency (few seconds) broadcast for commanding and enough reliable broadcast file transfer. The draft draft-doi-roll-mpl-nan-requirements-00 introduces the requirement….”

5. draft-ko-roll-mix-network-pathology<https://datatracker.ietf.org/doc/draft-ko-roll-mix-network-pathology/>

[first thread: http://www.ietf.org/mail-archive/web/roll/current/msg08494.html]

“...is there interest in pursuing this line of investigation at this time? We had previously put investigation of this on hold until we figured out a number of other things.   Please read this document, and consider whether this document would help advance this, or if we need one or a      number of approaches. Do we have a good enough problem statement?...”

[ additional thread: http://www.ietf.org/mail-archive/web/roll/current/msg08522.html ]

“...I also wonder the method for mixing storing and non-storing modes that we described in the draft is feasible or not. We suggested a new MOP that requires a few minor changes from existing storing mode and non-storing mode...”

Additional Topics

8.
6. Interest in opportunistic routing?

8.            [http://www.ietf.org/mail-archive/web/roll/current/msg08574.html]

         “...If there is interest, we can come up with a simplified version of the design presented in the paper, and propose a way to integrate it in RPL through only a few minor additions. To be more specific, the simplified version would use the existing RPL routing tables rather than Bloom filters, and would be MAC-layer agnostic (the only assumption being that the MAC layer supports anycast)....”

9.
7. draft on selective DIS?

         [http://www.ietf.org/mail-archive/web/roll/current/msg08594.html]

         “...here is an expired draft that I intend to revive http://tools.ietf.org/html/draft-goyal-roll-dis-modifications-01. <http://tools.ietf.org/html/draft-goyal-roll-dis-modifications-01> It basically consists in enriching the DIS a little bit, by allowing it to be more selective.  One benefit is that it saves a lot of energy in a dense environment when a new node joins an established network. …”

8. Interest in asymmetrical links support?

         [http://www.ietf.org/mail-archive/web/roll/current/msg08596.html]

“...The work was triggered by a discussion with Don Sturek, but failed to attract WG attention at the time. I can revive it if interests grows? ...”

9. Multiple PIO payloads in a single DIO

“...As far as I can see, there is nothing in RFC6550 to forbid multiple PIO options in a DIO, and therefore in a single DODAG.
Other than renumbering, it seems that most use cases where there could be multiple prefixes present in an LLN will use multiple DODAGs.
If renumbering is the only use for mutiple PIO options, then it seems that supporting at most 2 or 3 prefixes per DODAG seems reasonable….”

We would appreciate your comments about it.

Happy Easter! :-)

Thanks and Regards,

Michael & Ines.