Subject: [Roll] [roll] #158 (draft-doi-roll-mpl-parameter-configuration): mpl-parameter-configuration-00 - new MPL domain

From: "roll issue tracker" <[email-masked]>
Date: Fri, 16 May 2014 23:02:35 -0000

#158: mpl-parameter-configuration-00 - new MPL domain

 Source: [http://www.ietf.org/mail-archive/web/roll/current/msg08604.html]

 From: Yusuke DOI <yusuke.doi at toshiba.co.jp>
 Date: Fri, 14 Mar 2014 08:23:26 +0900

 "Typical open topics are:

 2) Add/Remove of new MPL domain"

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |      Owner:
  [email-masked]          |  [email-masked]
     Type:  defect                   |     Status:  new
 Priority:  major                    |  Milestone:
Component:  draft-doi-roll-mpl-      |    Version:
  parameter-configuration            |   Keywords:
 Severity:  Active WG Document       |
-------------------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/158>
roll <http://tools.ietf.org/wg/roll/>

---

From: Yusuke DOI <[email-masked]>
Date: Mon, 26 May 2014 18:08:31 +0900

On addition and removal of MPL domains:

New configuration shall add new parameter set for new MPL domain. I think the issues are

1) Shall the node allow new MPL domain on update of the configuration?
  1-1) If so, a node MAY/SHOULD/MUST add the new MPL domain?
    I think MUST is a bad choice (a node may have smaller resource than request).
    I prefer 'MAY'

2) If adding is possible, when is the time to remove/leave from the MPL domain?
  a) If the configuration is removed from DHCPv6 option
  b) If the configuration is given with explicit REMOVE flag
  c) other

  My draft is on idea a) because it is unclear when to remove a configuration
  with REMOVE flag.

Any idea?

// Yusuke DOI <[email-masked]>