Subject: [Roll] FW: [Anima] ANIMA draft charter

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 7 Aug 2014 10:18:44 +0100

Please excuse the spam.

There is a discussion about forming a working group for autonomic networking
that may be of interest to a number of you.

Please continue the discussion on the ANIMA mailing list (i.e., not here!)

Thanks,
Adrian
 
> -------- Original Message --------
> Subject: [Anima] ANIMA draft charter
> Date: Tue, 5 Aug 2014 08:19:15 +0000
> From: Michael Behringer (mbehring) <[email-masked]>
> To: [email-masked] <[email-masked]>
> 
> At the BoF in Toronto there was rough consensus to continue the work on an
> autonomic infrastructure. Brian, Sheng, Toerless,
> Laurent and I have now drafted a potential WG charter with the input of our
ADs.
> Note that this is not yet a formal charter
> proposal, it's for discussion only so far.
> 
> The assumption is that more general aspects of autonomics will continue to be
> discussed in the NMRG group.
> 
> If we were to go ahead with a WG, the goal would be to focus on realistic
> deliverables. So the plan is to start with a small,
> achievable set of deliverables, and, if successful and useful, expand after
re-
> chartering.
> 
> Please comment here on this draft charter proposal.
> 
> Thanks,
> Michael
> 
> 
> Autonomic Networking Integrated Model and Approach (ANIMA) WG
> 
> Description of Working Group
> 
> Autonomic Networking focuses on self-management of network elements. An
> autonomic function works in a distributed way across
> various network elements, allowing however central guidance and reporting.
> Autonomic functions already exist today, for example
> IGP routing protocols such as OSPF. However, all such functions have their own
> discovery, transport, messaging and security
> mechanisms.
> 
> To transform the somewhat abstract Autonomic Networking concept into
> concrete, realisable requirements, the first stage,
> undertaken in the Network Management Research Group (NMRG) of the IRTF,
> was to define terminology and design goals, and to
> derive a high-level gap analysis. The definitions and design goals, as well as
a
> simple architecture model are defined in
> draft-irtf-nmrg-autonomic-network-definitions; the gap analysis for AN is
> described in draft-irtf-nmrg-an-gap-analysis. The UCAN
> BoF at IETF 90 discussed use cases and some existing solutions. All the above
> work serves as a baseline for this working group.
> 
> This working group defines solutions for an initial set of components of an
> autonomic networking infrastructure, based on the
> simple architecture and design goals defined in draft-irtf-nmrg-autonomic-
> network-definitions. Future work may include a more
> detailed systems architecture to support the development of autonomic service
> agents. The Anima working group will initially
> focus on enterprise, ISP networks and IoT.
> 
> The solutions target to cover the following areas:
> o identity of nodes
> o common security model
> o discovery model
> o negotiation model
> o a secure and logically separated communications channel
> o an example for an autonomic management model
> 
> The goals of this working group are:
> 
> o Definition of a generic discovery and negotiation protocol for autonomic
> functions
>    Starting point: draft-jiang-config-negotiation-protocol
> o Definition of a mechanism to bootstrap a trust infrastructure
>    Starting point: draft-pritikin-bootstrapping-keyinfrastructures
> o Definition of an logically separated Autonomic Control Plane
>    Starting point: draft-behringer-autonomic-control-plane
> 
> In addition, autonomic service agents will need to be defined for specific use
> cases. The working group will initially consider
> one simple example as a test case for further work.
> 
> o Definition of <a selected use case by the group>
>   Starting point: draft-use-case-tbd
> 
> The initial set of work items is limited to the above list to stay focused and
avoid
> "boiling the ocean". Additional documents
> concerning policy intent, other autonomic infrastructure components, use cases
> or autonomic service agents are strongly
> encouraged, as individual submissions, but are not planned as working group
> deliverables for now. No additional work items will
> be accepted in the working group without re-chartering.
> 
> Milestones
> 
> Nov 2014 - WG formation and adoption of drafts
>            - Mar IETF -
> Jun 2015 - WGLC for draft-generic-discovery-negotiation-protocol
>            - Jul IETF -
> Aug 2015 - submit draft-generic-discovery-negotiation-protocol to IESG
> (standards track)
> Oct 2015 - WGLC draft-keyinfrastructure-bootstrap
> Oct 2015 - WGLC draft-use-case-tbd
>            - Nov IETF -
> Dec 2015 - submit draft-keyinfrastructure-bootstrap to IESG  (standards track)
> Dec 2015 - submit draft-use-case-tbd to IESG  (standards track)
> Jan 2016 - WGLC draft-autonomic-common-control-plane
>            - Mar IETF -
> Apr 2016 - submit draft-autonomic-common-control-plane to IESG  (standards
> track)
> Jul 2016 - recharter if needed, or close
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Thu, 7 Aug 2014 10:34:50 +0000

Hi Adrian, all

Thanks for sharing. Reading this charter, the following statement escapes me

"Autonomic functions already exist today, for example IGP routing protocols such as OSPF."

I would have said OSPF like any other IGP is adaptive (and from the current state only -not previous states-) but it is not autonomous: the same input leads to the same output (decision), i.e., there is no improvement of quality of the decision process over time and on the other hand there is no mean by which OSPF can by itself overcome degradation of performance (at best mitigate if pre-configured to execute fixed sequences for a sub-set of pre-determined conditions, cf.RFC 4222, so again driven by open control loops).

Setting of configurable constants is mainly driven by open control loops. Moreover individual routers can't make autonomous decisions in terms of area parameters configuration as all routers belonging to an area must agree on that area's configuration).

Thanks,
-dimitri.
> -----Original Message-----
> From: routing-discussion [mailto:[email-masked]] On
> Behalf Of Adrian Farrel
> Sent: Thursday, August 07, 2014 11:19 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: FW: [Anima] ANIMA draft charter
> 
> Please excuse the spam.
> 
> There is a discussion about forming a working group for autonomic
> networking that may be of interest to a number of you.
> 
> > At the BoF in Toronto there was rough consensus to continue the work
> > on an autonomic infrastructure. Brian, Sheng, Toerless, Laurent and I
> > have now drafted a potential WG charter with the input of our
> ADs.
> > Note that this is not yet a formal charter proposal, it's for
> > discussion only so far.
> >
> > The assumption is that more general aspects of autonomics will
> > continue to be discussed in the NMRG group.
> >
> > If we were to go ahead with a WG, the goal would be to focus on
> > realistic deliverables. So the plan is to start with a small,
> > Autonomic Networking focuses on self-management of network elements.
> > An autonomic function works in a distributed way across various
> > network elements, allowing however central guidance and reporting.
> > Autonomic functions already exist today, for example IGP routing
> > protocols such as OSPF. However, all such functions have their own
> > discovery, transport, messaging and security mechanisms.
> >
> > concrete, realisable requirements, the first stage, undertaken in the
> > Network Management Research Group (NMRG) of the IRTF, was to define
> > terminology and design goals, and to derive a high-level gap analysis.
> > The definitions and design goals, as well as
> a
> > draft-irtf-nmrg-autonomic-network-definitions; the gap analysis for AN
> > is described in draft-irtf-nmrg-an-gap-analysis. The UCAN BoF at IETF
> > 90 discussed use cases and some existing solutions. All the above work
> > serves as a baseline for this working group.
> >
> > This working group defines solutions for an initial set of components
> > of an autonomic networking infrastructure, based on the simple
> > architecture and design goals defined in draft-irtf-nmrg-autonomic-
> > network-definitions. Future work may include a more detailed systems
> > architecture to support the development of autonomic service agents.
> > The Anima working group will initially focus on enterprise, ISP
> > networks and IoT.
> >
> > o a secure and logically separated communications channel o an example
> > for an autonomic management model
> >
> > o Definition of a generic discovery and negotiation protocol for
> > autonomic functions
> > In addition, autonomic service agents will need to be defined for
> > specific use cases. The working group will initially consider one
> > simple example as a test case for further work.
> >
> > "boiling the ocean". Additional documents concerning policy intent,
> > other autonomic infrastructure components, use cases or autonomic
> > service agents are strongly encouraged, as individual submissions, but
> > are not planned as working group deliverables for now. No additional
> > work items will be accepted in the working group without
> > re-chartering.
> >
> > Milestones
> >
> > (standards track) Oct 2015 - WGLC draft-keyinfrastructure-bootstrap
> > Dec 2015 - submit draft-keyinfrastructure-bootstrap to IESG
> > (standards track) Dec 2015 - submit draft-use-case-tbd to IESG
> > (standards track) Jan 2016 - WGLC draft-autonomic-common-control-plane
> >            - Mar IETF -
> routing-discussion mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/routing-discussion