Subject: [Roll] Source-Routed Multicast

From: Carsten Bormann <[email-masked]>
Date: Tue, 04 Nov 2014 00:42:32 +0100

In Hawaii, there will be a BOF about a multicast forwarding control
scheme where a router on the way prefixes a multicast packet with a
special header that tells downtree routers where to forward the
multicast — Bit Index Explicit Replication, or BIER.

While BIER appears to be very focused on a carrier or datacenter
perspective (see draft-kumar-bier-use-cases and the other
draft-*-bier-*), there are applications in constrained node networks
that would benefit from source-routed multicast.

Several proposals on how to do source-routed multicast in constrained
node networks are getting ready for consumption.

With its current focus, I don’t think the BIER BOF itself is the right
place to have a technical discussion about this.
There is no ROLL meeting in Hawaii.
The 6lo agenda is almost full.
Should we do this in a side meeting?  (If we do this before Tuesday, we
can at least report in 6lo — if we do it on Sunday, we might even have
an opinion to air during the BIER BOF.)

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Mon, 03 Nov 2014 21:18:16 -0500

> that would benefit from source-routed multicast.

I take your point.

    > place to have a technical discussion about this.

On the contrary, I think it is important at a BOF for this topic to be
brought up, if ONLY for it to be CLEARLY ruled out of scope.

    > The 6lo agenda is almost full.

ROLL would have to be rechartered to work on it; this is not to say that this
could not happen, but rather to say that even if we were meeting, discussing
it might be out of scope anyway.

Having said that, this thread is most welcome.

    > an opinion to air during the BIER BOF.)

I abhor "side meetings" --- either have a proper BOF in a room, or get a
bunch of beers is my opinion.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 3 Nov 2014 16:01:33 -0800

Sunday works for me.

Greg

On Mon, Nov 3, 2014 at 3:42 PM, Carsten Bormann <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Tue, 4 Nov 2014 15:37:04 +0000

+1
-- 
Cheers,
Rajiv Asati
Distinguished Engineer, Cisco

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Monday, November 3, 2014 at 8:01 PM
To: Carsten Bormann <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [Bier] Source-Routed Multicast

>multicast ‹ Bit Index Explicit Replication, or BIER.
>
>With its current focus, I don¹t think the BIER BOF itself is the right
>can at least report in 6lo ‹ if we do it on Sunday, we might even have

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 Nov 2014 23:50:50 +0100

> Just one clarification, BIER is not Source-Routed multicast. i.e. we don’t include a list of hops that the packet needs to follow, we only include final destination in the form of Bit Positions, and each router along the path does a lookup on the Bit Position to determine where the packet is to be sent.

Indeed, that’s why I titled this E-mail “Source-Routed Multicast” so it is clear it is not the same as BIER.  Source-routing is important for RPL’s non-storing mode, where intermediate routers just don’t know what is below them.  (BIER could be applied to RPL’s storing mode, but then that already has a multicast approach written up, and it’s also not that clear that storing mode actually exists.  The next question would then be whether RPL networks are stable enough to have a stable egress router numbering applied to them.)

It seems several people would be able to make a Sunday hallway chat about this general approach.  Since I’m officially at a couple of meetings (in parallel) from 1600, how about 1500?

Grüße, Carsten

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 4 Nov 2014 14:28:12 -0800

Hi Carsten,

The ROLL case looks very interesting.

Thx,

Ice.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 5 Nov 2014 02:10:47 +0000

State  in BIER (one bitmap per child) is so limited and controlled that a constrained node that cannot do storing may be able to still do BIER. For such devices, we could propose a new mode of operation for RPL that is BIER only, for both unicast and multicast traffic.

If the preferred parent tree is acceptable for downward traffic, the DAOs would percolate up by ORing the bitmaps of the children and passing that to the preferred parent. Decision to forward down to a child (or of a child to process an incoming message) would be a simple AND of the bitmap in the packet and that of the child, regardless of unicast or multicast.

Cheers,

Pascal

> From: Roll [mailto:[email-masked]] On Behalf Of IJsbrand Wijnands
> (iwijnand)
> Sent: mardi 4 novembre 2014 14:28
> To: Carsten Bormann
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Roll] [Bier] Source-Routed Multicast
> 
> Hi Carsten,
> 
> Just one clarification, BIER is not Source-Routed multicast. i.e. we don't include
> a list of hops that the packet needs to follow, we only include final destination in
> the form of Bit Positions, and each router along the path does a lookup on the
> Bit Position to determine where the packet is to be sent.
> 
> Thx,
> 
> Ice.
> 
> > multicast - Bit Index Explicit Replication, or BIER.
> >
> > With its current focus, I don't think the BIER BOF itself is the right
> > Should we do this in a side meeting?  (If we do this before Tuesday,
> > we can at least report in 6lo - if we do it on Sunday, we might even
> > have an opinion to air during the BIER BOF.)
> >
> > Grüße, Carsten
> >
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 9 Nov 2014 14:53:55 -1000

> It seems several people would be able to make a Sunday hallway chat about this general approach.  Since I’m officially at a couple of meetings (in parallel) from 1600, how about 1500?

I’ll be near the registration desk around 15:00 (in 5 minutes).
Use my photo at http://www.ietf.org/wg/chair-photos.html to find me.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 10 Nov 2014 07:41:32 -1000

With the I-D embargo lifted, I finally was able to post our I-D.

Enjoy at:  https://tools.ietf.org/html/draft-bergmann-bier-ccast

If anybody wants me to talk about this at BIER, I also have slides.

Grüße, Carsten