Subject: [Roll] RPL implementation

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jan 2015 16:32:12 +0000

Dear all :

I'm curious about the progress of the protocol inside and outside LLN domains.
Do we have a status on current RPL implementations overall?
In particular, do we have opensource outside pure LLN devices, e.g. a generic linux implementation to play with?

Cheers,

Pascal

---

From: João Pedro Taveira <[email-masked]>
Date: Tue, 20 Jan 2015 17:53:45 +0000

Hi Dear Pascal,

I started a RPL implementation on Linux Kernel (
https://github.com/joaopedrotaveira/linux-rpl) with basic functionalities
such as RPL OF0. I test it with several ARM boards (BBW, RPi and olinuxino)
but since kernels versions are so different to this boards, it was quite
difficult to maintain it working in all this devices at same time with so
many kernel netstack changes.

Anyway, after a while I got tired to try to support RPL on this older
kernels (3.8.y and 3.10.x for BBB and RPi) and moved forward to get MRH OF
working with rfc6551 and etx. This changes are not on github yet.

Using Contiki with rf23x radios and linux with same transceivers, I started
to implement MRH (etx) with rfc6551 but it has been difficult to get
transceivers delivery status from radio links. This kind of information is
not available yet on linux netstack and, after some emails exchanged with
6lowpan linux group and netdev group, I realised that if I want it done, I
should get it working first and then submit it. Unfortunately, I have no
available time to work on this, but I want to continue this implementation
as soon as possible.

BR,
João Pedro Taveira

On Tue Jan 20 2015 at 16:32:23 Pascal Thubert (pthubert) <[email-masked]>
wrote:

>  Dear all :
>
>
>
> I’m curious about the progress of the protocol inside and outside LLN
> domains.
>
> In particular, do we have opensource outside pure LLN devices, e.g. a
> generic linux implementation to play with?
>
>
>
> Cheers,
>
>
>
> Pascal
>  _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 20 Jan 2015 18:14:30 +0000

Excellent João !

I'm adding it to my list 😊

Pascal

Le 20 janv. 2015 à 18:54, João Pedro Taveira <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Dear Pascal,

I started a RPL implementation on Linux Kernel (https://github.com/joaopedrotaveira/linux-rpl) with basic functionalities such as RPL OF0. I test it with several ARM boards (BBW, RPi and olinuxino) but since kernels versions are so different to this boards, it was quite difficult to maintain it working in all this devices at same time with so many kernel netstack changes.

Anyway, after a while I got tired to try to support RPL on this older kernels (3.8.y and 3.10.x for BBB and RPi) and moved forward to get MRH OF working with rfc6551 and etx. This changes are not on github yet.

Using Contiki with rf23x radios and linux with same transceivers, I started to implement MRH (etx) with rfc6551 but it has been difficult to get transceivers delivery status from radio links. This kind of information is not available yet on linux netstack and, after some emails exchanged with 6lowpan linux group and netdev group, I realised that if I want it done, I should get it working first and then submit it. Unfortunately, I have no available time to work on this, but I want to continue this implementation as soon as possible.

BR,
João Pedro Taveira

On Tue Jan 20 2015 at 16:32:23 Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all :

I’m curious about the progress of the protocol inside and outside LLN domains.
Do we have a status on current RPL implementations overall?
In particular, do we have opensource outside pure LLN devices, e.g. a generic linux implementation to play with?

Cheers,

Pascal
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Wed, 21 Jan 2015 12:46:00 -0500

> generic linux implementation to play with?

http://unstrung.sandelman.ca/ is an implementation for openwrt and smartphone
class devices running Linux; it doesn't speak 6lowpan specifically; but some
people have made it work with an not-yet-released linux device that had 802.15.4.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-