Subject: [Roll] DAO projection

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 19 Oct 2015 10:29:05 +0000

Dear all:

At the last IETF, I presented the concept of DAO projection, that enables a controlled amount of stateful routing in a general non storing mode.

https://www.ietf.org/id/draft-thubert-roll-dao-projection-00.txt

The draft enables loose source routing for long paths, eg:

              ------+---------

                    |          Internet

                    |

                 +-----+

                 |     | Border Router

                 |     |  (RPL Root)

                 +-----+                      |     ^        |

                    |                         | DAO | ACK    |

              o    o   o    o                 |     |        | Loose

          o o   o  o   o  o  o o   o          |  ^           | Source

         o  o o  o o    o   o   o  o  o       |  | DAO       | Route

         o   o    o  o     o  o    o  o  o    | ^            |

        o  o   o  o   o         o   o o       v | DAO        v

        o          o             o     o

                          LLN

It also enables the root to work with (or as) a PCE and project optimized routes in the network which could improve the operation whether the network is using storing or non-storing.

              ------+---------

                    |          Internet

                    |

                 +-----+

                 |     | Border Router

                 |     |  (RPL Root)

                 +-----+

                    |

              o    o   o    o

          o o   o  o   o  o  o o   o

         o  o o  o o    o   o   o  o  o

         o   o    o  o     o  o    o  o  o

        o>>o>>>o>>o>>>o         o   o o

        o          o             o     o

                          LLN

We did not have much discussion on this topic since the IETF. So in preparation of Yokohama, I'd like to sense interest in that topic. Continue, or drop?

Please jump in!

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Fri, 30 Oct 2015 09:44:02 -0400

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > We did not have much discussion on this topic since the IETF. So in
    > preparation of Yokohama, I'd like to sense interest in that
    > topic. Continue, or drop?

Continue.

I see the work as critical to the future: it lets us build much bigger
networks with far less congestion at the root, without the risk of running
out of routing table entries.

-- 
Michael Richardson
-on the road-