Subject: Re: [Roll] New proposed charter

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Dec 2015 18:28:30 +0000

Same as Michael

I'll note that we still have that RPL P2P is still experimental work, and it would deserve a standard track version at some point.
Is there energy (and charter) in the WG to work on that?

Cheers,

Pascal

> -----Original Message-----
> From: Roll [mailto:[email-masked]] On Behalf Of Michael Richardson
> Sent: vendredi 18 décembre 2015 18:06
> To: Abdussalam Baryun <[email-masked]>
> Cc: Routing Over Low power and Lossy networks <[email-masked]>; Ines Robles
> <[email-masked]>
> Subject: Re: [Roll] New proposed charter
> 
> 
> Abdussalam Baryun <[email-masked]> wrote:
>     > I agree with you. I think The problem is that the chair has to ask the
>     > working group to say what they want to be in scope. What is done so far is
>     > that our group chair is asking for new charter but still has the old scope of
>     > one protocol for the group. I only know that the WG has the power to
> change
>     > the scope if necessary when they prove that by discussion.
> 
> I am quite certain:
>   a) that the IESG will not approve a WG charter that includes more than one
>      routing protocol.
>   b) that I don't want to be chair of a group that works on multiple
>      protocols in the same WG.
>   c) that should the IESG do such a thing, that I will have significant
>      feedback for nomcom.
> 
> Meanwhile, I will repeat:
>   https://mailarchive.ietf.org/arch/msg/roll/odYLTGE2dkRP-SNrRSvx2-h-pU8
> 
> ++ the first step would not be to assume a solution ("a new routing
> ++ protocol"), but rather to establish clearly what the problem is.
> 
> So, if you have a draft that explains why another protocol is necessary, please
> point us to it.  It would certainly help figure out where the problem should be
> discussed; it could turn out that it's a trivial extension to the existing
> specification.
> 
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works
> IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 18 Dec 2015 15:49:25 -0300

Pascal,
            As far as I can understand, the basis of that work
should be RFC6997. Which would be the main missing elements
to go for a standard track?
            Regards,

                                              Diego

2015-12-18 15:28 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]>:

> Same as Michael
>
> I'll note that we still have that RPL P2P is still experimental work, and
> it would deserve a standard track version at some point.
> >     > I agree with you. I think The problem is that the chair has to ask
> the
> >     > working group to say what they want to be in scope. What is done
> so far is
> >     > that our group chair is asking for new charter but still has the
> old scope of
> >     > one protocol for the group. I only know that the WG has the power
> to
> > change
> >     > the scope if necessary when they prove that by discussion.
> >
> > I am quite certain:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Dec 2015 20:25:31 +0000

In my view that would be return from experience and for the lack of it better alignment to AODVv2 operations which are better proven in the real world.

Makes sense?

Pascal

Le 18 d?c. 2015 ? 19:49, Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> a ?crit :

Pascal,

                                              Diego

2015-12-18 15:28 GMT-03:00 Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>:
Same as Michael

Cheers,

Pascal

> From: Roll [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Michael Richardson
> Sent: vendredi 18 d?cembre 2015 18:06
> To: Abdussalam Baryun <[email-masked]<mailto:[email-masked]>>
> Cc: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>; Ines Robles
> <[email-masked]<mailto:[email-masked]>>
> Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:
>     > I agree with you. I think The problem is that the chair has to ask the
>     > working group to say what they want to be in scope. What is done so far is
>     > that our group chair is asking for new charter but still has the old scope of
>     > one protocol for the group. I only know that the WG has the power to
> change
> Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

--
DIEGO DUJOVNE
Acad?mico Escuela de Ingenier?a en Inform?tica y Telecomunicaciones
Facultad de Ingenier?a UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Michael Richardson <[email-masked]>
Date: Wed, 30 Dec 2015 16:30:34 -0500

> Is there energy (and charter) in the WG to work on that?

To date, to my knowledge, we have no implementation reports on *RPL* or
*RPL P2P* which mention interoperability.   I think that as the ETSI
6tisch minimal efforts/plugfests will provide sufficient evidence on RPL
to advance it along the standards track itself.

As for *RPL P2P* --- it's a good question.  The decision to put P2P on
experimental track predates the current chairs (and also the ADs), and
I'd have to go do some research to establish why it went that way in the
first place, and see if those concerns still exist.

While we do not need interoperation to get to PS, it would probably help
to alleviate whatever concerns drove it towards Experimental in the
first place.

I'd prefer to leave P2P alone in the short term; I think we will be
overloaded otherwise.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 30 Dec 2015 16:48:42 -0500

> first place, and see if those concerns still exist.

I meant to add: I see nothing in BCP9 that would make the existence of
RFC6997 any easier for production of a P2P Proposed Standard.  I will
ask around to understand if I've missed something about moving
Experimental to standards track.

[the re-read of of BCP9 makes it even more clear that our Applicability
Statements *do* belong on standards track, and not informational. For
those wondering what happened to our documents, see:
	https://www.rfc-editor.org/cluster_info.php?cid=C245 ]