Subject: [Roll] processing of multiple SRH-6LoRH

From: Michael Richardson <[email-masked]>
Date: Fri, 22 Apr 2016 09:48:40 -0400

Pascal,

section 5.5 of routing-dispatch says:

   Else (meaning that this is the last entry in the SRH-6LoRH header),
      and if there is no next SRH-6LoRH header after this then the SRH-
      6LoRH is removed.

Fair enough.

   Else, if there is a next SRH-6LoRH of a Type with a larger or equal
      value, meaning a same or lesser compression yielding same or larger
      compressed forms, then the SRH-6LoRH is removed.

okay, so when the new SRH provides more bytes, we remove the consumed one.

   Else, the first entry of the next SRH-6LoRH is popped from the next
      SRH-6LoRH and coalesced with the first entry of this SRH-6LoRH.

To get here, the next SRH-6LoRH must be of a higher level of compression,
so it encodes addresses with fewer bytes.  What is the logic to making the
next next 6LoRH smaller (popping), and keeping the larger current 6LoRH?
Why not just drop the current 6loRH here and have fewer bytes, period?

Or am I mis-reading this.  Maybe I have to write an example of what I think
this is saying.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 26 Apr 2016 11:21:34 +0000

Hello Michael:

Sorry I failed to respond to this.

> okay, so when the new SRH provides more bytes, we remove the consumed

> one.

> To get here, the next SRH-6LoRH must be of a higher level of compression, so

> it encodes addresses with fewer bytes.  What is the logic to making the next

> next 6LoRH smaller (popping), and keeping the larger current 6LoRH?

This is illustrated below:

The root sends a type 4 with the fill address of A (say that they do not share a same prefix)

When A receives the packet it must remove the first address in the SRH which is self.

As illustrated A pops B's compressed address from the next header (the type 3) and coalesces that in the first (type 4) to get the full address of B.

> Why not just drop the current 6loRH here and have fewer bytes, period?

If we had removed the type 4 then the first SRH would have been the type 3 and the prefix would be lost.

Makes sense?

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Wed, 27 Apr 2016 08:34:35 -0400

> As illustrated A pops B’s compressed address from the next header (the type
    > 3) and coalesces that in the first (type 4) to get the full address of B.

    > and the prefix would be lost.

okay, right, I get it.  The compression of B's address needs some bytes from A.
A single sentence to explain that would help.