Subject: [Roll] DIS Multicast behaviour

From: Shobhit <[email-masked]>
Date: Wed, 11 May 2016 15:11:34 +0530

Hi,

I have requirement to receive multicast DIS messages from any node without
resetting the trickle timer.

As standard indicates that if any node will receive the multicast DIS
message , it will be considered as inconsistency with respect to trickle
timer of recipient(RFC 6550 ,Sec 8.3).
It also indicates this behavior can be controlled by DIS flag.

But after checking the DIS flag option , it is mentioned that it is unused
filed (Sec 6.2.1).
"Flags: 8-bit unused field reserved for flags.  The field MUST be
         initialized to zero by the sender and MUST be ignored by the
         receiver."

Please suggest if there is any way to stop the reset of trickle timer in
case of reception of multicast DIS message.

-- 
Regards,
Shobhit

---

From: <[email-masked]>
Date: Wed, 11 May 2016 09:51:32 +0000

Shobbit,

Thank you so much for your interest in more diverse responses to DIS reception.
The DIS flag mentioned in RFC6550 and its interpretation is still work in progress.
You can see the most recent proposal in draft-zhong-roll-dis-modifications that expired just a few days ago.
https://tools.ietf.org/html/draft-zhong-roll-dis-modifications-00
I would very much appreciate if you could describe to us the kind of deployment that prompts for your stated requirement.
This would help up in finalising the draft.
With best regards

Dominique

De : Roll <[email-masked]<mailto:[email-masked]>> on behalf of Shobhit <[email-masked]<mailto:[email-masked]>>
Répondre à : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date : Wednesday 11 May 2016 11:41
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [Roll] DIS Multicast behaviour

Hi,

I have requirement to receive multicast DIS messages from any node without resetting the trickle timer.

As standard indicates that if any node will receive the multicast DIS message , it will be considered as inconsistency with respect to trickle timer of recipient(RFC 6550 ,Sec 8.3).
It also indicates this behavior can be controlled by DIS flag.

But after checking the DIS flag option , it is mentioned that it is unused filed (Sec 6.2.1).
"Flags: 8-bit unused field reserved for flags.  The field MUST be
         initialized to zero by the sender and MUST be ignored by the
         receiver."

Please suggest if there is any way to stop the reset of trickle timer in case of reception of multicast DIS message.

--
Regards,
Shobhit

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.