Subject: Re: [Roll] RPLinfo review

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 3 Jun 2016 14:23:11 +0000

Hello Ines:

Interworking between instances would be like redistributing a protocol within another. This yields loops and requires prioritization like admin distance in Cisoc routers. So far, we do not support that. Related: the draft on asym links added a capability for an upward instance (optimizing link metrics towards the root) to be coupled with a downwards instance, in case we have links with widely unbalanced metrics in both directions.

Cheers,

Pascal

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: mardi 24 mai 2016 12:43
To: [email-masked]
Cc: Routing Over Low power and Lossy networks <[email-masked]>
Subject: Re: [Roll] RPLinfo review

btw, I just found a proposed approach for interaction between RPL Instances

Barcelo, Marc, Alejandro Correa, Jose Lopez Vicario, and Antoni Morell. "Cooperative interaction among multiple RPL instances in wireless sensor networks." Computer Communications (2015).

Cheers,

Ines.

2016-05-24 13:26 GMT+03:00 Ines Robles <[email-masked]<mailto:[email-masked]>>:
Ah, got it, thank you very much.

Ines

2016-05-24 13:22 GMT+03:00 peter van der Stok <[email-masked]<mailto:[email-masked]>>:
Hi,

that means writing "one RPL instance" in figure 3 in stead of "RPL instance" to remove that ambiguity.
Writing in the use case section a phrase as the one below will be more than sufficient for me.

peter

Ines  Robles schreef op 2016-05-24 12:16:

Hi,

Thanks for the clarification.

We are just considering here one RPLInstance.

Working with different RPLInstances, involves deeply analysis, which
we could do in the future. But, actually I dont know if it is
possible/useful to send a message from one RPL Instance to another one
, since for example a RPL node may belong to multiple RPL Instances,
and it may act as a router in some and as a leaf in others[1], for
this reason it does not make sense to me sending packet from one
RPLInstance to other RPLInstance. Besides the control messages has one
field for RPLInstanceID, it does not have RPLInstanceID origen or
RPLInstanceID dst.

What do you think?

Thank you,

Ines

[1] RFC6550. Section 5. RFC 6550 describes only how a single instance
behaves

2016-05-24 12:17 GMT+03:00 peter van der Stok <[email-masked]<mailto:[email-masked]>>:
I also did not see a mapping of flow from one RPL instance to
another instance.

I do not understand this. Could you please clarify?

 A node belonging to one RPL instance sends a message to a node
belonging to another RPL instance.
This seems possible in Figure 3, with 3 RPL instances?

If possible, it means an additional use case.

Peter

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 3 Jun 2016 14:24:11 +0000

Yes, normally instances are logical beasts that operate as ship in the night. Think Vlans.

Cheers,

Pascal

> -----Original Message-----
> From: Roll [mailto:[email-masked]] On Behalf Of Michael Richardson
> Sent: mardi 31 mai 2016 04:53
> To: Routing Over Low power and Lossy networks <[email-masked]>
> Ines  Robles <[email-masked]> wrote:
>     > Working with different RPLInstances, involves deeply analysis, which we
>     > could do in the future. But, actually I dont know if it is
> 
> In general, you have to leave one instance (popping all artifacts as if going out
> to the Internet), and then enter the new instance.
> 
> It matters not if these are two RPLinstances (by instanceID), or two different
> LLNs seperated by the Internet.
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works  -=
> IPv6 IoT consulting =-
> 
>

---

From: Ines Robles <[email-masked]>
Date: Sat, 11 Jun 2016 04:24:38 +0300

Ok, thank you Pascal.

Ines

2016-06-03 17:23 GMT+03:00 Pascal Thubert (pthubert) <[email-masked]>:

> Hello Ines:
>
>
>
> Interworking between instances would be like redistributing a protocol
> within another. This yields loops and requires prioritization like admin
> distance in Cisoc routers. So far, we do not support that. Related: the
> draft on asym links added a capability for an upward instance (optimizing
> link metrics towards the root) to be coupled with a downwards instance, in
> case we have links with widely unbalanced metrics in both directions.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* Roll [mailto:[email-masked]] *On Behalf Of *Ines Robles
> *Sent:* mardi 24 mai 2016 12:43
> *To:* [email-masked]
> *Cc:* Routing Over Low power and Lossy networks <[email-masked]>
> *Subject:* Re: [Roll] RPLinfo review
>
>
>
> Barcelo, Marc, Alejandro Correa, Jose Lopez Vicario, and Antoni Morell.
> "Cooperative interaction among multiple RPL instances in wireless sensor
> networks." *Computer Communications* (2015).
>
>
>
> Cheers,
>
>
>
> Ines.
>
>
>
> 2016-05-24 13:26 GMT+03:00 Ines Robles <[email-masked]>:
>
> 2016-05-24 13:22 GMT+03:00 peter van der Stok <[email-masked]>:
>
> Hi,
>
> 2016-05-24 12:17 GMT+03:00 peter van der Stok <[email-masked]>:
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>
>