Subject: [Roll] "Charter inclusion: Work in RPL control messages: DIS Mod. - No-Path DAO"

From: peter van der Stok <[email-masked]>
Date: Mon, 25 Jul 2016 13:44:25 +0200

Dear all,

Following the ROLL Meeting at IETF 96, we would like to know your
opinion about the drafts, presented during IETF95 and IETF96. This is
the first set of three emails. The adoption of drafts as WG drafts
will be asked independently dependent on the status of the draft.

A: draft-gundogan-roll-dis-modifications-00
       DIS Modifications

•    Is the draft relevant to the working group.?
•    Do you foresee to contribute to the work described in the draft ?
•    Are you willing to review the draft ?
•    Should the draft be rejected by the WG ?

B: draft-jadhav-roll-no-path-dao-ps-01
       No-Path DAO Problem Statement

•    Is the draft relevant to the working group.?
•    Do you foresee to contribute to the work described in the draft ?
•    Are you willing to review the draft ?
•    Should the draft be rejected by the WG ?

It would be nice to know the reasons why you agree or disagree with the 
drafts

Thank you very much,

Peter and Ines

---

From: <[email-masked]>
Date: Tue, 26 Jul 2016 06:49:54 +0000

Dear all,

I support the adoption of both draft-gundogan-roll-dis-modifications-00
and draft-jadhav-roll-no-path-dao-ps-01
I think they both will help make RPL better in all sorts of environments.
I foresee a contribution to the first one, and a review of both.
Thanks

Dominique

Le 25/07/16 13:44, « Roll on behalf of peter van der Stok »
<[email-masked] on behalf of [email-masked]> a écrit :

>€    Is the draft relevant to the working group.?
>€    Do you foresee to contribute to the work described in the draft ?
>€    Are you willing to review the draft ?
>€    Should the draft be rejected by the WG ?
>
>€    Is the draft relevant to the working group.?
>€    Do you foresee to contribute to the work described in the draft ?
>€    Are you willing to review the draft ?
>€    Should the draft be rejected by the WG ?
>
>
>_______________________________________________
>Roll mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/roll

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Rahul Jadhav <[email-masked]>
Date: Tue, 26 Jul 2016 12:39:03 +0200

I too support both the drafts.
Please note I m a co-author for the later (no-path dao) draft.

A: draft-gundogan-roll-dis-modifications-00
•    Is the draft relevant to the working group.?
Yes. The draft aims at reducing control overhead in RPL signaling. I m
especially interested in the reduction of DIO network footprint proposed in
the draft.
•    Do you foresee to contribute to the work described in the draft ?
Yes. I could help in testing the draft.
•    Are you willing to review the draft ?
Yes
•    Should the draft be rejected by the WG ?
No

B: draft-jadhav-roll-no-path-dao-ps-01
•    Is the draft relevant to the working group.?
Yes. The draft aims to characterize and improve upon existing no-path DAO
messaging.
•    Do you foresee to contribute to the work described in the draft ?
Yes. I intend to find a tech soln for the problem stmt and test it in
simulation/real deployments.
•    Are you willing to review the draft ?
Yes. As a co-author.
•    Should the draft be rejected by the WG ?
No

-Rahul

On 26 Jul 2016 12:20 p.m., <[email-masked]> wrote:

> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Ines Robles <[email-masked]>
Date: Wed, 27 Jul 2016 00:40:25 +0300

Hi,

As an individual (co-chair hat off), I support to include in the charter
The DIS Modifications work. It would be interesting to see the performance
of the new DIS flags and the selectivity of multicast DIS messages. I am
willing to review the draft.

I support to include the No-Path DAO work as well. It is relevant to work
on the solutions to the problems of No-Path DAO messaging. I am willing to
review the draft.

Thanks to the authors for proposing these works,

Cheers,

Ines.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 28 Jul 2016 10:16:21 +0000

> Following the ROLL Meeting at IETF 96, we would like to know your opinion
> about the drafts, presented during IETF95 and IETF96. This is the first set of
> three emails. The adoption of drafts as WG drafts will be asked independently
> dependent on the status of the draft.
> 

Yes. This will improve the RPL operation. Unsure whether the client should always we proposing the bit settings. Probably in some instances the router knows better.

No

Yes

> •    Should the draft be rejected by the WG ?

Certainly not!

Yes

> •    Do you foresee to contribute to the work described in the draft ?

Maybe

Yes

> •    Should the draft be rejected by the WG ?

Unsure the PS should go RFC. In fact an errata to RFC 6550 may suffice

 : )

Pascal