Subject: [Roll] AD sponsoring draft-kivinen-802-15-ie-02

From: Suresh Krishnan <[email-masked]>
Date: Mon, 18 Jul 2016 12:39:10 +0000

Hi all,
   I am considering AD sponsoring the following draft

https://tools.ietf.org/html/draft-kivinen-802-15-ie-02

to request the allocation of an 802.15.4 information element from the IEEE 
for use in the IETF protocols that may need it. If you have any concerns 
either with the content of the draft or about requesting the IE at all please 
let me know before 2016/07/29.

Thanks
Suresh

NOTE: I have CCed: all the groups that I thought could be potentially 
interested in this work. If you think I have missed out some WG(s) please let 
me know.

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 22 Jul 2016 01:31:56 +0200

Suresh,

I strongly support the publication of this document. Since it defines a
mechanism which can be used by several working groups, AD sponsoring seems
perfect.

I'm attaching the XML of the the -02 version of that draft in which I have
corrected some typos. I'll let Tero and Pat decide what he wants to merge,
if anything. These changes are for the authors' information only, they do
NOT affect my support to publish this document.

Thomas

On Mon, Jul 18, 2016 at 2:39 PM, Suresh Krishnan <
[email-masked]> wrote:

> _______________________________________________
> IoT-DIR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iot-dir
>

---

From: Ralph Droms <[email-masked]>
Date: Fri, 22 Jul 2016 01:45:02 +0200

Seems to me this document could easily be a working group document.  Why have you decided to publish it as AD sponsored document?

- Ralph

> On Jul 18, 2016, at 2:39 PM 7/18/16, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi all,
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

---

From: Tero Kivinen <[email-masked]>
Date: Fri, 22 Jul 2016 11:29:23 +0300

Thomas Watteyne writes:
> corrected some typos. I'll let Tero and Pat decide what he wants to merge, if
> anything. These changes are for the authors' information only, they do NOT
> affect my support to publish this document.

Thanks, I have taken your most of your changes to my xml version, and
I will publish new version soon, with those fixes.
-- 
[email-masked]

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 22 Jul 2016 14:43:57 +0200

Awesome, thanks

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Tero Kivinen <[email-masked]>
Date: Fri, 22 Jul 2016 11:12:19 +0300

Ralph Droms writes:
> Seems to me this document could easily be a working group document.
> Why have you decided to publish it as AD sponsored document? 

As this will allocate number for the IETF, not for just one WG, the
authors though it would be better to get as wide coverage for it,
meaning having longer last call time, and advertising it in several
different working groups (who might use it in the future), instead of
having it for one WG draft in some WG.

Also it was not clear which WG it should be in. I think 6tisch is the
one who might need it first, but 6lo is most likely also going to
using it etc.
-- 
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Sat, 23 Jul 2016 07:30:18 -0400

> one who might need it first, but 6lo is most likely also going to

This makes me ask a question about 802.15.9:  would a new KMP created by the
IETF for 15.9 (such as OSCOAP or DTLS) need to use an IE under this subtype?
Or does 15.9 have it's own registry, and if so would we need different liason
request for that?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Don Sturek <[email-masked]>
Date: Sat, 23 Jul 2016 12:20:52 -0700

Hi Michael

IEEE 802.15.9 defines a multiplex ID covered by the IEEE 802.15 ANA.  To define a new KMP would only require a new annex that describes how the KMP works and an allocation of a new Multiplex ID.

There is also a vendor specific multiplex ID that could be used now without any written description in IEEE 802.15

Don

Sent from my iPad

> On Jul 23, 2016, at 4:30 AM, Michael Richardson <[email-masked]> wrote:
> 
> 
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 25 Jul 2016 11:32:35 +0000

> -----Original Message-----
> From: 6lo [mailto:[email-masked]] On Behalf Of Tero Kivinen
> Sent: Friday, July 22, 2016 11:12 AM
> To: Ralph Droms
> Cc: Internet Area; [email-masked]; [email-masked]; Suresh Krishnan; iot-
> [email-masked]; [email-masked]; [email-masked]; 6lo; 6tisch
> Subject: Re: [6lo] [6tisch] AD sponsoring draft-kivinen-802-15-ie-02
> 
> Ralph Droms writes:
> As this will allocate number for the IETF, not for just one WG, the authors
> though it would be better to get as wide coverage for it, meaning having
> longer last call time, and advertising it in several different working groups
> (who might use it in the future), instead of having it for one WG draft in
> some WG.
> 
> Also it was not clear which WG it should be in. I think 6tisch is the one who
> might need it first, but 6lo is most likely also going to using it etc.
> --
> [email-masked]
> 

The last argument is relatively easy to overcome. As both 6tisch and 6lo belong in the INT area, this could be a good candidate for a intarea WG document. I also have a slight preference for this path, as a WG document has typically a better level of scrutiny and review. 

Regards,

Dan