Subject: [Roll] "Charter inclusion: Work in Routing proposals: AODV_RPL - > DAO_Projection"

From: peter van der Stok <[email-masked]>
Date: Fri, 12 Aug 2016 08:49:41 +0200

Dear all,

Following the ROLL Meeting at IETF 96, we would like to know your
opinion about the drafts, presented during IETF95 and IETF96. This the
last set of three messages. The adoption of drafts as WG drafts will
be asked independently dependent on the status of the draft.

Please, do answer to the three messages before 2 September 2016.

  F: draft-thubert-roll-dao-projection-02
      Root initiated routing state in RPL

•    Is the draft relevant to the working group.?
•    Do you foresee to contribute to the work described in the draft ?
•    Are you willing to review the draft ?
•    Should the draft be rejected by the WG ?

  G: draft-satish-roll-aodv-rpl-00
        Asymmetric AODV-P2P-RPL in Low-Power and Lossy Networks (LLNs)

  •    Is the draft relevant to the working group.?
  •    Do you foresee to contribute to the work described in the draft ?
  •    Are you willing to review the draft ?
  •    Should the draft be rejected by the WG ?

It would be nice to know the reasons why you agree or disagree with the 
drafts

Thank you very much,

  Peter and Ines

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Aug 2016 16:12:06 +0000

I support both, Peter.

* We have studied reactive (like AODV) in the past and we know we need it for particular P2P flows, say this sensor and this actuator need a circuit (e.g. a 6TiSCH track) with particular characteristics. 
* As of DAO projection I support it as an author. Once we have reactive and proactive distributed routing, a hint of centralized routing seems the way to go for more deterministic / TE type of sensor communication. 

Cheers,

Pascal

> -----Original Message-----
> From: Roll [mailto:[email-masked]] On Behalf Of peter van der Stok
> Sent: vendredi 12 août 2016 08:50
> To: Roll <[email-masked]>
> Subject: [Roll] "Charter inclusion: Work in Routing proposals: AODV_RPL - >
> DAO_Projection"
> 
> Dear all,
> 
> Following the ROLL Meeting at IETF 96, we would like to know your opinion
> about the drafts, presented during IETF95 and IETF96. This the last set of three
> messages. The adoption of drafts as WG drafts will be asked independently
> dependent on the status of the draft.
> 
> It would be nice to know the reasons why you agree or disagree with the drafts
> 
> 
> Thank you very much,
> 
> 
>   Peter and Ines
> 
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Thu, 25 Aug 2016 09:38:13 +0000

Dear all,

I support the work on DAO projection and would be willing to review it.

This will bring value to a RPL based network.

Many thanks,

Patrick

---

From: peter van der Stok <[email-masked]>
Date: Thu, 25 Aug 2016 12:00:16 +0200

hat off

+1

may be change title from "dao-projection" (very technical) to 
"hybrid-storing" (more objective oriented?)

Peter

Patrick Wetterwald (pwetterw) schreef op 2016-08-25 11:38:
> On 12/08/16 08:49, "Roll on behalf of peter van der Stok"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>> Dear all,
>>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 25 Aug 2016 13:34:19 -0400

> "hybrid-storing" (more objective oriented?)

I think we should wind up with two documents.
1) DAO-projection mechanism that explains the packet, and what properties it
   has and how we signal which nodes understand it or not.

2) hydrid-storing mode which explains how to use the projected-DAO to get
   the desired properties.  It could be that there are other uses for it.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Mingui Zhang <[email-masked]>
Date: Mon, 29 Aug 2016 08:43:53 +0000

I support both.

For F: draft-thubert-roll-dao-projection-02

1) When I first read the Abstract, I thought the purpose of this draft is to only enable loose source routing (non-storing mode) down the DODAG. However, after I read the last 4 paragraphs of the Introduction, I realize the protocol extension specified in this draft can also benefit the storing mode.

2) page 10 last paragraph
s/the lest router in the path/the last router in the path/

3) In the paragraph underneath of Figure 5, there is a unfinished sentence.
OLD
   The process recurses till the destination which sends a DAO-ACK to
   the root.  In the example above, for target D, the list of via
   options is S, A, B and C.  The projected DAO is sent by the root to
NEW
   In the example above, the projected DAO is sent by the root to target D.  The list of via
   options is S, A, B and C.  D removes the last Via Option and passes the DAO to C.

4) The paragraph underneath of Figure 6 repeats the previous paragraph.
OLD
   The process recurses till the destination which sends a DAO-ACK to
   the root.  In the example above, for target D, the list of via
   options is S, A, B and C.  The projected DAO is sent by the root to
NEW
   The process recurses till S which sends a DAO-ACK to
   the root.

5) If changes 3) & 4) make sense, the following sentence is to be appended to the last paragraph on page 10.
The process recurses till the first router in the path; the first router sends a DAO-ACK to the root.

6) Underneath Figure 7, some concluding words are needed.

Thanks,
Mingui

> Sent: Friday, August 12, 2016 2:50 PM
> To: Roll
> Following the ROLL Meeting at IETF 96, we would like to know your opinion about
> the drafts, presented during IETF95 and IETF96. This the last set of three

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 31 Aug 2016 09:50:48 +0200

Yes, I support as well,

Thanks

AB

On Thu, Aug 25, 2016 at 11:38 AM, Patrick Wetterwald (pwetterw) <
[email-masked]> wrote:

> On 12/08/16 08:49, "Roll on behalf of peter van der Stok" <
> [email-masked] on behalf of [email-masked]> wrote:
>
> >Dear all,
> >

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 31 Aug 2016 12:03:05 +0200

+1 on the draft-thubert-roll-dao-projection

Allowing a centralized entity to install p2p routes between end-nodes is an interesting feature that can be very useful in real-time or very constrained networks among others. This could, among others, allow for a much richer path calculation in the PCE, otherwise be unfeasible by the end-nodes.

Best,
Alexander

> Le 31 août 2016 à 09:50, Abdussalam Baryun <[email-masked]> a écrit :
> 
> Yes, I support as well,
> 
> Thanks
> 
> AB
> 
> On Thu, Aug 25, 2016 at 11:38 AM, Patrick Wetterwald (pwetterw) <[email-masked] <mailto:[email-masked]>> wrote:
> Dear all,
> 
> On 12/08/16 08:49, "Roll on behalf of peter van der Stok" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
> >Dear all,
> >
> >[email-masked] <mailto:[email-masked]>
> >https://www.ietf.org/mailman/listinfo/roll <https://www.ietf.org/mailman/listinfo/roll>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/roll <https://www.ietf.org/mailman/listinfo/roll>
>