Subject: [Roll] comments on useorplinfo

From: peter van der Stok <[email-masked]>
Date: Sun, 13 Nov 2016 07:24:19 +0100

Hi all,

I have read useofrplinfo.

This version 9 is a great improvement over the other versions. All my 
earlier questions seem to be answered. However, there are still some 
(for me) confusing inconsistencies remaining.
I would recommend that someone who implemented the recommendations of 
this draft shares his experiences as well, because the issues are quite 
subtle.

In Table 1 the columns RPI and RH3 all have the same value, can be 
removed, and explained in the text.
In section 4, the relations between Internet, LLN, 6LBR, and DODAG can 
be better explained, while an example of a non-RPL aware node is 
necessary to understand the difference with Internet.
Page 10, line 6, what is a LR1, and 6LRN? Some tables have column header 
6LR and others 6LR(1..N). Please make this consistent. For example, one 
can use 6LR_i with 0 < i <N+1.
Table of section 5.4; is it only 6LRN that modifies RPI?
Section 5.5 is restricted to RPL aware “leafs”; A 6LR as source of the 
packet is also possible? If this is so, the title should mention RPL 
aware nodes instead of RPL aware leafs.
Page 13, last alinea; LLN is a network not a node, is that correct? The 
phrase is a bit cryptic. The subject is a packet to be sent through the 
DODAG?
Table of section 5.7. what is a 6LBN?
End of section 5.8, the text says that packet will not emerge from LLN, 
but it leaves the DODAG; consequently,  I fail to see the relevance of 
the LLN here.
Table section 5.9 mentions decreasing and increasing rank, which is not 
done in other tables. (suggest to remove)
Section 6.4 the column headers are different again.
Section 7.1, 2nd alinea, {TBD (also in section 7.2)} needs a number. And 
what does XXX mean?

NITS
General: past particle of show is shown and not showed.
Page 4,line 6, 11:  s/which is a leaf/which is a leaf of a DODAG/
page 6 line 1: s/in figure 2 is showed/Figure 2 shows/
page 8, line 3: s/rules it means/rules means/
page 8, line 12: removes /can be placed/
page 8, line 22: s/add to remove/add or remove/
page 8, last line: s/consise/concise/
page 9, line 11: s/three/two/
page 9, line 16: s/6LN/6LN in figure 2/

-- 

Hope this helps,

Peter

---

From: Ines Robles <[email-masked]>
Date: Mon, 14 Nov 2016 13:10:38 +0900

Thank you Peter, we will address your comments,

Cheers,

Ines.

2016-11-13 15:24 GMT+09:00 peter van der Stok <[email-masked]>:

> earlier questions seem to be answered. However, there are still some (for
> me) confusing inconsistencies remaining.
> I would recommend that someone who implemented the recommendations of this
> draft shares his experiences as well, because the issues are quite subtle.
>
> In section 4, the relations between Internet, LLN, 6LBR, and DODAG can be
> better explained, while an example of a non-RPL aware node is necessary to
> understand the difference with Internet.
> 6LR and others 6LR(1..N). Please make this consistent. For example, one can
> use 6LR_i with 0 < i <N+1.
> packet is also possible? If this is so, the title should mention RPL aware
> nodes instead of RPL aware leafs.
> but it leaves the DODAG; consequently,  I fail to see the relevance of the
> LLN here.
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>