Subject: [Roll] quasem load-balancing: Figure 3: The amended DIO message format

From: Michael Richardson <[email-masked]>
Date: Thu, 30 Mar 2017 13:29:12 -0400

In draft-qasem-roll-rpl-load-balancing, you show:

        0                   1                   2                   3
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       | RPLInstanceID |Version Number |             Rank              |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |G|0| MOP | Prf |     DTSN      |     Flags     |   Reserved    |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |                                                               |
       +                                                               +
       |                                                               |
       +                            DODAGID                            +
       |                                                               |
       +                                                               +
       |                                                               |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |                                                               |
       +                                                               +
       |                                                               |
       +                            Parent Address                     +
       |                                                               |

That is, you have changed the DIO Base Object in a non-backwards compatible
way.   There is no way to deploy this without upgrading all nodes.

Please instead, define a new DIO Option. This is trivially done and is
easily incrementally deployable.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
IETF ROLL WG outgoing co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: "Qasem, Mamoun" <[email-masked]>
Date: Thu, 30 Mar 2017 17:48:29 +0000

Yes you are right. So i amended the current with a new option format as below, and the presentation today gana to include this.

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |   Type        | Option Length |    Flags    |                 |                                                 |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+- +|                   +
       |                                                                                                                                  |
       +                                                                                                                               +
       |                                                                                                                                  |
       +                        Parent Address                                                                               +
       |                                                                                                                                  |
       +                                                                                            +-+-+-+-+-+-+-+-+-+
       |                                                                                             |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

You are most welcome to come along.
Mamoun

________________________________________
From: Michael Richardson [[email-masked]]
Sent: Thursday, March 30, 2017 6:29 PM
To: [email-masked]
Cc: [email-masked]
Subject: quasem load-balancing: Figure 3: The amended DIO message format

        0                   1                   2                   3

This message and its attachment(s) are intended for the addressee(s) only and should not be read, copied, disclosed, forwarded or relied upon by any person other than the intended addressee(s) without the permission of the sender. If you are not the intended addressee you must not take any action based on this message and its attachment(s) nor must you copy or show them to anyone. Please respond to the sender and ensure that this message and its attachment(s) are deleted.

It is your responsibility to ensure that this message and its attachment(s) are scanned for viruses or other defects. Edinburgh Napier University does not accept liability for any loss or damage which may result from this message or its attachment(s), or for errors or omissions arising after it was sent. Email is not a secure medium. Emails entering Edinburgh Napier University's system are subject to routine monitoring and filtering by Edinburgh Napier University.

Edinburgh Napier University is a registered Scottish charity. Registration number SC018373