Subject: [Roll] Route Projection

From: "Turner, Randy" <[email-masked]>
Date: Sat, 1 Apr 2017 00:25:53 +0000

Hi All,

After hearing the presentation on RPL route projection, I just wanted to clarify that, if this technique was utilized in a network that (for whatever reason) was experiencing a situation where routers were frequently changing parents and/or re-establishing routes, then this would invalidate the projected routes in the effected parts of the network (where the routes were changing) - in addition to re-establishing the routes through normal DAO/DAO-ACK, the root would also have to re-project any previously projected routes.  If this is indeed the case, I'm assuming the root may elect to avoid projecting routes in these types of scenarios.

At the moment, I'm only talking about non-storing mode...

Thx,

Randy

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 1 Apr 2017 05:50:05 +0000

Hello Randy:

The projected route may be computed based on a current state of the dodag but once installed it does not depend on its variation. IOW if a node moves packets end in the bucket just like for a stale route.

But if the projected route still works, the root does not need to react immediately to the churn in the dodag.

As you point out, SDN and high mobility are not really friendly. So yes, this technique is more appropriate for stable networks. We should add words on that in the draft.

More critical is to define the way the root learns the topology and node capacity.

Should (some of) that be in the same document?

Take care,

Pascal

Le 1 avr. 2017 ? 02:26, Turner, Randy <[email-masked]<mailto:[email-masked]>> a ?crit :

Hi All,

Thx,

Randy

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll