Subject: Re: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 8 Jun 2017 08:01:08 +0000

Dear Ines :

I support the adoption. There is value in cleanup downstream routes from the control plane.

Note that a (reactive to traffic) data plane solution exists that is reactive, based on flags in RPI. I think the draft should mention it and position itself, saying for instance that it extends the no path dao in RPL to proactively clean up routes going down a broken path, whether it is used or not.

I do not think that the term DAO should be used – that’s confusing - or that the DAO format should change. But this discussion can happen as a WG doc.

Take care,

Pascal
From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: lundi 29 mai 2017 16:13
To: Routing Over Low power and Lossy networks <[email-masked]>
Cc: peter van der Stok <[email-masked]>
Subject: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01

Dear all,

This starts a ROLL Working Group adoption call for draft-jadhav-roll-efficient-npdao-01.

https://datatracker.ietf.org/doc/draft-jadhav-roll-efficient-npdao/

Please send your opinion (for or against) to the mailing list on adopting this document as a Roll WG document. This call will end at 00:00 UTC on June 12, 2017.

Regards,

Peter, Ines

2017-05-13 19:06 GMT+03:00 Rahul Jadhav <[email-masked]<mailto:[email-masked]>>:

Dear All,

The solution for NPDAO improvements was presented in IETF98.
And based on the discussions there, following are the changes to the ID:
1.     Improved readability
a.       Removed couple of unnecessary sections
b.      Fixed wordings in some places
2.    Applicability for 6tisch
3.    Updated security considerations
4.   Fixed example section

For completeness, attaching link to the discussion that happened on the ML:
https://www.ietf.org/mail-archive/web/roll/current/msg09639.html

Looking forward for reviews and feedback.

Thanks,
Rahul

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-jadhav-roll-efficient-npdao-01.txt
Date: 13 May 2017 at 1:08:52 PM IST
To: "Rabi Sahoo" <[email-masked]<mailto:[email-masked]>>, "JADHAV RAHUL" <[email-masked]<mailto:[email-masked]>>, "Rahul Arvind Jadhav" <[email-masked]<mailto:[email-masked]>>, "Zhen Cao" <[email-masked]<mailto:[email-masked]>>, "Rabi Narayan Sahoo" <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-jadhav-roll-efficient-npdao-01.txt
has been successfully submitted by Rahul Arvind Jadhav and posted to the
IETF repository.

Name: draft-jadhav-roll-efficient-npdao
Revision: 01
Title: No-Path DAO modifications
Document date: 2017-05-12
Group: Individual Submission
Pages: 12
URL:            https://www.ietf.org/internet-drafts/draft-jadhav-roll-efficient-npdao-01.txt
Status:         https://datatracker.ietf.org/doc/draft-jadhav-roll-efficient-npdao/
Htmlized:       https://tools.ietf.org/html/draft-jadhav-roll-efficient-npdao-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-jadhav-roll-efficient-npdao-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-jadhav-roll-efficient-npdao-01

Abstract:
  This document describes the problems associated with the use of No-
  Path DAO messaging in RPL and a signaling changes to improve route
  invalidation efficiency.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Ines Robles <[email-masked]>
Date: Tue, 27 Jun 2017 15:00:51 +0300

Dear all,

Thank you very much for your replies and to the authors for their hard work.

We have a new WG draft,

https://datatracker.ietf.org/doc/draft-ietf-roll-efficient-npdao/

Looking forward for your comments/suggestions about it.

Bests,

Peter & Ines.

2017-05-29 17:13 GMT+03:00 Ines Robles <[email-masked]>:

> Please send your opinion (for or against) to the mailing list on adopting
> this document as a Roll WG document. This call will end at 00:00 UTC on
> June 12, 2017.
>
> Regards,
>
> Peter, Ines
>
> 2017-05-13 19:06 GMT+03:00 Rahul Jadhav <[email-masked]>:
>
>>
>> Dear All,
>>
>> *From: [email-masked]
>> *Subject: **New Version Notification for
>> draft-jadhav-roll-efficient-npdao-01.txt*
>> *Date: *13 May 2017 at 1:08:52 PM IST
>> *To: *"Rabi Sahoo" <[email-masked]>, "JADHAV RAHUL" <
>> [email-masked]>, "Rahul Arvind Jadhav" <[email-masked]>,
>> "Zhen Cao" <[email-masked]>, "Rabi Narayan Sahoo" <
>> [email-masked]>
>>
>>
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> The IETF Secretariat
>>
>>
>>
>> [email-masked]