Subject: Re: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01

From: "Tianxiang Li" <[email-masked]>
Date: Thu, 1 Jun 2017 16:56:36 +0800 (GMT+08:00)

Hi,

I would like to support the adoption of draft-jadhav-roll-efficient-npdao-01. Actually I have met a similar problem in our research prototype related to NP-DAO and the solution in this draft is clear and straightforward. I may have a try with a simple implementation of the algorithm or better if the code will be available.

Thanks,
Peter

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: Monday, May 29, 2017 10:13 PM
To: Routing Over Low power and Lossy networks <[email-masked]>
Cc: peter van der Stok <[email-masked]>
Subject: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01
 
Dear all,
 
This starts a ROLL Working Group adoption call for draft-jadhav-roll-efficient-npdao-01.
 
https://datatracker.ietf.org/doc/draft-jadhav-roll-efficient-npdao/
 
Please send your opinion (for or against) to the mailing list on adopting this document as a Roll WG document. This call will end at 00:00 UTC on June 12, 2017.
 
Regards,
 
Peter, Ines
 
2017-05-13 19:06 GMT+03:00 Rahul Jadhav <[email-masked]>:
 
Dear All, 
 
The solution for NPDAO improvements was presented in IETF98. 
And based on the discussions there, following are the changes to the ID:
1.     Improved readability
a.       Removed couple of unnecessary sections
b.      Fixed wordings in some places
2.    Applicability for 6tisch
3.    Updated security considerations
4.   Fixed example section
 
For completeness, attaching link to the discussion that happened on the ML: 
https://www.ietf.org/mail-archive/web/roll/current/msg09639.html
 
Looking forward for reviews and feedback.
 
Thanks,
Rahul

Begin forwarded message:
 
From: [email-masked]
Subject: New Version Notification for draft-jadhav-roll-efficient-npdao-01.txt
Date: 13 May 2017 at 1:08:52 PM IST
To: "Rabi Sahoo" <[email-masked]>, "JADHAV RAHUL" <[email-masked]>, "Rahul Arvind Jadhav" <[email-masked]>, "Zhen Cao" <[email-masked]>, "Rabi Narayan Sahoo" <[email-masked]>

A new version of I-D, draft-jadhav-roll-efficient-npdao-01.txt
has been successfully submitted by Rahul Arvind Jadhav and posted to the
IETF repository.

Name: draft-jadhav-roll-efficient-npdao
Revision: 01
Title: No-Path DAO modifications
Document date: 2017-05-12
Group: Individual Submission
Pages: 12
URL:            https://www.ietf.org/internet-drafts/draft-jadhav-roll-efficient-npdao-01.txt
Status:         https://datatracker.ietf.org/doc/draft-jadhav-roll-efficient-npdao/
Htmlized:       https://tools.ietf.org/html/draft-jadhav-roll-efficient-npdao-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-jadhav-roll-efficient-npdao-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-jadhav-roll-efficient-npdao-01

Abstract:
  This document describes the problems associated with the use of No-
  Path DAO messaging in RPL and a signaling changes to improve route
  invalidation efficiency.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Zuojing (2012 Laboratories)" <[email-masked]>
Date: Wed, 7 Jun 2017 09:03:29 +0000

Hi, all

I support the WG adoption of the 'no path DAO modifications' draft.

Kind regards,
Jing

From: Roll [mailto:[email-masked]] On Behalf Of Tianxiang Li
Sent: Thursday, June 01, 2017 4:57 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01

Hi,

Thanks,
Peter

From: Roll [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: Monday, May 29, 2017 10:13 PM
To: Routing Over Low power and Lossy networks <[email-masked]<mailto:[email-masked]>>
Cc: peter van der Stok <[email-masked]<mailto:[email-masked]>>
Subject: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01

Dear all,

Regards,

Peter, Ines

2017-05-13 19:06 GMT+03:00 Rahul Jadhav <[email-masked]<mailto:[email-masked]>>:

Dear All,

Thanks,
Rahul

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-jadhav-roll-efficient-npdao-01.txt
Date: 13 May 2017 at 1:08:52 PM IST
To: "Rabi Sahoo" <[email-masked]<mailto:[email-masked]>>, "JADHAV RAHUL" <[email-masked]<mailto:[email-masked]>>, "Rahul Arvind Jadhav" <[email-masked]<mailto:[email-masked]>>, "Zhen Cao" <[email-masked]<mailto:[email-masked]>>, "Rabi Narayan Sahoo" <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 8 Jun 2017 09:44:11 +0530

Hello Tianxiang,

Regarding code availability, we are working towards open sourcing it (in Contiki) in coming months.  Its really a simple implementation change with potentially many advantages… 

Thank you for your interest and feedback.

Regards,
Rahul

> On 01-Jun-2017, at 2:26 PM, Tianxiang Li <[email-masked]> wrote:
> 
> Hi,
>

---

From: "JR Lin" <[email-masked]>
Date: Fri, 9 Jun 2017 11:23:24 +0800 (GMT+08:00)

Dear all:
It looks good to me. The use cases/requirements are solid, and the solution is also straightforward. I would like to support the adoption, and can help review further versions of the draft if needed.

Best regards
JR Lin

-----Original Messages-----
From:"Tianxiang Li" <[email-masked]>
Sent Time:2017-06-01 16:56:36 (Thursday)
To: [email-masked], [email-masked]
Cc: [email-masked]
Subject: Re: [Roll] WG adoption call for draft-jadhav-roll-efficient-npdao-01

Hi,

Thanks,
Peter

 
Dear all,

 
 
Regards,
 
Peter, Ines

Dear All, 

 
 
Thanks,
Rahul

Begin forwarded message:

Abstract:

The IETF Secretariat