Subject: [Roll] Key points of draft-hou-roll-rpl-parent-selection

From: houjianqiang <[email-masked]>
Date: Wed, 19 Jul 2017 12:29:18 +0000

Dear all,

I am going to present my draft <draft-hou-roll-rpl-parent-selection-00> in Roll WG. The slides are online now. To make it easier for you to understand it, below are some key points in the presentation:

Issue: Randomly Unbalanced Networking

Goal: balancing the number of child nodes

Possible using scenario: Smart Meters

Solution:

1.
 Compute the Number_of_Children from Neighbor Table (Neighbor Cache Entry)

2.
 Store the Number_of_Children in a new Metric, and send it to downstream nodes with DIO

3.
 Downstream nodes choose parent node based on Number_of_Children

4.
 Combine the Number_of_Children with other metrics/constraints

The details of computing the Number_of_Children are related to the neighbor table management, and Rahul has given a good illustration in <draft-jadhav-lwig-nbr-mgmt-policy-00>. The child register/deregister in parent’s NCE according to DAO/NPDAO
 (storing mode) or NS+ARO/NS+ARO_0lftime (non-storing mode).

Cheers,
Jianqiang

---

From: houjianqiang <[email-masked]>
Date: Fri, 21 Jul 2017 08:37:42 +0000

Hi all,

I have received some feedback after the meeting. Following are some questions and the corresponding answers:

1.      Is this CNC metric only used for leaf nodes?
No. CNC metric can be used for all nodes in a RPL network. One-hop children (direct children) are counted for each parent node, but there can be lots of grandchild nodes in the downstream. We aim at the network with multihops.

2.      Why not use other metrics, e.g. throughput, as replacement?
In the smart meter scenario, each node upload data once per day or per month, it takes long time for nodes to calculate throughput and other metrics. If CNC is used, the balanced network can be formed from the very beginning.

3.      Why calculate the direct children rather than the total number of children?
Total number of children was considered previously, and the downward routing table can be used for this calculation. But if total the number of children is used, new joining downstream nodes will have an enormous impact on the upstream connection, then it will take long long time for the network to be stable. Also, the computing of total number of children always exists time delay.

4.      Why focus on this narrow topic?
The RPL network with hundreds, thousands of nodes have not been well studied but there are already such using scenarios in daily life. And moreover, nodes are almost the same in these scenarios, computing actuate traffic load takes longer time. CNC metric is enough, simple and effective.

Cheers,
Jianqiang

发件人： houjianqiang
收件人： [email-masked]<mailto:[email-masked]>
主题： Key points of draft-hou-roll-rpl-parent-selection
时间： 2017-07-19 14:29:19

Dear all,

Solution:

1.

2.

3.

4.

Cheers,
Jianqiang