Subject: [Roll] Route Projection draft

From: "Gillmore, Matthew" <[email-masked]>
Date: Wed, 12 Jul 2017 12:23:32 +0000

Hi Pascal,

My company (Itron) has implemented most of what has been described in https://tools.ietf.org/html/draft-ietf-roll-dao-projection-01.  We find this draft very useful and if possible we would like to make suggestions/improvements.

1)      We would like the ability to check what P-DAO routes have been sent to a router

a.       This could be done with a P-DAO acknowledgement

2)      What is meant by a "No-Path" when a path lifetime is 00?

3)      Could a device NACK a P-DAO?

Thanks!

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 13 Jul 2017 18:22:02 +0000

Hello Matt :

Many good points, please see below:

From: Roll [mailto:[email-masked]] On Behalf Of Gillmore, Matthew
Sent: mercredi 12 juillet 2017 14:24
To: [email-masked]
Subject: [Roll] Route Projection draft

Hi Pascal,

[Pascal] The DAO-ACK guarantees that the devices on the way have processed the DAO. Now there is no way in the current draft to go to a particular device and ask it what routes is has currently installed, and / or how many more rotes it can accept based on available resources. Would that be needed? Would you contribute?

2)      What is meant by a "No-Path" when a path lifetime is 00?
[Pascal] This terminology is inherited from RFC 6550. It really means that the DAO flow cleans up a state as opposed to adding one. The way to signal that is that the route lifetime is set to 0.

3)      Could a device NACK a P-DAO?
[Pascal] Yes, any device on the way can respond with a DAO-Ack as opposed to forward to the next node, indicating a problem in a status > 127. Then again we have to design the gory details and your help in edition and or with return from implementation would be highly welcome...

Take care,

Pascal

Thanks!